Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Excel - Excel czy VBA, czy uda się w excelu przypisywać?

alvarofun 01 Dec 2017 02:54 792 3
  • #1
    alvarofun
    Level 17  
    Witam,

    nie wiem jakiej użyć funkcji, już próbowałem kilka i cały czasklęska, pewnie się nie da tego zrobić w excelu tylko trzeba w Vba.

    w kolumnie A mam od wiersza 3
    aa
    bb
    cc
    dd
    ee
    ff

    w kolumnie B w wierszu 1 mam date

    nie wiem jakiej użyć funkcji żeby w wierszu 2 z miarą narastających dni
    przypisywały się wartości z kolumny A

    wyglądało by to tak

    A B C D E F G H I J K L M
    1 1_2_ 3_ 4_ 5_6_7_ 8_ 9_10_11_12_13 (tu są dni
    2 aa bb cc dd ee ff aa bb cc dd ee ff aa

    3 aa
    4 bb
    5 cc
    6 dd
    7 ee
    8 ff

    chodzi oto żeby ten zakres od B3:B8 sie powtarzał w wierszu 2
    Dało by się coś takiego ogarnąć w excelu?

    Dodano po 32 [minuty]:

    Coś tak jak by w komórce B2, powtarzać funkcję =transponuj(B3:B8) Ctrl+Shift+Enter, tyle że to działa tylko jeśli zaznaczę obszar (B2:B6), gdybym zaznaczył większy obszar to ARG, a ja bym chciał żeby znów transponowało od nowa w komórce H2
  • Helpful post
    #2
    Bezet-1147
    Level 11  
    .

    Tak, da się to "ogarnąć" formułami Excela, chociaż na początku będzie trochę "ręcznej" roboty.

    Zrobiłem to w wariancie z kompletem sześciu powtarzających się cyklicznie elementów, czyli tak jak napisałeś.
    Oczywiście można to zrobić również dla kompletu z większą liczbą powtarzających się elementów, tyle że wtedy będzie więcej "ręcznej" roboty na początku.

    1) W komórkach od A3, do A8 ponumeruj elementy składające się na komplet (w tym przypadku jest ich 6).
    2) W komórkach od B3, do B8 umieść elementy kompletu.
    3) W komórki B1, C1, D1, itd ..... wpisz kolejne liczby porządkowe (1, 2, 3, itd.....).
    4) W komórce B2 umieść formułę: =B3 [potem w C2 wpisz: =B4 ___ w D2 wpisz: =B5 .....itd, aż do G2 =B8].
    5) W komórce H2 umieść formułę: =JEŻELI((H1-B1)=$A8;B2;C2)
    6) Przeciągnij formułę z komórki H2, w prawo (aż do miejsca, gdzie kończą się liczby porządkowe zawarte w wierszu pierwszym.

    ------------------
    88

    .
  • #3
    JRV
    VBA, Excel specialist
    B2 =INDEKS($A:$A;MOD(NR.KOLUMNY()-2;6)+3)
    przeciagnij wprawo
    jesli w kol.A ilosc wartosci zmienna(<>6)
    B2=INDEKS($A:$A;MOD(NR.KOLUMNY()-2;ILE.NIEPUSTYCH($A:$A))+3)