Elektroda.pl
Elektroda.pl
X
CControls
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

wyczynowy 04 Gru 2017 17:40 915 10
  • #1 04 Gru 2017 17:40
    wyczynowy
    Poziom 2  

    Witam wszystkich, jest to mój pierwszy post na forum i proszę o pomoc w zweryfikowaniu problemu z niedziałającym poprawnie układem zabezpieczenia nadprądowego nad którym pracuję.
    Schemat układu zamieszczam poniżej:
    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

    Opis działania układu:

    Po uruchomieniu urządzenia uP włącza tranzystor Q2 a ten z kolei włącza tranzystor T1. Układ IC5A (wzmacniacz) służy do pomiaru prądu płynącego w obwodzie. Mierzony jest spadek napięcia na rezystorze 0,22 ohm'a. Rezystorowy dzielnik napięcia R58-R59 jest układem dzięki któremu mierzę napięcie na Drenie tranzystora T1 czyli na wyjściu tego układu. uP mierzy cały czas prąd i napięcie w obwodzie i po wykryciu prądu większego niż 1450 mA lub napięcia niższego niż 30V rozłącza zasilanie na wyjścu czyli wyłącza tranzystor T1. Bezpiecznik F2 jest to bezpiecznik polimerowy PTC. Układ działa dobrze do chwili w której robię zwarcie na wyjściu, czyli łączę ze sobą linie WY_+48V z linią WY_GND. uP wykrywa zwarcie i w czasie określonym przeze mnie wyłącza Q1 a ten T2. Problem w tym, że w tej chwili tranzystor T2 ulega uszkodzeniu i zostaje przebity. Pomiędzy D-S -> 0 ohm. Pomiędzy G-S / G-D -> ok 61 ohm. Tranzystor T2 to w tym przypadku tranzystor AOD409. Taką samą próbę przeprowadzam na tranzystorze IRFR5410PBF i tranzystor ten też ulega uszkodzeniu ale w inny sposób.

    Poinżej obrazek na którym widać to co się dzieje pod oscyloskopem:

    Kanał 1 - sygnał sterujący Tranzystorem Q2 (wyłączenie tranzystora T1) - tutaj czas programowo był ustawiony na 100ms od wykrycia zwarcia
    Kanał 2 - Baza badanego tranzystora
    Kanał 3 - Źródło badanego tranzystora
    Kanał 4 - Dren Badanego tranzystora

    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego
    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

    Poniżej ta sama chwila ale pomiary wykonywane w innych punktach

    Kanał 1 - napięcie na drenie badanego tranzystora
    Kanał 2 - prąd w obwodzie(prąd drenu)
    Kanał 3 - napięcie na tranzystorze sterującym(rozłączającym tranzystor badany) - tutaj czas programowo był ustawiony na ok 1ms od wykrycia zwarcia

    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego
    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

    Czasem przy próbie zwarcia uszkadza się ten tranzystor a czasem nie. Zamawiam niebawem 5 innych rodzajów tranzystorów o podobnych parametrach różnych firm, bo nie wiem co uszkadza te dwa tranzystory.

    Proszę szanownych forumowiczów o podpowiedzi co może uszkadzać ten tranzystor, jak go zabezpieczyć, bądź co jeszcze powinienem sprawdzić lub proszę powiedzieć co przeoczyłem.

    Pozdrawiam wszystkich i proszę o pomoc
    Dawid

    0 10
  • CControls
  • #2 04 Gru 2017 18:05
    jdubowski
    Specjalista - urządzenia lampowe

    wyczynowy napisał:
    Układ działa dobrze do chwili w której robię zwarcie na wyjściu, czyli łączę ze sobą linie WY_+48V z linią WY_GND. uP wykrywa zwarcie i w czasie określonym przeze mnie wyłącza Q1 a ten T2. Problem w tym, że w tej chwili tranzystor T2 ulega uszkodzeniu i zostaje przebity. Pomiędzy D-S -> 0 ohm.


    Cóż tu dziwnego - prąd zwarcia w impulsie większy niż może wytrzymać tranzystor.

    0
  • CControls
  • #3 04 Gru 2017 18:38
    rb401
    Poziom 33  

    wyczynowy napisał:
    Proszę szanownych forumowiczów o podpowiedzi co może uszkadzać ten tranzystor, jak go zabezpieczyć, bądź co jeszcze powinienem sprawdzić lub proszę powiedzieć co przeoczyłem.


    To co mi się rzuca w oczy to fakt że bardzo słabo wysterowywujesz bramkę tego AOD409 (ok. 3,7V). Nie widzę żadnego uzasadnienia takiego wyboru.
    Jeśli popatrzeć do DS to widać że z takim napięciem to AOD409 ma ogromną na jego możliwości oporność kanału i praktycznie limituje prąd drenu gdzie na góra kilkanaście amperów.
    Nie wiem ile Ci daje zasilacz, ale załóżmy że nie robi to na mim wrażenia i te 10A daje.
    To zauważ że przy zwarciu masz na mosfecie równocześnie 10A i 48V czyli 480W.
    W dodatku jeśli popatrzysz do DS na SOA to widać że taka kombinacja nie może trwać dłużej jak jakieś 100mikrosekund.
    Jeśli nawet wyrabiasz się z softwarową reakcją w tym czasie to musisz też uwzględnić fakt że wyłączając tego dolnego IRML0060 wyłączenie AOD409 następuje stosunkowo powoli bo rozładowujesz stosunkowo dużą pojemność bramki 3nF przez rezystor 2k.
    Czyli powstaje sporo możliwości by ten mosfet spalić.

    0
  • #4 04 Gru 2017 19:19
    wyczynowy
    Poziom 2  

    Wdg noty katalogowej ten tranzystor ma: Pulsed Drain Current C = -80A. Pik który zarejestrował oscyloskop miał dużo mniej

    0
  • Pomocny post
    #5 04 Gru 2017 19:37
    jarek_lnx
    Poziom 43  

    Cytat:
    Wdg noty katalogowej ten tranzystor ma: Pulsed Drain Current C = -80A. Pik który zarejestrował oscyloskop miał dużo mniej
    Przy czasie 10us, ty go katujesz ponad stukrotnie dłużej.

    Na czwartym oscylogramie widać jak po 1,66ms tranzystor ulega uszkodzeniu - prąd skokowo rośnie a po 2,08ms zdejmujesz sygnał sterujący, jak to ma sie do 1ms o której piszesz?

    Dziwię się że dysponując MOSFET-em którego można wyłączyć w czasie kilkudziesięciu ns, czekasz z wyłączeniem cztery rzędy wielkości dłużej, czas zadziałania bezpiecznika topikowego jest liczony w ms, ale elektroniczny może byc dużo szybszy, co za problem wyłączyć go w 1us? byle jaki komparator da ci połowę tego. A jak chcesz żeby prąd zwarcia płynął przez czas liczony w milisekundach to daj dwa MOSFET-y i rezystor, pierwszy tranzystor wyłączasz od razu przekierowując prąd do obwodu z rezystorem, drugi wyłączasz kiedy chcesz (ile rezystor wytrzyma) nawet po kilku sekundach.

    0
  • Pomocny post
    #6 04 Gru 2017 20:42
    rb401
    Poziom 33  

    wyczynowy napisał:
    Wdg noty katalogowej ten tranzystor ma: Pulsed Drain Current C = -80A. Pik który zarejestrował oscyloskop miał dużo mniej


    Zobacz gdzie jesteś na SOA:

    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

    Mógłbyś się trochę w lewo przesunąć, co dało by ci więcej czasu, ale mosfet masz wysterowany w pracy liniowej, gdzieś tu, właśnie z powodu małego napięcia bramki:

    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

    i tu akurat ta okoliczność że prąd masz mniejszy nawet niż te 80A, nie ratuje mosfeta przed nieuchronnym uszkodzeniem bo przekroczone są parametry mocy (z uwagi na duże Uds).
    Tak że jedna sprawa to konieczne podwyższenie napięcia sterującego na bramce (masz przecież limit 20V) a druga sprawa to sprawdzenie jak szybko w Twoim układzie wyłączasz tego mosfeta (ze względu na stałą czasową RC, pojemności bramki i opornika 2kΩ) i czy już tutaj nie wychodzisz poza SOA.

    0
  • #8 04 Gru 2017 21:31
    wyczynowy
    Poziom 2  

    Dziękuję za odpowiedzi. Rozumiem, że czas 10 us czy 100 us jest wzięty z tego wykresu nr.9 noty katalogowej. Przyznaje się, że nie wiedziałem ile ten pik prądowy może trwać. Teraz już rozumiem gdzie tego szukać.

    1. Na czwartym oscylogramie widać chwilę kiedy następuje przebicie. Prąd płynący przed przebiciem (kanał 2) wynosi w granicy 7,3 A(1A to 220 mV). Napięcie jakie odkłada się na rezystorze pomiarowym (kanał 1) to ok 8 V. Napięcie które odkłada się w tym czasie na tranzystorze to wdg. oscylogramu 2 (kanał 3) 36V - 8V(napięcie na rezystorze pomiarowym) = 28V. Zatem Moc chwilowa jaka wydzieli się na tranzystorze wynosi 28V * 7,3A = 204W i to właśnie to sprawia, że tranzystor zostaje uszkodzony, tak ?

    2. Rozumiem, że maksymalna temperatura złącza wynosi 150 st C. Temperatura na złączu podnosi się o 40 st na jeden Watt. W moim przypadku jest do rozproszenia aż 204 W, czyli temperatura złącza chciała by się podnieść aż o 204 * 40 = 8160 st C ?

    3. Rozumiem, że maksymalnie w czasie krótszym niż te 10 us (odczytane z wykresu) ten tranzystor jest w stanie przekazać 60W ze złącza na obudowę, a jednocześnie ciągłej mocy ten tranzystor jest w stanie rozproszyć z obudowy do otoczenia jedynie 2,5 W ?

    Poniżej wycinek z noty:

    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego
    Tranzystor mosfet ulega uszkodzeniu przy próbie zwarcia ukł. zabezpieczającego

    Proszę o komentarz pkt 1,2,3, bo chciałbym się upewnić czy dobrze rozumiem problem.
    Czym innym jest fakt, że tak długo zwlekam z rozłączeniem tego tranzystora ale to już inny temat...

    Widzę, że szybciej forum działa niż ja zdąże się ustosunkować i przemyśleć co chcę odpowiedzieć. Dziękuję.

    Rozumiem rb401, że gdybym z tego obszaru, który wskazałeś uciekł przed czasem 100 us to tranzystorek byłby cały.

    0
  • Pomocny post
    #9 04 Gru 2017 21:46
    jdubowski
    Specjalista - urządzenia lampowe

    wyczynowy napisał:
    2. Rozumiem, że maksymalna temperatura złącza wynosi 150 st C. Temperatura na złączu podnosi się o 40 st na jeden Watt. W moim przypadku jest do rozproszenia aż 204 W, czyli temperatura złącza chciała by się podnieść aż o 204 * 40 = 8160 st C ?


    40 stopni na wat w stanie ustalonym, w impulsie jest nieco lepiej - 25K/W. W każdym razie i tak o wiele za dużo.

    wyczynowy napisał:
    3. Rozumiem, że maksymalnie w czasie krótszym niż te 10 us (odczytane z wykresu) ten tranzystor jest w stanie przekazać 60W ze złącza na obudowę, a jednocześnie ciągłej mocy ten tranzystor jest w stanie rozproszyć z obudowy do otoczenia jedynie 2,5 W ?


    2,5W to bezpieczna moc rozpraszana bez radiatora. Natomiast 60W to moc którą można rozproszyć zapewniając temperaturę obudowy 25 st. C - to są warunki w praktyce trudno osiągalne, wyłaczając radiator chłodzony wodą lodową.

    0
  • #10 04 Gru 2017 21:49
    _lazor_
    Moderator Projektowanie

    40 stopni na wat wzrasta gdy nie ma radiatora, takie podstawowe pytanie czy masz radiator? Jeśli nie to załóż jakiś.
    Producenci podają że maksymalną moc rozproszenia w warunkach absurdalnych, trzeba niestety przyjmować połowę tej wartości ale tylko z dobrym radiatorem.

    1
  • #11 04 Gru 2017 21:54
    wyczynowy
    Poziom 2  

    Element jest montowany powierzchniowo i bez radiatora. Wiem już gdzie problem, teraz muszę tylko zastanowić się nad rozwiązaniem, bo temat nie jest do końca taki oczywisty jak go przedstawiłem. Dziękuję za pomoc i temat uważam za zamknięty.

    0