Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Arduino + wzmacniacz zasilane z akumulatorów

gandalf_58 16 Gru 2017 17:16 339 11
  • #1 16 Gru 2017 17:16
    gandalf_58
    Poziom 4  

    Witam, próbuję zbudować radio na bazie Arduino ale mam problemy konstrukcyjne. Chciałbym, aby układ składał się z: Arduino, wyświetlacza 5V 1602, wzmacniacza PAM8403 + 2x glosniki 3W 4Ohm, moduł rda5807, dwóch ogniw 18650 (obecnie mam je w konfiguracji równoległej). Podłączając wzmacniacz bezpośrednio do ogniw głośniki graja naprawdę dobrze, problem się pojawia po podłączeniu Arduino. Wyświetlacz jest na 5V i przy zasilaniu z 3,7V prawie nic na nim nie widać. Postanowiłem użyć przetwornicę StepUp. Ustawiam na niej napięcie 5,5-7V. Zasilenie wzmacniacza wpięte pod wyjście z przetwornicy równolegle z Arduino, od Arduino zasilane są pozostałe elementy. Wszystko działa ale tylko w przypadku, gdy głośność jest minimalna. Lekkie podgłośnienie powoduje powstanie trzasków i miganie ekranu synchronicznie z pierdzeniem głośnika. Mierząc prąd, jaki był pobierany przez wzmacniacz wyszło mi ~1,5A max (szczególnie w momencie, gdy zaczyna pierdzieć, wtedy skok jest duży, od kilkuset mA skacze do 1,1-1,5A). Dlatego chciałybm się spytać, jak podłączyć ten układ aby grał w miarę przyzwoicie (głośnik nie musi grac aż tak głośno jak bez Arduino, ale znowu nie tak cicho jak obecnie).

    0 11
  • Pomocny post
    #2 16 Gru 2017 17:35
    E8600
    Poziom 37  

    Ogniwa szeregowo i wywalić to przetwornicę gdyż audio nie lubi przetwornic impulsowych szczególnie step-up.
    Wybranie wzmacniacza audio na niskie napięcie 5V nie było dobrym pomysłem.

    0
  • #3 16 Gru 2017 17:56
    gandalf_58
    Poziom 4  

    Zależało mi na tym, aby można było jednocześnie podłączyć zasilanie zewnętrzne i wtedy ładować ogniwa, dlatego są równolegle. Jeżeli zdecyduję się na dwa ogniwa szeregowo to do każdego z nich powinna być osobna ładowarka (żeby ich nie zewrzeć), ale może da się je ładować z jednej? Jest może jakiś inny sposób na wybrnięcie?

    E: w zasadzie jak teraz patrzę na ceny balanserów na allegro to koszt nie jest jakis wysoki, chyba w takim razie sprobuje z balaneserem.

    0
  • Pomocny post
    #4 16 Gru 2017 18:02
    E8600
    Poziom 37  

    gandalf_58 napisał:
    Jeżeli zdecyduję się na dwa ogniwa szeregowo to do każdego z nich powinna być osobna ładowarka (żeby ich nie zewrzeć), ale może da się je ładować z jednej?

    Wystarczy zastosować balanser i można ładować z jednej ładowarki.
    Policzył kolega ile to będzie grało przy 2x3W i tylko 2x18650? Strzelam, że max półgodziny przy max głośności.

    0
  • #5 16 Gru 2017 18:19
    gandalf_58
    Poziom 4  

    Nie liczyłem, ale szacowałem około godziny. Jest to praca na uczelnie dlatego tez bardziej zalezy mi na rozwiazaniach technicznych niz funkcjonalnosci. Bardzo dziekuje za pomoc.
    P.S. Jak juz bede mial te 2 ogniwa szeregowo to powinienem uzyc np. 7805, nada sie do sprzetu Audio? Bo 7,4V na wzmacniacz 5,5V to troche duzo :)
    P.S.2 Tak sie zastanawiam jak wobec tego rozwiazano kwestie zasilania w takim JBL GO, ktore chyba gra troche dluzej niz te 30 min. Niby jak patrze na ten glosnik to wydaje sie, ze tam 4 ogniwa siedza.

    0
  • #6 16 Gru 2017 18:27
    E8600
    Poziom 37  

    gandalf_58 napisał:
    P.S. Jak juz bede mial te 2 ogniwa szeregowo to powinienem uzyc np. 7805, nada sie do sprzetu Audio? Bo 7,4V na wzmacniacz 5,5V to troche duzo

    Osobiście bym zmienił wzmacniacz na taki z szerszym zakresem zasilania (na wyższe napięcie). LM7805 ma max prąd 1,5A wiec nie polecam bo będą duże straty w ciepło na stabilizatorze liniowym i raczej na 100% się spali.

    0
  • #7 16 Gru 2017 18:53
    gandalf_58
    Poziom 4  

    A bez zmiany wzmacniacza czym najlepiej wyregulować to napięcie?

    0
  • #8 16 Gru 2017 19:04
    E8600
    Poziom 37  

    LM317 lub LM350 mają wyższe prądy ale wymagają użycia rezystorów do wysterowania napięcia ale też są to elementy liniowe wiec straty w postaci ciepła będą i to znaczne. Możesz spróbować przetwornicy step-down z odpowiednio dużym kondensatorem na wyjściu aby nie było tętnień-zakłóceń powinna się lepiej sprawdzić niż przetwornica step-up. Myślę, że LM2596 z radiatorem ( I=3A) powinien wystarczyć.

    0
  • #9 16 Gru 2017 19:35
    gandalf_58
    Poziom 4  

    Aha jeszcze jedna sprawa mi nie daje spokoju - dlaczego ten caly uklad tak tragicznie sie zachowuje? Przeciez ogniwo daje ~3A, zapotrzebowanie ukladu to jakies max 80mA na Arduino, 60mA na wyswietlacz (tam chyba sa 3 diody rgb bo swieci na bialo), sam wzmacniacz w stanie spoczynku 10mA, w czasie pracy te 500mA-1,5A max, odbiornik IR tez jakis maly prad, mysle, ze calosc powyzej 2A w skrajnym przypadku nie bierze. Niby ta przetwornica troche nam prad zmniejsza, ale tez dochodzi 2 ogniwo czyli pradowa wydajnosc zrodla rosnie, dlaczego wobec tego to zrodlo nie wyrabia?

    0
  • #11 16 Gru 2017 20:34
    gandalf_58
    Poziom 4  

    No tak ale laczylem tez tak, ze wpinalem wzmacniacz bezposrednio pod ogniwa i rownolegle przetwornica -> arduino z cala reszta.

    EDIT:
    Okej, problemem okazal sie przelacznik ON/OFF, chyba byl na 1A a prad rozruchowy jest zbyt duzy. Pozdrawiam i dziekuje za zaangazowanie.

    0
  • #12 07 Sty 2018 17:35
    gandalf_58
    Poziom 4  

    Okej, problemem okazal sie przelacznik ON/OFF, chyba byl na 1A a prad rozruchowy jest zbyt duzy. Pozdrawiam i dziekuje za zaangazowanie.

    0