Elektroda.pl
Elektroda.pl
X
Konica Minolta
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Karta Digitus PCI-E 2xRS232/1xLPT na MCS9901 nie działa pod Win10 1709

grzemo2 12 Sty 2018 21:56 300 14
  • #1 12 Sty 2018 21:56
    grzemo2
    Poziom 8  

    Miałem problemy z aktualizacją Windows 10 do wersji 1709 (a właściwie też już z wcześniejszą, chyba 1607). W końcu udało mi się ustalić, że problemem jest karta portów szeregowych i równoległego na PCI-E Digitus z chipsetem MCS9901. Po jej wyjęciu aktualizacja weszła bez problemu. Spróbowałem potem kartę włożyć z powrotem. System nawet się nie uruchomił (ciemny ekran, brak oznak pracy dysku)!
    Na stronie Digitus jest ta karta, ale w wersji 2 już obsługiwana przez win 10. Mojej nie ma nawet w archiwum. Czy to znaczy, że karta nadaje się jedynie do kosza? Co zmieniło się w kwestii sterowników, że ta stara karta tak "ścina" system? Dodam, że pracowała bez problemu pod inicjalną wersją Win 10, chyba oznaczoną 1511. Dlaczego konieczne były nawet zmiany sprzętowe, skoro Digitus nie opublikował sterowników pod Win 10 dla starszej karty?
    Jeszcze jedna kwestia. Wystarczyłaby mi w zupełności przelotka USB / RS232. Ale jaką kupić? Większość dostępnych na rynku nie ma w opisie windowsa 10. Wielu producentów udostępnia nowe sterowniki, ale czy one zadziałają ze starszymi przelotkami? Może tu też będzie potrzebna przelotka w hardware'owo nowszej wersji?

    0 14
  • Konica Minolta
  • Pomocny post
    #2 12 Sty 2018 22:38
    310artur
    Poziom 43  

    Jaka to płyta że blokuje ci windowsa tak szybko? Windows tak czy owak powinien się uruchomić. Męczyłeś go z tą kartą? Uruchom go bez karty i usuń sterowniki od niej (wszystkie). Zamontuj i zobacz czy się podniesie. Ja rozumiem że karta może nie działać ale system wstać powinien.
    Możesz też próbować go uruchomić w trybie awaryjnym z kartą. Pomęczyć automatyczne naprawy. Taki trik - jeśli z kartą widzisz choćby pierwsze ekran ładowania systemu to wyłącz na tym ekranie PC za pomocą przycisku power (przytrzymując) 2x - po 2 nieudanych próbach system sam podejmie próbę naprawy i da dostęp do zaawansowanych opcji naprawy.

    0
  • #3 13 Sty 2018 14:04
    grzemo2
    Poziom 8  

    310artur napisał:
    Jaka to płyta że blokuje ci windowsa tak szybko? Windows tak czy owak powinien się uruchomić. Męczyłeś go z tą kartą? Uruchom go bez karty i usuń sterowniki od niej (wszystkie). Zamontuj i zobacz czy się podniesie. Ja rozumiem że karta może nie działać ale system wstać powinien.
    Możesz też próbować go uruchomić w trybie awaryjnym z kartą. Pomęczyć automatyczne naprawy. Taki trik - jeśli z kartą widzisz choćby pierwsze ekran ładowania systemu to wyłącz na tym ekranie PC za pomocą przycisku power (przytrzymując) 2x - po 2 nieudanych próbach system sam podejmie próbę naprawy i da dostęp do zaawansowanych opcji naprawy.

    Było dokładnie tak, że pojawiał się pierwszy ekran ładowania systemu (to logo windowsa) a po chwili znikał, ekran czarny ale bez utraty sygnału - led na monitorze nadal świeciła się na zielono. W tym momencie zanikała taż wszelka aktywność twardego dysku. Po ok. 10 min wyłączałem komputer przytrzymując przycisk Power. Wyjmowałem kartę i odpalałem komp ponownie. Startował normalnie. Historia niezawodności wskazuje nieoczekiwane zamknięcie systemu ... i jakiś problem ze sklepem Windows. Czyżby próbował tam szukać sterowników? A może powinienem komputerowi dać więcej czasu? Czasami po aktualizacjach, po restarcie komp tak się zamyśli jakby wisiał a jednak po kilku minutach "ożywa".
    Co do usuwania sterowników, to zrobiłem to programem uninstal dołączonym do karty. W menadżerze urządzeń karty już nie ma. Ale gdzieś czytałem, że pod win10 takie uninstale nie działają, bo system ich nie dopuszcza tak głęboko (czyli że w rejestrze coś zostaje).
    Martwi mnie to, że Digitus wypuścił nową wersję tej karty - ze sterownikami pod win10. Czyżby więc problem nie leżał w samych sterownikach?

    0
  • Pomocny post
    #4 13 Sty 2018 19:20
    310artur
    Poziom 43  

    Problem jak najbardziej może być. Mnie dziwi że system wcale nie wstaje z kartą. Chociaż w trybie awaryjnym według mnie wstać powinien.
    Ile razy podjąłeś próbę uruchomienia z kartą? U mnie rekordowo bogowie komputerów potrzebowali 5 resetów na rozwiązanie problemu ;) Trzy próby to minimum - po 2 nieudanych win10 powinien sam podjąć próbę autonaprawy (uruchomienie diagnostyczne - pokaże się zaraz na początku pod logiem win napis "Czekaj")
    Co usuwania uninstalem - sterowniki same w sobie mogły zostać. System bardzo niechętnie oddaje raz dostarczone sterowniki. W managerze urządzeń trzeba wejść znaleźć kartę, kliknąć odinstaluj a na okienku które wyskoczy zaptaszkować "usuń sterowniki" czy oprogramowanie urządzenia czy jakoś tak.
    Opisana metoda jest ogólna dość uniwersalna - o samej karcie nie wiem nic więc konkretniej nie pomogę. Tak czy owak jak zmusisz system żeby wstał z kartą na pokładzie to będzie szansa coś kombinować w innym wypadku pozostaje trzymanie dwóch systemów - jeden dla karty drugi dla reszty. Domyślam się że nie zawsze potrzebujesz portu RS.
    Poza tym jesteś 100% pewien że nie masz portu COM na płycie głównej? LTP to od dłuższego czasu nie ma ale COM bywa obecny tylko nie wyprowadzony.

    0
  • Konica Minolta
  • #5 14 Sty 2018 14:14
    grzemo2
    Poziom 8  

    Dzięki za podpowiedzi. Dalsze walki w poniedziałek, bo komp jest w robocie.

    0
  • #6 14 Sty 2018 17:46
    masterten
    Poziom 28  

    Nie masz na tym komputerze może klucza HASP albo pozostałości po nim? Wiem, że się gryzie z kontrolerem LPT.

    Z moich doświadczeń wynika, że wszystkie adaptery USB-RS232 działają pod windows 10, nawet do tego stopnia że sam zaciąga sterowniki. Inna historia to do czego potrzebujesz tego COM, bo słyszałem, że o ile drukarki fiskalne czy inne popularne urządzenia działają na takich adapterach bardzo dobrze, to jakieś mniej popularne urządzenia jak interfejsy diagnostyczne mogą nie chcieć współpracować.

    0
  • #7 15 Sty 2018 12:08
    grzemo2
    Poziom 8  

    masterten napisał:
    Nie masz na tym komputerze może klucza HASP albo pozostałości po nim? Wiem, że się gryzie z kontrolerem LPT.

    Z moich doświadczeń wynika, że wszystkie adaptery USB-RS232 działają pod windows 10, nawet do tego stopnia że sam zaciąga sterowniki. Inna historia to do czego potrzebujesz tego COM, bo słyszałem, że o ile drukarki fiskalne czy inne popularne urządzenia działają na takich adapterach bardzo dobrze, to jakieś mniej popularne urządzenia jak interfejsy diagnostyczne mogą nie chcieć współpracować.

    Sęk w tym, że karta śmigała bez problemu pod win10 1511. Problem "wyskoczył" jak Microsoft zaczął mnie molestować aktualizacją do 1709 (Molestował też aktualizacją 1607 ale szybko dał spokój). Właśnie przez tą upie...ść aktualizacji (codziennie, a nawet 2x dziennie uruchamianie aktualizacji, info o napotkaniu problemu i powrót do poprzedniej wersji win10 i tak w kółko) postanowiłem wreszcie zmierzyć się z tematem i odniosłem aktualizacyjny sukces po wyjęciu karty PCI-E portów COM i LPT.
    A COM jest mi potrzebny właściwie tylko do podglądu transmisji RS485 pomiędzy projektowanymi urządzeniami, ewentualnie ładowania do nich ustawień konfiguracyjnych (prosty UART, na kompie korzystam z Hyper Terminala skopiowanego z Win XP).
    Początkowo karta miała też mi zapewnić LPT do podłączenia leciwego programatora UPROG. Ale sprawa padła ze względu na brak możliwości wybrania w UPROGu innego adresu dla LPT niż te dwa stosowane jeszcze w czasach DOSa (a tych z kolei nie udostępnia karta).

    Dodano po 16 [godziny] 46 [minuty]:

    310artur napisał:
    Mnie dziwi że system wcale nie wstaje z kartą

    Jest poniedziałek, więc kontynuuję tą nierówną walkę.
    Po drugim wyłączeniu kompa z przycisku, czyli za trzecim razem uruchomienie poszło dalej, do ekranu startowego. No i wyskoczył BSOD. Kod zatrzymania: PAGE FAULT IN NONPAGED AREA. Bez dodatkowych informacji, czy kodu błędu.
    Po zrestartowaniu się uruchomienie dotarło do tego samego momentu i BSOD. Za trzecim razem wszedł tryb diagnostyczny. Spróbowałem "Naprawę systemu podczas uruchamiania". Bez powodzenia ("system nie mógł naprawić problemu", czy jakoś tak). Szczerze mówiąc na tej karcie nie zależy mi aż tak bardzo, żeby przy moim niedouczeniu ryzykować poważniejszym zkaszanieniem systemu. Ale ewidentnie to karta włożona w PCIe powoduje problem.
    Posłałem jeszcze maila do Digitusa. Zobaczymy, czy coś odpowiedzą. Ale pewnie: kup nową wersję bo ona chodzi pod win10.

    0
  • Pomocny post
    #8 15 Sty 2018 13:52
    masterten
    Poziom 28  

    PAGE FAULT IN NONPAGED AREA to jest właśnie błąd który dawniej miał numer 0x00000050
    Możesz wrzucić tutaj plik zrzutu pamięci z tego blue screena który będzie w katalogu c:\windows\minidump i spróbuję odczytać coś o przyczynie błędu.

    0
  • #9 15 Sty 2018 15:05
    grzemo2
    Poziom 8  

    masterten napisał:
    PAGE FAULT IN NONPAGED AREA to jest właśnie błąd który dawniej miał numer 0x00000050
    Możesz wrzucić tutaj plik zrzutu pamięci z tego blue screena który będzie w katalogu c:\windows\minidump i spróbuję odczytać coś o przyczynie błędu.

    W załączniku plik dmp, spakowany.

    EDIT
    Chyba temat można zamykać. Dostałem odpowiedź z Digitusa:
    Dear Customer,
    sadly, this card isn't supported under 1709, there is also no update planned currently.
    Is it possible that you can uninstall the update?

    No aktualizacji raczej nie będę odinstalowywał.
    Dziękuję za podpowiedzi i zaangażowanie.

    Scaliłem. RADU23

    0
  • Pomocny post
    #10 15 Sty 2018 21:31
    masterten
    Poziom 28  

    Jeśli dobrze znalazłem, że to produkt Digitus DS-30040-2, to ostatni sterownik na ich stronie jest w wersji 3.0.0.0 z 2014 roku.
    Na stronie ASIX, do MCS9901 jest sterownik 3.18.1.0 z roku 2016:
    http://www.asix.com.tw/FrootAttach/driver/MCS..._Win10_Win8.x_64bit_driver_v3.18.1.0_WHCK.zip

    Spróbuj, może zadziała.
    Z pliku minidump wyczytałem jedynie, że sterownikiem który się wysypał jest "StnSport.sys" czyli faktycznie sterownik tego kontrolera.

    0
  • #11 15 Sty 2018 23:54
    grzemo2
    Poziom 8  

    masterten napisał:
    Jeśli dobrze znalazłem, że to produkt Digitus DS-30040-2

    Moja karta to DS-30040-1 czyli wcześniejsza wersja. Na stronie Digitusa jej nie ma, nawet w archiwum.
    Próbowałem użyć sterowników do wersji -2 ale bez powodzenia.
    Dzięki za info o StnSport.sys. Problemem może być to o czym pisaliśmy wcześniej: uninstal nie usunął starych sterowników z systemu. W menadżerze urządzeń niczego nie ma, ale w rejestrze znalazłem mnóstwo śladów. Szczerze mówiąc nie wiem jak to skutecznie posprzątać.

    0
  • #12 16 Sty 2018 00:11
    310artur
    Poziom 43  

    Może zainstalować całe te sterowniki i usunąć za pomocą "Revo uninstaller". Generalnie odradzam wszelkie "automaty" ale tego programu używam jak normalne formy odinstalowania zawodzą. Nagminnie nie ale jako narzędzia ratunkowego można próbować. Nigdy jak dotąd nie narobił bałaganu a posprzątać pomógł nie raz. Choć przyznam do takiego zadania nie testowałem.

    0
  • #13 16 Sty 2018 14:29
    grzemo2
    Poziom 8  

    Jest sukces!
    Walki trwały długo i trudno będzie mi odtworzyć pełny ciąg zdarzeń. Ale na pewno pomogło uruchomienie kompa w trybie awaryjnym z włożoną kartą i usunięcie z menadżera urządzeń karty i jej oprogramowania. Po tej operacji ale i kolejnym niebieskim ekranie system wreszcie się uruchomił, w menadżerze pojawiła się karta bez zainstalowanych sterowników. Zrobiłem Aktualizuj sterownik (system znalazł go w sieci). Dla portu LPT poszło bez problemu, dla COM zaraz po komunikacie o pomyślnym zaktualizowaniu sterownika ... BSOD. Powtórzyłem operację z trybem awaryjnym, ale tym razem przed ponownym uruchomieniem komputera wyjąłem kartę. Już w normalnym trybie i bez karty odpaliłem setupa ze sterownikami wyszukanymi przez mastertena (dzięki!). Setup zauważył, że w systemie są już jakieś sterowniki (starsze setupy tego nie sygnalizowały), wybrałem ich zastąpienie nowymi. Teraz to już tylko wyłączenie kompa, włożenie karty i restart. I cud: wszystko zainstalowało się prawidłowo, COM działa, w obie strony!
    Czyli najprawdopodobniej kluczem do sukcesu było zmuszenie systemu do skorzystania z nowych sterowników, co nie było łatwe.
    Wielkie dzięki za cenne uwagi. Udało się ożywić kartę mimo, że sam producent stwierdził, że się nie da.

    0
  • #14 16 Sty 2018 22:36
    310artur
    Poziom 43  

    Poinformuj jeszcze producenta w swojej dobroci serca :D Może się "zmobilizuje" i wesprze kartę żeby gorszym nie być od konkurencji to w razie czego będzie łatwiej.
    No i mówiłem - że nie działa OK ale nie powinna blokować systemu. Ach ten uparty windows nie chce oddać sterowników :D

    0
  • #15 17 Sty 2018 10:06
    grzemo2
    Poziom 8  

    310artur napisał:
    Poinformuj jeszcze producenta w swojej dobroci serca :D

    Nie odmówiłem sobie tej przyjemności :) Chyba się speszył bo nie odpowiada.

    0