Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Vertrigo server - łączy się z siecią tylko gdy uruchomię go jako admin

21 Sty 2018 19:19 765 2
  • Poziom 9  
    Witajcie,

    zaczynam naukę PHP i potrzebny mi jest Vertrigo Server, ale niestety otrzymuję komunikat o braku poprawnego działania Serwera HTTP Apache oraz serwera MySQL.
    Vertrigo server - łączy się z siecią tylko gdy uruchomię go jako admin

    Próbowałem już tego, co pokazują na youtube o tytule: "how to fix vertrigo apache http server does not work correctly on port 80" (niestety mam zbyt mało postów, żeby dodać tutaj linka), ale to rozwiązanie pomogło tylko połowicznie - dowiedziałem się, że mogę we właściwościach ustawić, by zawsze otwierał się program tak, jakbym go otwierał jako administrator, z tym że wolałbym, alby Vertrigo łączył się z siecią bez konieczności uruchamiania go z pozycji administratora.

    Próbowałem również tych rozwiązań:
    - odblokować port w zaporze windows 7, 8 i 10, czyli stworzyłem nowe reguły ruchu przychodzącego dla różnych portów, szczególnie 80, 443, 3306 (w google można znaleźć ten artykuł wpisująć: Jak odblokować port w Zaporze Windows 7, 8.1 i 10)
    - oraz porad z tego artykułu "WINDOWS 10 BLOKUJE PORT 80, ROZWIĄZANIE PROBLEMU" (w google można wpisać - bo znów nie mogę dodać linku zewnętrznego tutaj)
    ... ale żadne z tych rozwiązań nie przyniosło rezultatu.

    Próbowałem również czegoś takiego:
    Wszedłem do ustawień zaawansowanych firewalla. Zauważyłem, że są tam 3 rodzaje profilów:
    - profil domeny
    - profil prywatny
    - profil publiczny (jest aktywny)

    Wszedłem w “Reguły przychodzące” i właściwości ‘Apache HTTP Server’ (są tam dwie tak samo nazywające się pozycje - te same). W zakładce “Programy i usługi” ma ścieżkę do Vertrigo server. Na liście ma dozwolone akcje przychodzące.
    Vertrigo server - łączy się z siecią tylko gdy uruchomię go jako admin

    Wszedłem w “Reguły wychodzące” i nie zauważyłem na liscie nazwy ‘Apache HTTP Server’, więc ją stworzyłem z takimi samymi ustawieniami, jak w ‘Regułach przychodzących’.
    Vertrigo server - łączy się z siecią tylko gdy uruchomię go jako admin

    W “Monitorowanie” -> “Zapora” jest coś takiego:
    Vertrigo server - łączy się z siecią tylko gdy uruchomię go jako admin

    Zmieniłem więc aktywny profil na prywatny. Podczas uruchamiania Vertrigo zapora Firewall znów zapytała mnie o zezwolenie na połączenie, z tym że tylko w sieci prywatnej - ta druga (publiczna) była nieaktywna. Program nadal nie chce się łączyć z siecią. Windows nadal informuje o braku poprawnego działania Serwera HTTP Apache oraz serwera MySQL (czyli ten co na samej górze w tym poście).

    W ustawieniach zaawansowanych zapory, w Regułach przychodzących widnieją teraz 4 pozycje o nazwie ‘Apache HTTP Server’. - dwie dla sieci publicznych i dwie dla prywatnej.

    Pojawia mi się również taki komunikat, ale nie wiem co on oznacza:
    Vertrigo server - łączy się z siecią tylko gdy uruchomię go jako admin

    Czy ktoś z Was wie, jak rozwiązać problem, ewentualnie mógłby skierować do miejsca, gdzie będą wiedzieli co jest problemem? Przypuszczam, że problem jest prosty do załatwienia, ale ja się kompletnie nie znam na sieciach itp. rzeczach.
  • Poziom 9  
    Wyłączyłem zaporę i Vertrigo nadal nie chce połączyć się z siecią. Na jakimś forum czytałem, że ten problem jest powszechny. Ktoś radził, żeby wyłączyć, albo odinstalować MySQL Server, ale ja nawet nie wiem gdzie tego szukać. Z resztą to była wypowiedź z 2009 roku, więc nie wiem nwt czy coś takiego wgl jeszcze istnieje, żeby tego szukać na moim kompie :/

    Edit:
    Pomogło odinstalowanie Vertrigo i zainstalowanie na partycji D:\
    Wciąż jednak zastanawiam się, dlaczego na C:\ działał tylko wtedy, gdy uruchomiłem go jako admin.