Elektroda.pl
Elektroda.pl
X
Elektroda.pl
AdexAdex
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbka

mar449 14 Kwi 2019 21:59 5982 116
  • #91
    mar449
    Poziom 9  
    Witam. Do kolegi _jta_
    Kondensatory są dwa tak jak na schemacie.
    Wylutuję je i wlutuję jeden tak jak sugerujesz -jak się uda to jutro i napiszę co to zmieniło.
    Do kolegi CYRUS2
    Przykro mi to pisać, ale mam wrażenie kolega nie chce mi w niczym pomóc i jest nastawiony tylko na bezsensowną kłótnię z kol. _jta_
    W # 71 zadałem koledze kilka istotnych pytań odnośnie jego schematu, który ma niekompletny opis elementów. Niestety był czas kłócić się o bzdety, ale odpowiedzi na moje pytania nie ma do dziś. Wiele razy korzystałem z pomocy na elektrodzie, i dotąd zawsze spotykałem fajnych ludzi, którzy chcieli pomagać, a teraz pierwszy raz spotykam się z takim brakiem życzliwości. Proszę, żeby kolega CYRUS2 się ogarnął, wziął jakieś zioła na uspokojenie, albo przestał brać udział w tej dyskusji, bo jak będę musiał nadal coś takiego czytać, chyba zrezygnuję z tego forum.
  • AdexAdex
  • #92
    CYRUS2
    Poziom 40  
    mar449 napisał:
    Do kolegi CYRUS2
    W # 71 zadałem koledze kilka istotnych pytań odnośnie jego schematu, który ma niekompletny opis elementów.
    ale odpowiedzi na moje pytania nie ma do dziś.
    Dlaczego kolega kłamie ?
    Dostał kolega odpowiedzi w poście #72.
    Nawet zaproponowałem na PW wszystkie elementy w prezencie.
    Jeszcze mało ?
    mar449 napisał:
    a teraz pierwszy raz spotykam się z takim brakiem życzliwości. Proszę, żeby kolega CYRUS2 się ogarnął
    Chciałem nawet dać elementy w prezencie, a kolega mar449 nazywa to brakiem życzliwości !!!

    Żałuję, że chciałem pomóc i zamieściłem swój schemat na forum.
    Więcej takiego błędu nie zrobię.
  • AdexAdex
  • #93
    _jta_
    Specjalista elektronik
    Było pytanie: Podpowiedz, który z tych tranzystorów które wymieniłem będzie dobry.

    I odpowiedź: Trzeba im sprawdzić napięcia progowe.
    Barierą jest napięcie wyłączania aku 5,25V.
    To oznacza że tranzystor musi dawać prąd ok.400mA przy wysterowaniu napięciem 4,3V.


    No i jest to błędna odpowiedź. Napięcie progowe, to napięcie, przy którym MOSFET zaczyna przewodzić niewielki prąd, zwykle 0.25mA (dużo za mało dla silnika, który potrzebuje ponad 1000 razy więcej). A to, że tranzystor da 400mA, to mało - on ma mieć mały spadek napięcia przy 400mA - a więc ma mieć małą oporność, np. 0.1 oma przy napięciu bramki 4V.
  • #94
    CYRUS2
    Poziom 40  
    Cyrus2 napisał:
    Barierą jest napięcie wyłączania aku 5,25V.
    To oznacza że tranzystor musi dawać prąd ok.400mA przy wysterowaniu napięciem 4,3V.
    _jta_ napisał:
    No i jest to błędna odpowiedź.
    Nie wciskaj ciemnot kolego jta.
    Tego tekstu nie rozumiesz - to idź do do szkoły i naucz się czytać po polsku.
    _jta_ napisał:
    V531 to złudzenie Nie miernik, tylko klasa 0.01% - on miał dużo gorszą, a i to nie wiem, czy nie naciąganą.
    Nawet inżynierom z firmy Meratonik zarzucasz kłamstwa i naciąganie.
    To ostatni post w tym temacie.
  • #96
    mar449
    Poziom 9  
    Do kolegi CYRUS2'
    Faktycznie odpowiedź znalazłem i w niej odpowiedzi na wszystkie zadane przeze mnie pytania. Mogę Kolegę CYRUS2 tylko bardzo przeprosić za to, że przedstawiłem, go w fałszywym świetle. Bardzo przepraszam i proszę o wybaczenie.(Mam nadzieję,że przeprosiny zostaną przyjęte). Naprawdę tego posta nie widziałem i myślałem, że nie ma odpowiedzi, dlatego tak napisałem całkiem niepotrzebnie.
    Ps.
    Faktycznie była prywatna wiadomość z chęcią sprezentowania wszystkich elementów do tego układu i czegoś więcej, ale trafiła do kosza. TYM BARDZIEJ JEST MI PRZYKRO, ŻE TO NAPISAŁEM..
  • #97
    _jta_
    Specjalista elektronik
    :arrow: #95 - Już ktoś to przeliczył, zbudował, wy testował, po co wyważać otwarte drzwi?
    Tylko zmienić tranzystor na jakiś LogicLevel.


    Przecież właśnie to rozwiązanie znamy i od dawna je dyskutujemy - CYRUS2 napisał jest źle zaprojektowany i potem #88 stwierdził, że histereza w tym układzie nie działa.

    Oczywiście, wyłączanie przy 5.3V jest raczej nie do wykonania z TL431 - trzeba by mieć MOSFET-a z kanałem P, któremu -2.8V na bramce wystarczy do pełnego włączenia. I R1 trzeba zmienić - jeśli TL431 będzie potrzebował prądu 0.74mA, żeby normalnie działać, to przy obecnym R1 będzie na nim ponad 5V, a to zapewne spowoduje częściowe otwarcie T1.

    Cały problem jest w tym, że przy małych napięciach trzeba starannie dobierać parametry użytych elementów - dlatego zaproponowałem LM4041-ADJ zamiast TL431 (bo jest na mniejsze napięcie i ma mniejszy minimalny prąd) i N-MOSFET-a (bo łatwiej o Logic Level, niż dla P-MOSFET-ów), a i to mało który MOSFET Logic Level się nadaje. Schemat zamieścił autor w #46.
  • #98
    CYRUS2
    Poziom 40  
    mar449 napisał:
    .............
    Żal mi amatorów którzy chcą koniecznie sami coś zrobić, a brakuje im wiedzy.
    Szkoda, żeby się "użerali się" z układami które nie będą działać tak jak autorzy tego chcą.
    Powinni zrobić według schematu.
    Cieszyć się że sami coś zrobili i to spełnia ich oczekiwania.

    Sam wiedzy kiedyś potrzebowałem.
    Tylko dlatego jestem na forum.
    Ps Pewne słuszne zasady = należy zapominać aż 77 razy.
  • #99
    mar449
    Poziom 9  
    Witam.
    Do _jta_
    Odp do# 87 Do autora: jak obecnie jest z kondensatorami? Są wciąż dwa, czy jeden? Jaki i gdzie podłączony? Myślę, że rozsądnie byłoby dać kondensator kilka nF przy LM4041-ADJ między pinami 1 i 3, a usunąć oba pozostałe.

    Wylutowałem oba i wlutowałem jeden 6 nF między piny 1 i 3. Po dokonaniu tych zmian włączenie nadal następuje stopniowo. Chociaż od pojawienia się napięcia na wyjściu do pełnego załączenia tranzystora wystarczy wzrost napięcia na wejściu o 0,15V to przy powolnym wzroście napięcia na akumulatorze podczas ładowania go, to nie powinno być tego zjawiska.
    Do CYRUS2. A co ja robię jak nie wykonanie układu z gotowego podanego na forum schematu? Problem w tym,że nie wiem który schemat będzie działał zanim go nie uruchomię. Pozdrawiam. Marek.
  • #100
    mar449
    Poziom 9  
    Witam. Zauważyłem, że kondensator między pinami 1-3 układu LM spowalnia załączanie silnika, a między pinami 1-2 wyłączanie i usunąłem wszystkie kondensatory.
    Załączanie i wyłączanie wygląda teraz dobrze.
    Na wyjściu ukladu LM (3 pin) oscyloskop pokazał:
    To wykres przy szybkim załączeniu i wyłączeniu silnika przez zmianę napięcia:
    zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbkaIMG_23..JPG Download (32.29 kB)
    ten przy powolnym podnoszeniu napięcia:
    zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbkaIMG_23..JPG Download (34.05 kB)
    a ten przy powolnym obniżaniu napięcia.
    zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbkaIMG_23..JPG Download (32.23 kB)
    Napięcie zmieniałem pot. dokładnej regulacji na zasilaczu laboratoryjnym najwolniej jak się dało po ułamku milimetra.
    Te szpilki to chyba od silnika, bo pracuje głośno i nieregularnie, Chyba uszkodzone przekładnie.
    Czy ten układ może pracować bez kondensatorów?
  • #101
    _jta_
    Specjalista elektronik
    28 Kwi 2019 18:01 mar449 napisał:
    Te szpilki to chyba od silnika, bo pracuje głośno i nieregularnie, Chyba uszkodzone przekładnie.
    Czy ten układ może pracować bez kondensatorów?

    Jeśli się nie wzbudza, to może. Zakłócenia od silnika - jeśli to jest szczotkowy, to generuje zakłócenia przy przełączaniu sektorów komutatora. Jeśli pracuje głośno i nieregularnie przy zasilaniu z baterii/akumulatora bez elektroniki, to prawdopodobnie zużyte szczotki, być może pył ze szczotek zrobił zwarcia na komutatorze; jeśli tak jest tylko z elektroniką, to pewnie masz w niej jakieś wzbudzenie.
  • #102
    mar449
    Poziom 9  
    Dzięki za odpowiedź. Z akumulatora pracuje identycznie- nieregularnie i zgrzyta. To jest używany serwomechanizm modelarski mg 995 z usuniętą elektroniką i usuniętym bolcem blokady.
    Powiedz co sądzisz o działaniu tego układu który budujemy? Czy może pracować bez kondensatorów? I czy to jest twoim zdaniem (patrząc na oscyloskop) prawidłowe przełączanie?
  • #103
    _jta_
    Specjalista elektronik
    Po pierwsze nie wiem, co mierzysz - napięcie (gdzie?), prąd? Odnoszę wrażenie, że przy włączaniu pojawiają się jakieś oscylacje - jakkolwiek, jeśli to jest 100 sampli na sekundę, to mało co można zobaczyć. Na pierwszym przebiegu trudno powiedzieć, czy jest coś złego, czy nie; na drugim po skoku w górę jest wyraźna szpila w dół.

    Ale to nie musi być złe działanie elektroniki - uzwojenia silnika mają całkiem sporą indukcyjność, i oprócz niej pojemność, razem to się składa na jakiś obwód rezonansowy, może to są oscylacje tego obwodu? Można spróbować je wytłumić jakimś układem RC, ale na to trzeba znać ich parametry.
  • #105
    _jta_
    Specjalista elektronik
    Po pierwsze, nadal nie wiadomo, czy widzisz rzeczywisty przebieg o częstotliwości około 600 Hz, czy też jest to zdudnienie rzeczywistego przebiegu i samplowania. Trzeba to obejrzeć na większej częstotliwości samplowania - może masz przebieg, którego samplowanie 2.5 kHz nie odczytuje nawet z grubsza prawidłowo.

    Po drugie, jak już zobaczysz, jaką częstotliwość naprawdę tam masz, to sprawdź, co się stanie, kiedy zamiast silnika podłączysz taki opornik, przez który popłynie podobny prąd.
  • #106
    mar449
    Poziom 9  
    Ok. Czy oscyloskop Tektonix TDS 420A to zmierzy?
    Jeżeli tak, to zorganizuję odpowiedni opornik i to zmierzę. Nie mam do tego oscyloskopu instrukcji i to pierwszy oscyloskop z jakim miałem do czynienia. Fotki zrobiłem canonem, ale przebieg dosyć szybko się przesuwał, pewnie można ustawić jakieś wyzwalanie pomiaru zboczem, ale jeszcze do tego nie doszedłem. Będę próbował, potrzeba mi na zdobycie rezystora ze dwa dni.
  • #108
    mar449
    Poziom 9  
    Wiem, że to jest trudne, ale nie znam nikogo biegłego w tym temacie. Instrukcji obsługi nie ma w polskim języku. Czytam podstawy obsługi oscyloskopu, ale ten mój chyba ma więcej nastaw. Odezwę się, jak to sprawdzę z rezystorem.
  • #110
    _jta_
    Specjalista elektronik
    Kiedy akumulator jest rozładowany, to tranzystor T1 przewodzi i z akumulatora jest pobierany prąd dla LED1 + prąd dla cewki przekaźnika. Świetne narzędzie do wykańczania akumulatora. Niestety, jakoś tak jest, że często projektanci takich układów nie myślą o tym, by rozładowanego akumulatora nie rozładowywać jeszcze bardziej...
  • #111
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #112
    _jta_
    Specjalista elektronik
    Link: #66. Pisałem o nim wytrzyma tyle, ile wzmacniacz operacyjny, który jest zasilany napięciem wejściowym - jest kwestia, czy ta wada jest akceptowalna (wymaga nie za wysokiego napięcia wejściowego, albo innego wzmacniacza). Ale to inny temat i układ służy do czego innego.

    Którego kolega jta nie potrafi poprawić.

    Mam wrażenie, że pisałem, co poprawić, ale nie widziałem, by autor tematu pisał, że tak zrobił.
  • #113
    mar449
    Poziom 9  
    Witam. do kolegi Hydrantx. Dla mnie to nie jest męka tylko nauka. To jest moje hobby. Nic co się lubi nie męczy. Jeżeli się da, to chcę to uruchomić. Idzie wolno, bo mam na to teraz mało czasu. Poza tym układ który zrobiłeś działa na wyższe napięcia, a to jest dużo łatwiejsze. Takich zabezpieczeń do aku. 12 wolt zrobiłem kilka i działają poprawnie ( chociaż schemat był inny). Zauważ, że kolega _jta_ Tego układu nie buduje i nie uruchamia. Wszyscy go krytykują, a on nie ma żadnych możliwości nic w tej kwestii zrobić. Może tylko pomagać podpowiadając co poprawić. I to robi. Jeżeli chcesz koniecznie krytykować to krytykuj mnie, bo to ja nieudolnie uruchamiam ten układ.
  • #114
    mar449
    Poziom 9  
    Witam. Podłączyłem rezystor zamiast silnika.
    1). Przy podnoszeniu napięcia na wejściu jest stopniowe załączanie tranzystora. Potrzebna zmiana na wejściu od 6.21 do 6.24V ,żeby tranzystor się załączył.
    2). Podczas obniżania napięcia jest dużo gorzej. Przy powolnym spadku napięcia na wejściu następuje stopniowy spadek napięcia na wyjściu LM. Napięcie na wyjściu LM spada stopniowo o około 2,2V ( od 4,5V do 2,3V) a potem nagle spada do wartości 0.15V. co powoduje całkowite wyłączenie tranzystora. Na wejściu potrzebna jest zmiana od 5.24 do 5.19V żeby całkowicie wyłączyć tranzystor.
    W stanie pośrednim występuje niewielka oscylacja napięcia na wyjściu LM rzędu 0.3V. Wykres oscylacji przy wyłączaniu i załączaniu tranzystora wygląda na oscyloskopie tak samo.
    W stanie całkowitego wyłączenia i pełnego załączenia tranzystora wykres napięcia na wyjściu LM ładny.
    Prąd na rezystorze 0.8A. (przy poborze 0.2A wszystko było podobnie, tylko progi wyłączania i załączania trochę się przestawiły.)
  • #115
    mar449
    Poziom 9  
    Witam. Wygląda na to,że kolega Cyrus2 miał rację, że w tym układzie histerezy i poprawnego działania nie da się uzyskać. Proszę kolegę _jta_ o odpowiedź czy ma jeszcze jakiś pomysł, żeby to usprawnić. Jeżeli będą jakieś sugestie, to je wypróbuję, ale zbieram elementy, żeby złożyć układ, który zaproponował kolega Cyrus2 w# 58.
  • #116
    _jta_
    Specjalista elektronik
    Problemem jest to, że w układzie występuje wzbudzenie. Niestety nie studiowałem elektroniki, ale wiem o takiej zasadzie, że jak są w pętli trzy podobne stopnie wzmocnienia odwracające fazę, to wzbudzenie jest (niemal) pewne; to był problem przy konstruowaniu wzmacniaczy operacyjnych, w końcu znaleziono takie rozwiązania konstrukcyjne, że tylko jeden stopień odwraca fazę (tranzystor w układzie wspólnego emitera), pozostałe nie (tranzystory w układzie wspólnego kolektora, albo wspólnej bazy); w scalonych wzmacniaczach akustycznych często podłączało się kondensator, albo kondensatory tak, by ograniczyć pasmo przenoszenia dla jednego stopnia (na ogół albo kondensator kolektor-baza przy tranzystorze, albo do tego kondensator baza-masa przy tym samym tranzystorze - takie rozwiązania na ogół były skuteczne, inne nie - wzmacniacz się wzbudzał, albo zniekształcał, bo był blisko progu wzbudzenia (z praktyki pamiętam wzmacniacz, który miał kondensator kolektor-baza i zniekształcał - dodałem kondensator baza-masa i zaczął dobrze działać).

    Coś podobnego trzeba zrobić w twoim układzie, żeby przestał się wzbudzać, bo najwyraźniej to psuje jego działanie. Proponowałem kondensator anoda(to ta końcówka, która ma być połączona z bramką MOSFET-a)-ADJ przy LM4041-ADJ; może być jeszcze potrzebny ADJ-katoda. Niestety nie wiem, jaki dobrać, ale raczej 1nF, niż 100nF.

    Przy podłączeniu silnika, lub czegokolwiek, co ma indukcyjność, może wystąpić wzbudzenie spowodowane występowaniem indukcyjności i pojemności uzwojeń - działają one jak obwód rezonansowy. Moja propozycja: opornik zbliżony do stosunku napięcia do prądu silnika, szeregowo z nim kondensator (tu 100nF, albo i więcej, ale nie elektrolit, będzie na miejscu), i taki układ podłączony równolegle do silnika - tego typu układy często podłącza się do scalonych wzmacniaczy akustycznych równolegle do głośnika.
  • #117
    mar449
    Poziom 9  
    Witam. Ponieważ nie udało się uruchomić układu z którym walczyliśmy z kolegą_jta_, uruchomiłem układ kolegi CYRUS2. Układ działa prawidłowo i jest łatwy do regulacji. Najpierw ustawiamy napięcie wyłączenia przy zerowej histerezie, a potem zwiększamy histerezę kontrolując napięcie włączenia i napięcie wyłączenia.
    Przypominam schemat i wrzucam widok płytki i rozmieszczenie elementów, gdyby ktoś chciał skorzystać. Bardzo dziękuję wszystkim za pomoc, a najbardziej koledze CYRUS2.
    zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbkaschema..jpg Download (6.35 kB) zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbkapłytka.png Download (91.26 kB) zabezpieczenie akumulatora przed nadmiernym rozładowaniem (MOS) przeróbkarozmieszcz...mentów.png Download (821.11 kB)
    Widok płytki jest odwrócony, czyli gotowy do wydruku do termtransfru, natomiast ten ukazujący rozmieszczenie elementów pokazuje widok płytki od strony ścieżek drukowanych. Tranzystor można dać jakiś inny, na przykład do montażu przewlekanego, po dobraniu parametrów. Wymiary płytki wynoszą 18X45 mm.
    Pozdrawiam. Marek.