Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

UWAGA! Tania przetwornica step up/down - niespodzianka... XL6009

SylwekK 19 Lip 2018 11:44 8832 52
  • #31
    SylwekK
    Poziom 30  
    Niestety, ale twoje przykłady są kompletnie nietrafione ;-)
    Szyszkownik Kilkujadek napisał:

    Ależ proszę bardzo, pierwszy z brzegu:
    Montując instalację LPG do samochodu należy mieć zawsze benzynę w zbiorniku paliwa. Nawet jeśli jeździsz tylko na gazie i nie samochód od razu odpala na LPG. Przy braku benzyny, zatarciu ulegnie pompa paliwa.

    O tym zostaje użytkownik powiadomiony po instalacji (mnie mechanik informował). Poza tym tu są już dwa elementy -
    zbiornik paliwa i drugi lpg. Nijak się ma to do omawianej sytuacji zasilania.

    Szyszkownik Kilkujadek napisał:
    Inny przykład? Producent samolotu nie gwarantuje poprawnej pracy silników jeśli w zbiornikach jest mniej niż zalecana ilość paliwa.

    Odpowiedź zawarta w cytacie "nie gwarantuje", ale nie znaczy też, że na oparach nie doleci awaryjnie do lotniska.
    Szyszkownik Kilkujadek napisał:
    A co będzie jak zalejesz paliwo o niższej liczbie oktanowej niż minimalna zalecana przez producenta silnika? No też może nie pracować prawidłowo.

    Ile masz takich stacji benzynowych, na których popełnisz ten błąd? :)
    Szyszkownik Kilkujadek napisał:
    Kolejny? Żeby nie było, przykład z branży elektro: Co się stanie jak zasilisz silnik napięciem niższym od znamionowego i obciążysz znamionowym momentem? Cieplutko się zrobi. :-)

    I najbardziej nietrafiony argument ;-) Logika sama podpowiada, że coś tu jest nie tak... Podajesz za niskie napięcie i dziwisz się, że nie kręci - masz przynajmniej czas żeby zareagować zanim się sfajczy- robisz błąd na własne życzenie. W przypadku omawianej przetwornicy logika idzie w maliny biorąc pod uwagę efekt końcowy.
  • PCBway
  • #32
    Szyszkownik Kilkujadek
    Poziom 35  
    SylwekK napisał:
    O tym zostaje użytkownik powiadomiony po instalacji (mnie mechanik informował).

    A producent przetwornicy nie poinformował Cie jaki jest zakres napięć zasilających?
    SylwekK napisał:
    Odpowiedź zawarta w cytacie "nie gwarantuje", ale nie znaczy też, że na oparach nie doleci awaryjnie do lotniska.

    Może doleci, a może nie doleci. Ale zgodzisz się że tutaj ryzyko podejmuje na pewno nie producent?
    SylwekK napisał:
    Ile masz takich stacji benzynowych, na których popełnisz ten błąd?

    Jakieś 6500 w całym kraju. Znane są przypadki, gdy małe samoloty tankowane były nie paliwem lotniczym, a paliwem samochodowym.
    SylwekK napisał:
    I najbardziej nietrafiony argument Logika sama podpowiada, że coś tu jest nie tak... Podajesz za niskie napięcie i dziwisz się, że nie kręci - masz przynajmniej czas żeby zareagować zanim się sfajczy- robisz błąd na własne życzenie. W przypadku omawianej przetwornicy logika idzie w maliny biorąc pod uwagę efekt końcowy.

    Tak samo masz czas, żeby zareagować gdy przetwornicę zasilasz za niskim napięciem i widzisz, że na wyjściu jest nieprawidłowe napięcie. Powiedz mi na czyje życzenie przetwornica dostała za niskie napięcie? Kto popełnił błąd? Producent czy Ty?

    Być może moja logika jest inna od Twojej. Moja logika: urządzenie zasilane napięciem niższym od znamionowego = może nie pracować prawidłowo. Należy zapewnić urządzeniu prawidłowe zasilanie, albo odłączyć.

    Myślisz, że po co są zabezpieczenia podnapięciowe w energetyce?
  • PCBway
  • #33
    SylwekK
    Poziom 30  
    Kolego czy Ty naprawdę nie widzisz tej subtelnej różnicy między tą przetwornicą, a przykładami, które przytaczasz. Idąc tym tokiem rozumowania można przypisać tu każdy przedmiot użytkowany niezgodnie z instrukcją, natomiast mowa tu o urządzeniu niskonapięciowym, bateryjnym nawet bym powiedział, gdzie kompletnie wbrew logice i zdrowemu rozsądkowi przy stopniowym rozładowaniu tej baterii na wyjściu pojawia się napięcie momentalnie zabijające całą elektronikę połączoną do wyjścia o czym się nie mówi(!). Dla mnie ewidentnie jest to wada konstrukcyjna. We wszystkich Twoich przykładach albo była informacja o skutkach albo można było łatwo wyciągnąć logiczne wnioski co się może stać jeśli świadomie wyjdziesz poza zakres. Znajdź mi przykład adekwatny do tej przetwornicy albo skończmy dyskutować, bo ja osobiście nie znam podobnego przypadku takiej dezinformacji, a ten 1% podobnych przypadków podałem tylko dlatego, że nie jestem alfą i omegą i pewnie gdzieś bywają urządzenia zachowujące się niezgodnie z logiką i przewidywaniem, na które się jeszcze nie natknąłem.
    Przeczytaj jeszcze raz pierwszy mój post w tym temacie i wyciągnij na spokojnie wnioski. Pozdrawiam :)
  • #34
    Szyszkownik Kilkujadek
    Poziom 35  
    SylwekK napisał:
    wbrew logice i zdrowemu rozsądkowi przy stopniowym rozładowaniu tej baterii na wyjściu pojawia się napięcie momentalnie zabijające całą elektronikę połączoną do wyjścia o czym się nie mówi(!).

    Nie testujesz zachowania urządzenia pracującego w warunkach poza zakresem znamionowym? Przed jego finalną aplikacją, tego nie robisz? No na pewno robisz.
    Producent samolotów też nie mówi co się stanie gdy zalejesz paliwo samochodowe zamiast lotniczego. Mówi, jakie trzeba zalać i tyle. Zalejesz mniej oktanowe? No chyba logiczne, że jeśli Ci życie miłe to nie.
    SylwekK napisał:
    We wszystkich Twoich przykładach albo była informacja o skutkach albo można było łatwo wyciągnąć logiczne wnioski co się może stać jeśli świadomie wyjdziesz poza zakres.

    Zgodzę się, że opisane przez Ciebie zachowanie przetwornicy może być zaskakujące. Od początku się z tym zgadzam. Ale powtarzam: nikogo nie powinno dziwić, że jakieś urządzenie (szczególnie tania masówka z Chin) płata figle przy pracy w warunkach nie-znamionowych.
    Jeszcze raz dzięki za ostrzeżenie. Zapadło mi w pamięć. Nie znałem tego efektu przetwornic. Chociaż jak teraz analizuję to myślę że rozumiem skąd się bierze.
    Tyle ode mnie.
  • #35
    Slawek K.
    Poziom 31  
    Kolega @SylwekK ma racje, bo kazdy w tym przypadku spodziewalby sie, ze gdy podamy na wejscie napiecie nizsze niż zalecane to przetwornica nic nie wypluje na wyjsciu albo da napiecie nizsze niz ustawione, a tu jest zupelnie inny rezulatat, zdecydowanie nieoczekiwany.

    Pozdr
  • #37
    Slawek K.
    Poziom 31  
  • #39
    wosiekpl
    Poziom 21  
    Witam

    Bardzo ciekawy jest temat tego testu. Ponieważ ja zakupiłem dwa takie zasilacze mam w zwiazku z tym pytanie.
    Otoż jeden z nich chcę zastosować do zasilania Arduino Uno. Napięcie wejściowe będzie pobierane z zasilacza impulsowego 24 Vdc 4.2 A , następnie zostanie zmniejszone do 12 V i takim będzie zasilana płytka Arduino. I pytanie jakie mi się nasuwa to czy nie powinienem zastosować zabezpieczenie na wyjsciu tego modułu ?
    Pytam , bo czytając to co jest opisane w tym temacie , boję się , że kiedy po wyłączeniu zasilacza impulsowego , kiedy będzie spadać napięcie to przy tych 3.4 V na wyjściu może pojawić sie napięcie większe niż 12 V i uszkodzić Arduino.
    ( a może taki przypadek tutaj nie wystąpi bo w zasilaczu impulsowym nie ma dużego kondensatora na wejściu i to co piszę nie ma tutaj sensu ? )
  • #40
    Slawek K.
    Poziom 31  
    Po co grzać stabilizator liniowy na arduino podając 12V z przetwornicy, min napięcie zasilania to 7V i takie proponuje ustawić na przetwornicy.

    Pzdr
  • #41
    wosiekpl
    Poziom 21  
    Dziekuję za odpowiedź. Co prawda nie do końca wyjaśnia mi czy moje obawy o bezpieczeństo Arduino mają sens. W każdym razie , kiedy zasilacze dojdą to je zamontuję i zobaczę jak bedą sie sprawować.

    Pozdrawiam
  • #42
    SylwekK
    Poziom 30  
    Przy zasilaniu tej przetwornicy z zasilacza 24V nie powinno być problemu, bo jego kondek wyjściowy będzie już dość znacznie rozładowany i raczej nie pozwoli "odbić" się przetwornicy. Tak czy inaczej lepiej sprawdź to bez podłączania końcowego urządzenia żeby mieć 100% pewności.
  • #43
    maniek1979
    Poziom 11  
    Czy przetwornica na układach LM2596S oraz LM2577S ma ten sam problem? Może ktoś testował?
  • #44
    Szyszkownik Kilkujadek
    Poziom 35  
    Układy XL6009, XL6019 mają ten problem. Testowałem na przetwornicy step-up/step-down bez obciążenia. Zapomniałem sprawdzić pod obciążeniem. :-D
  • #45
    maniek1979
    Poziom 11  
    Ostatnio przetestowałem dwie przetwornice Step Up Down i zauważyłem następny problem. Podczas pracy polegającej na obniżeniu jak ją włączamy to na wyjściu mamy przez moment wyższe napięcie. Ja ustawiłem na wy=12.8V a na we=24V jak podałem zasilanie to przez moment miałem 17V. Usterka ta dotyczyła przetwornicy AT30 na XL6009 Obie zaczynają działać od około 4,5V- 5V bez usterki opisanej powyżej. Testowałem jeszcze SH-PWS14. Oczywiście o deklarowanych prądach producenta należny zapomnieć i grzeją się bardziej od zwykłych UP lub Down.
    AT30 to max 2,2A
    SH-PWS14 to max koło 5,5A
    UWAGA! Tania przetwornica step up/down - niespodzianka... XL6009 UWAGA! Tania przetwornica step up/down - niespodzianka... XL6009
  • #46
    SylwekK
    Poziom 30  
    No i kolejna przetwornica na XL6009 może narozrabiać.
    Właśnie szykowałem zasilanie do nowego układu i pomyślałem, że zrobię sobie test przy okazji. Tym razem to zwykła popularna step up. Przy napięciu wej około 3.3V na wyjściu mamy 45V. Fajerwerki kończą się po obniżeniu napięcia poniżej 2.8V. Uważajcie więc na źródło napięcia jakim je karmicie :)

    UWAGA! Tania przetwornica step up/down - niespodzianka... XL6009
  • #47
    krisRaba
    Poziom 28  
    Ech, szkoda im dwóch rezystorów, żeby zrobić UVLO na pinie EN, w który to XL6009 jest wyposażona :-/
    VinMIN 5V, EN threshold 1.4V.. czy to takie trudne wyliczyć dzielnik?! No ale wiem, pół centa na egzemplarz za rezystory, a przecież bez tego też "działa"...
    Inna sprawa, że w DS tego łopatologicznie nie rozrysowali, tylko dali przy EN przebieg HI/LO z opisem ON / OFF, to może konstruktorzy na to nie wpadli ;) A kto by tam testował jak zachowuje się produkt.. kolego Cziong Paj Fiong napisz, że działa od 5V i po sprawie ;)
  • #48
    SkywalkerPL
    Poziom 6  
    krisRaba napisał:
    Ech, szkoda im dwóch rezystorów, żeby zrobić UVLO na pinie EN, w który to XL6009 jest wyposażona :-/
    VinMIN 5V, EN threshold 1.4V.. czy to takie trudne wyliczyć dzielnik?! No ale wiem, pół centa na egzemplarz za rezystory, a przecież bez tego też "działa"...

    Mógłbyś proszę jaśniej? Jeśli to kwestia dzielnika to chętnie rozbudowałbym swój układ.
    W moim przypadku Li-Pol rozładował się poniżej 3.5V i układ usmażył Atm32U oraz kilka pomniejszych modułów, które zasilał :<
  • #49
    krisRaba
    Poziom 28  
    Tak, to kwestia dzielnika. Nie wiem tylko czy na PCB są jakieś pady pod rezystory. Pewnie nie i trzeba będzie pokombinować, tj. odlutować i podnieść pin EN przetwornicy, bo pewnie jest na krótko podpięty w pozycję ON. No i zrobić dzielnik.
    Po wykonaniu moda przetestować, czy prawidłowo wyłącza się przy obliczonym progu.

    Dodano po 8 [minuty]:

    Zerknąłem jeszcze raz w datasheet i jest szansa, że pin wisi w powietrzu, bo napisali, że niepodłączony jest domyślnie w stanie wysokim, czyli przetwornica załączona. Trzeba sprawdzić miernikiem, czy jest przejście między VIN i EN...
  • #50
    SkywalkerPL
    Poziom 6  
    krisRaba napisał:
    Tak, to kwestia dzielnika. Nie wiem tylko czy na PCB są jakieś pady pod rezystory. Pewnie nie i trzeba będzie pokombinować, tj. odlutować i podnieść pin EN przetwornicy, bo pewnie jest na krótko podpięty w pozycję ON. No i zrobić dzielnik.
    Po wykonaniu moda przetestować, czy prawidłowo wyłącza się przy obliczonym progu.

    Dodano po 8 [minuty]:

    Zerknąłem jeszcze raz w datasheet i jest szansa, że pin wisi w powietrzu, bo napisali, że niepodłączony jest domyślnie w stanie wysokim, czyli przetwornica załączona. Trzeba sprawdzić miernikiem, czy jest przejście między VIN i EN...


    Trochę jest podłączony do Vin, ale przy 3.5V zasilania napięcie na nóżce EN leci z wartości bliskiej Vin do 2.6V i układ zaczyna piłować na wyjściu. Miernik pokazuje brak połączenia z Vin. Na dodatek jak trzymam przewód doprowadzony do EN to układ zaczyna pracować w większym spektrum Vin 🤨

    Czy dobrze rozumiem że powinienem podać na wejście EN stan wysoki z Vin żeby to funkcjonowało czy powinienem utrzymać powyżej 2.6V?
  • #51
    krisRaba
    Poziom 28  
    Wychodzi na to, że ta wewnętrzna polaryzacja EN się rozjeżdża przy niższych napięciach. Spróbuj podpiąć do VIN, bo daje taką możliwość i zobacz jak pracuje. Chociaż UVLO jest lepsze, bo oszczedzi ogniwo wyłączając się odpowiednio wcześniej. No i ciekawe, że karta katalogowa mówi o zakresie pracy od 5V, a produkt złożony niby ma zakres od 3.8V.. ;-) Pewnie ktoś porobił testy i tak mu wyszło, ale to poza specyfikacją.
  • #52
    SkywalkerPL
    Poziom 6  
    Vin na pinie EN nie zmienia nic w kwestii pracy modułu. Wszędzie, gdzie tylko możliwe powinno być napisane wielkimi literami:

    Załączając moduł poniżej 3.8 V lub obniżając jego napięcie zasilania poniżej 3.5 V, można nabawić się przepaleń zasilanych układów. Moduł na samym załączeniu daje +15 V peaku na kilka ms nawet przy poprawnym zasilaniu. Nie wspominając już o pomylonym napięciu wyjściowym przy undervoltagu na wejściu. Paskudztwo.
  • #53
    krisRaba
    Poziom 28  
    To teraz jeszcze spróbuj UVLO. Możliwe, że ten pik na starcie jest związany z ładowaniem kondensatora wejściowego, czyli zanim się naładuje, to chwilowo pracuje na napięciu wejściowym poniżej specyfikacji.
    Z drugiej strony większa pojemność na wyjściu powinna łyknąć taki impuls ;-)