Elektroda.pl
Elektroda.pl
X
Relpol przekaźniki nadzorczeRelpol przekaźniki nadzorcze
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przerzutnik cd 4013 jak zrobić by przerzucał przy spadku napięcia ?

08 Mar 2018 09:01 909 29
  • Poziom 17  
    Witam wszystkich . Męczę się od jakiegoś czasu lecz nic mi nie wychodzi . Jedyna nadzieja w was drodzy forumowicze .
    Mam przerzutnik CD4013 . Potrzebuje by przełączał gdy napięcie w drugim układzie spada z około 14 V na 12,7 V .
    Na wejściu CD4013 podłączałem Ne 555 . Z kolei gdy wejście Ne555 zwieram do masy całość działa niestety gdy na to wejście podłączam drugi układ gdzie spada n apięcie Ne555 nie działa i nie uruchamia CD4013 .
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Relpol przekaźniki nadzorczeRelpol przekaźniki nadzorcze
  • Poziom 36  
    Witaj.
    Czemu do wykrywania zmian napięcia nie używasz komparatora?
  • Poziom 17  
    Bo nie wiedziałem że coś takiego istnieje . Wielkie dzięki nakierowałeś mnie na rozwiązanie. Właśnie się edukuję na temat komparatorów . Przeczytałem kilka artykułów , rozumiem zasadę działania lecz nie mogę znaleść informacji jaka musi być różnica potencjału między dwoma badanymi napięciami tak by komparator zadziałał np. LM 339
  • Poziom 36  
    Czułość przede wszystkim zależy od wzmocnienia wzmacniacza. Zainteresuj się też zagadnieniem stosowania histerezy.
  • Poziom 39  
    Rozwiązanie już miałeś w ręku, tylko nie potrafiłeś go umiejętnie wykorzystać.
    NE555 - ma prawie wszystko, czego potrzebujesz; dwa komparatory i przerzutnik. Brak tylko źródła napięcia odniesienia.
    Ale to żaden problem, dostawiasz zewnętrzne.
    Przerzutnik cd 4013 jak zrobić by przerzucał przy spadku napięcia ?
    Regulacja wstępna:
    * podajesz znamionowe napięcie robocze,mierzysz i zapisujesz napięcie na pinie 5,
    * podajesz napięcie przy którym układ ma zadziałać, ustawiasz połowę zapisanego napięcia na pinie 2,
    * podajesz napięcie przy którym układ ma powrócić do stanu nieaktywnego, ustawiasz zapisane napięcie na pinie 6,
    * sprawdzasz poprawność zadziałania i ew. korygujesz.
  • Poziom 17  
    Kurcze zanim przeczytałem post od zetdeel to już się napracowałem .
    Kupiłem LM 339N przylutowałem na uniwersalnej pytce .
    Zasiliłem niestabilizowanym 17 V .Na wejście komparatora podłączyłem to samo zasilanie przez dzielnik napięcia zrobiony z potencjometra ,ustawiłem na 10 V.
    Badane napięcie też podłączyłem na wejście przez dzielnik napięcia i bez obciążenia ustawiłem również równo 10 V . Na wyjściu podłączyłem diodę led by sygnalizowała pracę komparatora .

    Wszystko działa tylko odwrotnie od zamierzonego celu czyli wyjście jest zwarte gdy oba napięcia na wejściu są równe a gdy jedno spadnie to wyjście rozwiera mase .
  • Poziom 39  
    Witam,
    moze pomyliles wejscie "+" z "-" gdzie masz napiecie odniesienia a gdzie pomiar, dodatkowo sam komparator zasilasz z niestabilizowanego napiecia wiec on bedzie plywal razem z badanym napieciem to nie jest dobre podejscie.
    Wracajac do pytania z tematu postu, da sie to zrobic na 4013, na wejscie wyzwalajace daj tranzystor NPN ktorego baza zawiera rezystor do masy i diode zenera (okolo 13V) do tego napiecie ktore analizujesz z kolektora masz impuls wyzwalajacy o narastajacym zboczu.
    Oczywiscie 4013 i caly uklad zasilasz ze stabilizowanego napiecia.
    Pozdrawiam
  • Relpol przekaźniki nadzorczeRelpol przekaźniki nadzorcze
  • Poziom 39  
    Zamieść schemat, to zobaczymy, co trzeba poprawić.
    Poza tym:
    Cytat:
    Kupiłem LM 339N
    a powinieneś kupić LM393. Komparatory takie same, za to tylko 2, czyli tyle, ile akurat potrzeba.
  • Poziom 39  
    Witam,
    dwa komparatory a po co ? mamy wykryc spadek z 14V na 12.7V i tylko ten, czyli jeden komparator do wejscia "-" dajesz twoje badane napiecie, do "+" dajesz diode zenera 13V do masy i rezystor zapewniajacy odpowiedni prad dla diody do +Ucc stabilizowanego, tym samym napieciem zasilasz komparator. Dodoatkowo miedzy wyjscie a wejscie "+" komparatora daj rezystor powiedmy 100k to na histereze (dobierz wartosc zaleznie od potrzeb)
    Pozdrawiam
  • Poziom 17  
    Stabilizację zasilania i napięcia odniesienia na wejściu komparatora stabilizowałem na LM317 (akurat miałem ) Napięcie badane podłączyłem na wejście "-"(pin numer 6 ) a na wejście "+"podłączyłem stabilizowane (pin numer 7 )

    Niestety układ działa ale nadal odwrotnie czyli gdy napięcia na wejściu są równe to wyjście zwiera do masy a rozwiera gdy napięcie na wejściu "-" spada . :(
  • Pomocny post
    Poziom 39  
    Witam,
    podlaczyles odwrotnie, jak napisalem:
    - wej "-" tu podajesz napiecie odniesienia
    - wej "+" tu napiecie badane
    - GND 0V
    - Ucc +15V (wyzsze lub rowne napieciu badanemu !)
    Jezeli nie chcesz zmieniac swoejego ukladu dodaj inwerter na tranzystorze npn na wyjsciu i gotowe.
    Pozdrawiam
  • Poziom 17  
    Ok teraz działa jak powinien .
    Pojawił się kolejny problem .
    Cały układ steruje przekaźnikiem (wolał bym triakami ) a ten silnikiem od wyciągarki na prąd zmienny 240 V . Przekaźnik steruje prawymi , lewymi obrotami .
    Bez podłączenia silnika układ działa prawidłowo natomiast po podłączeniu układ NE555
    się sam wzbudza i generuje kilka impulsów po uruchomienia silnika .
    Cały układ zasilania scalaków ma dosyć mocno rozbudowany filtr sieciowy wyjęty z laptopa wstawiony po między siecią a trafem .
  • Poziom 39  
    guciofilucio napisał:
    ...Pojawił się kolejny problem .
    Cały układ steruje przekaźnikiem...a ten silnikiem od wyciągarki na prąd zmienny 240 V . Przekaźnik steruje prawymi , lewymi obrotami .
    Bez podłączenia silnika układ działa prawidłowo natomiast po podłączeniu układ NE555
    się sam wzbudza i generuje kilka impulsów po uruchomienia silnika...
    Wrzuć schemat całego układu.
  • Poziom 17  
    No właśnie nie mogę znaleźć prostego programu do rysowania schematów .
    Polecisz jakiś ?
    W między czasie napiszę co ustaliłem :
    -układ bez przekaźników czyli też bez zasilania silnika działa prawidłowo .
    -układ po podłączeniu całości wzbudza się w momencie rozłączania styków przekaźnika
    -układ bardzo rzadko wzbudza się z podłączonymi przekaźnikami bez zasilania silnika
    (właściwie to tylko raz tusz po włączeniu układu )
    - układ działa prawidłowo z przekaźnikami i silnikiem a z odłączonym komparatorem (wyzwalam układ ręcznie przez zwarcie wejścia ne 555 do masy )
    Komparator ma stabilizowane zasilanie 14 V na LM317 .Dodatkowo przylutowałem kondensator do zasilania przy samym scalaku .
    Wszystkie kable wejściowe i wyjściowe zawinięte są w koraliki ferrytowe .
    Przekaźniki mają oczywiście diody prostownicze przy samych cewkach . Zamieniłem na schottkiego (nic to nie dało )
  • Specjalista elektronik
    Do wykrywania, że napięcie nagle spadło o ponad 1V, spokojnie wystarczy tranzystor + kondensator + parę oporników.

    Wyłączanie silnika generuje zakłócenia i każde połączenie jest anteną, która je odbiera - być może wystarczają, by układ wykrył je jako spadek napięcia... Może na to pomóc przesyłanie sygnałów prądowych, a nie napięciowych (kondensator i tranzystor w tym układzie, dla którego spadek napięcia ma być wykryty, prąd tranzystora przesyłany do drugiego układu).
  • Poziom 39  
    Witam,
    mozesz podac schemat calosci z przakaznikiem i silnikiem.
    Czy silnik jest zasilany tak samo jak 555 ?
    Czemy zasilasz tylko komparator ze stabilizowanego zrodla - LM317 ?
    Prawdopodobnie silnik w chwili rozruchu generuje impulsy i tu masz problem.
    Zwieksz histereze w komparatorze.
    Pozdrawiam
  • Poziom 17  
    Dodałem rezystor 100 k jako histereze ale nic to nie dało .
    Zamieszczam schemat mam nadzieję że nic nie pomyliłem .
    Przerzutnik cd 4013 jak zrobić by przerzucał przy spadku napięcia ?
  • Poziom 17  
    Na schemacie nie ma tego rezystora ale jak pisałem wcześniej przylutowałem go z wyjścia najpierw do wejścia + potem do wejścia - i nic to nie dało :(

    Chyba komparator nie jest problemem ponieważ go całkiem odłączyłem .

    Pożyczyłem oscyloskop analogowy by zobaczyć gdzie tworzą się szpilki (w zasadzie wszędzie ) i gdy sonda jest połączona z wejściem ne 555 tak samo się wzbudza przy rozłączaniu styków przekaźnika . Dla przypomnienia - gdy na wejściu ne 555 nic nie ma wtedy zwieranie przekaźnika go nie wzbudza

    Myślałem by przekaźnik zastąpić triakiem ale nie wiem jak go wysterować . Podglądałem inne schematy ale jestem za cienki by samemu sobie z tym poradzić :(
  • Poziom 17  
    Oczywiście wszystkie masy , również badanego układu są połączone .
    Zrezygnowałem z Ne 555 i podłączyłem komparator bezpośrednio do CD 4013 .
    Pojawiły się kolejne problemy :

    - CD 4013 w momencie impulsu wejściowego z komparatora przez tranzystor przeskakuje kilkadziesiąd razy (w czasie mniejszym niż sekunda ) na wyjściu i nie można przewidzieć na którym wyjściu się zatrzyma więc ne 555 wydaję się być potrzebny .

    _CD 4013 również sam wzbudza się od styków przekaźnika z tą różnicą że raz na około 10 włączeń a ne 555 wzbudzał się prawie krzy każdym .

    Na ten moment myślę żę najlepszym rozwiązaniem będzie wymiana przekaźników na triaki
  • Specjalista elektronik
    A może da się spowolnić wykrywanie spadku napięcia tak, by nie reagowało na szybkie wahania? Na przykład przed wejściem CD4013 szeregowy opornik ze 300k i kondensator 100nF do masy. Czy jest potrzebna szybka reakcja na wystąpienie spadku napięcia?

    Mam wrażenie, że CD4013 potrzebuje mniejszego napięcia do zadziałania, więc dziwne, że rzadziej się wzbudza.

    Nadal nie wiem, jak to jest zrobione - gdzie są jakie połączenia, które ma jaką długość. To ma wpływ na podatność na zakłócenia. Po której stronie komparatora jest połączenie między układami?
  • Poziom 17  
    Tych przewodów trochę jest. Ale myślę że zakłócenie i tak robią wyłącznie przekaźniki. Układ składa się z dwóch przekaźników z których pierwszy odłącza napęd w momencie zamiany obrotów chodzi o to by nie wyhamowywać silnika prądem. Mniejsza o to. Pierwszy z przekaźników ten który zatrzymuje silnik zamieniłem już triakiem który jest sterowany optotriakiem. Wszystko działa, zamieniłem działanie układu tak by triak w momencie impulsu z ne 555 rozłączał i z tym też sobie poradziłem .Problem mam z tym ,że próbuje przedłużyć zwieranie tranzystora
    do masy tak by triak wyłączał na około 3 sekundy . Dołączenie do bazy tranzystora kondensatora nawet 1000µF nic nie zmienia .Dołączenie do diody w optotriaku również .

    Czy jest jakiś prosty sposób na to ?
    Przerzutnik cd 4013 jak zrobić by przerzucał przy spadku napięcia ?
  • Specjalista elektronik
    Myślę, że optotriak jest albo włączony, albo wyłączony, bez stanów pośrednich, więc kondensator może co najwyżej opóźniać zmiany, nie może sprawić, by były płynne.

    Ale nie bardzo wiem, o co ci właściwie chodzi - piszesz zbyt niejasno. Gdzie masz jaki sygnał, co chcesz przedłużyć, co rozumiesz przez to przedłużenie?

    Nie jest pewnie istotne, do czego to ma służyć, ale jest istotne, jakie sygnały i w jakiej sekwencji czasowej mają wchodzić i wychodzić.

    Można by spróbować zastosować transoptor, żeby wyeliminować generowanie zakłóceń na przewodach.
  • Poziom 17  
    Chodzi mi oto że tranzystor dostaje napięcie na bazę z wyjścia ne 555 przez powiec my sekundęi wtedy zwiera do masy a ja potrzebuję by ten tranzystor podtrzymał przewodzenie około 3 sekundy .
  • Specjalista elektronik
    Naładować tym napięciem kondensator - poprzez diodę, żeby NE555 nie mógł potem go rozładować - i z tego kondensatora dawać prąd na bazę tranzystora. Z tym, że wtedy przewodzenie będzie malało stopniowo, a kondensator musi mieć sporą pojemność - np. około 2200uF. Jeśli przewodzenie ma być wyłączane skokowo, będzie potrzebny bardziej złożony układ. Można też zamiast tranzystora użyć drugiego NE555 i mieć skokowe wyłączanie; można użyć MOSFET-a, albo Darlingtona, żeby wystarczyła dużo mniejsza pojemność...
  • Poziom 17  
    Wstawienie diody na wyjściu ne 555 załatwiło sprawę .
    Zrobiłem dodatkową płytkę z triakami BT136-800 i optotriakami .
    Wszystko pięknie działa to znaczy na diody w optotriaku założyłem rezystory 130 ohm bo tak działają na napięcię 2,7 V bo tyle wychodzi z CD4013 .
    Gdy podłączę optotriaki do zasilacza regulowanego 2,7 V triaki przewodzą (sprawdzam na żarówce 240 V ) .

    Niestety w CD4013 działa tylko wyjście 1 .
    Gdy przerzucę na wyjście pin 2 CD4013 się blokuje , triak przewodzi lecz nie da się już przełączyć na pin 1 . Da się to odblokować dopiero po odłączeniu pin 2 .

    Podsumowując - Cd4013 blokuje się po podłączeniu pin 2 do optotriaka a działa po podłączeniu do optotriaka na wyjście pin 1
    Dodam jeszcze że CD4013 działa normalnie gdy na wyjściu są same diody Led.
    Zamieniłem też sam scalak Cd4013 na inny nowy i całość działa bez zmian .
  • Poziom 17  
    1 -Załączyłem schemat we wcześniejszym poście .
    2 -Zamiast przekaźników podłączyłem optotriaki MOC3063 .
    3- Optotriaki sterują triakiami BT138-800
    4 - CD4013 przestaje działać gdy jego wyjście Q2 (pin 2 ) jest podłączone do optotriaka .
    5 - Za to CD4013 działa prawidłowo gdy na wyjściu Q1 (pin1) jest podłączony optotriak .
    6 - Innymi słowy oba wyjścia Q1 i Q2 CD4013 działają z przekaźnikami a z optotriakami działa tylko wyjście Q1 .

    Którego punktu nie rozumiesz ?