Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Schemat z atmega8, jak podłączyć wyświetlacz

krzywy1 12 Mar 2018 09:20 771 6
  • #1 12 Mar 2018 09:20
    krzywy1
    Poziom 12  

    Witam
    Może banalne pytanie, ale jestem zielony w temacie. Jak podłączyć wyświetlacz, skoro na schemacie są tylko oznaczenia z numerami?
    Schemat z atmega8, jak podłączyć wyświetlaczMPPT-Ardui...cb (2).jpg Download (189.83 kB)

    0 6
  • Pomocny post
    #2 12 Mar 2018 09:31
    miszczo997
    Poziom 27  

    Najprawdopodobniej:
    od prawej strony na schemacie
    Złącze SL2
    1-VSS 2-VDD 3-VE 4-RS 5-E
    Złącze SL1
    1-D4 2-D5 3-D6 4-D7
    Pin RW wyświetlacza na stałe do GND
    Żeby powiedzieć jak jest na pewno trzeba zajrzeć w kod.

    0
  • #3 12 Mar 2018 09:32
    ghost2000
    Poziom 17  

    Jaki wyświetlacz? Można się domyśleć, że chodzi o LCD w trybie 4-bit. Jeśli tak, to także można się domyśleć jak. Wystarczy Link tam dotrzesz do noty katalogowej. Aby mieć całkowitą pewność, trzeba w programie, którego nie załączyłeś, sprawdzić funkcje poszczególnych GPIO. Piszesz, że jesteś zielony, więc wnioskuję, ze program masz gotowy bo nie potrafisz sam napisać.

    0
  • #4 14 Mar 2018 07:07
    krzywy1
    Poziom 12  

    Dzięki koledze miszczo997 wyświelacz ruszył i atmega wydaje się działać poprawnie. Ale układ do końca nie działa prawidłowo.Po podłączeniu akumulator wygląda wszystko ok, ale jak od strony solarów dam testowo zasilanie to akumulator nie jest ładowany, a napięcie jakie pokazuje wyświetlacz dochodzi tylko do 6,9V i stoi pomimo dalszego zwiększania napięcia na zasilaczu. Jednocześnie przy zwiększaniu napięcia od strony solarów napięcie na akumulatorze spada o 0,3-0,5V.
    Czy kondensatory c14 i c11 powinny mieć taką samą wartość jak c15? bo na schemacie nie są opisane. Jak sprawdzić sam układ przetwornicy?

    0
  • Pomocny post
    #5 14 Mar 2018 09:17
    andrzej55
    Poziom 34  

    Zweryfikuj omomierzem wartości dzielnika napięcia R3 i R4. Jeśli napięciem odniesienia dla ADC Atmegi ustawione jest na 5V(VCC), to zakres pomiarowy prawdopodobnie będzie wynosił ok. 0-28V(po dzielniku 0-5V).

    0
  • #6 15 Mar 2018 00:25
    krzywy1
    Poziom 12  

    Raz już to sprawdzałem i jednak sprawdziłem źle, bo okazało się, że rezystory faktycznie były zamienione. Po przelutowaniu wydaje się, że wszystko działa jak należy i ładuje akumulator. Jutro, jak będzie słoneczko, przetestuję wszystko dokładnie.

    0
  • #7 22 Mar 2018 00:27
    krzywy1
    Poziom 12  

    Działa, ale jednak nie do końca :cry: , tzn. wszystko wyświetla poprawnie ale pwm startuje tylko wtedy, jak dotknę palcem obudowy atmegi, ,pokazuje to na na wyświetlaczu i jest ładowanie akumulatora. Jak tylko przestane dotykać, pwm spada do zera, brak ładowania. O co tu chodzi? Dodam tylko, że na początku pwm działał poprawnie.
    Poczytałem o niepodłączonych pinach i zakłóceniach. Pin 27 i 28 są niepodłączone. PWM zaczyna działać , kiedy palcem dotknę obudowy właśnie w tym miejscu, nad pinami 27 i 28. Jest na to jakieś rozwiazanie?

    0