Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Electrolux EDH97981W suszarka - Naprawa zasilacza w sterowniku, potrzebna ident

talbotsolara 25 Apr 2018 10:01 1869 6
  • #1
    talbotsolara
    Level 9  
    Electrolux EDH97981W suszarka - Naprawa zasilacza w sterowniku, potrzebna ident
    Sterownik od suszarki Electrolux EDH97981W. W sterowniku było jakieś zwarcie, upalona ścieżka, spalony rezystor R76 - 47Ω, dławik L3 chyba 10mH, przebita dioda Zenera SMD DZ2, oraz wybrzuszony tranzystorek Q4 przy przetwornicy LNK304PN (zostały tylko nóżki). Reszta jak na razie wydaje się ok. (również elementy które zwykle padają), okaże się przy rozruchu. Może jeszcze ukruszona dioda D8 do wymiany, może przetwornica (później sprawdzę). Naprawiane dla siebie, więc jestem gotów trochę przy tym posiedzieć.

    Nie mam schematu i prosiłbym o pomoc w identyfikacji elementów DZ2 (jakie napięcie) i Q4 (jaki tranzystorek)? Co do tranzystorka to wystarczy chyba dobre zdjęcie lub podanie opisu elementu ze sprawnej płytki.
    Electrolux EDH97981W suszarka - Naprawa zasilacza w sterowniku, potrzebna identElectrolux EDH97981W suszarka - Naprawa zasilacza w sterowniku, potrzebna ident
    Pozdrowienia!
  • Helpful post
    #2
    valdib74
    Level 11  
    Witam,

    DZ2 = 5,6V 2%
    Q4 = BC817-25 (kod na tranzystorze 6CW)
    D8 = US1B
    L3 = 10uH
    R76 = 47Ω
    Sprawdź LNK304 (Może być tam również 364) pomiędzy nóżkami D i S czy nie ma zwarcia oraz kondensator 22µF/400V.

    Pozdrawiam
  • #3
    talbotsolara
    Level 9  
    Bardzo dziękuję!

    LNK304 ma 220Ω - jeszcze nie sprawdzałem czy to po stronie scalaka czy od strony płytki, zostawiłem na później. Kondensator 22µF/400V wygląda na żywy (zostało mu 20µF z 22µF oryginalnie), ale nie zaszkodzi wymienić.
    Ciekawe, czy jeszcze coś znajdę i dam znać.
    Edit:
    LNK304 również był spalony.
  • #4
    talbotsolara
    Level 9  
    Po wymianie uszkodzonych elementów sytuacja wygląda następująco - po zasileniu z 230V przetwornica startuje, płytka ogólnie również i zgłasza się diodami, ale po dłuższej chwili zaczyna "wariować". Nie podoba mi się napięcie zasilania kontrolera - cyklicznie waha się pomiędzy 5.1V, a 6.5V (faluje sobie mniej więcej 2x sekundę). Niestety nie widzę żadnego stabilizatora ani nic co w oczywisty sposób odpowiadałoby za "produkcje" napięcia 5VDC. Co w tej płytce stabilizuje to napięcie? Jakaś dioda Zenera?

    Edit:
    Napięcie skacze bo diody Led mrugają. Z LNK304PN wychodzi już to niskie napięcie (5.1...6.3V). Czy tam powinno być ustabilizowane na 5V? Czy wyższe (~12V?), a 5V robione z tego jest gdzieś dalej?
  • Helpful post
    #5
    valdib74
    Level 11  
    Napięcie 5V powinno być na kondensatorze C24. Falowanie wskazuje na przeciążoną przetwornicę - LNK304 włącza i wyłącza się cyklicznie. Musisz sprawdzić napięcie 12V pomiędzy masą C24, a zasilaniem cewki jakiegoś przekaźnika. Przekaźniki są sterowane do masy przez tranzystory oznaczone na płytce jako QD, a zasilane 12V na stałe. Jeżeli nie ma tam napięcia to właśnie jest gdzieś zwarcie. Jeżeli też 12V pływa to masz problem z przetwornicą - do LNK304 musi dochodzić sygnał zwrotny z wyjścia zasilacza - więc dla tego przy LNK304 napięcie pływa. Elementy, DZ2 i Q4 pracują w obwodzie sygnału zwrotnego do LNK304.
  • #6
    talbotsolara
    Level 9  
    Dzięki, z tymi informacjami i datasheetem LNK304 powinieniem to rozgryźć.

    Układ albo jest niewydolny prądowo i 5V faluje w tempie mrugania diód led, albo rzeczywiście LNK304 nie dostaje sygnalu FB i restartuje co 0,8s i stąd to falowanie. LCD świeci i mikrokontroler pracuje, ale napięcie jest bardzo niestabilne (podświetlenie LCD nierównomiernie migocze). Zasilany zewnętrznie z 5VDC układ pracuje normalnie (pobiera może 10-30mA), na 12V zwarcia nie ma (przy podaniu tam z zewnątrz 12VDC nic nie pobiera).

    edit: pod mikroskopem znalazłem upalone dość ważne przelotki, powinienem wcześniej na to wpaść że upalone ścieżki mogą znaczyć również upalone przelotki w pobliżu. Naprawiłem. Teraz układ rzeczywiście w kółko restartuje co <1s tak że kontroler nawet nie zdąży się inicjalizować. Muszę szukać dalszych uszkodzeń, może jeszcze gdzieś brakuje połączenia. Schemat bardzo by pomógł...
    Nie rozumiem tylko czemu przetwornica w ogóle startuje skoro na FB ma cały czas >2V :/ muszę wrzucić to na oscyloskop.

    edit2: Wykazywane na multimetrze napięcie na Fb w okolicy 2V (spodziewałem się nominalnego 1,65V) jest normalne przy pracy tej przetwornicy (sprawdzone w sprawnej płytce), zgaduję, że nie jest stałe i szczegóły widać dopiero na oscyloskopie.
  • #7
    talbotsolara
    Level 9  
    Działa.
    Ostatnią "usterką" okazała się zbyt wysoka rezystancja wymienionego dławika L3 - nie było osiowego, wstawiłem więc tymczasowo pionowy. Niestety pionowy miał 30Ω i to było za dużo by układ stabilnie pracował, po zamianie na osiowy z R<1Ω układ zadziałał normalnie.
    Dziękuje za udzieloną pomoc !