Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Fatek Fb's 2LC skoki sygnału

05 Maj 2018 20:41 417 5
  • Poziom 2  
    Cześć,

    Mam problem ze surowym sygnałem wejściowym na moduł Fatek'a Fb's 2LC. Sygnał pochodzi z belki tensometrycznej SQB-A 3 1000kg o klasie dokładności C3, rezystancji wyjściowej 352 Ohmy +/- 3 Ohmy, którą zasilam z modułu Fb's 2LC (5V).Rozdzielczość modułu Fb's 2LC to 16 bitów.

    Surowy sygnał wejściowy z belki tensometrycznej strasznie skacze, +/-20 j i nie istotne jest czy tensometr jest obciążony czy nie.

    Jedyne co mi do tej pory przyszło do głowy to usrednienie sygnału surowego. Zrealizowałem to przez wpisywanie wartości co 0,5s kolejno do 32 rejestrów i wyciągając średnią co 1s. Niestety sygnał też potrafi skakać o +/- 5 j co przekłada się na wynik ok 1kg. Próbowałem już zmieniać czasy wpisu wartości i uśredniania, zmiana wartości do skalowania i niestety nic to nie daje bo sygnał cały czas skacze.

    Pomiar wagi tyczy się zbiornika o 4 podporach do którego będzie dozowanie 7 kolejnych komponentów. Minimalna dokładność którą muszę uzyskać to 0,5kg. I wszystko już by grało gdyby nie te skoki sygnału.

    Pomiar wagi chciałbym zrobić na jednej belce ale jeśli będzie trzeba mogę zrobić to na 4.

    Moje pytanie do was, czy ktoś ma propozycje rozwiązania skoków sygnału surowego?

    Z wyrazami szacunku,
    Karol
  • Pomocny post
    Poziom 25  
    W module ustaw wzmocnienie 2 mV/V, a także wykorzystaj wbudowane filtry, sygnał powinien być w miarę stabilny.
    Przy belce 1000 kg jak masz zainstalowany zbiornik, czy wisi na niej całkowicie? Jak masz skalibrowaną wagę. Ile % zakresu pomiarowego tensometru wykorzystujesz? Np. Zbiornik całkowicie podparty ( zawieszony na belce ) powinien mieć masę do ok . 200 kg. Masa ważonego towaru maksymalnie to ok 600 - 800 kg. Przy takim założeniu wskazania powinny być stabilne. Jeśli przy zastosowaniu belki 1000 kg będziesz kalibrował wage w zakresie pomiarowym do 100 kg to nie uzyskasz stabilnych wskazań. Niestety rozdzielczość tylko 16 bitów to dla modułu wagowego słabiutko i trzeba bardzo dokładnie dobierać obciażenie tensometru.
  • Poziom 2  
    Sygnał właśnie przy ustawieniu 2mV/V Hz = 8 i t = 8 skacze. Zbiornik nie jest całkowicie podparty, ciężko mi określić w jakim stopniu zbiornik opiera się na tensometrze. Wykorzystuje ok. 80 - 85% jego zakresu, z 3000 j. Nie mam problemu z wyskalowaniem wagi bo uzyskałem dokładność 0,2 kg. Problemem jest jednak skok wartości surowej sygnału wejściowego. Przyjmijmy, że po skalowniu otrzymuje wartość 102,25 kg ale wartość ta skacze +/- 1 kg co przy podaniu komponentu o wadze 1,25 kg ma trochę znaczenie. Dodam, że usrednienie wartości po skalowniu też nie pomaga. Znalazłem gdzieś na forum podobny temat z włączeniem potencjometru obrotowego we wyjście + z tensometru. Czy ktoś próbował czegoś takiego? Czy zastosowanie 4 belek tensometrycznych pomoże?

    Pytam Was bo chce uniknąć dodatkowych kosztów związanych z kupnem rzeczy które nie uproszczą sprawy.

    Alternatywą jaka przychodzi mi do głowy jest kupno 4 belek, sumatora, wzmacniacza na 4 - 20 mA i wymiana Fb's 2LC na kartę analogową Fb's 6AD. Wiąże się to z większymi kosztami i też nie jestem do końca przekonany co do tego rozwiązania. Czy wtedy uzyskam stabilny sygnał wejściowy...
  • Poziom 25  
    4 belki wyeliminują Ci mechanikę. Spróbuj podłączyć sam tensometr bez zbiornika zamontowany w jakimś uchwycie i obciążyć go np 20 kg. Sprawdź odczyty. W większości za niestabilność odpowiada mechanika. Czy masz tam jakiś układ dźwigniowy? W jaki sposób jest montowany zbiornik? Może jakieś foto? Czy brak stabilności jest przy pustym i przy napełnionym zbiorniku?Czy do zbiornika są podpięte jakieś dodatkowe mechanizmy typu mieszadło , wibrator?
  • Poziom 2  
    Opiszę dzisiejsze zajście... Po uwolnieniu tensometru sygnał surowy wynosił 171 j +/- 15j. Znalazłem w kącie starą wagę, mocno przechodzoną. Podłączyłem belkę do wejścia CH0 a CH1 uwolniłem. Jak się okazało sygnał z wagi z kąta był stały, waga stacjonarna do 10 kg. Natomiast wartość wejścia CH1 wynosiła -32755 do -32765 (nic nie było podłączone). Po 30min podłączyłem feralny tensometr do wejścia CH1 i sygnał również był staly... Aż się łza w oku kręci.... Następnie obciążyłem feralny tensometr jakimiś 400 kg wartość zmieniła się z 18j na 224j a po kilku chwilach zmieniła się na 84.... Ale nie było skoków sygnału....
    Macie jakieś logiczne wytłumaczenie? Mi zabrakło... Dodam, że wszystko ma podpięte PE



    Właśnie szukam innego tensometru. Może macie jakieś sprawdzone? Zbiornik maksymalnie będzie ważył 1200 -1300 kg
  • Pomocny post
    Poziom 25  
    Faktycznie, może być tensometr, niestety to już nie ta jakość jak 20 lat temu.
    Osobiście z firmowych robię na Flintec seria SLB (belki tensometryczne). Ne priv namiar na firmę która rozprowadza różne tensometry mają również sprawdzone inne.