Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Niepoprawny klucz centrali Satel Perfecta 16-WRL

DawidMisiak 20 Maj 2018 18:37 993 6
  • #1 20 Maj 2018 18:37
    DawidMisiak
    Poziom 8  

    Czołem Forumowicze.

    Piszę z następującym problemem.

    Mam centralę SATEL Percecta 16 WRL, którą właśnie zainstalowałem. Do tego manipulator w wersji WRL.

    Po uruchomieniu centrali podpiąłem ja do RSa i odpaliłem Perfecta Soft. Program bez problemu odczytał informacje o centrali. Zmieniłem tylko funkcję "Łącz z PERFECTA CONTROL przez serwer SATEL" i "Łącz z PERFECTA SOFT przez serwer SATEL" bez ruszania klucza centrali w konfiguracji i wysłałem ustawienia do centrali. Uruchomiłem ją ponownie i od tamtej pory przy próbie połączenia z Perfect Soft mam info o niepoprawnym kluczu centrali. W ustawieniach programu pole z kluczem jest puste.

    Próbowałem już:
    1. resetu ustawień przez JP1
    2. Upgrade firmware do 1.01
    3. Downgrade do 1.00
    4. Połączenie z innego komputera

    Kabel nie jest uszkodzony, bo poprawnie czyta i wgrywa firmware. Oczywiście ustawienia portów są poprawne, bo Perfect Soft inicjuje połączenie z centralą, na RS zapalają się diody informujące o przesyłaniu danych.

    Z tego co wiem, w Perfect Soft nie trzeba podawać klucza centrali, jeśli ta ma ustawienia fabryczne. Zwarcie JP1 i ponowne podpięcie zasilania powinno je przywrócić, ale chyba to nie działa. Wydaje mi się, że centrala ma domyślnie włączoną blokadę trybu serwisowego. Potwierdzacie?

    Nie mam podpiętego manipulatora przewodowego, więc nie mogę potwierdzić ewentualnego kasowania ustawień. Nie zdążyłem też dodać manipulatora bezprzewodowego, na którym komunikat miałby się wyświetlić (tak przynajmniej podaje instrukcja). Macie jakieś pomysł, jak ją zresetować?

    Z góry dzięki za wszelkie uwagi i wskazówki.

    PS Czytałem temat https://www.elektroda.pl/rtvforum/topic3371538.html,, ale to nie mój przypadek.

    0 6
  • Pomocny post
    #2 20 Maj 2018 20:24
    norbert.s.

    VIP Zasłużony dla elektroda

    DawidMisiak napisał:
    Zwarcie JP1 i ponowne podpięcie zasilania powinno je przywrócić, ale chyba to nie działa.
    To jest sposób wejścia w tryb serwisowy z tzw. kołków, a nie przywrócenie ustawień fabrycznych.

    DawidMisiak napisał:
    Wydaje mi się, że centrala ma domyślnie włączoną blokadę trybu serwisowego. Potwierdzacie?
    Nie potwierdzamy.

    DawidMisiak napisał:
    Próbowałem już:
    .....
    2. Upgrade firmware do 1.01
    3. Downgrade do 1.00
    4. Połączenie z innego komputera
    Jakim cudem chciałeś to zrobić nie mając klucza centrali?

    DawidMisiak napisał:
    Macie jakieś pomysł, jak ją zresetować?
    Podłączyć manipulator przewodowy i odczytać klucz centrali.

    0
  • #3 20 Maj 2018 22:29
    DawidMisiak
    Poziom 8  

    norbert.s., masz absolutną rację - JP1 to tryb serwisowy a nie resetowanie do ustawień fabrycznych. Mój błąd.

    Flashowanie firmware'u poszło bezproblemowo bez klucza centrali. Skąd to wiem? Do flashowania jest osobny program, który weryfikuje wersję firmware przed flashowaniem i prosi o potwierdzenia przy downgrade. Miałem pierwotnie wersję 1.00, wgrałem 1.01 i później przy downgarde do 1.00 zapytał mnie, czy faktycznie chcę wgrać starszy soft. Wgrałem. Kolejny flash to był powrót do 1.01 i program wyświetlił, że flashuje z wersji 1.00 do 1.01. Także flashowanie można zrobić bez klucza centrali.

    Z manipulatorem przewodowym mam taki problem, że nie mam takiego manipulatora. Kupować bym nie chciał, bo nie będę z niego korzystał (brak okablowania), a z pożyczeniem może być problem. Ale nie mam innego wyboru jak znaleźć gdzieś taki.

    Dzięki za pomoc!

    0
  • Pomocny post
    #4 20 Maj 2018 22:47
    norbert.s.

    VIP Zasłużony dla elektroda

    DawidMisiak napisał:
    Do flashowania jest osobny program...

    Tak wiem, wielokrotnie aktualizowałem i ciągle aktualizuję Perfecty. Na zdjęciu piewsza z dostępnych aktualizacji, kwiecień 2017.
    Wydaje mi się, że nie ma innej możliwości, niż podpięcie manipulatora przewodowego.

    0
  • #5 23 Maj 2018 11:02
    DawidMisiak
    Poziom 8  

    Podłączenie manipulatora oczywiście pomogło. Wszystko dziła, czujki, manipulatory i piloty dodane.

    Zauważyłem jednak ciekawą rzecz. Z manipulatora przewodowego w FS odczytałem 16-znakowy klucz centrali i wklepałem go do Perfecta Soft. Program go nie rozpoznawała i nadal zgłaszał błędny klucz. Dopiero reset do ustawień fabrycznych pozwolił na ponowne połączenie.

    W instrukcji programowania Perfecty daleko, daleko w tekście jest informacja o tym, że w przypadku pierwszego programowania centrali program wybiera losowo 16 znaków i nadaje je centrali jako klucz. Nie doczytałem tego fragmentu i stąd moje kłopoty. Swoją drogą mogliby nie robić tego z automatu, ale przypomnieć użytkownikowi, że nie ma nadanego klucza centrali i poprosić go o podanie własnego ciągu znaków.

    Temat do zamknięcia.

    0
  • #6 24 Maj 2018 17:03
    montersi.pl

    Poziom 15  

    DawidMisiak napisał:
    Z manipulatora przewodowego w FS odczytałem 16-znakowy klucz centrali i wklepałem go do Perfecta Soft. Program go nie rozpoznawała i nadal zgłaszał błędny klucz.

    Czy do programu został wprowadzony klucz dużymi literami? Klucz jest tak właśnie zapisywany, tzn. przy użyciu dużych znaków. Jeżeli wprowadzamy klucz do centrali przy użyciu małych znaków, to niestety to nie zadziała.
    Ważna jest wielkość liter.

    0
  • #7 24 Maj 2018 18:26
    DawidMisiak
    Poziom 8  

    Klucz był wprowadzany (kilkukrotnie) tak jak był prezentowany na wyświetlaczu - duże litery + cyfry, razem 16 znaków. Ponieważ nie miałem zapisanych żadnych istotnych ustawień w pamięci centrali i nie chciałem już szukać powodów niezgodności klucza zrobiłem reset do ustawień fabrycznych.

    0
  Szukaj w 5mln produktów