Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nie widać drukarek, konfiguracja switcha?

PanKierownik 06 Cze 2018 11:23 399 28
  • #1 06 Cze 2018 11:23
    PanKierownik
    Poziom 9  

    Problem może i banalny, nie wiem, ale stoję nad nim i się nie mogę ruszyć...
    Dotychczas używaliśmy w sieci zwykłego, niezarządzalnego switcha i wszystko było ok.
    Przy okazji wymiany, kupiliśmy tp-link JetStream Smart Switch model T1600G-28TS.

    Wszystko ok, działa poprawnie, natomiast nie widać drukarek sieciowych.
    Modele drukarek: Dell 1815dn oraz Kyocera M3025dn.

    Zarówno w ustawieniu drukarek DHCP jak i przy statycznym IP. Oczywiście adresacja sprawdzona, jest ok.
    Ping także nie dociera, po prostu drukarki są niewidoczne, mimo że diody Link na switchu świecą.

    Czy drukarki używają jakiegoś protokołu, który domyślnie jest w switchu wyłączony, czy ki diabeł?

    0 28
  • #3 06 Cze 2018 20:48
    PanKierownik
    Poziom 9  

    Myślisz że to może coś dać?
    Kurde, jak podłączam stary switch to działa bez problemu...
    Ta sama adresacja, dopiąłem do starego switcha ten nowy - do niego bezpośrednio jeden z komputerów - i już nie widzi się z drukarką.
    Przepnę z powrotem do starego switcha - działa... Co do diaska?

    Zresztą, to są drukarki sieciowe - nawet jakbym chciał ponownie je zainstalować w Windows, to skoro nie pinguja, to Windows ich nawet nie wykryje...

    0
  • #4 06 Cze 2018 21:11
    krzysiozak
    Poziom 35  

    Nie wiem jak u ciebie, u mnie drukarki po WiFi. Po zmianach należy ponownie zainstalować za pomocą kabli USB. Później kabelek nie potrzebny.
    Choć głowy nie dam uciąć, ale proponuje spróbować.

    0
  • #5 07 Cze 2018 01:32
    IC_Current
    Specjalista Sieci, Internet

    Switche poprawnie skonfigurowane? Szczególnie VLANy i ACL? Te TP-Linki to cuda potrafią wyprawiać. Zamiast drukarki na próbę podłącz inny PC (z wyłączoną zaporą) i sprawdź komunikację.

    0
  • #6 07 Cze 2018 08:15
    PanKierownik
    Poziom 9  

    Switch zakupiony był nowy, z fabryczna konfiguracją, co było na nim zrobione to:
    - zmiana IP z domyślnego na inny, statyczny [bo adres .1 używa brama internet]
    - wszystkie porty przypisane do jednej sieci: system-VLAN 1
    - Spanning tree - off
    - IGMP snooping - off
    - MLD snooping - off
    - QoS - nic nie było ruszane
    - ACL - nic nie było ruszane
    - Network security - też nic nie było ruszane
    - SNMP - off
    - LLDP - off
    - utworzona statyczna tablica routingu do bramy internetowej

    Do dowolnego portu wpinam drukarkę - nic.
    Do dowolnego portu wpinam PC - bezproblemowo.

    No kurde, niemożliwe żeby zarządzalny switch nie potrafił pracować z drukarką...
    Poprzedni to D-link DES-1024D i żadnych problemów z nim...

    edit:
    hm, i jeszcze jedno:
    Sprawdzam w statystykach ruchu dla portu, gdzie drukarka podpięta - wykazuje tam pakiety odebrane i wysłane, po próbie pingowania się zwiększa - dlaczego?
    Jeśli pinguję z komputera, to mam 4 wysłane i 4 odebrane, komunikat: Destination host unreachable
    Natomiast jeśli pinguję bezpośrednio ze switcha, to mam 4 wysłane i 0 odebrane, komunikat: Request time out.

    0
  • #7 07 Cze 2018 09:11
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:

    Jeśli pinguję z komputera, to mam 4 wysłane i 4 odebrane, komunikat: Destination host unreachable
    Natomiast jeśli pinguję bezpośrednio ze switcha, to mam 4 wysłane i 0 odebrane, komunikat: Request time out.

    W pierwszym przypadku to chyba switch odpowiada, że nie może znależć drukarki.
    W drugim przypadku, switch wysyłała pakiety ale nic nie wraca.

    0
  • #8 07 Cze 2018 09:13
    PanKierownik
    Poziom 9  

    A, no tak, racja z tymi pingami.

    Kurde, a nikt nie spotkał się z podobnym problemem drukarek?
    Co tu zadziałać?

    0
  • #9 07 Cze 2018 09:21
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:
    A, no tak, racja z tymi pingami.

    Kurde, a nikt nie spotkał się z podobnym problemem drukarek?
    Co tu zadziałać?

    A podłącz w miejsce drukarki kopmuter z takim samym statycznym adresem.
    Jak zadziała, problem raczej leży w drukarce. Wtedy bym zaczał od jakiegoś restary do ustawień fabrycznych.

    0
  • #10 07 Cze 2018 09:30
    PanKierownik
    Poziom 9  

    Ano sprawdzone, z komputerem działa bez problemu.
    Próbowałem w drukarce DHCP, też nie działa.
    No a poza tym - drukarka, jedna i druga, działa jednak bez problemu podpięta do starego switcha...

    A ponadto - kiedy drukarkę podepnę do starego switcha - to komputery podłaczone do tego starego mają łączność z drukarką, a podpiete do nowego juz nie...
    Przy czym między komputerami z obu switchów jest swobodna komunikacja, internet itd, więc cała komunikacja wszędzie przebiega prawidłowo - poza drukarkami...

    0
  • #11 07 Cze 2018 09:34
    m.jastrzebski
    Poziom 36  

    Jak nie-toperz, to nie wiem.
    Spróbowałbym zresetować drukarki do ustawień fabrycznych (jeśli maja taka opcje) podłaczyć przez USB lub z menu drukarki przeprowadzić konfiguracje sieci od nowa.

    0
  • #12 07 Cze 2018 10:21
    hermes-80
    Poziom 43  

    Sprawdź poprawność zaciśnięcia kabli (czy wszystkie żyły-8 działają poprawnie, standardy czy się zgadzają) a jak nic nie da spróbuj kabel krosowany (switch-drukarka).

    0
  • #13 07 Cze 2018 15:35
    KOCUREK1970
    Poziom 43  

    @PanKierownik
    Jaki soft w switchu, switch zresetowany i ustawiony ponownie?
    Jeśli jest do niego nowszy soft to wgrać.

    0
  • #14 08 Cze 2018 05:17
    glus266
    Poziom 10  

    Świecące diody Link oznaczają, (tylko) że coś jest podłączone,,czy w ogóle coś mruga po podłączeniu.
    A porty w swtchu ustawione na autonegocjacje, czy na stałe 1Gb, zmień (ustaw) na 100 ,
    albo zobacz co będzie gdy drukarki do starego, stary i kompy do nowego.

    0
  • #15 08 Cze 2018 09:08
    Samuraj
    Poziom 35  

    Spróbuj pomiędzy nowy switch a drukarkę wpiąć na próbę stary switch.

    0
  • Pomocny post
    #16 11 Cze 2018 12:15
    szaleniec
    VIP Zasłużony dla elektroda

    Intuicja podpowiada mi, by sprawdzić konfigurację vlanów.

    0
  • #17 12 Cze 2018 10:23
    PanKierownik
    Poziom 9  

    @hermes-80: Oczywiście, kable sprawdzone testerem

    @KOCUREK1970: switch z softem fabrycznym, nowszego nie ma

    @glus266: próbując pingować drukarkę – widać że diody mrugają, więc jakaś komunikacja chyba idzie. Próbowałem zmieniać prędkość łącza z auto na wymuszone 100 i 1000Gb, nie pomogło. Efekty kombinowanego połączenia starego i nowego switcha opisałem wyżej.

    @Samuraj: Efekty kombinowanego połączenia starego i nowego switcha opisałem wyżej.

    @szaleniec: to prawdopodobne, że jednak namieszałem.

    Dziękuję wszystkim za zaangażowanie.
    Problem jednak ostatecznie rozwiązany przez reset switcha do ustawień fabrycznych… Pewnie powinienem to zrobić najpierw, ale nie sądziłem że coś mogłem zwalić przy prostej konfiguracji – a jednak…
    Co więcej, nie wiem co to było – niestety nie umiem więc powiedzieć, ale obstawiałbym jednak coś vlan, mimo że była tylko jedna i wszystkie porty do niej przypisane?
    Albo może coś popsułem w staycznym routingu do bramy internetowej? Bo po twardym resecie w ogóle takowej nie konfigurowałem, a jednak wszystko działa?

    Tym niemniej działa!
    kłaniam się.

    0
  • #18 12 Cze 2018 10:30
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:

    Albo może coś popsułem w staycznym routingu do bramy internetowej? Bo po twardym resecie w ogóle takowej nie konfigurowałem, a jednak wszystko działa?
    Nie ma powodu żeby nie działało. Statycznego routingu do dowolnego komputera też nie konfigurowałeś, a działa.

    0
  • #19 12 Cze 2018 10:34
    PanKierownik
    Poziom 9  

    no tak, ale adresy lokalnych komputerów są w ARP, natomiast skąd switch "sam" wie, dokąd skierować wywołanie np. www.wp.pl?

    0
  • #20 12 Cze 2018 10:40
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:
    no tak, ale adresy lokalnych komputerów są w ARP, natomiast skąd switch "sam" wie, dokąd skierować wywołanie np. www.wp.pl?

    1. DNS - > www.wp.pl = IP = 1.2.3.4
    2. Czy 1.2.3.4 jest w mojej sieci lokalnej? (sprawdza się swoj adres IP vs maska)
    3. Tak -> ustal adres MAC tego IP (i przechowaj go przez chwile w tabli ARP) i wyslij na ten adres MAC.
    4. Nie -> ustal adres MAC brawmy domyślej, i wyślij do bramy domyślnej, niech się martw jak znależć rzeczony 1.2.3.4 w sieci.

    To nie switch decyduje że dany pakiet ma pojsc do bramy domyślnej. Switch zapewnia komunikacje i sterowanie przeplywem tylko pakietów zaadresowanych MAC-iem. To, że pakiet ma być wysłany do bramy domyślnej, decyduje się pietro wyżej. Switch tylko pomaga ustalić na którym jego porcie dany adres MAC się znajduje

    0
  • #21 12 Cze 2018 10:58
    PanKierownik
    Poziom 9  

    fajne, przejrzyste wyjaśnienie, jednak nadal nie rozumiem punktu 4 - jak switch sam ustala, gdzie jest brama domyślna?
    Myślałem że to właśnie muszę skonfigurować...

    hm.. jak słuchałem wiresharkiem, to wywołania IP moich drukarek pozostawały bez odpowiedzi - dlaczego zatem?
    aha - chyba dlatego, że zgodnie z adresacją winny być w LAN...

    Jeszcze mi zostało nierozwiązane jedno - ustawienia czasu w switchu:
    Jest tam fabrycznie podany primary i secondary adres serwera NTP, a jednak switch nie dostaje danych, mam komunikat failed to get time from NTP server - czemu?
    Sprawdzałem wpisując inne adresy serwerów NTP, za każdym razem failed...
    a teoretycznie switch powinien wysyłać nieznany adres na bramę domyślną, nie?

    0
  • #22 12 Cze 2018 11:13
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:
    fajne, przejrzyste wyjaśnienie, jednak nadal nie rozumiem punktu 4 - jak switch sam ustala, gdzie jest brama domyślna?

    Chyba plączesz warstwy sieci. Switch nie ustala.

    Komputer chce coś wysłać na IP 1.2.3.4, i wiec że leży to poza siecią lokalną, czyli trzeba wysłać do bramy domyślnej.
    Komputer ma w swojej konfiguracji zdefiniowaną bramę domyślną, powiedzmy 192.168.1.1
    Najpierw komputer ustala adres MAC tej bramy domyślnej. Wysyła broadcast ethernetowy. Ramke ethernetową zaadresowaną do wszystkich komputerów w sieci lokalnej. Switch wyśle taki pakiet na każdy swój port, rozgłosi po całej sieci. Wewnatrz siedzi „pytanie” o to, kto ma adres IP 192.168.1.1.
    Tylko jeden komputer (router odpowie) JA!! Ja mam adres IP 192.168.1.1. i mój adres MAC to=2C:2C:2C:2C:2C:2C.
    W ten sposób komputer nauczy się i przetrzyma przez jakiś czas w tabeli ARP że lokalne IP 192.168.1.1 to taki a taki adres MAC. Nasteonym razem nie bedzie musiało szukać tylko od razu wyśle na dany adres MAC.

    Switch ze swojej strony, nauczy się zas, że adres MAC 2C:2C:2C:2C: 2C: 2C jest na porcie nr 5. I każdy następny pakiet tak zaadresowany wyśle tylko na port 5, nie zawracajać „dooopy” komputerom na innych portach. Switch nie uczy się tego na zawsze. Też ma jakąś krócej lub dłużej żyjącą tabele ale przyporządkowującą adresy MAC do swoich portów. Od czasu do czasu sprawdza.

    Drzewiej były HUBy. Te były rozgłeznikami elektrycznymi. Co dostały na jednym porcie natychmiast bez sprawdzenia wysyłały na WSZYSTKIE pozotałe porty. Generowało to duży i niepotrzebny ruch.

    0
  • #23 12 Cze 2018 11:21
    PanKierownik
    Poziom 9  

    oki, switche działają w warstwie drugiej.
    ok, w konfiguracji karty sieciowej wpisałem IP bramy domyślnej - racja, więc poplątałem sam.

    Dalsze tłumaczenie też dla mnie jasne [doceniam łopatologię]

    Ale dlaczego switch nie może trafić do serwera czasu, gdzie podany jest adres IP?
    Czy dlatego, że on sam nie ma nigdzie zdefiniowanej bramy domyślnej [bo IP, warstwa 3, to nie jego robota] - więc w tym celu musiałbym mu zdefiniować jednak ten statyczny adres bramy?

    0
  • #24 12 Cze 2018 11:22
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:
    oki, switche działają w warstwie drugiej.
    ok, w konfiguracji karty sieciowej wpisałem IP bramy domyślnej - racja, więc poplątałem sam.

    Dalsze tłumaczenie też dla mnie jasne [doceniam łopatologię]

    Ale dlaczego switch nie może trafić do serwera czasu, gdzie podany jest adres IP?
    Czy dlatego, że on sam nie ma nigdzie zdefiniowanej bramy domyślnej [bo IP, warstwa 3, to nie jego robota] - więc w tym celu musiałbym mu zdefiniować jednak ten statyczny adres bramy?

    No bez tego się raczej nie obejdzie.

    0
  • #25 12 Cze 2018 11:31
    PanKierownik
    Poziom 9  

    aha... czyli de facto routing statyczny do bramy zdefiniować muszę tak naprawdę tylko dla samego switcha...
    Nikt inny tego nie potrzebuje...

    Dziękuję za cierpliwość, @m.jastrzebski.
    Miłego dnia życzę.

    0
  • #26 12 Cze 2018 11:47
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:
    aha... czyli de facto routing statyczny do bramy zdefiniować muszę tak naprawdę tylko dla samego switcha...
    Nikt inny tego nie potrzebuje...

    Dziękuję za cierpliwość, @m.jastrzebski.
    Miłego dnia życzę.

    Każdy tego potrzebuje, ale każdy kopputer ma to u siebie zdefiniowane, jeśli chce komunkować się ze światem po za siecią lokalną.

    Formalnie to nie jest routing.
    To jest zdefiniowanie bramy domyślnej, tak samo jak masz ją zdefiniowaną na dowolnym komputerze, w konfiguracji sieci.

    Lub inaczej to wskazanie urzadzenia w sieci LAN gdzie trzeba wysyłać wszelkie pakiety do komputerów spoza sieci LAN. I to urządzenie ma wieciedzieć co z tym zrobić dalej :-)

    Routing to byłby jakbyś powiedział switchowi, że do sieci 10.1.1.0 idz przez tą bramę.
    A do sieci 10.1.1.5 idz przez inną bramę. inną drogą.

    0
  • #27 12 Cze 2018 11:52
    PanKierownik
    Poziom 9  

    ok, rozumiem, jednak zdaje się, ze ten switch nie ma możliwości zdefiniowania bramy domyślnej ot tak po prostu, jak w konfiguracji karty sieciowej... A może ma, tylko ja jeszcze tego nie znalazłem.
    Pewnie to przerost formy nad treścią, tak czy inaczej, ustawiłem routing statyczny do 0.0.0.0 na bramę domyślną, i switch juz wie która godzina ;-)

    0
  • #28 12 Cze 2018 11:55
    m.jastrzebski
    Poziom 36  

    PanKierownik napisał:
    ok, rozumiem, jednak zdaje się, ze ten switch nie ma możliwości zdefiniowania bramy domyślnej ot tak po prostu, jak w konfiguracji karty sieciowej... A może ma, tylko ja jeszcze tego nie znalazłem.
    Pewnie to przerost formy nad treścią, tak czy inaczej, ustawiłem routing statyczny do 0.0.0.0 na bramę domyślną, i switch juz wie która godzina ;-)

    I tak operacja w połączeniu z VLANAmi mogła chyba drukarkę zamordować. Bo VLANy działają w warstwie 3.
    Ale grunt że teraz działa.

    0
  • #29 12 Cze 2018 12:06
    PanKierownik
    Poziom 9  

    sam nie wiem, teraz mam tak samo ten routing statyczny, a jednak drukarki działają...
    cóż, zapewne to jednak z vlanem coś miałem nie tak...
    no ale nic, ważne że teraz działa.

    0
  Szukaj w 5mln produktów