Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Excel wyszukiwanie w komórkach znaków i ich warunkowe oznaczanie

licbarskim 24 Aug 2018 15:25 567 3
  • #1
    licbarskim
    Level 5  
    Witam

    Mam mały problem z formułą.
    Chcę by excel wyszukiwał mi w danej komórce ciągu znaków np części zdania z wstawionego tam teksu i w wypadku jego znalezienia wstawiał mi np na pozytywne odnalezienie , np Tak a w przypadku nie odnalezienia Nie

    Utworzyłem formułę : jeżeli(nr.komórki zawierający tekst z mogącą znaleźć się tam szukaną frazą="szukana.fraza";Prawda;Fałsz) - sęk w tym że przy tej formule zawsze jest fałsz mimo iż szukana fraza się tam znajduje.
  • #3
    licbarskim
    Level 5  
    Trochę zmieniłem i wygląda to tak

    =JEŻELI(JEŻELI.BŁĄD(SZUKAJ.TEKST("JAKIŚ TEKST";C2);0)>0;"OK";"NIE")

    Idąc dalej zauważam że jest potrzebna zmiana koloru komórki na OK i NIE (np. zielony/czerwony) oraz skopiowanie samego wyniku reguły o komórkę dalej ale tylko samego teksu bez reguł.
  • #4
    Prot
    Level 38  
    licbarskim wrote:
    jest potrzebna zmiana koloru komórki na OK i NIE (np. zielony/czerwony)

    Wprowadź swoją formułę do warunkowego formatowania całej kolumny na pożądany kolor wypełnienia :idea:
    licbarskim wrote:
    skopiowanie samego wyniku reguły o komórkę dalej ale tylko samego teksu bez reguł.

    Formuła w wyniku daje tylko "OK i NIE" - jeśli potrzebujesz w wyniku fragment tekstu poczynając od "wyszukanej frazy" to musisz użyć funkcji FRAGMENT.TEKSTU() :D