Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel wyszukiwanie w komórkach znaków i ich warunkowe oznaczanie

24 Sie 2018 15:25 273 3
  • Poziom 4  
    Witam

    Mam mały problem z formułą.
    Chcę by excel wyszukiwał mi w danej komórce ciągu znaków np części zdania z wstawionego tam teksu i w wypadku jego znalezienia wstawiał mi np na pozytywne odnalezienie , np Tak a w przypadku nie odnalezienia Nie

    Utworzyłem formułę : jeżeli(nr.komórki zawierający tekst z mogącą znaleźć się tam szukaną frazą="szukana.fraza";Prawda;Fałsz) - sęk w tym że przy tej formule zawsze jest fałsz mimo iż szukana fraza się tam znajduje.
  • Poziom 4  
    Trochę zmieniłem i wygląda to tak

    =JEŻELI(JEŻELI.BŁĄD(SZUKAJ.TEKST("JAKIŚ TEKST";C2);0)>0;"OK";"NIE")

    Idąc dalej zauważam że jest potrzebna zmiana koloru komórki na OK i NIE (np. zielony/czerwony) oraz skopiowanie samego wyniku reguły o komórkę dalej ale tylko samego teksu bez reguł.
  • Poziom 34  
    licbarskim napisał:
    jest potrzebna zmiana koloru komórki na OK i NIE (np. zielony/czerwony)

    Wprowadź swoją formułę do warunkowego formatowania całej kolumny na pożądany kolor wypełnienia :idea:
    licbarskim napisał:
    skopiowanie samego wyniku reguły o komórkę dalej ale tylko samego teksu bez reguł.

    Formuła w wyniku daje tylko "OK i NIE" - jeśli potrzebujesz w wyniku fragment tekstu poczynając od "wyszukanej frazy" to musisz użyć funkcji FRAGMENT.TEKSTU() :D