Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Podłączenie przedwzmacniacza do uC/raspberry Pi - zbyt niski sygnał

*vip* 03 Wrz 2018 23:36 111 1
  • #1 03 Wrz 2018 23:36
    *vip*
    Poziom 17  

    Witam,
    Próbuję zrobić prosty licznik częstotliwości sygnału z mikrofonu elektretowego na Raspberry Pi. Planuję liczyć zbocza w czasie. Zrobiłem przedwzmacniacz z projektu J-250 firmy Jabel, zasilam go obniżonym napięciem 3.3V (raspberry pi), ale TL082 zdaje się pracować prawidłowo.Przy podawaniu sygnału akustycznego na mikrofon o częstotliwości bodajże 400Hz na wyjściu układu mam ładny przebieg prawie sinusoidalny o tej samej częstotliwości, ale amplitudzie około 2V (od -1 do 1V). Próbowałem zwiększać/zmniejszać wmocnienie preampa ale nic to nie daje. Taki sygnał jest za słaby aby wejście raspberry pi wykryło zbocza. Postanowiłem wzmocnić go za pomocą dodatkowego tranzystora NPN bc547 jak na poniższym schemacie i wykrywać zbocza opadające:

    Podłączenie przedwzmacniacza do uC/raspberry Pi - zbyt niski sygnał

    Niestety układ działa prawidłowo przez około 2s po czym sygnał na wyjściu zanika. Bez tranzystora układ działa prawidłowo w nieskończoność, ale sygnał jest za niski. Proszę o sugestie, pozdrawiam

    0 1
  • #2 04 Wrz 2018 09:16
    arturavs
    Poziom 38  

    Baza tranzystora jest niespolaryzowana. Podłącz rezystor 10k z bazy do kolektora. Ten między kondensatorem na wyjściu wzmacniacza a bazą usuń.

    0