Elektroda.pl
Elektroda.pl
X
Metal Work Pneumatic
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Zasilanie czujników Arduino z przetwornicy step down

m1s1ek 14 Wrz 2018 20:52 87 3
  • #1 14 Wrz 2018 20:52
    m1s1ek
    Poziom 10  

    Mam taką oto przetwornicę step-down:

    Przetwornica Step-Down LM2596 woltomierz LED
    Moduł regulowanego zasilacza - przetwornicy DC/DC step-down (obniżającej napięcie) z układem LM2596S oraz woltomierzem LED.

    DANE TECHNICZNE:
    Napiecie wejściowe IN: 4.5-40V
    Napięcie wyjściowe OUT: 1,27-35V (płynna regulacja potencjometrem)
    Max prąd wyjściowy: 2A (3A z zamontowanym radiatorem / 25W)
    Max moc przetwornicy: 15W / 25W
    Wbudowany woltomierz LED
    Informacja o aktualnym napięciu IN lub OUT, wyboru dokonuje się przyciskiem
    sprawność przetwornicy < 92%
    częstotliwość kluczowania - przełączania 150kHz
    temperatura pracy (w warunkach przemysłowych i mocy mniejszej niż 10W): -40°C do +85°C
    zabezpieczenie przed zwarciem: ograniczenie prądu
    dokładność regulacji napięcia: ± 2,5%

    Zdjęcie w załączniku.

    Chciałem przy jej pomocy zasilać czujniki w arduino, odciążając w ten sposób mikrokontroler. Przetwornica podłączona na wejściu do zasilacza 12V 1,5A. Jednak kiedy podłączam czujnik pomimo tego, że przetwornica daje 5V na wyjściu to czujnik nie działa, dioda wskazująca zasilanie czujnika się świeci np. DS3231. Po podłączeniu do zasilania arduino działa bez zarzutu. Czy zasilając czujniki w ten sposób trzeba dodatkowo dodać jakieś elementy, żeby to wszystko działało?

    0 3
  • Metal Work Pneumatic
  • #2 14 Wrz 2018 21:06
    eurotips
    Poziom 35  

    Może ten moduł ma za słabą filtrację, duże tętnienia napięcia zakłócają pracę czujników.
    Zwiększ pojemność elektrolitów na wejściu i wyjściu tej przetwornicy, dobierz doświadczalnie wartości.

    0
  • Metal Work Pneumatic
  • Pomocny post
    #3 14 Wrz 2018 22:00
    noel200
    Poziom 23  

    Połączyłeś masę wyjscia przetwornicy z masą arduino?

    0
  • #4 15 Wrz 2018 00:28
    m1s1ek
    Poziom 10  

    Dokładnie to było problemem, dzięki noel200.
    Temat do zamknięcia.

    0