Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Arduino z przekaźnikiem SSR, miganie podpiętego oświetlenia

ckonrad_ 23 Wrz 2018 12:53 345 18
  • #1 23 Wrz 2018 12:53
    ckonrad_
    Poziom 3  

    Witam wszystkich jest to mój pierwszy post, jestem laikeim jeżeli chodzi o elektronikę i arduino,
    chciałbym zrobić sterowanie żarówką led (oświetleniem) za pomocą Arduino nano oraz przekaźnika SSR oraz przycisku dzwonkowego, pobrałem kod z sieci wgrałem na płytę i wszystko wydaję się działać, mam jednak problem arduino lub sam przekaźnik odbiera prawdopodobnie jeakieś zakłucenia które występują w sieci 230V, a mianowicie czasami zdarza się tak że sam zmienia stan kiedy np. wyłacza się lodówka.
    Również jest problem gdy właczam swiatło na tym samym obwodzie tzn. żarówka podłaczona pod przekaźnik mignie.
    Jak poradzić sobie z rozwiązaniem tego problemu ?

    0 18
  • Relpol
  • #2 23 Wrz 2018 13:25
    khoam
    Poziom 17  

    ckonrad_ napisał:
    pobrałem kod z sieci wgrałem na płytę i wszystko wydaję się działać


    A co to za tajemniczy kod? Jaki to model przekaźnika SSR?

    0
  • #3 23 Wrz 2018 13:44
    ckonrad_
    Poziom 3  

    Kod: c
    Zaloguj się, aby zobaczyć kod


    dodano po 2 [minuty]:

    moduł przekaźnika ssr
    moduł z przekaźnikiem półprzewodnikowym: (ssr) solid state relay. ten rodzaj przekaźnika nie posiada elementów mechanicznych i z powodzeniem może zastąpić parę triak + transoptor. przekaźnik może być sterowany przez dowolny system, np arduino, raspberry pi itp.

    liczba przekaźników w module: 1
    zastosowany przekaźnik: g3mb-202p omron
    napięcie zasilania: 5v
    napięcie sterujące: 0-2.5v (stan niski)
    max prąd przełączany: 2a dla 240v ac
    umożliwia przełączanie napięć stałych oraz przemiennych
    detekcja przejścia przez zero
    ch wejście sterujące
    b1 a1 "styki" przekaźnika, stan niski na wejściu sterującym ch, uaktywnia przepływ napięcia pomiędzy tymi złączami
    dc+ plus napięcia zasilania (5v)
    dc- masa napięcia zasilania
    w zestawie

    moduł z przekaźnikiem ssr low level tigger

    0
  • #4 23 Wrz 2018 14:25
    khoam
    Poziom 17  

    Rozumiem, że wykorzystujesz bibliotekę MySensor do obsługi przekaźnika ...
    Na początek proponuję, aby zmienił poniższą linię kodu:

    Kod: c
    Zaloguj się, aby zobaczyć kod


    na:

    Kod: c
    Zaloguj się, aby zobaczyć kod

    0
  • #5 23 Wrz 2018 18:28
    3227441
    Użytkownik usunął konto  
  • Relpol
  • #6 24 Wrz 2018 21:58
    ckonrad_
    Poziom 3  

    Witaj,
    zdecydowanie zakłucenia występują tylko na module przekaźnika, jakiś pomysł jak to rozwiązać ?

    0
  • #7 25 Wrz 2018 05:55
    3227441
    Użytkownik usunął konto  
  • #8 25 Wrz 2018 06:06
    emarcus
    Poziom 35  

    ckonrad_ napisał:
    Witaj,
    zdecydowanie zakłucenia występują tylko na module przekaźnika, jakiś pomysł jak to rozwiązać ?

    To nie sa zakłócenia....
    Podajesz na przekaźnik zbyt niskie napięcie sterowania .
    Z twojego arduino na wyjściu masz 3.3 V (maxymalnie !!!), a przekaźnik wymaga 5V albo co naimniej 4V.
    Patrz jego wymagania elektryczne:

    Mode: G3MB-202P
    Control Input: 5V (4V-6V) DC
    Load : 75V ~ 264V AC 2A

    Jeżeli w układzie zasilania tego systemu występuje 5V to dodaj pośrednio, pomiędzy wyjście arduino a pin sterujący przekaźnika, dowolny tranzystor małej mocy NPN (obudowa T-92) zasilany ze źródła 5V. Układ taki znajdiesz w wielu źródłach.

    e marcus

    0
  • #9 25 Wrz 2018 06:37
    rs6000
    Poziom 27  

    emarcus napisał:
    ckonrad_ napisał:
    Witaj,
    zdecydowanie zakłucenia występują tylko na module przekaźnika, jakiś pomysł jak to rozwiązać ?

    To nie sa zakłócenia....
    Podajesz na przekaźnik zbyt niskie napięcie sterowania .
    Z twojego arduino na wyjściu masz 3.3 V (maxymalnie !!!), a przekaźnik wymaga 5V albo co naimniej 4V.
    Patrz jego wymagania elektryczne:

    Mode: G3MB-202P
    Control Input: 5V (4V-6V) DC
    Load : 75V ~ 264V AC 2A

    Jeżeli w układzie zasilania tego systemu występuje 5V to dodaj pośrednio, pomiędzy wyjście arduino a pin sterujący przekaźnika, dowolny tranzystor małej mocy NPN (obudowa T-92) zasilany ze źródła 5V. Układ taki znajdiesz w wielu źródłach.

    e marcus

    Z tego co kojarzę, to arduino nano jest w dwóch wersjach, jedna z atmega168 a druga popularniejsza z atmega328 na pokładzie, zatem skąd wniosek, że na "wyjściu" jest maksymalnie 3.3V ?

    Pozdr

    0
  • #10 25 Wrz 2018 15:54
    emarcus
    Poziom 35  

    rs6000 napisał:

    Z tego co kojarzę, to arduino nano jest w dwóch wersjach, jedna z atmega168 a druga popularniejsza z atmega328 na pokładzie, zatem skąd wniosek, że na "wyjściu" jest maksymalnie 3.3V ?

    Pozdr

    Bo tak gdzieś wyżej napisał, że ma arduino 'pro-mini' 8 MHz/ 3,3 V, więc na wyjściu nie będzie więcej niż 3.3V co jest powyżej stanu logicznego "LOW' dla przekaźnika, który wg./ relacji authora, załacza uklad oświetlenia, lecz występuje pewna niestabilnośc pracy, ponieważ jest to jednak niżej niż stawiane wymagania dla obsługi przekaźnika (min 4V), którego wewnętrzny uklad elektryczny nie jest znany.

    Ktoś dociekliwy i ma czas, niech poszuka ten fragment....,
    albo może autor coś powie na ten temat...(?)

    e marcus

    0
  • #11 25 Wrz 2018 16:19
    rs6000
    Poziom 27  

    ckonrad_ napisał:
    Witam wszystkich jest to mój pierwszy post, jestem laikeim jeżeli chodzi o elektronikę i arduino,
    chciałbym zrobić sterowanie żarówką led (oświetleniem) za pomocą Arduino nano oraz przekaźnika SSR oraz przycisku dzwonkowego, pobrałem kod z sieci wgrałem na płytę i wszystko wydaję się działać, mam jednak problem arduino lub sam przekaźnik odbiera prawdopodobnie jeakieś zakłucenia które występują w sieci 230V, a mianowicie czasami zdarza się tak że sam zmienia stan kiedy np. wyłacza się lodówka.
    Również jest problem gdy właczam swiatło na tym samym obwodzie tzn. żarówka podłaczona pod przekaźnik mignie.
    Jak poradzić sobie z rozwiązaniem tego problemu ?

    Ja tu czytam o Nano, chyba, że autor sam nie wie.

    Pozdr

    0
  • #12 25 Wrz 2018 22:12
    pimpuk
    Poziom 22  

    ckonrad_ napisał:
    [syntax=c]
    napięcie sterujące: 0-2.5v (stan niski)

    więc wersja Atmega nieistotna.
    Podaj kolego kod. (łącznie z bibliotekami

    0
  • #13 25 Wrz 2018 22:39
    shadow0013
    Poziom 34  

    Zacząłbym od podstaw:
    - prawidłowe filtrowanie VCC i AVCC arduino,
    - prawidłowe podłączenie Resetu (zgodnie z zaleceniami producenta),
    - nieużywane piny ustawić jako wyjścia lub wejścia.

    0
  • #14 25 Wrz 2018 22:42
    starob
    Poziom 25  

    Jak długie są przewody do sterowania przekaźnikiem?

    0
  • #15 26 Wrz 2018 11:22
    3227441
    Użytkownik usunął konto  
  • #16 28 Wrz 2018 12:08
    bimki
    Poziom 15  

    hej,

    podepnę się pod temat, bo wydaje się, że mam zbliżony problem.
    Posiadam SSR-40DA 40A (FOTEK) i oprogramowałem go za pomocą mySensors - wszystko działa ok gdy zmienię napięcie na wysokie - prąd podawany do gniazdek w pomieszczeniu działa bez zakłóceń :)
    Jednak gdy zmienię stan na niski, to dioda na przekaźniku gaśnie (OK), ale jakiś niewielki prąd dochodzi do gniazdek. Jest on mały - miernik pokazuje ok 200V, ale żadne urządzenie nie chce działać. Tak jakby przekaźnik nie do końca zamykał obwód.

    Czy ktoś może spotkał się z czymś takim?

    aha - problem mam tylko z SSR-40DA 40A, bo mam też analogicznie oprogramowany OMRON G3MB-202P (8 mniejszych przekaźników), którymi steruję światło, rolety, popmpy CO i to działa ok.

    pozdr

    0
  • #17 29 Wrz 2018 08:21
    ckonrad_
    Poziom 3  

    Witam,
    u mnie nie występuje problem na płycie arduini, jest to ewidentne przepięcie zakłucenie na przekaxniku (nawet po odłączeniu płyty) przekaźnik sam się załącza ni kilka milisekund jeżeli są jakieś skoki napięcia w sieci 230, wyięnię chyba na zwykły i może problem się rozwiąże.

    0
  • #18 30 Wrz 2018 14:51
    kaczakat
    Poziom 16  

    @bimki a nie masz jakieś kontrolki do pokazywania stanu przekaźnika? Kiedyś wymieniłem zwykłą żarówkę na ledową i po włączeniu świeciła się normalnie, po wyłączeniu lekko żarzyła. Okazało się, że wyłącznik schodowy ma kontrolkę, która zaświeca się gdy żarówka jest wyłączona, przez tę kontrolkę płynie niewielki prąd, z żarówką 40W działało OK, ale te szczątkowe mA wystarczają by żarówka ledowa się lekko świeciła. Po wymianie przełącznika na taki bez kontrolki działa normalnie.

    0
  • #19 30 Wrz 2018 20:45
    bimki
    Poziom 15  

    hej

    @kaczakat - no nie mam żadnej kontrolki poza diodą wbudowaną w przekaźnik (które po wyłączeniu gaśnie).
    @ckonrad_ - a może da się w jakiś sposób pozbyć tych zakłóceń? Ja mam już wszystko zabudowane w rozdzielni i ciężko byłoby mi wymieniać na coś innego. Może jakis mały opornik po stronie DC (ale nie znam się - nie wiem czy to dobry pomysł)? Mam 3 takie przekaźniki i na każdym to samo.

    0
  Szukaj w 5mln produktów