Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dell Latitude 10-ST2E - Tablet Dell Latitude 10 ST-2E. Dump flash-odczytanie.

06 Paź 2018 16:59 408 18
  • Poziom 22  
    Witam wszystkich.
    Jeśli zły dział, to proszę o przeniesienie.

    Kupiłem tableta Dell Latitude 10 ST2E z windowsem. Tablet żywy, wyświetlający błąd
    0x10000001 Security version mismatch detected. Make sure you are updating to a new version of the System Firmware or contact you support representative.

    Nie szło nic zrobić. Ani wejść do biosu ani nic innego. W końcu go "ożywiłem".
    Grzebiąc przy kostce SPI FLASH Winbond 25x40 (512KB). Po zwarciu nóg 1 i 2 układu. Tablet przeszedł w tryb testmode. Mogę także wejść do biosu. W końcu udało mi się zainstalować na nim system. Ową kostkę spi wylutowałem, ale ścieżki nóżek 1 i 2 są zwarte, inaczej tablet wraca do błędu który już opisałem.
    Zauważyłem że nie ma w biosie info o service tag itd.
    Chciałem doinstalować w działającym już systemie sterowniki. Przy instalacji chipset driver, system wywala windowsowski bluescreen Czyli napisy o błędzie i smutna buźka.
    Wyłączyłem go i na razie leży. W między czasie sczytałem kod z owej kostki SPI.

    Czy może ktoś zerknąć na tego dumpa?
  • Poziom 37  
    Jak jesteś w bios to masz tam gdzieś opcję aktualizacji biosu ewentualnie jak system wystartuje to może uda ci się wgrać czysty bios do tej kości .

    Dell Latitude 10-ST2E - Tablet Dell Latitude 10 ST-2E. Dump flash-odczytanie.
    Dodatkowo sprawdź czy uda ci się zrobić backup biosu tym programem Universal BIOS Backup ToolKit jak tak to podeślij tu info o biosie i backupa.
  • Poziom 22  
    A wiec tak:
    Uniwersal bios backup powoduje niebieski ekran.
    Biosu zaktualizować nie mogę, bo tablet przestał ładować choć zasilacz widziany jest w biosie. Do aktualizacji potrzebny jest podpięty zasilacz do gniazdka czego system nie widzi.
    Chcę wgrać bios A07 programatorem, jednak nie wiem jak wydobyć go z pliku exe.
  • Poziom 37  
    Te pliki bin coś mi się nie podobają jak by nie kompletne były sam nie wiem może ta pamięć jest uszkodzona i dla tego sypie bluscrinem.

    Zobacz czy uda ci się taki myk.

    Skopiuj ST2eA07.EXE do jakiegoś folderu na tablecie i uruchom CMD jako administrator i cd i podaj ścieżkę do folderu w którym jest ten plik ST2eA07.EXE. Następnie wpisz ST2eA07.EXE /writeromfile i po tym sprawdź czy obok pliku ST2eA07.EXE nie pojawił się kolejny plik.

    Tu są narzędzia AMI BIOS ale nie wszystko da się pobrać. Chyba jakieś dane wołają.
  • Poziom 22  
    Te pliki bin nie wiem czym są, ale na pewno nie biosem. "Myk" się powiódł i wyłuskałem sam plik rom. Bios A07 ma prawie 4,5mb 8-O .



    Innych znanych mi kostek SPI/I2C nie znalałem, więc bios siedzi gdzie indziej.
    Spróbuję wrzucić bios A07 narzędziem od AMI i am znać co i jak.

    Apropos tych dwu binów które załączyłem. Nie ma dobrego programu żeby zweryfikować co to za dane są?
  • Poziom 37  
    Podeślij zdjęcie płyty głównej może coś się uda zdziałać.
  • Poziom 22  
    Zdjęcie podeślę jutro.
    Narzędzia od AMI nie dają rady, twierdzą że to nie jest kompatybilny bios.
    Nie próbowałem jeszcze spod dos-a. Tylko że tu jest UEFI.
    Ponad to, za każdym razem muszę zwierać 1 i 2 nogę kostki w25x40 bo inaczej wywala błąd. Po zwarciu pokazuje się na chwilę "Manufacturing Mode Level 01"
    I przechodzi do bootowania.
  • Poziom 37  
    A masz tam gdzieś małą baterię od biosu cmos ? Jeśli jest to sprawdzałeś jakie ma napięcie ?
    A i jakie napięcie masz na baterii czy na samym zasilaczu go uruchamiasz ?
    I czy jesteś w stanie podać jaką aktualnie wersję biosu masz wgraną ?
  • Poziom 22  
    Bateria jest od CMOS-u. Zawinięta w czarną folię. Pokazuje 2,2V.
    Bateria główna trzyma i się ładuje. System tego nie widzi przez co nie mogę zrobić update biosu. Myślisz że to bat. cmos? miałem sprzęty z bateriami 1,7v i działały normalnie.
  • Poziom 37  
    inspector_electro napisał:
    Pokazuje 2,2V.

    Ten błąd może być spowodowany właśnie niskim napięciem baterii o ile to 3V bateria.
    Możliwe ze niski poziom baterii nie pozwala na aktualizację biosu.
  • Poziom 22  
    Bateria CMOS wymieniona na nową - bez rezultatu.
    Nie mam pomysłu na update biosu. Próbowałem z komendą ST2eA07.EXE /forceit
    Po wejściu w dos przez CMD jako administrator. Chwilkę myśli i system się restartuje.
    Niestety dalej jest ta sama wersja bios A01. Ciekawe jest także to, że sterowniki do chipsetu są od intela, natomiast na płycie nie ma żadnego układu od intela.

    Załączam fotki płyty od strony układów. Z drugiej strony płytka nie ma nic.
  • Poziom 37  
    Sprawdź czy czasem wersje biosu od A02 w górę ci się nie wgrają może kolejność musi być zachowana wgrywania.
  • Poziom 22  
    Próbowałem, nie idzie. Po resecie systemu dalej ten sam bios.
    Pewnie ma to związek z kostką Winbonda W25x40 na której zwieram 1 i 2 nogę żeby
    normalnie wystartował.
    Sterowniki udało mi się zainstalować, ale po identyfikatorach występowania urządzenia. Zasilacz jest widoczny i bateria tez w systemie. Tylko ten cholerny bios nie rusza.
  • Poziom 37  
    Może ta kość jest walnięta i nie działa. Nie masz jakiejś innej aby ją podmienić albo wykasuj całkowicie ją i wlutuj czystą i sprawdź efekt.
  • Poziom 22  
    Pamięć raczej jest ok. Zgrywałem z niej, kasowałem i wgrywałem z powrotem.
    Kości może w ogóle nie być i wstanie bez niej. Oczywiście ze zwartymi polami 1 i 2.

    Znowu mam problem z zainstalowaniem sterowników chipsetu. Po instalacji ginie obraz, zostaje podświetlenie a system działa.
  • Poziom 37  
    Podaj Service Tag jeszcze coś sprawdzę.

    Jakie oznaczenia maja te dwa układy ?

    Dell Latitude 10-ST2E - Tablet Dell Latitude 10 ST-2E. Dump flash-odczytanie.
  • Poziom 22  
    1. to jest LDO regulator - APL5155
    2. MX25L1606 flash spi

    Service tag - F0R2ST1
  • Poziom 37  
    MX25L1606 2MB
    MX25L1606 512KB

    Więc ni jak się to ma do tego pliku .bin z biosu. Może wgrywane to jest do pamięci NAND FLASH . Może ktoś bawił się już tego typu tabletem i będzie wiedział coś więcej. Jeśli nie ma tam więcej jakiś pamięci SPI FLASH to nie wiem gdzie ten bios się wgrywa.

    Dodano po 22 [minuty]:

    TU koleś ma program do tego wyciągania plików z .exe ale nie wiem czy to jakiejś licencji nie trzeba wykupić i czy to nie fejk jakiś.
    http://www.egyfixlab.com/

    Link
  • Poziom 22  
    Odpuszczam sobie tego tableta. Nie mam nerwów do niego.