Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Tranzystor w funkcji przełącznika 0/1 - Pali tranzystor T1

Marvell_88i8945 11 Paź 2018 14:42 153 8
  • #1 11 Paź 2018 14:42
    Marvell_88i8945
    Poziom 3  

    Witam, dawno mnie tu nie było, mam problem z układem, otóż zbudowałem sobie na 2 tranzystorach przełącznik na elementach SMD.
    Elementy jakie wybrałem są następujące:
    T1 - MBTA2222 (SOT23)
    T2 - BCP69(SOT223)
    R1 - 22K
    R2 - 4,7K
    R3 - 100K
    R4 - 1K
    C1 - 10uF(1206)
    C2 - 100n(0603)
    Dled - czerwona
    Nie było by tego tematu, gdyby nie pewien problem, otóż po podaniu napięcia 12V na resystor R1 momentalnie pali mi tranzystor T1 MBTA2222(przerwa między złączem Baza emiter lub niska rezystancja między złączem Baza-kolektor). Nie mam pojęcia gdzie leży błąd czy w wartościach rezystorów, czy wybrałem za słaby tranzystor?
    Załączam schemat narysowany w Eagle:

    0 8
  • #2 11 Paź 2018 14:56
    Marian B
    Poziom 35  

    Nie dopracowany układ. Po prostu nie pomyślałeś o stanach przejściowych przy przełączaniu.
    Droga zwarcia:
    Emiter-baza tranzystora T2, oraz kolektor-emiter T1 w chwili jego wlączenia. T2 niema rezystora w emiterze.
    Rozwiązanie:
    rezystor ograniczający w emiterze T2 lub w kolektorze T1, ewentualnie w bazie T2.

    0
  • Pomocny post
    #3 11 Paź 2018 15:03
    trymer01
    Moderator Projektowanie

    Układ błędny, gdyż brak ograniczenia prądu bazy T2 - przez B-E T2 i C-ET1 płynie prąd ograniczony tylko przez wartość R1 i zależny od bety T1 i ma wartość rzędu beta x Ib= ok. 100 x 0,5mA= ok. 50-100mA.
    Moc wydzielana na T1 wynosi wtedy (12V-UbeT2)Ic = rzędu 1-2W i to go niszczy. Nie macasz elementów? - powinien parzyć.
    BCP69 ma maxIb=0,4A więc to wytrzymuje (moc to Ube x Ib= ok. 100mW)
    W kolektorze T1 powinien być opornik rzędu 10k.

    Dziwny układ - bo dla zapalenia LED-a wystarczyłby LED z opornikiem R4. Po co tranzystory skoro sterujesz napięciem zasilania?

    0
  • #5 11 Paź 2018 15:08
    trymer01
    Moderator Projektowanie

    Marvell_88i8945 napisał:
    R4 Jest w kolektorze T2, albo dalej się mylę?

    Mylisz się - on ogranicza tylko IcT2 i prąd LED-a.
    Czytaj wyżej. Potrzebny opornik ograniczający prąd IcT1 (czyli IbT2) - najlepiej w kolektorze T1 - pomiędzy CT1 a punktem połączenia BT2 i R3.

    0
  • #7 11 Paź 2018 15:10
    trymer01
    Moderator Projektowanie

    I nic tu nie mają do rzeczy

    Marian B napisał:
    Po prostu nie pomyślałeś o stanach przejściowych przy przełączaniu.

    stany przejściowe.

    0
  • #8 11 Paź 2018 15:37
    Marvell_88i8945
    Poziom 3  

    trymer01 napisał:
    Nie macasz elementów? - powinien parzyć.
    Uruchamiam z ogranicznikiem poprzez zasilacz labolatoryjny. I faktycznie parzy. A układ zbudowałem z myślą zobaczenia jak działa tranzystor w funkcji przłącznika. Tyle nic więcej.
    Dziękuję serdecznie, za okazała pomoc i sugestie, co należałbym zrobić z tym układem aby zadziałał prawidłowo. Temat zamykam.

    Dodano po 25 [minuty]:

    Userzy naprowadzili mnie jak powinienem udoskonalić układ przedstawiony na początku tematu.

    0
  • #9 12 Paź 2018 00:43
    Marvell_88i8945
    Poziom 3  

    trymer01 napisał:
    Nie macasz elementów? - powinien parzyć.
    Uruchamiam z ogranicznikiem poprzez zasilacz labolatoryjny. I faktycznie parzy. A układ zbudowałem z myślą zobaczenia jak działa tranzystor w funkcji przłącznika. Tyle nic więcej.
    Dziękuję serdecznie, za okazała pomoc i sugestie, co należałbym zrobić z tym układem aby zadziałał prawidłowo. Temat zamykam.

    Dodano po 25 [minuty]:

    Userzy naprowadzili mnie jak powinienem udoskonalić układ przedstawiony na początku tematu.

    Dodano po 9 [godziny] 6 [minuty]:

    Problem rozwiązany, Zamieniłem R1 z 22K na 47K, oraz R2 z 4,7K na 3K co ograniczyło prąd T1 i tranzystor przestał się grzać, oraz palić, a cały układ zadziałał zgodnie z założeniem. Pozdrawiam! I zamykam temat!

    0