Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

RCF 312A - Grzeje się IRFP9140N

18 Paź 2018 19:49 726 23
  • Poziom 6  
    Dzień Dobry! Mam kolumnę aktywną RCF 312A, niestety, podczas imprezy rodzinnej kolumna podłączona do agregatu prądotwórczego uległa awarii. Postanowiłem wymienić elementy wzmacniacza które wizualnie nosiły znamiona uszkodzenia, czyli dwa tranzystory MOSFET - IRFP140, IRFP9140N, dwa tranzystory Darlingtona - SAP16PY, SAP16NY oraz dwa stabilizatory - LM337 oraz LM317T pojawia się problem.

    Otóż bez obciążenia wzmacniacz się uruchamia i elementy pozostają chłodne, jednak w momencie kiedy podłączę obciążenie (pod postacią głośnika), IRFP9140N natychmiast zaczyna się nagrzewać, dosłownie w ułamku sekundy, przy czym jego para, IRFP140, pozostaje chłodna. Oczywiście pokrętło głośności ustawione na minimum.

    Czy to znaczy że jest za niskie napięcie otwierające? Czy to znaczy że kupiłem uszkodzone Darlingtony?

    Zamieszczam obrazek poglądowy zamieszczony na tym portalu przez innego użytkownika

    RCF 312A - Grzeje się IRFP9140N
  • Poziom 34  
    Dzisiaj zeszły z mojego warsztatu dwie szt. 310A, w obu poszły oba SAP'y (tylko).
    Sprawdź, czy masz przy nich wszystko dobrze połączone i niema mikro zwarć (te pady lutownicze wołają o pomstę do nieba)
    U mnie nie obyło się bez kilku drobnych niespodzianek.
    Co ciekawe oba wzmacniacze same robią się ciepłe po włączeniu nawet bez sygnału, ale wszystko działa jak należy.
    Mierzyłeś napięcie stałe na wyjściach na głośniki? U mnie oscylowało w okolicach pojedynczych mV.
    Kolumny oddane właścicielowi, w sobotę przejdą chrzest bojowy, na jakiejś pogadance. Dam znać czy przetrwały.
  • Poziom 32  
    1. W jakiej konfiguracji pracuje wzmacniacz: klasa AB czy D ?
    2. Jakie obwody zasilają stabilizatory LM 337 i 317 ?
  • Poziom 6  
    Justyniunia napisał:
    Mierzyłeś napięcie stałe na wyjściach na głośniki?

    Nie przyszło mi do głowy, właśnie sprawdziłem, bez obciążenia jest to -35V prądu stałego!
    michald napisał:
    1. W jakiej konfiguracji pracuje wzmacniacz: klasa AB czy D ?

    Klasa D
    michald napisał:
    2. Jakie obwody zasilają stabilizatory LM 337 i 317 ?

    Niskonapięciowe, jeszcze nie sprawdziłem jakie - podejrzewam że między innymi wzmacniacz LM3886
  • Poziom 34  
    TurPoznanski napisał:
    Nie przyszło mi do głowy, właśnie sprawdziłem, bez obciążenia jest to -35V prądu stałego!

    I nie poleciał bezpiecznik jak podłączyłeś głośnik?
    Macie schemat, czy zamieścić?
  • Poziom 6  
    Nie mam schematu, byłbym wdzięczny.
  • Pomocny post
    Poziom 34  
    W załączniku schemat ze strony:
    https://www.electronica-pt.com/esquema/

    Zawsze przed podłączeniem głośnika sprawdzaj stałe na wyjściu, bo możesz narobić większego bigosu :)
  • Poziom 6  
    Justyniunia napisał:
    Zawsze przed podłączeniem głośnika sprawdzaj stałe na wyjściu, bo możesz narobić większego bigosu

    Jak myślisz, skąd tak wysokie napięcie stałe na wyjściu? Ubita dioda D37? Czy włożyłem uszkodzony SAP 16PY? Szczerze powiedziawszy, to moje pierwsze zderzenie z wzmacniaczem klasy D.
  • Poziom 34  
    Nie wiem, sprawdź oba, to chwila roboty.
    TurPoznanski napisał:
    Szczerze powiedziawszy, to moje pierwsze zderzenie z wzmacniaczem klasy D.

    Bo to nie klasa D tylko G.
    To zwykły wzmacniacz, tylko że MOSFET'y załączają wyższe napięcie na końcówkę mocy (para SAP) kiedy jest potrzebne.
  • Poziom 6  
    Po przyłożeniu elektrod miernika do tej diody wygląda na to że przewodzi w obie strony, sprawdzę czy mam taką lub podobną diodę, podmienię i zobaczę czy wyklarowała się sytuacja negatywnego napięcia na wyjściu na woofer.
    Jak myślisz, czy spokojnie mogę zastąpić UF4004 na 1N5408?
    https://www.diodes.com/assets/Datasheets/ds28007.pdf
    https://www.vishay.com/docs/88755/uf4001.pdf
    Ma wyższe parametry takie jak maksymalne napięcie zaporowe i niepowtarzalny szczytowy prąd przewodzenia, te parametry są krytyczne w celu poprawnej pracy układu?
  • Poziom 32  
    Justyniunia napisał:
    Bo to nie klasa D tylko G.
    To zwykły wzmacniacz, tylko że MOSFET'y załączają wyższe napięcie na końcówkę mocy (para SAP) kiedy jest potrzebne.

    Szczerze powiedziawszy od początku mi nie pasował ten opis sterowania przez parę HEXFET z prądem max drenu 30A i dlatego zadałem pytanie odnośnie konfiguracji.
  • Poziom 6  
    michald napisał:
    Szczerze powiedziawszy od początku mi nie pasował ten opis sterowania przez parę HEXFET z prądem max drenu 30A i dlatego zadałem pytanie odnośnie konfiguracji.

    Kierowałem się tym co wyczytałem w internecie, mając jednak do dyspozycji schemat podobnej konstrukcji (310) dostarczony przez Justyniunię, widzę że faktycznie, konstrukcyjnie zbliżony jest do AB, chociaż jeszcze nie rozumiem zasady załączania tych IRFP, to lektura dla mnie na noc :)
  • Poziom 34  
    Nie wiem, czy oba wzmacniacze w ogóle się różnią.
    310 od 312 różni się chyba tylko zastosowanym wooferem (jeśli to tak można nazwać)
  • Poziom 6  
    Justyniunia napisał:
    Nie wiem, czy oba wzmacniacze w ogóle się różnią.

    Do tej pory śledząc schemat jedyną różnicę jaką zauważyłem to niezgodność opisu elementów na schemacie w stosunku do tego co nadrukowane jest na pcb, ale różnice te są niewielkie i nie zakłócają czytelności :)
  • Poziom 34  
    No i lipa. Po godzinie grania oba wzmacniacze tonów niskich wyzionęły ducha.
    Problem widocznie leży gdzieś indziej, a uszkadzanie końcówki mocy jest tylko jego następstwem. Zasilanie... ?
    Pomiary multimetrem wskazywały że wszystko ok, może wkradają się jakieś szpile, nie wiem.
    Może układ na zasilaniu dający "kopa" nie funkcjonuje prawidłowo.
    Niestety tego nie sprawdzę, odpuszczam temat.
  • Poziom 6  
    Sprawdź czy w SAPach nie upalił się wyłącznie rezystor, moim zdaniem umieszczenie w jednej obudowie dwóch tak ciepłogennych elementów jak darlington i rezystor emiterowy to zwykły bubel. Ja sobie dałem pauzę na weekend, ale od dziś znowu ruszam temat.
    W moim przypadku do czego doszedłem to że diody D37 i D35 są w porządku.
    Kondensator C92 jest w porządku.
    Większość rezystorów które sprawdziłem też, jednakże, po przypadkowym przekręceniu potencjometru volume, napięcie na wyjściu na woofer wzrosło do -80VDC z -35VDC
    Pomierzę za chwilę napięcia HV+, HV-, LV+ oraz LV-.
  • Specjalista - zasilacze komputerowe
    TurPoznanski napisał:
    po przypadkowym przekręceniu potencjometru volume, napięcie na wyjściu na woofer wzrosło do -80VDC z -35VDC
    A czy był w tym czasie jakiś sygnał akustyczny na wejściu wzmacniacza? Mam na myśli punkt R130, C84.
    Czy masz możliwość skorzystania z oscyloskopu?

    Zwykle powodem uszkadzania się tranzystorów stopnia końcowego jest stopień utrzymywania prądu spoczynkowego. Podczas pracy z dużą mocą tranzystory nagrzewają się a to powoduje przesunięcie punktu pracy złącz BE.
    Skutkiem jest zwiększenie prądu spoczynkowego i jeszcze większe grzanie. Jeśli do tego dodać wydzielanie ciepła z powodu wzmacniania sygnału akustycznego to mamy niezły piecyk.

    Zwykle poprawnie skonstruowany układ korekcji prądu spoczynkowego wykorzystuje informację o temperaturze radiatora by nadążać za korektą prądu podczas jego nagrzewania.
    Często na radiatorze bywał termistor włączony w obwód korekcji prądu spoczynkowego lub dodatkowy tranzystor zmniejszający napięcie wymuszające prąd polaryzujący bazy tranzystorów końcowych.

    Obawiam się, że naprawa polegająca tylko na wymianie uszkodzonych elementów bez poznania przyczyny problemu to wbijanie się w koszty i niepotrzebne rozczarowania.
  • Poziom 6  
    Kolumna została uszkodzona wskutek uszkodzenia agregatu prądotwórczego z którego była zasilana.
    W.P. napisał:
    Obawiam się, że naprawa polegająca tylko na wymianie uszkodzonych elementów bez poznania przyczyny problemu to wbijanie się w koszty i niepotrzebne rozczarowania.

    Masz stuprocentową rację, pomierzyłem napięcia, część z nich oscyluje wokół pewnych wartości, obawiam się że uszkodzonych elementów jest rzeczywiście więcej, nie przywiązałem do nich uwagi nie wykazywały wizualnie znamion uszkodzenia, ale napięcia wskazują na to że dzieje się coś dziwnego, tutaj fragment schematu z pomierzonymi napięciami DC względem masy:
    RCF 312A - Grzeje się IRFP9140N

    W.P. napisał:
    A czy był w tym czasie jakiś sygnał akustyczny na wejściu wzmacniacza? Mam na myśli punkt R130, C84.

    Nie.
    W.P. napisał:
    Czy masz możliwość skorzystania z oscyloskopu?

    Tak.
    W.P. napisał:
    Zwykle poprawnie skonstruowany układ korekcji prądu spoczynkowego wykorzystuje informację o temperaturze radiatora by nadążać za korektą prądu podczas jego nagrzewania.

    Niestety, w tym wzmacniaczu układ korekcji prądu spoczynkowego składa się wyłącznie z potencjometru.
  • Pomocny post
    Specjalista - zasilacze komputerowe
    Przy takich wartościach napięć zacząłbym od usunięcia dolnego MOS-a (9140). Nie ma prawa przewodzić bez sygnału akustycznego. Dziwne te wartości, zwłaszcza spadek na R155.

    W tej chwili Q14 powinien przewodzić wymuszając przewodzenie Q11. Po napięciach widać, że nie przewodzą. Czy Q15 nie ma zwarcia?

    Trzeba się tez upewnić, czy wzmacniacz U15 ma poprawne zasilanie.

    Na czas czynności związanych z naprawą można odłączyć tranzystory MOS3 i MOS4 bądź wylutowując je, bądź zwierając bramki ze źródłem (po uprzednim sprawdzeniu diod w obwodach bramek). Sposobów jest wiele a chodzi tu o to by maksymalnie obniżyć napięcie zasilające na czas czynności serwisowych.

    W gniazda bezpieczników warto wstawić (zamiast bezpiecznika) element sporządzony ze spalonego bezpiecznika, do którego okuć dolutowany jest rezystor ok. 100Ω/2W. To tak na wszelki wypadek.
    Oczywiście dalsze prace bez włączonego obciążenia aż do momentu gdy na wyjściu pojawi się 0V a napięcia zaczną być symetryczne w odpowiednich miejscach układu.

    Dodano po 28 [minuty]:

    Jeśli masz oscyloskop to masz prawie wszystko co potrzeba do takiej naprawy. Prawie bo jeszcze przydałby się jakiś generator, ale to żaden problem.

    Dowolny zasilacz, dowolny wzmacniacz operacyjny, kilka elementów i masz w pajączku generator trójkąta. To już wystarczy.
    RCF 312A - Grzeje się IRFP9140N
    Układ nasmarowany naprędce wiec nie zdziw się jak częstotliwość będzie z kosmosu. Właściwą możesz ustalić przez korektę wartości elementów. Na rysunku błąd (z kopiowania), górne wyjście Wy1 to prostokąt, dolne Wy2 trójkąt.

    Ustal odpowiednio amplitudę i podłącz wyjście trójkąta na wejście wzmacniacza U15B, nóżka 5 przez kondensator.
    Teraz możesz oglądać i analizować przebiegi. Miernik będzie mniej potrzebny.
  • Poziom 6  
    Podaję zaktualizowane napięcia:
    RCF 312A - Grzeje się IRFP9140N
    W.P. napisał:
    zwłaszcza spadek na R155

    Spadek pływa, oscyluje w granicach 1 - 10V
    W.P. napisał:
    Czy Q15 nie ma zwarcia?

    Badając przewodzenie wykazuje te same właściwości co w sprawnym egzemplarzu, ale jeszcze raz sprawdzę.
    W.P. napisał:
    dowolny wzmacniacz operacyjny

    Na podorędziu mam TL072CP, wystarczy? Zasilacz mam nastawny, do 30V

    To jest jednak kolejna sytuacja w życiu kiedy brakuje mi generatora częstotliwości, będę chciał się w najbliższym czasie w takowy zaopatrzyć, jednak w innych sytuacjach podpierałem się po prostu aplikacją na telefonie w celu badania przebiegów w zakresie do 10kHz

    Dodano po 3 [godziny] 27 [minuty]:

    W międzyczasie, usunąłem MOS3 oraz MOS4 oraz ponownie pomierzyłem napięcia, wygląda na to że Q11 do wymiany, jeśli mnie wnioski nie mylą, dziwi mnie też brak spadku na R141:
    RCF 312A - Grzeje się IRFP9140N
  • Specjalista - zasilacze komputerowe
    TurPoznanski napisał:
    Na podorędziu mam TL072CP, wystarczy
    Bardzo dobry, niskoszumowy (ten parametr tu akurat bez znaczenia).

    Dobierz wartości R2, R3 tak by amplituda napięcia na kondensatorze była na poziomie 1/20 napięcia zasilania (dla +/- 12V będzie to ok. 0,6V. Trójkąt będzie utworzony z fragmentów krzywej wykładniczej ale przy tak małych amplitudach można przyjąć, że to trójkąt. Po prostu nie chciałem rozbudowywać układu o źródła prądowe ani o integrator. To tu wystarczy.

    Za częstotliwość odpowiada para R1, C1. Możesz obwód R1 rozbudować dodając potencjometr.

    Za maksymalną amplitudę trójkąta odpowiada para R5, R4 (1+R5/R4). Dla podanych wartości wzmocnienie tego stopnia wynosi 11.

    Co do napięć na schemacie. No już na pierwszy rzut oka:

    ZD8 - napięcie na niej to różnica podanych czyli 30V. A dioda na 15V. Wniosek jasny.
    R155 - 47Ω a na nim 5V czyli ok. 100mA. Gdzie to płynie? Przez bramkę MOS-a? Przez kondensator C93?
    R123 - powinien świecić mając na sobie ok. 12V, to prawie 1,5W.
    R151 - 83V-82V=1V czyli przez emiter płynie ok 2,5mA ale Ube=0V. Jak to możliwe?

    Jest trochę miejsc do sprawdzenia.

    Dodano po 16 [godziny] 39 [minuty]:

    Kurczę... Dziś dopiero zobaczyłem nowy schemat.

    Q13 nie powinien przewodzić przy takich napięciach. Skąd na jego emiterze -1,4V (przy napięciu na bazie wyższym niż na emiterze)?
    Widać jednak, że przewodzi w sposób niekontrolowany (patrz spadek na R139). Taki stan może być powodem silnego przewodzenia Q17 i wyjścia całości poza stan równowagi.
  • Serwisant
    Minus 12V na R136 jest? R136 poprawiłem.
  • Poziom 6  
    TOMI napisał:
    Minus 12V na R136 jest? R136 poprawiłem.

    Jest. Muszę trochę poczekać na części ponieważ nie mam takich tranzystorów w obudowie SOT23, a na miejscu w Poznaniu w sklepach mają tylko do 50V, gdzie producent zastosował 300V