Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

IBM ThinkPad T41 - Nowa karta WiFi nie działa poprawnie

08 Lis 2018 23:29 219 6
  • Poziom 15  
    Posiadam laptopa IBM T41 bez karty WiFi. Dokupiłem kartę Intel 2200BG.
    Po zainstalowaniu sterowników karta jest prawidłowo wykrywana i jestem w stanie połączyć się z internetem poprzez router WiFi z mojego telefonu Galaxy Note 4. Problem pojawia się kiedy zechcę skorzystać z mojego mobilnego routera, jakim jest Huawei E5573.
    Sieć jest zablokowana WPA2 router obsługuje standard a/b/g/n.
    Przy próbie połączenia windowsowym menadżerem otrzymuję komunikat "trwa oczekiwanie na sieć" i można tak czekać cały dzień.

    Problem nie tkwi w szyfrowaniu, ponieważ bez hasła jest to samo. Karta działa w trybie 802.11 b/g, wszystkie opcje na auto.
    Zależy mi na połączeniu z siecią mobilną z tego konkretnie routera.
  • Poziom 9  
    Witam,
    czy pomaga ustawienie szyfrowania w trybie WEP?
    Ewentualnie przydzielenie do karty sieciowej stałego adresu IP? Być może próbuje ona wydzierżawić adres, który nie został prawidłowo zwolniony.
  • Poziom 15  
    Szyfrowanie w WEP nie pomaga. Przypisanie adresu IP również, chociaż mam wątpliwości co do swojej metody bo przypisałem mu na stałe adres IP jaki miał na internecie z telefonu.
    Zauważyłem też, że po zaszyfrowaniu sieci z telefonu przez WPA2 komputer łączy się z siecią, ale nie ma dostępu do internetu.
  • Moderator - Komputery Serwis
    Witaj.
    Jaką masz wersję systemu (plus wersja Service Pack), jaką wersję sterowników do karty Intela?
  • Poziom 15  
    System to Windows XP Pro 32 SP3.
    Sterownik w wersji 9.0.4.8.
    Po włożeniu karty z routera do telefonu można połączyć się z internetem tak długo jak nie ustawi się hasła - wtedy wszystko staje na pobieraniu adresu sieciowego.
    Problem jest więc po pierwsze z komunikacją między routerem a komputerem a później z szyfrowaniem WPA2.
    Jak zawsze podłączyłem przewód szary do AUX i czarny do MAIN..
  • Moderator - Komputery Serwis
    Teoretycznie SP3 powinno mieć zintegrowaną tę poprawkę, ale spróbuj ją zainstalować (załącznik). Jeśli już jest zainstalowana, to instalator o tym poinformuje. Poprawka KB893357 umożliwia obsługę WPA2 w XP.

    Sam Intel 2200BG dość mało ciekawie działał z WPA2-AES (można spróbować go przetestować na WPA1-TKIP). Są też nowsze sterowniki i warto spróbować na nich, czasem w tych ostatnich wersjach wprowadzano ważne poprawki.

    Załączam również sterownik w wersji 9.0.4.39 (wersja do instalacji przez menedżer urządzeń), oraz oficjalny pakiet sterowników Intela dla kart z tamtego okresu (podejrzałem pliki w tym instalatorze, jest to również wersja 9.0.4.39).

    Ostatecznym rozwiązaniem może być wymiana karty sieciowej - ja w swoim T42 zamontowałem kartę na układzie Atheros i do dzisiaj nie mam problemów z łączeniem się nowymi routerami. Tylko że w przypadku tych modeli IBM trzeba uważać, bo z włożoną "nieoficjalną" kartą laptop zaprotestuje i nie uruchomi się. Trzeba ominąć blokadę (można poszukać w Google więcej informacji wpisując no1802 albo ibm error 1802).
  • Poziom 15  
    Po zastosowaniu się do rad jedyne co się zmieniło, to że mogę korzystać z narzędzia Intela i za jego pomocą mogę połączyć się z siecią z hasłem. Po włożeniu karty z routera do Note i zaszyfrowaniu jej przez WPA2 mogę połączyć się z siecią. Na routerze dalej cisza. Próbowałem wymusić pasmo 20MHz - zero skutku.