Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Kamera IP przez 2 routery

Jerzy_Maslon 08 Dec 2018 18:58 768 4
Optex
  • #1
    Jerzy_Maslon
    Level 7  
    Witam, proszę o pomoc.
    Z uwagi na słaby zasięg sieci WIFI zastosowałem drugi router i wykorzystałem stary telefon jako kamera IP.
    Z góry przepraszam za długi post ale chciałem przedstawić sytuację jak najbardziej klarownie

    Schemat:
    Funbox 2.0 => DIR-300 => Kamera IP (IP Webcam na tel. z Android)

    Ustawienia Kamera IP:
    Adres (statyczny) : port: 192.168.0.101:8081

    Ustawienia DIR-300:
    LAN:
    IP Address : 192.168.0.1
    Subnet Mask : 255.255.255.0

    INTERNET:
    IP Address : 192.168.1.17
    Subnet Mask : 255.255.255.0
    Default Gateway : 192.168.1.1
    DNS : 192.168.1.1

    Włączone przekierowanie portów ustawione na DIR-300: z 8081 na 1001 (oczywiście dla 192.168.0.101 czyli adres kamery)

    Funbox 2.0:
    adres IP modemu FunBox: 192.168.1.1
    maska podsieci LAN: 255.255.255.0
    adres dla DIR-300 (statyczny): 192.168.1.17

    Objawy po zalogowaniu przez PC do WIFI z DIR-300
    1. Widoczny w przeglądarce obraz z kamery : 192.168.0.101:8081
    2. Dostęp przez przeglądarkę do ustawień DIR-300: 192.168.0.1
    3. Dostęp przez przeglądarkę do ustawień Funbox 2.0: 192.168.1.1
    4. Jest dostęp do internetu.

    Objawy po zalogowaniu przez PC do WIFI z Funbox 2.0:
    1. Brak połączenia z kamerą w przeglądarce: 192.168.1.17:1001
    2. Brak dostępu przez przeglądarkę do ustawień DIR-300: 192.168.1.17 (wyniki ping poniżej)
    3. Dostęp przez przeglądarkę do ustawień Funbox 2.0: 192.168.1.1
    4. Jest dostęp do internetu.

    Testowałem także włączenie DMZ dla adresu kamery (192.168.0.101) w DIR-300 przy wyłączonym i włączonym
    przekierowaniu portów (8081 => 1001) niestety bez rezultatów.

    Dziwi mnie brak dostępu do DIR-300 z poziomu Funbox 2.0.

    Wyniki ping dla DIR-300 z poziomu sieci Funbox 2.0:
    --------------------------------------------------------------------------------
    Badanie 192.168.1.17 z 32 bajtami danych:
    Odpowiedź z 192.168.1.17: bajtów=32 czas<1 ms TTL=128
    Odpowiedź z 192.168.1.17: bajtów=32 czas<1 ms TTL=128
    Odpowiedź z 192.168.1.17: bajtów=32 czas<1 ms TTL=128
    Odpowiedź z 192.168.1.17: bajtów=32 czas<1 ms TTL=128

    Statystyka badania ping dla 192.168.1.17:
    Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0
    (0% straty),
    Szacunkowy czas błądzenia pakietów w millisekundach:
    Minimum = 0 ms, Maksimum = 0 ms, Czas średni = 0 ms
    --------------------------------------------------------------------------------

    Chciałbym się dowiedzieć jak połączyć się z kamerą z poziomu Funbox 2.0 bo docelowo chciałbym mieć podgląd z poza moich sieci.
    Taki dostęp już opanowałem za pomocą ddns i mam już inną kamerę (też stary telefon) połączoną ale bezpośrednio do Funbox 2.0 i
    wszystko działa bez zarzutu. Oczywiście nie jestem specjalistą z sieci więc w przypadku oczywistego błędu proszę o wyrozumiałość.

    Z góry dziękuję za podpowiedzi.
    Pozdrawiam
    Jurek
  • Optex
  • Optex
  • #3
    Jerzy_Maslon
    Level 7  
    Śmiga! Bardzo dziękuję za poradę. Obie kamery widoczne są teraz z zewnątrz sieci.

    Niestety nie pomyślałem wcześniej, żeby powrócić do pierwotnych ustawień na każdym urządzeniu.
    Zmiana ustawień zgodna ze wskazówkami w DIR-300 , bez zmiany MAC adresu okazało się tego samego jak w PC1,
    spowodowała brak dostępu do internetu dla PC1 zarówno przy połączeniu z Funbox 2.0 jak i z DIR-300.
    Dopiero reset DIR-300 i ponowne jego ustawienie, następnie ustawienie Funbox 2.0 z poziomu PC2 pomogło w rozwiązaniu problemu
    kontaktu z kamerą IP.

    Problem z PC1 niestety pozostał pomimo zmiany MAC adresu w DIR-300.

    Obecnie przy łączeniu się PC1 czy to przez DIR-300, czy przez Funbox 2.0, przypisywany jest mu adres spoza sieci??, np.
    PC1 (Funbox 2.0) - IPv4: 192.168.0.100 MAC: 00:21:5D:36:89:10
    PC1 (DIR-300) - IPv4: 169.254.130.166 MAC: 00:21:5D:36:89:10

    Ustawienie statycznego IP w Funbox 2.0 dla MAC z PC1 nie pomogło:

    Ustawienia adresów:
    Funbox 2.0: 192.168.1.1
    DIR-300: 192.168.1.100

    Na innych urządzeniach jak PC2 i inne smartfony wszystko działa tzn. internet z obu routerów i podgląd na kamery IP.

    Problem dotyczy tylko PC1. Restart Windowsa czy reset karty nic nie pomógł.

    Czy ktoś ma jakiś pomysł?

    Dodam tylko, że przy połączeniu z Darmowe_Orange_ WiFi z Funbox 2.0 jest dostęp do internetu w PC1.
  • Helpful post
    #4
    makosuu
    Network and Internet specialist
    169.x.x.x to adres autokonfiguracji, sam sobie go przypisuje. To znaczy że nie pobrał go z DHCP. Ale tak nie powinno się dziać, Funbox takie problemy miał z repeaterami a nie podłączonymi po kablu AP.
  • #5
    Jerzy_Maslon
    Level 7  
    Przypisanie IP np. 192.168.1.80 w PC1 pomogło uzyskać dostęp.
    Póki co wystarczy,

    Dziękuje i Pozdrawiam. Temat do zamknięcia.