Elektroda.pl
Elektroda.pl
X
Metal Work Pneumatic
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Prostownik regulowany - transformator, mostek i przetwornica DC/DC 9A XL4016 .

tomi0002 24 Gru 2018 14:26 327 16
  • #1 24 Gru 2018 14:26
    tomi0002
    Poziom 5  

    Witam.
    Chcę zrobić prostownik do ładowania akumulatora samochodowego tzw "bezobsługowego". Wiec chce mieć możliwość ograniczenia napięcia ładowania do 14,4V. Akumulator max 60 ah więc prąd 6A wystarczy.

    Chciałbym to zrobić na w większości gotowych modułach. Na forum już widziałem podobną konstrukcję w tym temacie https://www.elektroda.pl/rtvforum/viewtopic.php?p=16223120#16223120
    Tu są też opisane elementy które chcę użyć czyli DC/DC 9A XL4016 i miernik panelowy DSN-VC288
    https://www.elektroda.pl/rtvforum/topic3455795.html#17185036

    Całość ma się składać z elementów które akurat mam:
    - transformatora toroidalnego do halogenów z wyjściem 11,5 V moc80VA i prąd wtórnego 6.96A
    - mostka prostowniczego KBPC50005 na 50 V i 50 A
    Plus moduły od chińskich przyjaciół:
    - przetwornica DC-DC 9A / 20A 300W Step Down Buck Converter XL4016
    - miernik DSN-VC288
    - ewentualnie jeszcze moduł XH-M604 wyłączający po osiągnięciu na akumulatorze np.14,4v

    W podanym wcześniej temacie zrobiony podobnie zasilacz działa ale było tam też kilka wątpliwości odnośnie działania przetwornicy DC-DC dlatego mam kilka pytań.

    1. Czy w ogóle taki układ prostownika, który chce zrobić ma sens ? Czy lepiej szukać innych rozwiązań?
    2. Czy taki transformator jest odpowiedni? Wydaje się, że tak. Moc do 6A wystarczająca. Napięcie szczytowe po wyprostowaniu koło 15V
    3. Czy na wyjściu mostka trzeba dołożyć jeszcze kondensator elektrolityczny? I jakiej pojemności? Ta przetwornica ma niby kondensatory na wejściu.
    4. Ktoś napisał w tych podanych tematach, że jak w przetwornicy padnie sterowanie to na akumulator poleci maksymalny prąd i napięcie. Rozumiem, że w tym przypadku to 6A i 15V szczytowego z mostka? Na taką okoliczność może też zadziałać moduł XH-M604, który odłączy wtedy ładowanie.
    5. Ktoś miał też obawy co się stanie gdy na wyjście przetwornicy podłączy się akumulator ale na wejście przetwornicy nic się nie poda. I podobno nic się nie stało. Związku z tym jeszcze ogólne pytanie czy jakoś zabezpieczyć cały układ pomijając bezpieczniki 2A przed trafo i koło 10 A na wyjściu przetwornicy?

    0 16
  • Metal Work Pneumatic
  • #2 24 Gru 2018 15:20
    gimak
    Poziom 38  

    Nie bardzo rozumiem, po co ta przetwornica.
    Wg mnie w zupełności wystarczy to wymienione trafo + mostek prostowniczy na radiatorze + miernik + ewentualnie "układ" nie dopuszczający do wzrostu napięcia ładowanego ponad ustaloną wartość. Praca tego układu powinna wyglądać w ten sposób, że przy wzroście napięcia np do tych 14.4 V następuje przerwanie ładowania, napięcie wtedy spada i jak spadnie do np 13.0 V wznawiane jest ładowanie, napięcie wzrasta i po osiągnięciu wartości 14.4 V ładowanie zostaje przerwane ... i tak w kółko.
    Ten ewentualny "układ" raczej nie będzie potrzebny, bo rzadko będzie miał okazję zadziałać a jak już będzie to wskazana jest możliwość wyłączania jego działania.
    Mam taką samoróbkę i wiem co piszę - u siebie mam ustawione napięcie nie 14.4 V, a 14.8 V. .

    0
  • #3 24 Gru 2018 15:55
    tomi0002
    Poziom 5  

    Ta przetwornica po małej przeróbce i wyciągnięciu potencjometrów na obudowę ma załatwić regulację prądu i napięcia. Dość małym kosztem bo kosztuje z 4 dolary. Wtedy można tego użyć też do mniejszych akumulatorów i ustawić im mniejszy prąd ładowania. Ewentualnie też do akumulatora z dostępem do cel, któremu można podać wyższe napięcie. Tu i tak pewnie nie osiągnę więcej jak 15 V z kawałkiem.

    A w takim układzie jak piszesz to moduł XH-M604 po mostku załatwia sprawę. Można mu ustawić napięcie załączenia np. z 13V i napięcie wyłączenia np.14,4 V. I będzie tak w kółko załączał i wyłączał.
    Ale nie wiem czy nie lepszym sposobem ładowania będzie jak ustawi mu się sztywno te 14,4V i poda prąd 1/10 pojemności .
    Nie wiem jaka charakterystyka ładowania będzie przy użyciu przetwornicy. Czy ona od razu poda na starcie 14,4V i potem pomału prąd będzie spadał. Czy tak jak w zwykłym prostowniku napięcie powoli dojdzie do 14,4V.

    0
  • #4 24 Gru 2018 17:11
    gimak
    Poziom 38  

    tomi0002 napisał:
    Ale nie wiem czy nie lepszym sposobem ładowania będzie jak ustawi mu się sztywno te 14,4V i poda prąd 1/10 pojemności .

    Też nie wiem, ale wiem, że przy tych parametrach napięciowych trafo i tylko mostku prostowniczym, prąd dobiera sobie sam akumulator i on w normalnych warunkach, na samym początku pobiera prąd rzędu Q/10 i stopniowo maleje, a napięcie wzrasta. U mnie na całkiem nowym aku spadł do ok 150 mA. Pisząc normalne warunki mam na myśli akumulator nie za mocno rozładowany, bo przy głęboko rozładowanym ten prąd na początku jest większy i u mnie na aku 55 Ah, dochodził do 8 A, a to jest prąd na pewno mniejszy niż prąd pobierany okresowo przez aku z alternatora.
    Sprawa, którą powinieneś wziąć pod uwagę, to ładowanie akumulatora wyziębionego, bo wtedy przy takim ustawienia górnego napięcia (14.4 V), akumulatora nie naładujesz, będzie się zachowywał jakby był naładowany. U mnie coś takiego wystąpiło przy ustawionym napięciu 14.8 V. Myślałem początkowo, że układ kontroli napięcia fiksuje w niskich temperaturach, ale jak podłączyłem inny prostownik, w którym to napięcie było ustawione na 15.8 V i rozpoczęło się normalne ładowanie, ale napięcie na aku wynosiło 15.2 V i prąd ładowania był mały rzędu 1.5 A. W trakcie ładowania prąd zaczął wzrastać, a napięcie spadać. Po jakimś czasie prąd i napięcie się ustaliły, a następnie prąd zaczął maleć, a napięcie wzrastać.
    Po tym przypadku, na czas rozruszania akumulatora, zrobiłem możliwość wyłączania układu kontroli napięcia.
    Nie mam specjalnych doświadczeń z ładowania dużych akumulatorów z zasilaczy impulsowych. Sądząc po zachowaniu się prądu i napięcia przy ładowaniu aku 18650 zasilaczem ustawionym na 4.2 V, to napięcie się trzymało cały czas takie samo, a spadał prąd ładowania - początkowo 1A, a na końcu 70 mA, to tu, jeżeli zasilacz wydoli prądowo, to może być podobnie.

    0
  • Metal Work Pneumatic
  • #5 24 Gru 2018 19:09
    139534
    Użytkownik usunął konto  
  • #6 24 Gru 2018 20:39
    tomi0002
    Poziom 5  

    Trudno powiedzieć. Na razie transformator był sprawdzony w podłączeniu do małego akumulatora dosyć naładowanego. Przy poborze koło 1A napięcie za mostkiem na akumulatorze doszło do 15,4V
    Przy pełnym obciążeniu z akumulatora nie wiem do ilu spadnie.
    Transformator z mostkiem i elektrolitem sprawdzany był na obciążeniu z żarówek, które miały brać koło 6A i wtedy napięcie mu mocno spadło i wydawał się niewydajny prądowo. Ale nie wiem czy to był dobry sposób sprawdzania. Nie wiem jak zachowa się w podłączeniu do dużego akumulatora z dużym poborem prądowym. Nie miałem takiego akumulatora pod ręką.
    Co ciekawe, po podłączeniu tych żarówek przed mostkiem do samego trafo, transformator działał poprawnie. Dał duży prąd a napięcie mu nie spadło. Więc trafo wydaje się wydajne prądowo. Przynajmniej na AC. Nie ma pojęcia dlaczego tak spadło napięcie już za mostkiem i elektrolitem. Elektrolit był chyba o pojemności 2200.
    To transformator Indela. Na stronie podają napięcie wtórne pod obciążeniem 11,5V Nie wiem tylko czy pod pełnym obciążeniem. Prąd uzwojenia wtórnego 6,66A.

    Przetwornica ma napięcie wejściowe DC 7-32 v

    gimak napisał:
    Sprawa, którą powinieneś wziąć pod uwagę, to ładowanie akumulatora wyziębionego, bo wtedy przy takim ustawienia górnego napięcia (14.4 V), akumulatora nie naładujesz, będzie się zachowywał jakby był naładowany.
    Dlatego też chciałem mieć wyjście regulowane i prądowo i napięciowo. Żeby mieć swobodę w regulacji.
    Na elektrodzie znalazłem pomysł zastosowania tej przetwornicy DC-DC. A, że te moduły nie są drogie zastanawiam się czy ich nie wykorzystać.

    0
  • #7 24 Gru 2018 22:16
    139534
    Użytkownik usunął konto  
  • #8 24 Gru 2018 23:13
    gimak
    Poziom 38  

    Obciąż trafo z mostkiem samym kondensatorem (oczywiście po mostku) i zmierz na nim napięcie, to będziesz wiedział do jakiego napięcia byłby naładowany idealny akumulator (bez strat i zjawiska elektrolizy). Będzie to prawdopodobnie ok. 17 V, ale w realu nigdy takiej wartości akumulator nie osiągnie. Jak dojedzie do 16 V, to będzie sukces.

    tomi0002 napisał:
    napięcie mu mocno spadło i wydawał się niewydajny prądowo.

    To że napięcie spadło, to nie znaczy, że jest niewydajny prądowo, bo nawet gdyby tak było, to
    dla akumulatora jest akurat zdrowe, zapobiega przymusowemu ładowaniu akumulatora.
    Zamiast kombinować jak koń pod górę, do prostownika (trafo + mostek + moduł miernika) podłącz (bez obawy - nic się nie stanie) akumulator ten docelowy i go ładuj, obserwując jak się zachowuje prąd oraz napięcie i wnioski same się nasuną. Sprawdzaj też na początku ładowania temperaturę trafo i mostka - może się grzać, to wtedy trzeba przewidzieć radiator.

    1
  • #9 25 Gru 2018 11:07
    tomi0002
    Poziom 5  

    BC109B napisał:
    Miernik nie zmierzy prawidłowo niewygładzonego napięcia i stąd te dziwne wskazania. Kolega niech się opiera na pomiarach napięcia zmiennego pod obciążeniem - będą obarczone znacznie mniejszym błędem.
    Nawet gdy obciążeniem jest akumulator? Nie działa on jak kondensator? Wtedy pomiar też jest mocno niedokładny? Dodam, że mierzę miernikiem z true rms o ile to ma jakieś znaczenie dla takich pomiarów za mostkiem.

    gimak napisał:
    To że napięcie spadło, to nie znaczy, że jest niewydajny prądowo, bo nawet gdyby tak było, to
    dla akumulatora jest akurat zdrowe, zapobiega przymusowemu ładowaniu akumulatora.
    Nie dopisałem. Napięcie mu wtedy spadło mocno ale też i nie dał na te żarówki tych 6 A. Dał mniej niż połowę mocy. Napięcie mierzone za kondensatorem spadło gdzieś do 8V. Żarówki świeciły się słabiej. Dlatego trafo wydał mi się niewydajny prądowo. Ale podłączyłem żarówki do samego trafo i wtedy działało to poprawnie. Trafo dał duży prąd i napięcie tak nie spadło. Zastanowiło mnie skąd ta różnica między podłączeniem do samego trafo a między podłączeniem po mostku i kondensatorze.

    gimak napisał:
    Zamiast kombinować jak koń pod górę, do prostownika (trafo + mostek + moduł miernika) podłącz (bez obawy - nic się nie stanie) akumulator ten docelowy i go ładuj, obserwując jak się zachowuje prąd oraz napięcie i wnioski same się nasuną. Sprawdzaj też na początku ładowania temperaturę trafo i mostka - może się grzać, to wtedy trzeba przewidzieć radiator.
    Nie miałem pod ręką dużego akumulatora. Obciążałem tym co było.
    Mostek jest na radiatorze. Jest na 50A więc ma pewien zapas. Jak się będzie grzał to zwiększę radiator. Trafo przykręcony do metalowej podstawy.

    0
  • #10 25 Gru 2018 11:17
    139534
    Użytkownik usunął konto  
  • #11 25 Gru 2018 11:21
    tomi0002
    Poziom 5  

    Edytowałem i dopisałem wyżej. Mierzę miernikiem z true rms. Fluke. O ile ma to jakieś znaczenie do pomiarów za mostkiem.
    Pomiary robiłem przed i za mostkiem. Ten mostek obniża gdzieś o 1.1V Tak ma w specyfikacji i o dziwo faktycznie coś koło tego jest.

    Toczę dyskusję nad jednym zagadnieniem, które mnie zaciekawiło. Dlaczego za mostkiem na żarówki nie poszedł pełen prąd 6A a przy podłączeniu przed mostkiem już tak.
    Resztę rzeczy sprawdzę na podłączeniu do dużego aku.

    0
  • #12 25 Gru 2018 12:20
    gimak
    Poziom 38  

    tomi0002 napisał:
    Dlaczego za mostkiem na żarówki nie poszedł pełen prąd 6A a przy podłączeniu przed mostkiem już tak.

    Prąd fizycznie będzie prawie ten sam. Prawie taki sam, bo pomniejszony przez spadek napięcia na mostku. Różnica na mierniku wynika z tego, że przed mostkiem jest prząd przemienny i mierzysz wartość skuteczną, a za mostkiem jest prąd pulsujący i mierzysz wartość średnią.

    0
  • #13 10 Lut 2019 16:51
    tomi0002
    Poziom 5  

    Prostownik już wstępnie złożony. Trafo + mostek + moduł XH-M604 + miernik DSN-VC288

    Niestety występuje problem z pomiarem. Gdy jest podłączony tylko akumulator moduł XH-M604 i miernik mierzą poprawnie. Gdy włączę prostownik Pomiary zaczynają skakać.
    Na mierniku pomiar napięcie oscyluje od 14 do 15V Prąd też skacze np. od 0.8A do 1.6A
    Pomiar na XH-M604 skacze już nawet o 2 V. I tu jest największy problem bo trudno jest wtedy dokładnie ustawić progi załączania i wyłączania.
    Dodanie elektrolitu 4700 micro trochę tylko pomogło.
    Pomiary zwykłym multimetrem oczywiście wychodzą stabilne.
    Czy ktoś ma pomysł co jeszcze można zrobić?

    0
  • #14 10 Lut 2019 18:27
    yogi009
    Poziom 42  

    Bo bawisz się chińskim wynalazkiem. Ostatnio na Elce któryś z Kolegów opisywał swoje problemy z jakąś mniejszą przetwornicą z PRC. Ja bym to zrobił wg starego, sprawdzonego projektu Kolegi JozefaG (o ile dobrze pamiętam nick).

    0
  • #15 10 Lut 2019 18:42
    tomi0002
    Poziom 5  

    Mam to co mam w tej chwili. I problem dotyczy tego co mam. Tu potrzebuje rozwiązania.
    Zawsze można zrobić coś innego. Źle mi będzie jeździł Trabant mogę kupić Mercedesa. Ale nie o to chodzi.

    Pomiar samego napięcia za mostkiem z podłączonym kondensatorem i odpiętym akumulatorem wypada poprawnie i na module XH-M604 i na module miernika.
    Pomiar z mostka z odpiętym kondensatorem - napięcie skacze.
    Pomiar napięcia z podłączonym aku i kondensatorem w momencie gdy prostownik ładuje akumulator - mierzone napięcie i prąd skaczą.
    Tak jakby były mierzone tylko szczyty przebiegu wtedy kiedy jest ładowany aku i spadki w momencie kiedy nie jest ładowany. Ale akumulator i kondensator powinien to przecież wygładzić.

    0
  • #16 10 Lut 2019 19:03
    gimak
    Poziom 38  

    tomi0002 napisał:
    Niestety występuje problem z pomiarem. Gdy jest podłączony tylko akumulator moduł XH-M604 i miernik mierzą poprawnie. Gdy włączę prostownik Pomiary zaczynają skakać.
    Na mierniku pomiar napięcie oscyluje od 14 do 15V Prąd też skacze np. od 0.8A do 1.6A
    Pomiar na XH-M604 skacze już nawet o 2 V. I tu jest największy problem bo trudno jest wtedy dokładnie ustawić progi załączania i wyłączania.

    To że napięcie skacze to wg mnie raczej normalny objaw, ale nie bardzo rozumiem skakanie prądu, chyba że tak działa ten układ, że przy wzroście napięcia do górnego progu układ nie przerywa ładowania tylko je mocno ogranicza i gdy napięcie opadnie (a czy opadnie w tej sytuacji tego nie jestem pewien) do dolnego progu, to ponownie włącza pełne ładowanie.
    Mój układ działa w ten sposób - gdy napięcie wzrośnie do górnego progu przerywa ładowanie i prąd spada do zera i napięcie na akumulatorze zaczyna wtedy opadać. Jak napięcie spadnie do dolnej granicy to następuje wznowienie ładowania w trakcie którego napięcie zaczyna wzrastać i cykl się powtarza. Okresy (czas) ładowania i przerwy w ładowaniu zależą do wielkości prądu ładowania i stopnia naładowania akumulatora.
    Co do ustawienia progów załączania i wyłączania, to przy tym sposobie ustawiania to ich dokładnie nie ustawisz. Ja miałem dokładnie taki sam problem u siebie, gdy tak próbowałem to ustawiać, bo to jest sytuacja dynamiczna.
    Teraz mam na to sposób, pozwalający na bardzo precyzyjne ustawienie tych progów. Sposób polega na tym, że sam układ podłączam do zasilacza z regulowanym napięciem. napięcie ustawiam na górny pułap i wtedy ustawiam na układzie przerwanie ładowania (odłączenie napięcia na wyjściu). Zjeżdżam z napięciem w dół do momentu pojawienia się napięcia na wyjściu i ponownie najeżdżam bardzo powoli z napięciem do góry i sprawdzam czy odłączenie napięcia występuje w punkcie w którym chcę aby to nastąpiło. Jeżeli jest za nisko lub za wysoko, to koryguję ustawienie potencjometru w układzie odpowiedzialnego na napięcie i ponawiam próbę. Jeżeli jest dobrze, to zjeżdżam powoli z napięciem w dół i sprawdzam przy jakim napięciu następuje ponowne włączenie napięcia na wyjściu (moment wznowienia ładowania). Jeżeli mi ten poziom nie odpowiada, to koryguję ustawienie potencjometru odpowiedzialnego za histerezę i ponawiam próbę.
    U mnie ja te progi mam ustawione z dokładnością 0.1 V.
    Nie wiem, czy przy Twoim układzie, to się sprawdzi, bo on chyba nie przerywa ładowania tylko je ogranicza, ale nie wiem czy kryteria tego ograniczenia są napięciowe. Jeżeli są napięciowe, to sądzę, że na wyjściu trzeba będzie podłączyć jakiś odbiornik (np mała żarówkę, nie akumulator czy kondensator) i zwiększając napięcie na wejściu sprawdzić przy jakim napięciu następuje ograniczenie prądu i ewentualnie to skorygować. Tak samo postąpić z ustawieniem progu napięcia przywracający prąd do poprzedniej wartości. To są tylko takie moje dywagacje, bo nie wiem na jakiej zasadzie działa Twój układ.
    Jako zasilacz o napięciu regulowanym wykorzystałem zasilacz od laptopa z napięciem wyjściowym 19 V, do którego dołożyłem układ na LM317, jako regulator napięcia.

    0
  • #17 10 Lut 2019 21:04
    yogi009
    Poziom 42  

    A próbowałeś obciążyć tą przetwornicę rezystorem mocy? I wtedy pomierz... zobaczymy co za cuda pokaże.

    0