Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zyxel NAS326 - nie zachowuje stawień

02 Jan 2019 18:54 1290 19
  • Level 8  
    Zyxel NAS326 - nie zachowuje stawień

    Witam. Posiadam serwer plików jak na powyższym zdjęciu, czyli Zyxel NAS326, sprzęt ogólnie sprawny, działają wszystkie funkcje, można go skonfigurować jak się chce i wszystko jest dobrze do restartu nasa. Po ponownym uruchomieniu dysk sieciowy "zapomina" wszystkie ustawienia, wita nas ekranem zmiany hasła ze standardowego 1234 na własne, po czym przechodzi do konfigurowania wszystkich usług od początku. Jedyne co zostaje po restarcie to dane na dysku, których nie można odczytać do momentu przywrócenia konfiguracji sprzed zaniku ustawień. Jako średnio obeznany w temacie naprawy tego typu sprzętu wymieniłem baterię podtrzymującą rtc (pewnie bez znaczenia) i wgrałem jeszcze raz najnowsze oprogramowanie. Nie dało to żadnego efektu, stąd mój post tutaj, może ktoś naprowadzi na rozwiązanie problemu, ewentualnie podpowie adres jakiegoś serwisu który byłby wstanie pomóc. Podejrzewam uszkodzoną pamięć flash/eeprom HT66F30, tyle że nie mam wiedzy ani sprzętu do jej zaprogramowania i przelutowania.

    Za wszelkie rady będę wdzięczny, bo chciałbym przywrócić urządzenie do życia.
  • Helpful post
    Level 27  
    Podobnie może zachowywać się serwer jeśli kupiłeś używanego i nie zrobiłeś przywrócenia do ustawień fabrycznych (fizycznym przyciskiem). Jeśli chodzi o uszkodzoną pamięć to poszukaj na forach od Zyxela. Zdaje się, że gdzieś kiedyś przewijał mi się wątek z uszkodzoną pamięcią i sposobie jej zdiagnozowania. Jako, że nie był on w moim zainteresowaniu to i nie za bardzo pamiętam co tam się robiło. Na pewno można dostać się do NAS'a przez terminal i uruchomić linuksowe polecenie backupu pamięci a potem porównać z tym co ma być. Ale jest to zabawa która wykonana niewłaściwie może uwalić ci serwerek.
  • Level 8  
    Zrobię jak piszesz, może reset z przycisku pomoże. Zajrzę na forum zyxela, chociaż jak tam zaglądałem to było pełno tematów o tym jak znaleźć serwer w sieci...

    Logowałem się do nasa przez SSH, tyle że nie znam komend i nie chciałem nic więcej uszkodzić .
  • Level 41  
    Możliwe że pamięć jest uszkodzona i będzie konieczna jej wymiana. Podobnie się zachowują uszkodzone karty pamięci, które można formatować i kasować a dane na niej pozostają.
    Próbowałeś wgrać starszą wersję oprogramowania?
  • Level 8  
    Nie ma możliwości wgrania starszego oprogramowania, można je ściągnąć ze strony producenta, ale jest blokada i nie rusza proces downgrade'u oprogramowania, przynajmniej nie z poziomu panelu użytkownika.

    Próbowałem resetu ustawień przyciskiem. Po tej operacji serwer włączał się dłużej niż zwykle, niestety zachowanie bez zmian, nie zapisuje żadnych ustawień. Zastanawiam się czy gdybym wymienił pamięć flash/eeprom to trzeba ją wstępnie programować, czy wstawia się nową i nas ją zapisuje po skonfigurowaniu? Nie wiem w ogóle na jakiej zasadzie nas działa, jeżeli tak samo jak pc, to podstawowa konfiguracja sprzętu (czyli bios) zapisany jest w eeprom i po wymianie bez programowania będę miał cegłę. Dobrze kombinuję?

    Inna sprawa, to nawet nie wiem czy konfiguracja jest zapisywana w eepromie, czy może w pamięci flash na której jest przechowywany system. Jeżeli tak by było, to znaczy że pamięć jest sprawna, bo system się uruchamia normalnie i działa, a problemem jest sam system.
  • Level 41  
    Niektóre serwery NAS jak np Netgear po zresetowaniu ustawień ładują caly soft na dysk twardy i na nim tez są zapisane ustawienia. Jak dziala ten ZyXEL nie mam pojecia, chociaz posiadam mniejszy i chyba troche starszy model NSA310 na 1 dysk. Po wyjęciu dysku z ZYXELa NAS rusza, jak wyjąłem dyski z Netgeara serwer był martwy.
  • Level 8  
    NSA310 też mam od kilku lat i działa bezawaryjnie, ten byłby jego następcą gdyby działał. W sumie jest o co walczyć, w tej chwili jestem w stanie powiedzieć o NAS326, to że dyski usb przy zapisie osiągają prędkość około 60MB/s, a dyski sata osiągają około 90MB/s. Są to wartości nieosiągalne dla NSA310 (max45MB/s z dysku sata i około 20MB/s z dysku usb).

    Zyxelowi nie robi różnicy czy ma dysk, czy nie i tak się uruchamia i w żadnej kombinacji nie zapisuje konfiguracji. Możliwe że ktoś przede mną coś grzebał przez konsolę i stąd problem z zapisem ustawień. Płytka, wentylator, obudowa, wszystko wygląda zaskakująco czysto, nie ma żadnych śladów ingerencji mechanicznej, ani żadnych śladów uszkodzeń elementów. Pomierzyłem napięcia na wyjściach przetwornic, wszystkie są poprawne.
  • Helpful post
    Level 27  
    Jeśli dałeś radę zalogować się do terminala to możesz z jego poziomu zmienić hasło. Jeśli dobrze pamiętam to jest też możliwość podejrzenia haseł innych użytkowników w tym admin (do terminala logujesz się chyba na root). A w ogóle masz terminal uruchomiony? We wcześniejszych modelach trzeba było go włączyć (lub użyć odpowiedniego programu), bo domyślnie był wyłączony. System na nim to Debian więc zmiana haseł dokonujemy jego poleceniami (passwd).
    Teraz tak. Czy reset (oczywiście chodzi o pełen tak zwany twardy reset) robiłeś w taki sposób?
    Zyxel NAS326 - nie zachowuje stawień

    Polecam zapoznanie się z tym wątkiem https://homeforum.zyxel.com/discussion/588/nas326-firmware-upgrade Ludzie mają problem z aktualizacją 5.21. Podany jest też sposób na downgrade oprogramowania (pendrive na fat32 i wgranie plików z obrazem), ale zapoznaj się wcześniej z całym wątkiem. Może coś to pomoże.
  • Level 8  
    Tak, robiłem reset wg tego schematu co podałeś na obrazku. Hasło mogę sobie zmieniać bez problemu na jakie chcę, tylko po restarcie serwer wraca do ustawień domyślnych, włącznie z przywróceniem domyślnego hasła "1234".

    Co do terminala, wystarczy putty, połączenie przez ssh i użycie hasła jakie ma admin. Nic nie musiałem kombinować.

    Większość ludzi miało problemy po aktualizacji z usuwaniem danych z dysku i kopiowanim usb <-> dysk wewnętrzny, a u mnie są problemy z ustawieniami. Ale sprawdzę ten trop, może jest to problem aktualizacji.

    Dodano po 3 [godziny] 8 [minuty]:

    Zrobiłem downgrade softu, zgodnie z instrukcjami spod linka i nas jest w 100% sprawny, wszystko działa i zachowuje ustawienia. Nie wiem jak mam się odwdzięczyć za pomoc, ale bardzo dziękuję i pozdrawiam :)
  • Level 27  
    Jeśli chcesz to mam niepotrzebny we wcześniejszej wersji. Z nim nie było żadnego problemu :D
  • Level 8  
    Tak się zastanawiałem, czy ktoś stąd też chciał kupić ten serwer :P Ostatecznie opłaciło się, bo w 1/3 ceny mam sprawny sprzęt (całość z przesyłką wyszła 129zł)

    Aktualnie kopiuje dane ze starego nasa czyli NSA310 na ten naprawiony, czyli NAS326. Po całym zamieszaniu z tym softem, pierwsze co zrobiłem, to upewniłem się że aktualizacje automatyczne softu są wyłączone :D W tym momencie wszystko wskazuje na pełen sukces, kilka razy restartowałem serwer, na kilka minut był wyłączony żeby wstawić do niego dyski i nadal pamięta całą konfigurację.

    Tak poza tematem tego wątku... jest jakiś prosty sposób na przegranie danych między nasami bez pośrednictwa PC? Czytałem o tym, że trzeba włączyć FTP w serwerze źródłowym i przez ssh ściągać pliki... Ale mam za dużo danych żeby takie rzeczy robić przez terminal.
  • Level 27  
    Chyba szybciej będzie przez sieć lokalnie, bez pośrednictwa FTP. Użyj na przykład multicommander to skopiuje ci wszystko za jednym kliknięciem.
  • Level 8  
    Teraz tak robię, co prawda używam eksploratora, ale na jedno wyjdzie. Folderów dużo nie mam do zgrania, ale danych w sumie jest 1TB, nawet przy 1Gb/s łączu będzie to trwało całą noc (szczególnie, że mam dużo małych plików). Chciałem coś wykombinować, żeby przy kopiowaniu danych nie musiał działać komputer.
  • Level 27  
    Ogólnie to istnieje taka możliwość, ale nie jestem pewien czy na 310 będziesz mógł ją zastosować. Instalujesz (na NAS) program do replikacji (lub backupu) i jako miejsce docelowe podajesz drugiego NAS'a
  • Level 8  
    Przez noc wszystkie dane się przegrały. Rano przełożyłem pozostałe dyski, teraz w sumie mam 4TB, przy okazji jak już miałem serwer "na stole" założyłem radiatory. Miałem w zapasie od raspberry, może trochę mały jest na SOC, ale lepsze to niż nic.

    Zyxel NAS326 - nie zachowuje stawień

    Także dziękuję jeszcze raz za pomoc.
  • Level 8  
    Po niecałym roku problem wrócił. Wszystko działało jak należy, znając problemy softwareowe tego serwera nie aktualizowałem jego oprogramowania - skoro działa nie ruszam. No i pech chciał że wyjechałem na tydzień, przed wyjazdem wyłączyłem nasa. Po powrocie okazuje się że serwer sam się włączył, konfiguracja się zresetowała. W tym momencie nie pomaga już nic ani downgrade, ani upgrade softu. Za każdym razem nas nie zapisuje ustawień, jedyny plus, że udało się odzyskać dostęp do plików.
  • Level 27  
    Sprawdź jeszcze raz baterię. Pisałeś, że ją wymieniałeś, ale może miałeś jakąś starą. Jeśli to nie bateria to raczej coś fizycznego, lub dalej oprogramowanie ci szwankuje. Ciężko coś takiego namierzyć a finansowo to nie wiem czy się opłaca w niego inwestować.
  • Level 8  
    Bateria raczej nie stwarzałaby problemu z zachowywaniem ustawień serwera. Jeżeli byłaby rozładowana, to powodowałaby raczej zerowanie RTC. Z oprogramowanie zyxela chyba są większe problemy niż myślałem, bo udało mi się go znowu naprawić, ale trzeba szukać czegoś lepszego. Już piszę jak tym razem ożywiłem ustrojstwo.

    A więc: w desperacji wyciągnąłem kabel zasilający na włączonym serwerze, za chwilę go włączyłem na nowo. Dało mi do myślenia, że samo podłączenie zasilania od razu uruchomiło serwer (tak było ustawione przed awarią). Po zalogowaniu się do panelu administracyjnego, okazało się że nas "pamięta" część ustawień. Po uzupełnieniu konfiguracji i zapisie ustawień znowu wszystko działa.

    Więc przyczyną wszystkiego prawdopodobnie był zanik zasilania, tylko dlaczego usterka ustąpiła po wywołaniu kolejnego zaniku?
  • Level 27  
    Zapewne przy ponownym uruchomieniu systemu NAS nie odczytał (lub nie mógł) poprawnie odczytać konfiguracji. Czas mógł być zsynchronizowany z internetem i nawet tego nie widziałeś. Tak czy inaczej ja bym myślał o innym egzemplarzu.
  • Level 10  
    Witam,
    wiem, że sporo czasu minęło, ale może komuś się przyda.
    Kupiłem NAS326 i od razu nie trzymał żadnych ustawień po restarcie.
    Support polecił mi zwrot urządzenia ponieważ jest to uszkodzenie sprzętowe.
    Kolejny NAS, który do mnie przyszedł nie miał juz tej wady.