Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Wzmacniacz operacyjny - sterowanie tranzystora MOSFET

cloudpol7 07 Sty 2019 21:49 573 7
  • #1 07 Sty 2019 21:49
    cloudpol7
    Poziom 16  

    Mam szybkie pytanie, bo przy prostej aplikacji nie mogę dojść, w czym tkwi problem.

    Układ jak ze schematu. Zabezpieczenie nadnapięciowe. Bez podłączenia bramki do wzmacniacza napięcie na jego wyjściu jest ok. 8 V, czyli OK, i w dobrym momencie się załącza, ale po podłączeniu IRLZ44N napięcie nawet przez duży rezystor ograniczający prąd (mimo że MOSFET go nie ciągnie w stanie ustalonym) jest rzędu 3 V i stopniowo narasta przy znacznym przekroczeniu napięcia, przy którym zabezpieczenie ma się włączyć.

    Coś czuję, że to kwestia, że nie jest to komparator, ale dlaczego napięcie tak spada mimo braku poboru prądu z wyjścia?

    Założeniem układu "wzmacniacz operacyjny + MOSFET" miało być natychmiastowe pełne otwarcie tranzystora MOSFET po przekroczeniu różnicy napięć wejść + i - wzmacniacza.

    Proszę o wytłumaczenie.

    0 7
  • Pomocny post
    #2 08 Sty 2019 00:14
    jarek_lnx
    Poziom 43  

    cloudpol7 napisał:
    Bez podłączenia bramki do wzmacniacza napięcie na jego wyjściu jest ok. 8 V, czyli OK, i w dobrym momencie się załącza, ale po podłączeniu IRLZ44N napięcie nawet przez duży rezystor ograniczający prąd (mimo że MOSFET go nie ciągnie w stanie ustalonym) jest rzędu 3 V i stopniowo narasta przy znacznym przekroczeniu napięcia, przy którym zabezpieczenie ma się włączyć.
    Gdyby MOSFET się załączył całkowicie, to napięcie na wejściu (i wyjściu) komparatora/wzmacniacza musiałoby natychmiast spaść, co wyłączy tranzystor.

    Możliwe są dwa tryby pracy, oscylacje lub liniowe sterowanie tranzystora, pewnie masz ten pierwszy. W wersji z komparatorem można uzyskać szybszą reakcję, ale uniknąć oscylacji raczej się nie da, wzmacniacz (z kompensacją częstotliwościową) może wysterowywać tranzystor proporcjonalnie do energii przepięcia, jednak działa wolniej niż komparator.

    Jeśli mierzysz napięcie woltomierzem w układzie, który oscyluje, to wynik może być względnie niski, jeśli czas załączenia tranzystora jest znacznie krótszy od czasu wyłączenia. Taka asymetria może wynikać z asymetrii SR lub wydajności prądowej stopnia końcowego wzmacniacza. Przebiegi takich oscylacji miewają bardzo dziwne kształty, woltomierzem z detektorem szczytowym (R, C, D) mógłbyś cokolwiek sensownego zmierzyć, ale lepiej oscyloskopem.

    0
  • #3 10 Sty 2019 17:21
    2210063
    Użytkownik usunął konto  
  • #4 16 Sty 2019 22:24
    cloudpol7
    Poziom 16  

    jarek_lnx napisał:
    Możliwe są dwa tryby pracy, oscylacje lub liniowe sterowanie tranzystora, pewnie masz ten pierwszy. W wersji z komparatorem można uzyskać szybszą reakcję, ale uniknąć oscylacji raczej się nie da, wzmacniacz (z kompensacją częstotliwościową) może wysterowywać tranzystor proporcjonalnie do energii przepięcia, jednak działa wolniej niż komparator.

    W związku z tym, myślałem że dodanie histerezy do wzmacniacza rozwiąże problem ale prąd niewiele się zwiększył, a wydaje mi się że powinien do max na jaki pozwala rezystor przy drenie. Gdzie się myle?
    Nawet z kondensatorem jak w załaczonym schemacie niewiele się poprawiło.
    Tam są lepsze do tego zastosowania wzmacniacze i ultra low level FET ale w moim schemacie gdzie zasilam wzmacniacz wyższym napięciem też powinno to działać chyba.

    Wzmacniacz operacyjny - sterowanie tranzystora MOSFET

    jaszto napisał:
    Ten układ jest fizyczny?
    Jeżeli teoretyczny, to literka rezystora drenu mili czy Mega?

    Fizycznie rezystor jest rzędu 0,1Ohm

    0
  • #5 17 Sty 2019 10:25
    jarek_lnx
    Poziom 43  

    cloudpol7 napisał:
    W związku z tym, myślałem że dodanie histerezy do wzmacniacza rozwiąże problem ale prąd niewiele się zwiększył, a wydaje mi się że powinien do max na jaki pozwala rezystor przy drenie. Gdzie się myle?
    Jeśli źródło ma bardzo małą rezystancję wewnętrzną to masz rację jeśli nie to działają jednocześnie dodatnie i ujemne sprzężenie zwrotne. Na schemacie #4 nie ma histerezy, kondensator daje ujemne sprzężenie dla wysokich częstotliwości, to tylko sposób na liniową pracę bez oscylacji.

    Inaczej mówiąc załączanie tranzystora spowoduje spadek napięcia o x, histereza musiała by być większa.

    cloudpol7 napisał:
    Tam są lepsze do tego zastosowania wzmacniacze i ultra low level FET ale w moim schemacie gdzie zasilam wzmacniacz wyższym napięciem też powinno to działać chyba.
    Prawdę mówiąc nie wiem jak dokładnie wygląda twój układ, jeśli chcesz mogę przytaknąć.

    cloudpol7 napisał:
    Fizycznie rezystor jest rzędu 0,1Ohm
    A jaka jest rezystancja wewnętrzna źródła?

    0
  • #6 17 Sty 2019 19:48
    cloudpol7
    Poziom 16  

    Na schemacie nie ma histerezy ale próbowałem z rezystorem wprowadzającym ją + kondensator.
    Rezystancja szeregowa żródła jest pomijalna bo układ testuje na zasilaczu laboratoryjnym i problem w tym że pobierany prąd rośnie zbyt wolno względem wzrostu napięcia na wejściu.
    Dopiero przy przekroczeniu granicy o 1-2V prąd jest rzędu 2A, a układ ma służyć za balancer do superkondensatorów 2,5V ładowanych wyższym prądem.
    Chciał bym dojść do przyczyny problemu tego układu bo mnie ta niewiedza męczy;P ale jeżeli możesz zasugerować jakiś sprawdzony układ do tego celu był bym bardzo wdzięczny.
    Zacząłem od samych tranzystorów bo chciałem prostote układu, a tak to wygląda że zaraz skończy się na uC...

    P.S.
    Mój układ jest jak z pierwszego postu na LM358 zasilanym z 10V + IRLZ44N. Napięcie odniesienia to LM385 1,24V

    0
  • #7 18 Sty 2019 12:32
    jarek_lnx
    Poziom 43  

    cloudpol7 napisał:
    Rezystancja szeregowa żródła jest pomijalna bo układ testuje na zasilaczu laboratoryjnym i problem w tym że pobierany prąd rośnie zbyt wolno względem wzrostu napięcia na wejściu.
    Dopiero przy przekroczeniu granicy o 1-2V prąd jest rzędu 2A
    Sprawdzałeś czy układ sie wzbudza?

    cloudpol7 napisał:
    Chciał bym dojść do przyczyny problemu tego układu bo mnie ta niewiedza męczy;
    Nie ma mnie tam i dostaję tylko wyrywkowe informacje, więc co ja mogę?
    Nie wiem jak wygląda fizyczna realizacja twojego układu.
    Napisałem ci jak działają takie układy i gdzie należy szukać problemów.
    Piszesz w stylu wszystko jest dobrze, ale nie działa, kiedy ja konstruuję i zaczyna mi się tak wydawać, to wiem że za słabo zbadałem układ, zabieram się do roboty i nie ma szans żebym nie znalazł.
    Testujesz jakieś konkretne realizacje z konkretnymi elementami, a ja dostaję tylko wyrywkowe że dodanie histerezy nie dało efektu, cóż mogę powiedzieć "dziwne, u mnie działa"

    cloudpol7 napisał:
    jeżeli możesz zasugerować jakiś sprawdzony układ do tego celu był bym bardzo wdzięczny.

    W sieci jest wiele schematów balansera na TL431 z dodatkowym tranzystorem, zbadałem kiedyś ten układ działa bardzo dobrze w zakresie prądów od 300uA do kilku amperów, pracuje liniowo więc nie do końca tak jak byś chciał, z prawidłowym layoutem ma bardzo małą rezystancję wyjściową, pojedyncze mΩ, oczywiście TL431 dla 2,5V nie bardzo się nadaje ale z TLV431 LMV431 albo podobnym można by spróbować.

    0
  • #8 18 Sty 2019 23:15
    cloudpol7
    Poziom 16  

    Układ działa prawidłowo.
    Przyczyną problemu okazała się za duża rezystancja styków (płytka stykowa) głównego obwodu zasilającego, co powodowało spore spadki napięcia wraz ze wzrostem prądu, układ działał liniowo i pobierał niski prąd. Nawet bez zastosowania histerezy układ działa niemal "lawinowo" a nie liniowo więc zgodnie z założeniami.

    0