Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Display port i monitor - Display port nie daje obrazu?

DarthJarJar 22 Jan 2019 23:03 27621 4
  • #1
    DarthJarJar
    Level 6  
    Witajcie!
    Nie do końca wiedziałem, w jakim dziale umieścić ten problem, gdyż nie do końca wiem czego dotyczy. Sytuacja wygląda następująco - posiadam złożonego przez siebie PCta, dla pewności podam specyfikację:
    Mobo Asus PrimeZ370-P,
    i5 8600k i na nim Fera 3,
    GTX1070Ti, od Gigabyte'a,
    16G ramu, 2400Mhz,
    dysk ssd i dysk hdd, odpowiednio 128G i 1Tb,
    Vero L2 bronze 600W.
    Powyższa stacja jest podłączona do monitora Lenovo Y25f przez kabel DisplayPort.
    I tu się zaczyna historia - komputer często zostawiałem na uśpieniu (lub całkowicie go nie wyłączałem, gdy coś pobierałem). Rano włączając z powrotem ekran wyświetlał on "No signal, check input cable", po czym sam przechodził w tryb uśpienia i znowu za moment się załączał pokazując tą samą informację. Najczęściej pomagał hard reset komputera przyciskiem na obudowie (myślałem początkowo, że to wina stricte PC, ale czytajcie dalej).
    Sytuacja powtarzała się bardzo losowo, jednak apogeum naszło raz, gdy chciałem włączyć komputer od 0. PC w ogóle nie postował obrazu na monitor, co mnie przeraziło (uszkodzona grafika to ostatnie czego chciałem). Reset komputera również już nie pomagał, ale mając podłączone słuchawki mogłem usłyszeć dźwięki Windowsa, gdy nacisnąłem coś na klawiaturze. Dlatego to co zrobiłem od razu, to wymiana kabla DP na inny i podłączenie w innym porcie - sytuacja się powtórzyła. Będąc kompletnie załamany poszedłem spać - na następny dzień komputer się odpalił normalnie, spostował obraz do monitora.
    Gdy sytuacja się jednak powtórzyła - odłączyłem Display port i podłączyłem HDMI (bodajże to nowsze, bo 144Hz przez niego działają). Powyższy przypadek nie powtórzył się ani razu z podłączonym PC przez kabel HDMI (sic!). Wycwaniłem się więc, podłączając kabel i HDMI i Display Port, włączając w panelu Nvidia priorytezowanie obrazu z DP, przez co, gdy nie działał, nawet o tym nie wiedziałem, bo błyskawicznie się przełączał na HDMI.
    Dzisiaj jednak dla testu odłączyłem HDMI (by przy okazji stestować ten nowy Gsync, który działa! :P) i sytuacja się powtórzyła tym razem randomowo - podczas przeglądania internetu (co warto powiedzieć, nie zdarzyło się wcześniej).
    Moi drodzy, czy po tej rozprawce jesteście mi w stanie poddać jakiś pomysł? Oprócz oczywiście wysłania monitora do Lenovo.
    Warto zaznaczyć, że próbowałem wypiąć grafikę i podłączyć bezpośrednio Mobo z ekranem. Było to jednak z pomocą kabla HDMI, który, jak widać wyżej, działa bez zarzutu. Stąd też wykluczam uszkodzenie grafiki (niekręcona zresztą, nówka sztuka kupowana).
    Dzięki!
  • Helpful post
    #2
    Aseri15
    Level 32  
    Stawiam, że winowajcą jest raczej przewód DP. Też kiedyś miałem problem z DP i być może ten temat coś Ci pomoże -> https://www.elektroda.pl/rtvforum/topic3366789.html

    W szczególności sprawdź post nr #11 i #13 użytkownika MiroLord ( są tam opisane podobne przypadki do Twojego ) i mój ostatni post #14. Być może ( a raczej na pewno ) Twój kabel jest tak samo jak mój 20 pinowy i dlatego powoduje problem.
  • #3
    DarthJarJar
    Level 6  
    Dzięki!
    Generalnie dziwna sprawa, bo jeden kabel DP przyszedł z samym monitorem, a drugi dokupiłem osobno. W obydwu nie wiem ile pinów mają, jeszcze nie sprawdzałem, ale oba faktycznie dają ten sam efekt. Czytając też tamten wątek zobaczyłem, że "zakłócenia" również mogą występować, co jest zabawne - bo faktycznie takie "śnieżenie" obrazu występowało raz czy dwa. W takim razie chyba problem namierzony, dziwne tylko, że producenci dalej lecą w ch i nie podają, że coś się może stać.
  • #4
    Aseri15
    Level 32  
    Być może producenci sami nie wiedzą, jakie kable pakują do swoich urządzeń. Ja nie miałem razem z monitorem, więc kupiłem w sklepie komputerowym. Jak widać, takie sklepy też nie wiedzą, co mają, gdyż teoretycznie taki przewód jest kompatybilny. Ale jak widać, nie do końca.

    Producent pcha to co ma i wątpię, aby to sprawdzali. Brak opisów tych przewodów, sprawia, że trudno jest stwierdzić, czy dany przewód jest 19-sto, czy 20-sto pinowy. Sprzedawane są po prostu jako DisplayPort i nic poza tym, dlatego później wychodzą takie klocki ;)
  • #5
    DarthJarJar
    Level 6  
    Dzięki jeszcze raz.
    Czas na kupno.