Elektroda.pl
Elektroda.pl
X
Elektroda.pl
TermopastyTermopasty
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Ładowanie baterii w laptopie - Regeneracja ogniw Old

Deamon :) 25 Feb 2007 14:42 905084 1355
  • #1081
    Tofel
    Level 12  
    redart:
    Ja również zauważyłem to ze obecna pojemność się nie zgadza z naminalną. Ale nie wiem jak to zmienić. Pamieć eeprom zczytałem ale nic w niej nie ma związanego chyba z tymi danymi z sbworkshopa. Nawet jeśli wymontuje pamiec z sterownika to sbworshop pokazuje mi te dane. Co to może być?
  • TermopastyTermopasty
  • #1082
    grzesiek.r86
    Level 11  
    do tofel
    obecna pojemność się zmniejsza z czasem zwiększania iloci cykli ładowań i to wszystko zapamiętuje właśnie eeprom i w tym sęk że trzeba zmienić te wartości na orginalne czyli poj. nominalną i cykli jak najmniej(0), najlepszym sposobem jest chyba zczytanie wsady z nowej baterii (ale jesteśmy zmuszeni zmienić sami bo nikt tak owego nie umieścił i pewnie nie umieści). Są tam dane w systemie szesnastkowym i dlatego nis nie widać gołym okiem trzeba je przeliczyć na dziesiętny

    do millon z tego co zauważyłem to ostatnio do tematu dużo wnosisz tu pytanie jak idą prace nad sumą kontrolną gdzie jest zapisywana i jak zmienić? Ja wyczyściłem wsad i nie mam wcale dlatego podesłał byś mi wsad do sl220 (bat dell 4700mAh na chipie m37516) o którym pisałeś wcześniej po modyfikacjach na e-mail grzesiek.r86(malpa)wp.pl
    Powodzenia w dalszej walce. Pozdro
  • TermopastyTermopasty
  • #1083
    redart
    Level 23  
    Tofel:
    Jak kilka postów wcześniej zauważyłem, niestety nie znalazłem pdf'a do BQ8011, a to nieco komplikuje interpretację danych z eeproma (czytaj uniemożliwia :cry:). Że zacytuję Panią Graczykową: jesteś w "mylnym błędzie" sądżąc, że zawartość pamięci nie koresponduje z danymi baterii. Gwarantuję Ci, że bez zawartości eepromu reszta to tylko kawał szmelcu. Rzeczą normalną jest, że wraz z czasem pojemność aku spada. Niestety te sterowniki są na tyle inteligentne, że aktualizują sobie tę wartość nadpisując odpowiednie komórki pamięci i wtedy widzą tylko taką pojemność. Więc władowują tylko tyle ile wynosi aktualny max mAh. Co gorsza, bardzo trudno jest im wytłumaczyć, że zmieniliśmy pakiety i trzeba by zaktualizować pojemność w górę. Czasem pomaga zwykły reset (np w SBW) albo odpięcie i ponowne podpięcie stera do pakietów. Podkreślam słowo czasem...
    Nie wiem co wylutowałeś z płytki stera, może ten BQ trzyma dane pomimo odpięcia ogniw (bo nie wierzę, że wylutowałeś pamięć przy podpiętym zasilaniu :|)
    Dane przechowywane w eepromie to tylko suche liczby, nabierają znaczenia po dopasowaniu ich do odpowiednich funkcji (znaczenia dla sterownika) oraz przeliczeniu (czasem wg wzorów zależnych od zastosowanego scalaka sterującego). I jest sporo parametrów zapisywanych szestnastkowo na 2 bajtach, więc wyczajenie interpretacji jest bez pdf'a praktycznie niemożliwe.
    Wniosek: szukaj opisu do BQ8011...
    Pzdr.
  • #1084
    daniru
    Level 10  
    Prawdopodobnie masz uszkodzone jedno albo więcej ogniw sprawdź kolejno ogniwa , pamięć musisz wylutować i zczytasz jakimkolwiek programatorem albo SBDW z interfejsem np.pod LPT. przeczytaj wcześniejsze posty, ten temat był już poruszany na forum.
  • #1086
    miloon
    Level 19  
    :arrow: jukasek,
    1. co sie dzieje z ta bateria?
    2. czy juz cos grzebales w tym wsadzie?
    3. czy to na pewno bq2040, bo wedlug wstepnej weryfikacji wynika ze to na bq2060 ta bateria...?
    pozdr
  • #1087
    redart
    Level 23  
    jukasek:
    Na początku 32 strony jest wsad do tego BQ poprawiony przeze mnie i instrukcja interpretacji najważniejszych komórek. Przejrzyj to i sprubój sam...
    Powodzenia.
  • #1088
    elcorro
    Level 11  
    redart
    pozwól że się podłącze, możesz podać mi jakie wartości mam wpisać
    do pamięci w baterii Lithium-lon 14.8v 6.0Ah.Muszę zbudować nowy wsad bo mój eprom jest uszkodzony i nie mogę go odczytać.Za wzór wezmę wsad ze strony 32.W baterii wymieniłem trzy ogniwa więc licznik ładowań ustawię ok 200 pojemność na 6000mAH, napięcie się zgadza, ale nie wiem co dalej.
  • #1089
    yodi
    Level 11  
    Mój wsad do baterii hp 9,6 4500mAH i znaleziony na stronach początkowych, czy to zadziała? Dla chętnych program, do edycji ww. wsadów.
    A może ktoś zaproponuje poprawę tych wsadów - o postępach dam znać.
  • #1090
    jukasek
    Level 10  
    miloon wrote:
    :arrow: jukasek,
    1. co sie dzieje z ta bateria?
    2. czy juz cos grzebales w tym wsadzie?
    3. czy to na pewno bq2040, bo wedlug wstepnej weryfikacji wynika ze to na bq2060 ta bateria...?
    pozdr


    sorki za pomylke, rzeczywiscie to jest bq2060
    bateria nie za bardzo chciala trzymac i komp wylaczal sie po 5 minutach. wgralem jakis wsad do bq2060, ktory znalazlem wczesniej podobno zaczytany z nowej baterii ale teraz nie chce jej ladowac i nie za bardzo wiem co robic dalej
  • #1092
    redart
    Level 23  
    elcorro wrote:
    redart
    pozwól że się podłącze, możesz podać mi jakie wartości mam wpisać
    do pamięci w baterii Lithium-lon 14.8v 6.0Ah.Muszę zbudować nowy wsad bo mój eprom jest uszkodzony i nie mogę go odczytać.Za wzór wezmę wsad ze strony 32.W baterii wymieniłem trzy ogniwa więc licznik ładowań ustawię ok 200 pojemność na 6000mAH, napięcie się zgadza, ale nie wiem co dalej.


    Wystarczy uaktualnić pojemność. Myślę, że tabelka w tym pomoże. Napięcie bez zmian, a co do licznika ładowań to proponuję wrzucić 0, nie 200.
    Ale nie jest tak różowo. Jednym z parametrów pakowanych do eeproma jest wartość rezystora pomiarowego zamontowanego na płytce stera (0.05 lub 0.1Ω). Liczy się to tak: 3.2/R (3 i 2 dziesiąte podzielić na rezystancję opornika wyrażoną w omach) np: R=0.05Ω to 3.2/0.05=64, więc 64dec = 40 hex i taką wartość ładujemy do eeproma po d adresem 78dec (4Ehex). Ster mierzy na nim spadek napięcia i na jego podstawie oblicza wartość prądu.
    Drugi istotny parametr zależny od zastosowanych elementów to wartość dzielnika służącego sterowi do pomiaru napięcia. Zgodnie ze schematem aplikacyjnym
    http://www.alldatasheet.com/view.jsp?Searchword=BQ2040

    są to rezystory R4 i R5. Liczymy to tak: (R4+R5)/R4. Przykład: R4=100k, R5=720k to (100+720)/100=8.2. To jest współczynnik który przed zapakowaniem do pamięci przeliczamy: Liczba całkowita wynosi 8, zaś element dziesiętny 0.2. Teraz mnożymy 0.2 * 255 = 51. 51dec (33hex). To jest przeliczony element dziesiętny całego dzielnika. Wartość 8 pakujemy pod adres 87dec (57hex), a 51dec (33hex) pod adres 86dec (56hex). Poprawność wprowadzonego współczynnika weryfikujemy odczytując napięcie wyświetlane przez SBW lub jakiś inny program i porównując je z tym co aktualnie pokazuje miernik. W razie rozbieżności modyfikujemy współczynnik (zawartość wymienionych dwóch komórek pamięci) i próbujemy znowu...
    Jest jeszcze parę innych parametrów istotnych z punktu widzenia stera pracującego w określonym lapku. Wartość napięć EDV1 i EDV2 - napięcia końca rozładowania. Gdy napięcie aku spadnie do wartości EDV1 to ster rozłącza MOSFET'a wyjściowego na chwilkę. Laptop się wyłącza, a napięcie na pakietach wzrasta i tranzystor jest ponownie włączany. Gdy napięcie osiągnie EDV2 to ster już nie załącza tranzystora. Jeśli nie doładujemy aku (czasem trzeba zrobić to 'ręcznie') to za nic nie uzyskamy napięcia na wyjściu. EDV1 to z reguły 12.0 - 12.4V. Minimum to 12V, poniżej oznacza dobijanie ogniw (daje to 12/4= 3V na pakiet, a więc minimalne dopuszczalne napięcie na pojedyńczym ogniwie). Wartość EDV2 jest o ok. 0.4 do 0.8V mniejsza od EDV1. To kolejne zabezpieczenie przed zniszczeniem ogniw, ale mało kto zdaje sobie z tego sprawę i dziwi się, że gdy aku ma na ogniwach 10V to na wyjściu nic nie ma.
    Pzdr.

    Dodano po 17 [minuty]:

    6000mAh to 1770hex. Więc pod adres 11hex i 61 hex ładujemy wartość 17hex, zaś pod 10hex i 60 hex wartość 70hex. Pod adresami 10(Lbyte) i 11(Hbyte) przechowywana jest pojemność znamionowa akumulatora. A aktualna pod adresami 60(Lbyte) i 61(Hbyte).
    W razie czego można pokombinować z wartością prądu ładowania inicjującego (adres 08 i 09hex) oraz prądem szybkiego ładowania (1A i 1Bhex). Radzę zapoznać się z pdf'em do BQ2040, a szczególnie z tabelką przedstawiającą przykładową zawartość pamięci (Table 10. Example Register Contents - str. 23).
    Powodzenia.

    Dodano po 8 [minuty]:

    I jeszcze jedno: wartość napięcia aku to po prostu np 14400mV czyli 3840hex, więc pod adresem 13hex jest 28hex, a pod 12hex umieszczamy 40hex. Natomiast wartość EDV1 i EDV2 zapisuje się inaczej. Np EDV=12000mV, ale nie przeliczamy tego bezpośrednio na hex tylko najpierw 65536-12000 = 53536 i dopiero tę wartość (D120hex) ładujemy do pamięci.
    Jak mi się coś przypomni to dopiszę :D.
  • #1093
    redart
    Level 23  
    elcorro:
    Zmieniłem:
    - 0Ehex: licznik cykli na 0,
    - 2Ehex: poziom BATTERY LOW na 3% (było 59% !)
    - 49hex: offset temperatury na 12.8 stopnia, było 7stopni
    - 4Ahex: max temperatura ładowania i delta (wg pdf'a: 61st i 4,6st)
    - 5C i 5Dhex: EDV1 na 12000mV - było 13000
    - 5E i 5Fhex: EDVEnd na 11600mV - było 11500
    - 60 i 61hex: pojemność aktualna na 6000mAh - było 7Ah z hakiem

    Nie wiem co to za wartości pod adresami od 65 do 7Fhex, podobno BQ ich póki co nie używa :D.
    Pzdr.
  • #1094
    elcorro
    Level 11  
    Redart
    Zmieniłem trochę twój eeprom w Battery status mam, 64 ale nie mam pewności czy to dobrze, Initial charging current i Fast-charging current 2200.Miałem jeszcze dużą różnicę przy pomiarze prądu, program pokazywał 12V a miernik 15V, więc zmieniłem w Voltage gain 1 z 8, 06 na 10, 2 i teraz pomiar napięcia jest prawie taki sam.
    Następnie zauważyłem, że komputer wyłącza się, a na baterii jest 13000V komórka EDV1=12000V, więc zmieniłem EDV1=11600 EDV2=11100 chcąc przedłużyć trochę pracę nie szkodząc baterii.
    Po tych modernizacjach bateria naładowała się 57% i komputer chodził 1h10min to już sukces.
    Ale gdy się rozładował to program BateryMon pokazywał napięcie 13.08V i 540mAV z tego wynika, że komputer nie wyłączył się przy spadku napięcia tylko pojemności baterii, bo 540mAV to 8% a przy tej wartości komputer sygnalizuje niski stan baterii i się wyłącza. Jeszcze jedno podczas ładowania napięcie dochodzi do 17, 02V czy nie jest to za dużo przy baterii 14800 a komórka
    Charging Voltage=16800.Właśnie kończy się drugie ładowanie i bateria 60,9%, do tej pory każde następne ładowanie to był spadek %.Po pierwszych niepowodzeniach zamówiłem nowe ogniwa a tu spory sukces.
    Redart napisz, co o tym myślisz a ja jeszcze potestuję.
  • #1095
    toni_c
    Level 11  
    Szanowni Panowie :)

    Ze mnie taki sobie elektronik ale temat zainteresował mnie bardzo

    mam dwie prośby:

    1. Nigdzie nie mogę namierzyć SBW (serwery zrzucają na error404)
    jeśli ktoś ma jakiś działąjący link lub może podesłać
    2. Moja bateria jest do compaqa presario 700
    na eepromie 25c040
    jakiś wsad znalazłem ale jeszcze nie mam czym go zaprogramować
    tu proszę o wszelkie rady co z nią począć (jak i czym) (linki, etc)

    Ten dłuuuuugi temat chyba już przeczytałem ale zrobię to jeszcze raz :) jest takiiii długi :)

    Dzięki za rady i pomoc

    Toni
  • #1097
    redart
    Level 23  
    elcorro:
    Jeśli istnieją rozbieżności w napięciu mierzonym przez sterownik i miernik to należy bezwzględnie zmienić współczynnik dzielnika! Jest to ewidentny błąd w danych wpisanych do eeproma. Zrób to szybko, bo dobijasz ogniwa ładując je ponad 4,20V.
    Żeby zobaczyć przy jakim napięciu lapek się wyłącza trzeba najpierw zrobić to co pisałem wyżej (zgrać wartość dzielnika z rzeczywistością), potem obserwować napięcie na mierniku w trakcie rozładowywania. Ponieważ to normalne, że gdy aku osiągnie np 12,0V, lapek się wyłącza (lub rozłącza się tranzystor stera) to po ustaniu obciążenia ogniw zaczyna na nich wzrastać napięcie. Zanim je odczytasz w programie, to z 12V może wzrosnąć nawet do 14V. Im dłużej czekasz tym napięcie będzie bliższe znamionowemu (u Ciebie 3,7V na ogniwo).

    A skąd wziąłeś te 8%? Wartość 8 w komórce BATTERY LOW to nie 8% tylko 3%, ponieważ liczy się to tak: BatLo[%] * 2,56 = wartość do wpisania... (3% * 2,56 = 7,68 czyli ≈ 8 ) :wink: .
    Pzdr.

    tomasz999:
    Po polsku??? Ktoś musiałby to zrobić specjalnie dla Ciebie, bo w sieci nie ma opisów w PL. Pozostaje słownik/tłumacz albo nauka ENG...
  • #1098
    Profil-gsm
    Level 2  
    Witam. Mam baterie 75UYF od della c640 odlutowalem ogniwa od elektroniki zaprogramowalem innym wsadem eeprom i teraz mam problem poniewaz nie pamietam jak dokladnie byly podlaczone kabelki. Z tego co zuwazylem juz to minus mam wlutowac do VG, plus do VT i zostaje jeszce podlaczyc kabelki do VH, VP, VM i VL. Jesli ktos wie gdzie je dokladnie zalutowac to prosze o pomoc.
    Pozdrawiam
  • #1099
    redart
    Level 23  
    Profil-gsm wrote:
    Witam. Mam baterie 75UYF od della c640 odlutowalem ogniwa od elektroniki zaprogramowalem innym wsadem eeprom i teraz mam problem poniewaz nie pamietam jak dokladnie byly podlaczone kabelki. Z tego co zuwazylem juz to minus mam wlutowac do VG, plus do VT i zostaje jeszce podlaczyc kabelki do VH, VP, VM i VL. Jesli ktos wie gdzie je dokladnie zalutowac to prosze o pomoc.
    Pozdrawiam


    No tak, "popsułem - ratujcie" :D...
    Ogniwa liczymy od minusa do plusa, nie wiem ile ich masz, jeśli są 4 pakiety to tak:
    VG - voltage ground: minus ogniw;
    VL - voltage low: plus pierwszego ogniwa;
    VM - voltage medium: plus drugiego ogniwa;
    VH - voltage high: plus trzeciego ogniwa;

    Nie widziałem tej baterii, ale na mój gust VP powinno być do plusa całego aku. Co do VT to nie mam pojęcia. Kiedyś spotkałem się z tym, że było połączenie minusa bezpośrednio z ogniw (opisane VG) oraz VT - to był minus puszczony przez bezpiecznik termiczny. Ale czy tak jest w tym przypadku to nie wiem, daj jakieś fotki, to zobaczymy.
    Pzdr.

    PS
    Na przyszłość myśl co robisz...
  • #1100
    Profil-gsm
    Level 2  
    Dzieki za podpowiedz. Dokladnie to sprawa wyglada tak ze mam kilka baterii do della i w innych modelach inaczej jest pozaznaczane jak zalutowac kabelki a w tej nie popatrzylem i sie troche zagubilem.
    Co chodzi o VT to raczej na pewno plus ma byc podlaczony bo w innym wypadku lapek nie rozpoznaje baterii, a VP w tym przypaku to raczej nie jest ani plus ani minus bo mierzylem napiecie i jest tak okolo 12V podobnie jak w VH.
    To VP gdzies bylo podlaczone bo widac slad lutowania :)
    Ogolnie nie podlaczajac VP laptop zorpoznaje baterie, pokazuje stan naladowania i wyswietla ze laduje ale w rzeczywistosci nie laduje a kontrolka baterii mruga caly czas na pomaranczowo:(
    Mam jeszce pytanko odnosnie innej baterii 1691P, a dokladnie chodzi mi o wsad do eepromu sl220, uklad sterujacy M3751x, ma ktos moze taki sprawdzony ?
  • #1101
    redart
    Level 23  
    Napisz ile jest pakietów w tym aku i co jest podpięte (jakie elementy) do ścieżek Vx. A najlepiej wrzuć fotki sterownika. To wiele wyjaśni.
    Pzdr.
  • #1102
    elcorro
    Level 11  
    Zmieniłem dzielnik na 10,2 komórka (Voltage gain 1) i mam różnicę 0,1Vnastępnie zmieniałem na 10,30 10,53 11,8 9,8 i nie mogę ustawić lepiej, po tych zmianach nie było wielkiej różnicy chyba że zmieniam niewłaściwą komórkę, a teraz to uszkodziłem pamięć 24c02.
    A może zmienić napięcie z 16800V na 16700V.Wtedy prąd ładowania powiniwn spaść o 0,1V,bo dochodzi do 17V.
  • #1103
    GumbaS
    Level 11  
    Witam,


    Mam problem z baterią do Compaq Armada e500 - trzyma około 20 minut, ładuje się ze 30.
    Diody po wciśnięciu guzika sugerują czasem dobrze (rozładowana), a czasem pokazują 100% podczas gdy komputer się już nie włącza. Bateria stara, dane:
    seria: PP2061E
    napięcie: 11.1V
    pojemność: 4.8 AHr
    9 ogniw, rev. 2.04

    Nie znam się na tyle na elektronice, aby zmontować jakiś układ, więc pytam czy jest sens, żebym czytał te całe 37 stron? :)
    Bo tak przejżałem i widzę, że potrzeba jakiś programator kupić/zrobić i potem przy jego pomocy majstrować.

    Da radę coś z tym zrobić samemu - choćby jakoś sprawdzić, czy muszę albo zrobić/kupić programator itd albo oddać komuś, kto się na tym zna?
  • #1104
    DarLord
    Level 1  
    Witam

    Jestem początkujący w temacie regeneracji baterii. Zczytałem wsad pamięci z padniętej baterii Dell c1295 11.1v 4700mAH pamięć 93c56 chipset m37516.
    Czy ktoś z forumowiczów wie co należy poprawić w tym wsadzie.
    Za wszelką pomoc z góry dziękuję.

    Pozdrawiam
    DarLord
  • #1105
    Calineczka*
    Level 31  
    Witam Panowie;-)
    Ale się z tego zrobił długi temat!
    Mam pytanko. Usiłuję zregenerować akku od Della L400. Chcę wymienić ogniwa ale są nietypowe...a może raczej rzadko spotykane, pryzmatyczne. Czy może ktoś z Was zastosował z powodzeniem do laptopa akumulatory z telefonu gsm? Są teraz tak tanie że aż się prosi o takie doświadczenia. Może potraficie mi podpowiedzieć jaki akumulatorek będzie miał podobne wymiary, parametry? Potrzebuję ogniw 3,6V (4,2V) o wymiarach 49mm długości, 33mm szerokości i jakieś 11mm wysokości.
    Gdyby ktoś zamieścił jakiś pewny wsad do Della L400 był bym wdzięczny ;-)
  • #1106
    Skuroskok
    Level 11  
    Witam I Prosze o pomoc
    Mianowice mam Baterie z ibm thinkpada390(fimyAPC)
    aku.9szt sa w 100%sprawne(laczone 3x3)tylko co s zelektornika jest ni tak .Na wyjsciu jest 0V(bateri laptok niwidzi nic tak jak by jej nibylo)bezpieczniki sa dobre opory wszytkei tak ogulnie wszytko sprawdzilem oprucz(bo niwiem jak)
    293A(16pin)
    bq2040(16pin)
    2xtpc8106(8pin)
    k212l(lub 24c01to powyzej mnijszymi pize na tym samym)

    Prosze o pomoc mam nazady z innej bateri tylko teraz co przelutowac i jak sprawdzic co nidziala .Moje gg 8261481 mail SKuroskok(malpa)interia.pl.
    LICZE AN WASZA POMOC
  • #1107
    rapsik
    Level 11  
    Witam

    Przepraszam jeśli nie znalazłem/doczytałem mojego problemu.

    A więc mam della latiude 610 i po poczytaniu kilku postów zrobiłem zrobiłem programator pod ltp na 74ls05, sbworkshop pokazuje ze smbus jest ok. Jeśli chce zczytać z baterii dane - komunikat ze baterii nie znalazł. Mam pinologie, baterii, nie mam howto od sbw ponieważ nie da sie sciągnąc z ich strony archiwum, miałem gołą setupke sbwdemo.

    Nie wiem jak zmusic baterie do odczytu??

    aa jak podłączam do baterii mierniczek to nie pokazuje mi napięć, a bateria jest "naładowana" (działa w laptopie do 10 min), podłączanie żarówki też nic nie daje.

    Bat.
    typ: 75uyf
    3,5A
    14,8V
    3800mAh
  • #1108
    Tofel
    Level 12  
    Witam wszystkich.

    Co nieco udało mi sie pozmieniać w ustawieniach mojej baterii na bq8011 tylko nie wiem do końca jakie parametrty po ustawiać. Prosze o pomoc.
    Załączam sreen z moimi obecnymi informacjami z sbworkshop.

    Ładowanie baterii w laptopie - Regeneracja ogniw Old


    Pozdrawiam!!!
  • #1109
    redart
    Level 23  
    Calineczka*:
    Gdzieś w okolicach 30 strony jest mój 'wyrób' oparty o ogniwa do nokii. Chodzi dosyć przyzwoicie, jak na swoją cenę. Używam aku z tymi ogniwami jakieś pół roku i jest OK. Trzymają od 1 do 1,5h, co biorąc pod uwagę mój sprzęt jest niezłym wynikiem. Proponuję rozejrzeć się za bateriami i dobrać takie gabaryty aby można było to upchnąć w obudowę. Ja zastosowałem 3 ogniwa na pakiet i jestem zadowolony.
    Pzdr.

    Dodano po 3 [godziny] 26 [minuty]:

    Tofel:
    Przeprowadź ze 2 cykle ładowania i dopiero sprawdzaj parametry. Patrząc na aktualne napięcie to wygląda na stan tuż po naładowaniu. Co do pojemności to bez rewelacji: znamionowa 4400mAh, zaś aktualna 1155mAh, więc tak około 25%. Cudów nie ma.

    Dodano po 8 [minuty]:

    Skuroskok:
    Taki sam efekt 'osiągnąłem' po uwaleniu diód zenera na zabezpieczeniu linii SDA i SCL... W moim przypadku była to podwójna dioda zenera w SMD (wygląda jak tranzystor), dostała zwarcia, więc wszelkie sygnały na magistrali były sprowadzane do poziomu masy. Jakby tego było mało, to takie samo zabezpieczenie jest w lapku na magistrali SMBus, do której podpina się aku. Sprawdź na płytce stera jaka jest rezystancja pomiędzy liniami SDA i masą oraz SCL i masą (przy odłączonych ogniwach!). Mniejsza niż kilka kΩ oznacza, że trzeba szukać przyczyny w elementach zabezpieczenia lini magistrali albo w samym sterowniku.
  • #1110
    Profil-gsm
    Level 2  
    Z tamta bateria dalem sobie spokuj, ale mam kolejnych kilka sztuk a dokladnie baterie do della model 66Whr, wszystkie Sanyo i wszystkie maja ten sam objaw mrugaja trzy diody, pierwsza, trzecia i piata. Uklad sterujacy BQ8011 i jest jeszcze BQ29310PW a eeprom to 24C01. Wszystkie baterie po podpieciu do laptopa wyswietlaja zerowy stan naladowania i standardowo mruga dioda od baterii przy lapku. Oczywiscie komputer po odlaczeniu zasilacza wylacza sie. Jedna z tych baterii przy pierwszym wlozeniu do lapka ladowala sie ale nie mogla naladowac wiec podejzewalem ogniwa i bylo uszkodzona jedna para ogniw, po wymianie na sprawne ogniwo i wyrownaniu napiecia na wszystkich ogniwach okazalo sie ze po powrotnym podpieciu elektroniki bateria jest uszkodzona, mrugaja trzy ww. diody. Modyfikowalem lekko wsad eepromu ale nie przynosilo to skutku zadnego:( Wie ktos moze jakim sposobem postawic te baterie? Dodam jeszcze ze mam taka sama sprawna baterie ale boje sie odpinac elektronike zeby jej nie zepsuc. Ponizej zalaczam zwie zgrane zawartosci eepromow z dwoch baterii, moze ktos na nie zobaczyc i napisac co jest nie tak z nimi.