Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Sklep ElwronSklep Elwron
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ładowanie baterii w laptopie - Regeneracja ogniw Old

Deamon :) 30 Wrz 2006 17:01 902282 1355
  • #721
    Grzegorzxxx
    Poziom 12  
    A wiec tak:(Rozebralem baterie i okazalo sie ze sa polonczone po,cztery dzialy ogniw,kazdy dzial ma 3 ogniwa rowonlegle polonczone.PO zmierzeniu na nich napiec 1-3 dzialy maja 4 V(chyba przeladowane),a na 4 dziale jest prawie 0.Czyli to pewnie te trzy ogniwa sa padniete.
    Nastepnie wlozylem rozebrana baterie do laptopa w celu sprzwdzenia czy wogole ja ładuje. Po ponownych pomiarach na wszystkich od 1-3 było rowno ok 4,2 V ładowanie, a na tym 4 bylo okolo 4,5-5.
    Czyli ładowanie raczej jest i elektronika w baterii tez OK tylko chyba to te 3 ogniwa z 4 dzialu sa padniete:( JAK MYSLICIE??
  • Sklep ElwronSklep Elwron
  • Pomocny post
    #722
    janek1815
    Poziom 38  
    czyli ta bateria sie nie moze naladowac bo jej zywot sie zakonczył takie moje zdanie i 3 acu do wymiany
  • #723
    Grzegorzxxx
    Poziom 12  
    W takim razie sprobuje wymienic te 3 i zobacze co wtedy będzie ,bo jesli podaje na nie napiecie to plus ze wszystko pozostale jest ok:)Pozdrawiam i bede pisal co po wymianie sie dzieje.Jesli by ktos mial jeszcze inną opinie chetnie sie z nia zapoznam.
  • #724
    all510
    Poziom 13  
    Może nie mogę zaprogramować dlatego ,że jest pamięć nieodpowiednia (24U02 sprzedawca powiedział ,że to taka sama jak 24C02) ?
    Wgrywają mi się jakieś głupoty z błędami ,zamówię taką jaka była może będzie lepiej ?:cry:
  • Sklep ElwronSklep Elwron
  • #725
    tzok
    Moderator Samochody
    all510 napisał:
    Zaczynam już tracić cierpliwość do tego programatora ,mogę odczytać czysty eprom i zapisać ,jeśli zmienię chociaż jedna komórkę to już nie wczyta do epromu i wyskakuje błąd.Odpaliłem też icproga i to samo "błąd weryfikacji przy adresie 000h"(mam xp) zetknął sie ktoś z takim problemem ?
    To może przeczytaj w końcu opis od tego programu? Aby to w ogóle działało z XP musisz albo skonfigurować program do wykorzystania Windows API a nie Direct I/O albo zainstalować i skonfigurować program UserPort (ew. GiveIO). Po drugie nóżki EEPROMa nr 1, 2, 3, 4 i 7 muszą być zwarte do masy, na nóżce 8 musi być 5V.
  • #726
    all510
    Poziom 13  
    Wszystko się zgadza porty są odblokowane ,zainstalowałem też tego userporta ,napięcia tak jak maja być podłączyłem nawet wszystkie nogi do programatora jest tak samo jak było można odzczytać czysty eprom i zapisywać tylko jakieś bzdury z błędami w API jest błąd testu .Icprog mam zainstalowany ze zgonością win 2000 i takie same są objawy .

    Dodano po 52 [minuty]:

    Cały dzień się męczyłem i na koniec podłączyłem jeszcze do laptopa i poszło za pierwszym razem :!::idea:
    Teraz przydałby się konkretny wsad do e500 .Olzbych ten ostatni co podałeś jest ok ,trzyma godzine ?
  • #727
    slimax
    Poziom 17  
    Witam!
    Potrzebuję dobrać się do pamięci z baterii notebook-a ibm t21, w elektronice tej baterii jest scalak 8mio nóżkowy wyglądający na pamięć. Napisy na nim to "451A" i "O1Z" albo "012". Co to jest i jak się do tego dobrać? Nigdzie nie mogę tego znaleść...
    Proszę o pomoc.

    07.10.2006
    Parę dni zajęło mi znalezienie pamięci SL394 po drugiej stronie płytki:)
    A zaglądałem tam już wcześniej:D Wyjeżdzam 10.10.2006 do Londynu za pracą, więc przyspieszam prace nad tą bateryjką...
  • #728
    olzbych
    Poziom 12  
    all510
    osobiście do zmiany zawartości eeproma 24c01 w elektronice baterii compaq armada e500 użyłem programarora tego którego schemat zamieściłem wcześniej. Choć prosty sprawdza się doskonale do odczytu w układzie. Należy zwrócić uwagę że są połączne nogi 6 i 7 w złączu rs232 bo inaczej nie działa z programem pony prog.
    Czynność ta wykonywałem z wlutowanym eepromem do elektoniki baterii, przeciąłem ścieżkę prowadzącą do nogi 7 a po przeprogramowaniu polutowałem tę ścieżkę.
    Większe trudności miałem z własciwym dobraniem deklarownej pojemności baterii, z tego co wynika z programu SBW to mogłem okreslić wartość taką która po odczycie tym programem nie przewyższy wartości nowych ogniw czyli 4800mAh, jednak moje ogniwa z tą wartością ładowały się źle a później krótko trzymały.
    Wartość dobrałem eksperymentalnie - ogniwa nie są nowe. Teraz ogniwa trzymają ok 1 godziny, przekonany jestem że powymianie jeszcze jednej sekcji wynik byłby lepszy.
    Może przy nowych ogniwach wartości odczytu eeproma z SBW demo są poprawne
  • #729
    TTOM
    Poziom 11  
    a moze ma ktoś receptę na dobranie się do baterii fujitsu siemens amilo el - mam takiego i tez bateria juz dawno skapitulowala - problem w tym ze nie ma jak jej rozebrac - próbowałem rozkleic ale predzej rozłupie sie cała obudowa - jesli ktos z takim cudem cos zrobił niech da znać
  • #730
    all510
    Poziom 13  
    Czyli ten ostatni mogę wgrać (tylko tam wychodzi 13824mAh ,czy to dobrze )? Moje ogniwa też nie są nowe, ale przed całą aferą trzymały 1godz. 40min ,ostateczne zrobiłem to icprogiem ,ale myślę że pony tez da się.Które komórki są odpowiedzialne za pojemność bo zdaje się ,że wzależności od rodzaju baterii (do innych laptopów )są różne ?
  • #731
    olzbych
    Poziom 12  
    all510
    zamieszczam dwa wsady. Pierwszy oznaczony 100% ma wpisana pojemność 4800mAh przynajmniej tak odczytuje SBW demo raczej do nowych ogniw, drugi natomiast jest kombinacją a dedykowany do eksperymentów na uzywanych ogniwach.
    Przy eksperymentach warto kontrolować proces ładowania pojemność, prąd napięcie np. przy uzyciu programu BatteryMon
  • #732
    all510
    Poziom 13  
    ok ,jak nie będzie innych problemów to jutro przetestuję ,wielkie dzięki !
  • #733
    all510
    Poziom 13  
    No nic z tego ,kontrolka ładowania mruga z czestotliwością 3sek. (tak jak wcześniej)batterymon odczytuje dane baterii z obu wsadów ,wiec to chyba nie jest wina pamięci.Ktoś kiedyś pisał o bespiecznikach w baterii ,gdzie jest tu taki ?W mojej bateri jest napięcie na stykach zewntrznych 0,5v ,a na całości ogniw 11,7 (abyło też ponad 12v) co jeszce można zrobić ?
  • #734
    tzok
    Moderator Samochody
    Bezpiecznik jest zazwyczaj oznaczony literą F i _zazwyczaj_ jest koloru zielonego, wygląda jak rezystor SMD (większy) lub przewlekany.
  • #735
    all510
    Poziom 13  
    Chyba znalazłem, (ale czarny) SC 5A SF 1205A ,to jet to ?
  • #737
    all510
    Poziom 13  
    Srawdzałem go jest dobry ma przejścia na wszystkie nogi, to teraz już nie wiem co jeszcze można się zrobić . :|
  • #738
    olzbych
    Poziom 12  
    all510
    Jeżeli stosujesz używane ogniwa to wybierz najlepsze. napięcie powyżej 3.6v bo ładowanie może nie ruszyć. Po naładowaniu należy sprawdzić poszczególne sekcje baterii pod wzgledem napięcia i nateżenie okreslić najlepsze i najsłabsze i w miarę mozliwości wymienic. Użycie systemowej kalibracji baterii w/g mioch spostrzeżeń lepiej dostosowuje ogniwa do do nowego wsadu eeprom.
    Wsady które zamieściłem na forum są wynikem moich eksperymentów. Wyniki zapewne będą różne w zależności od kondycji baterii.
    Wiem że gdy ogniwa nie są w najlepszej kondycji lub mają różna faktyczną moc to trudno dobrać właściwą wartość pojemnoci która gwarantuje że po wpisaniu do wsadu eeproma bateria będzie się ładować i trzymać moc.
    Wsad który zamieściłem pod nazwą e500_1900 zapewnia, że bateria po ok 7 ładowaniach trzyma 35-50 minut w zależności od użycia. Pojemność baterii zminiejszyła sie do 14000mWh.
    Wydaje mi się że jeżeli miga pomarańczowa kontrolka na początku ładowania to napięcia ogniw są za niskie aby ruszyło ładowanie
  • #739
    all510
    Poziom 13  
    Możesz miec rację ,bo przed kombinacją z epromem ładowało do 4% i koniec (z dnia na dzień po kazdym ładowaniu wydajnośc spadła z 1,4godz.do 0)cały zestaw miał ponad 12V ,ale laptop nie chodził na baterii, potem rozładowałem ogniwa żarówką do 3,7 (miały ponad 4v) myślałem,że to coś pomoże, przy okazji jedna żgrzewka się mocno grzała i wyszło że dwa ogniwa są do bani ,teraz są wymienione , sprawdziłem nawet dzisiaj wszystkie maja ok 3,71-3,77v w zgrzewkach oraz osobno.Czyli radzisz żeby je podładować osobno? Mam ładowarkę mikroprocesorową do akumulatorków AA oraz mikroprocesorową do akumulatorów żelowych 12Vlub jakies zasilacze ,czym mozna by ewentulnie pobudzić je?

    Dodano po 2 [godziny] 52 [minuty]:

    Zrobiłem taki test:podłączyłem do kompletu ogniw szeregowo żarówkę i miernik na zakresie 10A na wyswietlaczu pojawił się wynik 1,55 (ale pewnie żarówka też pobiera prąd) ,czy to oznacza ,że cały komplet ma pojemność 1550mA,czy ten test jest bez sensu ?Żarówka świeci bardzo jasno ,a wczesniej rozładowywałem zestaw ponad godzinę.Czy tak niska pojemnosć 1550mA może być przyczyną ,że bateria nie może teraz wystartować z ładowaniem ?Napięcie jest teraz 11,2V .
  • #740
    olzbych
    Poziom 12  
    Wynik pomiaru przy obciążeniu ogniw żarówką opisany wyżej informuje tylko jaki prąd pobiera żarówka. Aby określić pojemność należy uwzględzić pomiar w określonym czasie. Należy uważać aby nie wyładować nadmiernie ogniw bo zniszczą się bezpowrotnie. Najszybszym pomiarem jest prąd zwarcia chyba szkodliwy dla ogniw. Wykonałem ten pomiar dla swoich ogniw. Dwie sekcje mają po 15A, trzecia 12A.
    Uważam, że ładowanie osobno nic nie da. Jeżeli ogniwa maja takie same napięcie i pojemność (faktyczna) ładowanie przebiegnie sprawniej i mniej wykonamy eksperymentów z wsadem do eepromu.
    Nie wiem jak dalej należy jeszcze zmienić wsad do eeproma aby używane ogniwa jeszcze działały.
    Może ktoś kto posiada pełną wersję SBW wykona reset eeprom zamieszczonego poniżej w celu porównania wprowadzonych zmian.
    Zamieszczam jeszcze trzy wsady znalezione na rosyjskim forum
  • #741
    all510
    Poziom 13  
    Czy mozesz mi jeszcze podać jakie są napiecia na wyjsciwych stykach ?BO polutowałem ten bezpiecznik i pojawiło mi sie tam napięci na dwóch po ok 11V i trzy środkowe 4,2 v ,chyba coś spaprałem .
  • #742
    Grzegorzxxx
    Poziom 12  
    Witam:) Mama jeszcze pytanko jak wyjać z baterii ogniwa zeby nie zniszczyc calej baterii bo sa one posklejane a ja potrzebuje wymienic tylko 3 z 12/Pozdrawiam!!
  • #744
    tzok
    Moderator Samochody
    Grzegorzxxx napisał:
    Witam:) Mama jeszcze pytanko jak wyjać z baterii ogniwa zeby nie zniszczyc calej baterii bo sa one posklejane a ja potrzebuje wymienic tylko 3 z 12/Pozdrawiam!!
    To nie jest dobry pomysł, jak już to wymienia się wszystkie ogniwa. Nie wiem jak są połączone czy w sekcji szeregowo a sekcje równolegle czy w sekcji równolegle a sekcje szeregowo, w pierwszym przypadku ewentualnie mozna by wymienić jedną sekcję, w drugim - taką samą ilość ogniw w każdej sekcji.
  • #745
    Grzegorzxxx
    Poziom 12  
    Dzieki arik sprobuje tak wlasnie zrobic ,a co do ilosci ogniw i polaczen to chodzi mi o wymiane 3 rownolegle polaczonych ogniw.Jest to jedna z 4 sekcji w baterii bo pozniej kazda trojka ogniw lonczona jest szeregowo, a pozostale bardzo dobrze sie spisaly na testach prądowych wiec zaryzykuje tylko ta trojke:)
  • #746
    all510
    Poziom 13  
    Tak jak przypuszczałem coś poszło w srodku wczoraj wydawało mi sie ,że poszedł lekki dymek ze środka płytki .polutowałem bezpiecznik ,ale napięcia przy wyciągniętej baterii nie powinno być. https://www.elektroda.pl/rtvforum/topic429865.html
    Teraz muszę zaopatrzyć sie w nowy egzemplaż testowy :D
  • #747
    siwy26
    Poziom 11  
    Witam

    Od jakiegoś czasu interesuje sie regebneracją batri od Dell'a z seri CPi 75UYF.
    Przeczytałem prawie cały wątek i jednoznacznie nie znalazłem odpowiedzi czy jest szansa uratować czy zregenerować tą baterie. Z wymianą ogniw nie było by problemu, problem natomiast pojawia się w momencie kiedy trzeba by było zresetować eproma. Moje pytanie: Czy ktoś bawił sie z tą baterią i czy ewentualnie udało mu sie podnieśc jej sprawnosć. Dodam jeszcze że moja wogule się nie ładuje, wskaźnik bateri wynosi 0% a napięcie na obu segmentach jest nierówne na jednym 1,75 V a na drugim 2,43V czyli chyba zdecydowanie za niskie.

    Właśnie rozbebeszyłem baterie i siedzi tam min taki układ BQ8011DBT i BQ29310PW . Ogniwa na 100% padnięte tak więc zastanawiam się co dalej bo jeśli była by szansa zresetować pamięć to mozna by zaryzykować i kupić nowe ogniwa jeśli jedna nie da sie ruszyć eepromu to chyba nie warto bawic się w to wszystko.
  • #748
    Grzegorzxxx
    Poziom 12  
    Mam jeszcze jedno pytanie czy ogniwa sa jakos miedzy soba w kazdej grupie zlutowane przewodami czy tlko zgrzane.BO boje sie ze porozrywam wszystko a chce tylko te 3 wymienic z 12?
  • #749
    slimax
    Poziom 17  
    Witam!
    Wymieniłem ogniwa w baterii dla IBM ThinkPad T2X, niestety okazało się że elektronika odcina ich ładowanie zanim zostaną w pełni naładowane:( wcześniej jak pojemność pakietu była około 1000MAh elektronika łądowała go do pełna (jakieś 12,5V). Wskażniki ładowania w windzie i na kontrolkach notka wskazywały na pojemność jakieś 400Mah ale kontroler baterii wykorzystywał jej faktyczną pojemność. Na tych 1000Mah notek pracował do 70min. A wedługo tego co pokazywał stan naładowania baterii w windzie i na kontrolkach notka nie powinien pracowac dłużej niż 12-15min. Dlatego też olałem sprawe tych wskażników i kupiłem nowe ogniwa 2Ah(łącznie pakiet ma teraz 4Ah). Ładnie je równo wyładowałem na początek do 2,5V no i przystąpiłem do ładowania...
    Niestety ładowanie zakończyło się na napięciu około 11V !!!
    Odłączyłem więc zasilacz tak aby je troche rozładować (około minuty) i znowu łądowanie... pomogło na trochę, niestety zakończyło się ono przed osiągnięciem 12V powtórzyłem tą czynność aż napięcię zatrzymało się na 12,5V a prąd ładowania spadł do paruset miliamperów. Na tak naładowanej baterii notek pracuje faktycznie jak na baterii 4000MAh, ale takie ładowanie jest zupełnie nie do przyjęcia! ;( Proszę o pomoc w przeprogramowaniu eproma tej baterii!!! pare postów wyżej zamieściłem opis i zdjęcie elektroniki Pomóżcie!!!
  • #750
    tisher
    Poziom 13  
    Jak duzy jest układ 24c01 spotykany w bateriach? Mam takowy ale on ma jakies 3x3mm, o wiele mniejszy niz podstawki na takieuklady stosowane w programatorach jakie widzialem na allegro. Mam tam taki uklad: S24C0 1BV26 5564 i nie chce przypadkiem zaprogramowac czegos co eepromem nie jest :D