Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Osprzęt kablowy
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ładowanie baterii w laptopie - Regeneracja ogniw Old

Deamon :) 13 Sty 2007 15:01 890765 1355
  • #931
    redart
    Poziom 23  
    SebaD:
    Może jutro albo w poniedziałek, bo dzś wybywam. Jeśli jesteś zainteresowany to mogę dać interpretacę ważniejszych komórek z przykładowymi wartościami, wtedy chociaż będziesz wiedział co robisz.
    Pzdr.
  • Osprzęt kablowy
  • #932
    SebaD
    Poziom 16  
    redart napisał:
    SebaD:
    Może jutro albo w poniedziałek, bo dzś wybywam. Jeśli jesteś zainteresowany to mogę dać interpretacę ważniejszych komórek z przykładowymi wartościami, wtedy chociaż będziesz wiedział co robisz.
    Pzdr.


    Ok zaczekam, jeśli byś chciał to możesz pokazać mi co trzeba zmieniać....
  • Osprzęt kablowy
  • #933
    miki123456
    Poziom 10  
    chłopaki moje trzy grosze lap t20 eprom s29l394 zresetować i zaprogramować na nowo udało sie z
    accplus 1.3 bez problemu (sbwshop jest demo accplus tak samo ale na netu jest pomoc ...) :D
  • #935
    Rychuu
    Poziom 21  
    Posiadam laptopa Gericoma Millenium lecz identyczny laptop produkuje Dell pod nazwa Inspirion 5000.

    Oryginalna bateria po wymianie ogniw ożyła tylko w połowie ponieważ teraz gdy naciskam tester na baterii wyświetla się +-+-+ (tam gdzie plus to paląca sie dioda, gdzie minus to nie paląca dioda). Laptop niby ją ładuje lecz tak naprawdę jej nie rusza.
    Posiadam jeszcze jedna elektronikę jako dawce od Della Inspirion 5000 jako dawce bo ma kilka części upalonych.
    Porównanie elektronik:
    Właściwie elektroniki są identyczne, takie same oznaczenia maja lecz są tu dwa układy scalone i różnią sie na nich napisy, a mianowicie :
    Oryginalna elektronika:
    1.
    BH5740AFS
    024 164C
    2.
    AS354D
    A30
    0233A
    elektronika od della
    1.
    BH5740AFS
    110 1460
    2.
    AS359D
    A40
    1200A

    I teraz dodam ze mam jeszcze baterie również od Della Inspiriona 5000 (taka sama jak ta wyżej) i działa w laptopie bez problemów.

    Teraz pytanie jak zresetować elektronikę ? Albo jak ją zmusić do działania w laptopie bo ogniwa powinny wytrzymać choć trochę.
    Niemniej wydaje mi sie ze te zapalone diody oznaczają jakiś błąd.

    Ewentualnie może znacie kogoś kto potrafi zrobić takie coś za nie wygórowaną cenę ?

    PS.
    Diody na baterii mrugają 3 razy. Baterie która mam w laptopie normalnie zapalają sie na 5 sec w dobrej kolejności od prawej stan słaby do lewej stan naładowany.
    Bateria gdy jest w laptopie i podlacze zasilanie to nastepuje ladowanie baterii..

    PS2.
    Tak wygląda elektronika:

    Ładowanie baterii w laptopie - Regeneracja ogniw Old

    (jeszcze przed rozmontowaniem...)


    PS2.
    Smart Battery Workshop
    Rozumiem zeby program zaczal cos pokazywac musze miec to:
    http://www.sbworkshop.com/i2c.jpg
    Zrobienie tego to nie problem, ale jak to podlaczyc pod baterie?
    Które piny czy muszę wylutować coś?
    Post został poprawiony !
    TONI_2003
  • #936
    redart
    Poziom 23  
    SebaD:
    Zmieniłem zawartość komórek 0Eh 0Fh gdzie znajduje się licznik cykli wyzerowując je. Było 93 zliczone cykle. Pojemność twoich aku zmierzona przez sterownik i zapisana do pamięci to 332mAh!!! Zmieniłem zawartość komórek 60h 61h ustalając realną (aktualną) pojemność na 4000mAh czyli na taką, jaka zapisana jest w komórkach 10h 11h - tu przechowywana jest pojemność nominalna. Sterownik po kilku cyklach znów zaktualizuje realną pojemność nadpisując komórki 60h i 61h.

    Trochę oświaty w załączniku:
    Interpretacja do BQ2040
    Ładowanie baterii w laptopie - Regeneracja ogniw Old
    , a w drugim gotowy bin.
    Pzdr.
  • #937
    redart
    Poziom 23  
    SebaD:
    No problem, daj znać jak poszło.
  • #938
    miki123456
    Poziom 10  
    interfejs do accplus jest taki sam jak do sbwshopa shemat w pliku help accplus i kilka dodatkowy uwag.Poszukujem dobry sad do t20 3600mAh 10.8v na eprome 80AF
  • #940
    gen999
    Poziom 23  
    Wybaczcie że sie wcinam. Ale mam dwie bateria AST litówke i wodorówke. Jedna ma 9 volt a powinna mieć 12 a druga, litówka, ma 0 mimo tego że ogniwa mają po 3v oznaczenia bateri to odpowiednio SSB500EN i SSB 500EL w NiMH nie ma elekroniki w litówce jest płytka z dwoma 4435 8 nożnymi i chyba jeszcze jakimś jednym scalakiem z drugiej strony drukum ale nie pamiętam symbolu. Nie mam pojęcia jak sie do tego zabrać ale dobrze by było jakby te baterie jeszcze wydały z siebie prąd.
  • #941
    Robert 29
    Poziom 13  
    @yaris101
    Mam ten sam problem co ty, od wczoraj czytam ten temat ale nic konkretnego na temat IBM thinkpad 600e nie znalazłem, również chciał bym odczytac ta pamięć i zapiasać na nowo. Prosze o pomoc osoby które wiedzą jak to zrobić..

    pozdr..
  • #942
    redart
    Poziom 23  
    gen999 napisał:
    ... 4435 8 nożnymi i chyba jeszcze jakimś jednym scalakiem z drugiej strony drukum ale nie pamiętam symbolu...


    Te 4435 to MOSFET'y - jeden do załączania ładowania, a drugi puszcza fazę w drugą stronę. Ale bez zdjęcia lub przynajmniej symbolu scalaka nic nie można powiedzieć - to kluczowa sprawa. Zapodaj symbol, jeśli będzie opis w necie to można ruszyć.
    Jeżeli ogniwa trzymają napięcie, a na wyjściu nic nie ma, to oznacza, że sterownik (ten nieszczęsny scalak) nie załącza tranzystora. Ale przy napięciu lion'ów na poziomie 3V to mu się nie dziwię. To tylko świadczy o tym, że ten sterownik jeszcze sensownie działa zabezpieczając aku przed nadmiernym rozładowaniem.
  • #943
    gen999
    Poziom 23  
    Ten scalak to 735 MM1248B ma 16 nóg
    A co do tego 3V to nie jestem do końca pewien ile tam było ale jeszcze sprawdze i napisze ile tam tak naprawde jest, w każdym bądź razie nie są puste.
    Druga bateria, ta NiMH nie ma elektroniki ale jest wyraźnie pusta. Przy zwieraniu + i - nic sie nie dzieje. Zastanawiam sie czy ten mój zakichany laptop nie jest jakiś walnięty bo jak wsadze do niego tą baterie to on daje do zrozumienia że bateria jest naładowana. Laptop AST A Series.
    A może da sie jakoś tą wodorówke jakoś inaczej naładować. Myślałem o prostowniku ale to chyba nie przejdzie.
  • #944
    redart
    Poziom 23  
    gen999:
    To urządzenie (MM1248) to banał. Prosty ster do akumulatorów, bez pamięci i innych skomplikowanych ustrojstw. Jego opis: http://pdf1.alldatasheet.com/datasheet-pdf/view/87820/MITSUMI/MM1248.html
    Jak czaisz trochę język Shakespeare'a to wszystko zrozumiesz. Generalnie wystarczy podpiąć ogniwa do płytki i jazda. Niestety z napięciem 3V nie masz co startować, należy je najpierw odlutować od płytki i każdą parę ogniw naładować (np zasilaczem regulowanym). Napięcie 4,2V (ni grama więcej), najlepiej z ograniczeniem prądu do wartości C, czyli pojemności akumulatorów (np: aku 4000mAh to pojedyńcze ogniwo ma 2000mAh, więc prąd ładowania max 2A). Jeśli po naładowaniu (prąd ładowania ok 5% C - dla powyższych wartości to będzie 100mA) ogniwo trzyma 3,7V to jest OK. Czynność powtórzyć dla pozostałych par ogniw. Podpiąć całość do sterownika i ma chodzić. Jak długo i jak dobrze to zależy tylko i wyłącznie od kondycji ogniw, ale to już inna sprawa :D.

    Jak akumulator niklowy (NiMH) ma 0V to go wywal. Nawet po pobudzaniu b. dużym prądem jak zaskoczy, to i tak na dłuższą metę nie będzie trzymał. Rozładowanie takie - do zera - i pozostawienie ich w tym stanie dłuższy czas wyklucza jakikolwiek sens zajmowania się takim złomem :cry:.
  • #945
    gen999
    Poziom 23  
    No dobra, ale jak ja mam je rozdzielić skoro one są zgrzane poprzez takie jakby listwy tzn blaszki aluminiowe.
    Poza tym to wygląda tak że dwa ogniwa są z boku, a reszta jest połączona w dwa bloki jeden 3 a drugi 4 ogniwa i nie wiem jak je rozdzielić.
    Ładowanie baterii w laptopie - Regeneracja ogniw OldŁadowanie baterii w laptopie - Regeneracja ogniw Old
    Moderowany przez TONI_2003:

    :arrow: Kliknij aby powiększyć :!:
    Proszę tylko zamieszczać fotki tak jak w linku poniżej!
    Sądzę że jest to zrozumiale dla wszystkich, a przynajmniej powinno być!
    Choć jakoś nie mogę się przekonać do tego obserwując co poniektórych!
    Ogłoszenie: Wklejanie zdjęć.

  • #946
    redart
    Poziom 23  
    gen999:
    Trzeba było zacząć od fotek... Tak na przyszłość to podając maximum informacji na początku unikasz nieporozumień i niedomówień. Z tego co widzę, to jeden pakiet składa się z 3 ogniw połączonych równolegle, a takich pakietów jest 3 i są połączone w szereg, więc napięcie aku to 11,8V - jeśli jest inaczej to napisz.
    Nie rozdzieraj ich, tylko podepnij ładowanie do każdego pakietu osobno (3 ogniwa zrównoleglone) napięcie 4,2V. W przypadku tego sterownika (brak balancera) można pokusić się o ładowanie całego zestawu naraz, ponieważ ster tak robi, tzn. podłączyć 12,6V do całego zestawu. Trzeba jednak pilnować, aby w trakcie ładowania napięcie na pakiecie nie przekroczyło 4,2V bo go dobijesz. Potem podpinasz do stera, i sprawdzasz, czy napięcie jest przepuszczane na złącze. Jeśli scalak i mosfet'y są OK to powinno się tam pokazać U.
  • #947
    gen999
    Poziom 23  
    Są trzy pakiety po 3 ogniwa równloegle na pakiet. Na dwóch jest 3.8V a na 3 jest 0V. Jedno z ogniw wygląda na to że sie wylało no i jest troszeczke zardzewiałe. Troche ten aku zakręcony no ale już załapałem. Na obudowie aku napisano że ma mieć 10.8V na wyjściu, więc chyba ta płytka jest od tego żeby obniżyć napięcie do tej wartości bo jak by nie liczyć to 3.8 X 3 = 11.4V No to jak mam łądować te pakiety? Podłączyć ten jeden pusty pakiet do 4.2V?? Czy wszystkie po kolei?? Jakim prądem ładować i jak długo?? Chyba musze poszukać regulowanego zasilacza bo inaczej nie da rady.

    Mam potężny poniemiecki transformator regulowany 0-220V tylko trzebaby wyprostować prąd z niego wychodzący. Jakie diody dać do prostownika i czy duży kondensator?? Może mnie wyśmiejecie ale diody wym wydłubał ze starego ubitego zodiaka bo chyba wytrzymają do 2A czy raczej nie??
  • #948
    redart
    Poziom 23  
    Cytat:
    Są trzy pakiety po 3 ogniwa równloegle na pakiet.

    To znaczy, że mi wzrok nie siada :D.

    Cytat:
    Na dwóch jest 3.8V a na 3 jest 0V. Jedno z ogniw wygląda na to że sie wylało no i jest troszeczke zardzewiałe.

    Te co trzymają 3,8V są OK, ale ten trzeci szrot... otwórz szeroko okno i ...

    Cytat:
    Troche ten aku zakręcony no ale już załapałem.

    Ten akumulator i jego sterownik to NAJPROSTRZA aplikacja jaką widziałem :!:.
    Cytat:
    No to jak mam zrobić? Podłączyć ten jeden pusty pakiet do 4.2V?? Czy wszystkie po kolei??

    Patrz odp. druga. Jeśli pakiet ma 0V to jest do bani. Możesz spróbować go rozdzielić (rozcinając blaszki łączące) przyłożyć do każdego z ogniw na 10 sek. napięcie 4,2V i sprawdzić czy się 'podniosło' to ogniwo (jest jakieś napięcie). Przy łączeniu równoległym wystarczy, że jedno ogniwo ma 0V, a reszta też będzie na zwarciu. Utrzymywanie takiego stanu prowadzi do bezpowrotnego uszkodzenia ogniw. Jeśli są ślady elektrolitu (korozja) to nie ma o czym mówić - kibel. Tylko do wyrzucenia.

    Cytat:
    Jakim prądem ładować i jak długo??

    Napisałem ci wcześniej jak ładować akumulatory lion! NAPIĘCIEM 4,20V DO MOMENTU SPADKU PRĄDU ŁADOWANIA DO POZIOMU 1/20 C (5% C), GDZIE C TO POJEMNOŚĆ ZNAMIONOWA! Czytaj to co ludzie piszą.

    Cytat:
    Chyba musze poszukać regulowanego zasilacza bo inaczej nie da rady.

    Chyba napewno. Zasilacz regulowany to minimum, nie mówię o ładowarce ogniw lion, bo zdaję sobie sprawę, że to nie jest sprzęt podstawowy, w przeciwieństwie do zasilacza.

    Cytat:
    Mam potężny poniemiecki transformator regulowany 0-220V tylko trzebaby wyprostować prąd z niego wychodzący. Jakie diody dać do prostownika i czy duży kondensator?? Może mnie wyśmiejecie ale diody wym wydłubał ze starego ubitego zodiaka bo chyba wytrzymają do 2A czy raczej nie??

    Po tym tekście mam nieodparte wrażenie, że próbujesz szpadlem mieszać herbatę... Są pewne niezbędne urządzenia i narzędzia, które musisz mieć, żeby ruszać taką sprawę jak akumulator do lapka. Młotkiem tego nie zrobisz. A autotransformator to ostatnia rzecz na którą bym wpadł... Zmontuj najpierw zasilacz, a potem bież się za aku. Proponuję trafo min 35W dające 15 do 24V, mostek (4 diody) min 2A (nie wiem co tam znalazłeś w Zodiaku, ale jeśli w zasilaczu to powinno starczyć) i LM 350. Do tego 5 elementów i masz zasilacz jak marzenie. W zasilaczu starczy ci elektrolit 470µ. To nie zasilacz do wzmaka. Szukaj schematu na elektrodzie.

    Jeszcze słowo na niedzielę:
    Na upartego możesz rozdłubać te wszystkie sprawne ogniwa i zamiast 3szt w pakiecie zastosować 2szt. Wtedy uzyskasz 3 pakiety po dwa zrównoleglone ogniwa. Pojemność spadnie o 33%, ale jeśli 6 jest sprawnych to po połączeniu i podłączeniu do stera powinno od razu ruszyć, bo i napięcie będzie właściwie. teraz masz 2 razy po 3,7V i jeden kawałek drutu - ten trzeci rozwalony pakiet, więc się nie dziw, że sterownik nie chce załączyć tranzystora wyjściowego.
    Tniesz blaszki w środku długości, potem lutujesz (tylko blaszki!) szybko (tzn krótko, bez niepotrzebnego grzania) i skutecznie. O tym było w tym temacie już kilka razy.
    Do roboty!
    Pzdr.
  • #949
    gen999
    Poziom 23  
    Dobrze spróbuje ją naładować.
    Wracająć do tej wodorówki to bardzo sie pomyliłem pisząc że jest pusta. Na obudowie pisze że ma mieć 12V na wyjściu. Aktualnie ma 9.5V. Na ogniwach przy plusach widać minimalny biały nalot, no ale jakby nie patrzeć jakośtam trzymają prąd. Jakim napięciem powinna być ładowana. Rozkręce tego lapka bo może za małe napięcie daje do baterii i stąd takie cyrki.
  • #950
    redart
    Poziom 23  
    gen999:
    Biało-zielony nalot na akumulatorze należy usunąć. Najprościej tak: rozpuszczasz 2 łyzki stołowe sody oczyszczonej (sklep spożywczy) w połowie szklanki wody. Szczoteczka do zębów (najlepiej cudza) :D i szorować. Wysuszyć i naładować. NiMH ładuj napięciem 1,45 - 1,5V. Na początek wystarczy, chociaż są sterowniki które ładują do 1,67 na ogniwo.
    Z tego co piszesz tych NiMH jest 10 sztuk (połączone wszystkie w szereg). Najpierw zmierz napięcie na każdym ogniwie, jeśli wszystkie trzymają napięcie to jest dobrze. Rozładowane nie powinny zejść poniżej 0,9V bo mniej im szkodzi. Po wyczyszczeniu (przypadkiem nie jakimś metalowym przedmiotem!) można je naładować. Na upartego wszystkie razem w szeregu (po odlutowaniu sterownika) napięciem 14-15V. Po dwóch godzinach mierzysz znowu i widzisz który przyjmuje U, a który zachowuje się jak kołek.

    A lapka zostaw póki co w spokoju.
    Daj jakieś foty (stera i połączeń ogniw) bo póki co to mogę tylko teoretyzować. Mimo wszystko mam nadzieję, że chociaż trochę pomogłem.
    Pzdr.
  • #951
    gen999
    Poziom 23  
    W tej wodorówce nie ma sterownika. Tylko między dwoma ogniwami jest coś o symbolu 4MM70T-09 P6J i między dwoma kolejnymi jest chyba dioda o symbolu KFHAD G4A51. Pozatym ogniw jest 5 i są połączone w szereg.
  • #952
    polaq
    Poziom 10  
    Witam wszystkich forumowiczów.
    Czytam to forum i widzę, że nikt jeszcze na poważnie nie zabrał się za ożywienie baterii na bq8011 i bq20390. Najnowszy SBWorkshop teoretycznie obsługuje bq8011. Więc zabrałem się za moją baterię do Della D400.

    Podstawowe dane:
    Pojemność 1800mAh
    4 oniwa Li-Ion (Niestety nie popularne, bo płaskie...)
    Napięcie 14.8V
    bq8011+bq20390+24c01

    Niestety specyfikacje tych układów są nieosiągalne. Jak narazie udało mi się dojść do tego, że eeprom nie przechowuje informacji o producencie, dacie produkcji i numerze seryjnym, chciaż system je skądś bierze. Podejrzewam, że bq20391 też posiada jakąś pamięć.
    Za pomocą SBW udało mi się odnaleźć komórki odpowiedzialne za ilość cykli ładowania i pojemność fabryczną. Niestety nie wiem, które komórki przechowują informację o błędach a tym bardziej który bit trzeba ustawić żeby te błędy usunąć. Nie udało mi się też odnaleźć komórek odpowiedzialnych za pojemność aktualną.

    Jeżeli ktoś ma jakieś doświadczenia z prób z bq8011, to niech da znać może wspólnie uda się to rozpracować.
  • #953
    redart
    Poziom 23  
    gen999:
    To, że w szereg to jasne, tylko czegoś tu nie czaję. Standardowe ogniwo NiMH daje 1,2V. 1,2V x 5 = 6V! Skąd wziołeś 12V?
    Chyba, że te ogniwa to jakieś monobloki z podwójnym ogniwem, ale jakoś tego nie widzę.
    W pakietach aku stosuje się bezpiecznik nadprądowy i bezpiecznik termiczny - z regóły montowane pomiędzy kolejnymi ogniwami. Jak sądzę to są te dwa magiczne elementy.
    Daj fotki, bo nic już nie rozumiem z tymi napięciami. Może masz tylko połowę ogniw z tej baterii...

    polaq:
    Bez datasheet'a to jak dziecko we mgle. Same dane nic nie mówią, a interpretacja w opisie. Kwadratura koła. Ja niestety nie mam pojęcia o tych BQ. Może ktoś już walczył z tematem, ale on zdaje się umierać :cry:.
  • #954
    lki
    Poziom 10  
    Witam.
    Mam taki problemik z bateria tzn lezala okolo roku nie ładowana, teraz po wlozeniu do laptopa pokazuje 0% i ładowanie calutki czas, kiedys nawet doszla do 40% ale po odlaczeniu zasilacza laptop zdycha. Aku jest litowo-jonowy 4000mAh fujitsu-siemens identyczny jak w hp XE2 na bq2040 i 24L00. Mam pytanie czy da się go ożywić czy to już śmietnik.
  • #955
    look100
    Poziom 12  
    witam Mam problem z baterią w laptopie mógłby mi ktoś pomóc go rozwiązać chciałbym wgrać ten wsad co umieścił Przekręt na 2 stronie
    do laptopa hp omnibook 6100 , tylko nie wiem jak mam to zrobić byłbym bardzo wdzięczny za doradzenie pozdrawiam
  • #956
    Charlie_JL
    Poziom 11  
    Witam

    Mam bardzo dziwna rzecz z baterią w HP/Compaq Presario R3000 , zx5000 i inne tego odmiany laptopów .
    Chodzi o to że bateria się normalnie ładuje , trzyma napięcie , ale uruchomienie na niej laptopa jest nie możliwe , pojawia się komunikat systemowy taki jak na zdjęciu.
    Ładowanie baterii w laptopie - Regeneracja ogniw Old
    Na podłączonym zasilaczu można uruchomić laptopa i jak się później podepnie baterie i odłączy zasilanie to wszystko jest ok , WIN ją widzi. Pokazuje dokładne dane baterii. Trzyma jakieś 2 godziny
    Moje pytanko o co chodzi:
    soft baterii , ogniwa , elektronika ?
    Liczę na ludzi którzy spotkali się z tym problemem .
    Pozdrawiam
  • #957
    gen999
    Poziom 23  
    no fakt te 12V mój błąd. jest na bateri ta wartośc ale chodzi o wejście (input).
    A bateria wygląda tak.

    Ładowanie baterii w laptopie - Regeneracja ogniw Old
  • #958
    redart
    Poziom 23  
    gen999:
    A mi to jednak wygląda jakoś dziwnie, te ogniwa są dłuższe - tak ze dwa razy. Może to faktycznie 2,4V na ogniwo? Zmierz miernidłem albo przeczytaj co na nich napisano. Nie słyszałem o baterii 6V do lapka, a na samym akumulatorze zawsze pisana jest wartość znamionowa napięcia. Dlatego upieram się przy koncepcji monobloków, to wygląda na podwójne ogniwo NiMH.

    PS
    A skoro nie ma sterownika to w czym rzecz? Jeśli aku ma być 12V to podepnij 14,5V i ładuj!
  • #959
    k.xman
    Poziom 12  
    spróbuj ustawień w biosie może tam tkwi błąd ew. zrób upgrade biosu
  • #960
    redart
    Poziom 23  
    :arrow: Rychuu
    Cytat:
    Teraz pytanie jak zresetować elektronikę ?

    Najprościej odpinając zasilanie od sterownika. O kolejności pisano już parę razy, włącznie ze mną, więc odsyłam do https://www.elektroda.pl/rtvforum/topic354605-930.html.
    Tak na marginesie to należało tam pytać, bo wszelkie problemy i ich rozwiązania zamieszczane w głównym temacie mogą komuś pomóc, a tworzenie indywidualnego tematu utrudnia potem poszukiwania.

    Cytat:
    Niemniej wydaje mi sie ze te zapalone diody oznaczają jakiś błąd.

    I słusznie ci się wydaje.

    Cytat:
    Ewentualnie może znacie kogoś kto potrafi zrobić takie coś za nie wygórowaną cenę ?

    Za niewygórowaną cenę to człowiek robi sam. A goście co z tego żyją (popatrz na allegro) mają zupełnie inne wyobrażenie znaczenia słowa "niewygórowana cena".

    Cytat:
    Diody na baterii mrugają 3 razy. Baterie która mam w laptopie normalnie zapalają sie na 5 sec w dobrej kolejności od prawej stan słaby do lewej stan naładowany.
    Bateria gdy jest w laptopie i podlacze zasilanie to nastepuje ladowanie baterii..

    Miganie diody od ładowania oznacza tyle, że lapek widzi baterię i zapodaje jej energię, a na samym aku są diody po to, żeby w przybliżeniu określić stan jej naładowania.

    Cytat:
    Smart Battery Workshop
    Rozumiem zeby program zaczal cos pokazywac musze miec to:
    http://www.sbworkshop.com/i2c.jpg

    Przydało by się, bo szczerze powiedziawszy SBW inaczej niczego nie odczyta. Gdzieś te kabelki trzeba wsadzić. Budując ten interfejs UWAŻNIE sprawdź numerację pinów złącza LPT, bo to częsty wypadek przy pracy.

    Cytat:
    Zrobienie tego to nie problem ale jak to podlaczyc pod baterie??(ktore piny? musze wylutowac cos?:/)

    Nic nie trzeba wylutowywać żeby odczytać dane z aku. Należy podpiąć sygnały SDA i SCL (no i masę) z aku do interfejsu. Zapodać 5V i już. Niestety nie wiem jaka jest organizacja sygnałów na takim złączu, bo mój sterownik (od Dell'a) ma 7 pinów, a u ciebie widzę 8. Musisz szukać.

    Co do tych scalaków to efekty moich poszukiwań datasheet'ów do nich są marne. Po prostu nic nie znalazłem. A czytałeś cały temat? Może ktoś już z takim sterownikiem walczył?

    Dodano po 4 [godziny] 29 [minuty]:

    Charlie_JL:
    No to rzeczywiście magic. Najgorzej jak coś chodzi jak kierunkowskazy: działa, nie działa...
    Ja tam stawiam na bios. Jeśli coś byłoby uwalone w starze od aku, to nawet po zabiegach z zasilaczem nic by się nie zmieniło. To samo dotyczy magistrali I²S w lapku. Kiedyś wysadziłem diody zenera na zabezpieczeniu linii SDA i SCL (raz w aku i raz w laptoku), a właściwie to diody dostały nieodwracalnego zwarcia. Wtedy po załączeniu wyskakiwało 8 komunikatów o niewłaściwych parametrach różnych (chyba dopuszczalnych) typów baterii. Tym bardziej w windzie nie było jej w ogóle widać.
    Bateria komunikuje się poprzez magistralę dwuprzewodową, ale jest też trzeci sygnał identyfikacji zainstalowania baterii. W dell'u i gericom'ie opisany jako ID. Jest to jakiś stan (L/H) wymuszony rezystorem w sterowniku, w moim kompie jest to 390Ω do masy. Jeśli lapek wyczai wymagany poziom, to stwierdza że aku jest podłączony i pozwala na ładowanie/rozładowanie oraz komunikuje się ze sterownikiem czytając parametry.
    W twoim przypadku ID jest na pewno, kwestia właściwej komunikacji. Dlatego sądzę, że to bios. Odczytuje typ baterii ale jakoś mu nie wychodzi jej uaktywnienie, bo np stwierdza że to głupie dane.