Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wzmacniacz operacyjny LM358P działa nieprawidłowo

lokk 09 Lut 2019 14:04 360 19
  • #1 09 Lut 2019 14:04
    lokk
    Poziom 3  

    Problem dotyczy wzmacniacza operacyjnego LM358P.

    Zasilam wzmacniacz napięciem 5V.

    W układzie wzmacniacza nieodwracającego gdzie wzmocnienie wynosi około 0.33, podaję na wejście 5V i otrzymuję na wyjściu jakieś 0.60V, gdy powinno być 1.5V. W dodatku jest ono z plusem zamiast z minusem.

    W układzie bez żadnej pętli sprzężenia zwrotnego, gdzie po prostu podaję na wejście 5V, na wyjściu dostaję 3V.

    W dokumentacji jest napisane, że maksymalne napięcie wyjściowe jest mniejsze od Vcc, ale nie aż o tyle.
    Wiele razy sprawdzałem połączenia, biegunowość.

    Czy wzmacniacz jest uszkodzony?

    0 19
  • #2 09 Lut 2019 14:16
    krzysiek_krm
    Poziom 35  

    lokk napisał:
    W układzie wzmacniacza nieodwracającego gdzie wzmocnienie wynosi około 0.33

    W tym układzie wzmocnienie jest zawsze większe od jedności.
    Jeżeli jest jednak odwracający
    lokk napisał:
    podaję na wejście 5V i otrzymuję na wyjściu jakieś 0.60V, gdy powinno być 1.5V. W dodatku jest ono z plusem zamiast z minusem.

    to jak Ci się wydaje, skąd ten wzmacniacz ma "wziąć" ujemne napięcie, jeżeli
    lokk napisał:
    Zasilam wzmacniacz napięciem 5V.
    ?
    lokk napisał:
    W układzie bez żadnej pętli sprzężenia zwrotnego, gdzie po prostu podaję na wejście 5V, na wyjściu dostaję 3V.

    W dokumentacji jest napisane, że maksymalne napięcie wyjściowe jest mniejsze od Vcc, ale nie aż o tyle.
    Wiele razy sprawdzałem połączenia, biegunowość.

    Czy wzmacniacz jest uszkodzony?

    Przeczytaj dokładnie dokumentację i zapoznaj się z ograniczeniami.

    0
  • #3 10 Lut 2019 13:20
    lokk
    Poziom 3  

    Tak, chodziło o odwracający.

    Przeczytałem dokumentację jeszcze raz. Czy chodzi o ten fragment?
    Wzmacniacz operacyjny LM358P działa nieprawidłowo

    "Voltage output swing from rail" - czyli w moim przypadku dla 5V napięcie na wyjściu będzie o 1.5V mniejsze od maksymalnego.

    To dlaczego było o 2 mniejsze?

    Co do tego, że nie ma skąd wziąć napięcia ujemnego - czy mam dać zasilanie do wzmacniacza odwrotnie? Myślałem że zawsze Vcc to plus. A jeśli chodziło o napięcie wejściowe no to było podane odwrotnie, czyli chyba prawidłowo.

    0
  • #4 10 Lut 2019 18:14
    _jta_
    Specjalista elektronik

    Myślałem że zawsze Vcc to plus.

    Prawidłowo. Nie piszesz jasno, co gdzie podajesz, więc jak ktoś ma się do tego ustosunkować?

    0
  • #5 11 Lut 2019 00:27
    lokk
    Poziom 3  

    Racja.

    No więc jak wyjaśnić te mniejsze od spodziewanego napięcie wyjściowe - zakładając, że połączenia są prawidłowe? Wzmacniacz jest zasilany (Vcc) 5V, a na wejście odwracające podaję 5V. Nie mogę uzyskać dobrych rezultatów w opisanych wyżej sytuacjach.

    0
  • #6 11 Lut 2019 00:56
    _jta_
    Specjalista elektronik

    A co podajesz na nieodwracające? Jaki jest zakres napięć wejściowych tego układu? Jeśli wychodzisz poza zakres, nie licz na prawidłowe działanie.

    0
  • Pomocny post
    #7 11 Lut 2019 06:51
    rs6000
    Poziom 29  

    Dla LM358 napięcie wejściowe nie moze być wyższe niż VCC-1,5V czyli w Twoim przypadku max 3,5V, to samo dotyczy napiecia wyjściowego. Musisz zasilić układ napięciem wyższym o ~2V od oczekiwanego napiecia wyjściowego lub wejściowego, zawsze od tego które jest wyższe, pamiętając oczywiscie o maksymalnym dopuszczalnym.

    Pozdr

    0
  • #8 11 Lut 2019 13:40
    lokk
    Poziom 3  

    Spróbowałem kolejny raz. Podaję sytuację:

    Wzmacniacz operacyjny LM358P działa nieprawidłowo
    Masa to minus ładowarki 5V.

    Napięcie wejściowe dzięki dzielnikowi wynosi około 1,3V (zmierzone, sprawdzone)
    Wobec tego napięcie zmierzone woltomierzem V powinno wynosić:

    $$U_{wy} = -\frac{2.17 k\Omega}{6.82 k\Omega} \cdot U_{we} \approx -0,41V.$$

    Tymczasem napięcie zmierzone wynosi około 0,60V na plusie.
    Wszystkie rezystory sprawdziłem omomierzem.

    Pozdrawiam.

    0
  • #9 11 Lut 2019 13:44
    krzysiek_krm
    Poziom 35  

    lokk napisał:
    Tymczasem napięcie zmierzone wynosi około 0,60V na plusie.

    Już Ci pisałem. Żeby wzmacniacz dał na wyjściu ujemne napięcie musi mieć ujemne zasilanie, powinieneś zasilić go zarówno dodatnim jak i ujemnym napięciem.

    0
  • #10 11 Lut 2019 14:06
    lokk
    Poziom 3  

    To jak to zrobić? Zasilam układ z ładowarki do telefonu 5V. Kabelek USB ma tylko +5V i GND.

    0
  • #11 11 Lut 2019 14:48
    rs6000
    Poziom 29  

    Możesz użyć tzw. sztucznej masy, wtedy z 5V będziesz połowę potencjału na masie, zatem zasilanie lm358 będzie wynosić +2.5V na VCC i -2.5V na VSS układu.
    Tu pierwszy z rzędu przykład https://www.elektroda.pl/rtvforum/topic1897621.html

    A tu fajny film wyjaśniający


    Link

    Innym rozwiązaniem jest użycie układu np. ICL7660 który dostarczy ujemnego napiecia z dodatniego.

    Pozdr

    0
  • #12 11 Lut 2019 16:17
    trymer01
    Moderator Projektowanie

    rs6000 napisał:
    Możesz użyć tzw. sztucznej masy,

    Nie, to się tu nie sprawdzi, gdyż dzielniki napięcia Uwe oraz sprzężenia zwrotnego pobierają prąd co "rozchwieje" dzielnik sztucznej masy.
    Nie róbcie zamieszania młodemu adeptowi, bo będzie 10 następnych pytań.
    Tylko prawdziwe zasilanie symetryczne +-5V, a jeszcze lepiej +-15V. Czyli dwa zasilacze 5V (albo 15V) połączone szeregowo.
    W ostateczności symetryzator na WO i parze komplementarnej, który to symetryzator trzyma sztywny podział napięcia: https://www.elektroda.pl/rtvforum/viewtopic.php?p=11568575#11568575
    ale wtedy trzeba napiecie zasilania min. 10V ->+-5V

    0
  • #13 11 Lut 2019 16:22
    rs6000
    Poziom 29  

    trymer01 napisał:
    rs6000 napisał:
    Możesz użyć tzw. sztucznej masy,

    Nie, to się tu nie sprawdzi, gdyż dzielniki napięcia Uwe oraz sprzężenia zwrotnego pobierają prąd co "rozchwieje" dzielnik sztucznej masy.
    Nie róbcie zamieszania młodemu adeptowi, bo będzie 10 następnych pytań.
    Tylko prawdziwe zasilanie symetryczne +-5V, a jeszcze lepiej +-15V. Czyli dwa zasilacze 5V (albo 15V) połączone szeregowo.
    W ostateczności symetryzator na WO i parze komplementarnej, który to symetryzator trzyma sztywny podział napięcia: https://www.elektroda.pl/rtvforum/viewtopic.php?p=11568575#11568575
    ale wtedy trzeba napiecie zasilania min. 10V ->+-5V

    Dodano po 1 [minuty]:

    rs6000 napisał:
    Możesz użyć tzw. sztucznej masy,

    Nie, to się tu nie sprawdzi, gdyż dzielniki napięcia Uwe oraz sprzężenia zwrotnego pobierają prąd co "rozchwieje" dzielnik sztucznej masy.
    Nie róbcie zamieszania młodemu adeptowi, bo będzie 10 następnych pytań.
    Tylko prawdziwe zasilanie symetryczne +-5V, a jeszcze lepiej +-15V. Czyli dwa zasilacze 5V (albo 15V) połączone szeregowo.
    W ostateczności symetryzator na WO i parze komplementarnej, który to symetryzator trzyma sztywny podział napięcia: https://www.elektroda.pl/rtvforum/viewtopic.php?p=11568575#11568575
    ale wtedy trzeba napiecie zasilania min. 10V ->+-5V


    Twoje rozwiązanie się nie sprawdzi, kolega ma do dyspozycji tylko 5V :

    lokk napisał:
    To jak to zrobić? Zasilam układ z ładowarki do telefonu 5V. Kabelek USB ma tylko +5V i GND.


    Pozdr

    0
  • Pomocny post
    #14 11 Lut 2019 16:49
    trymer01
    Moderator Projektowanie

    rs6000 napisał:
    Twoje rozwiązanie się nie sprawdzi, kolega ma do dyspozycji tylko 5V :

    Nie.
    Napisał tylko:
    lokk napisał:
    Zasilam układ z ładowarki do telefonu 5V.

    Co nie wyklucza, iż posiada drugą taka ładowarkę. Nie ma? - niech się postara.
    Poza tym ja pisałem:
    trymer01 napisał:
    wtedy trzeba napiecie zasilania min. 10V ->+-5V

    co odnosiło się do ogólnego podanego tam symetryzatora na nieznanym WO (np. 741).
    Używając LM358 (bo przecież taki posiada) - będzie działać na zasilaniu 5V dając na wyjściu +-2,5V.
    Tak więc - sprawdzi się.
    Autor tematu ma dwie możliwości - druga Ładowarka (zasilacz) albo symetryzator na drugim WO posiadanego już LM358.
    A teraz, kiedy już kolega "pobił pianę" lecząc urażoną dumę i zaśmiecając temat nieprzemyślanymi postami - może na tym skończymy?

    UWAGA:
    lokk napisał:
    Zasilam układ z ładowarki do telefonu 5V.

    Niektóre ładowarki dają napięcie tętniące - bez filtracji.

    0
  • #15 11 Lut 2019 17:35
    lokk
    Poziom 3  

    Dzięki za wszystkie odpowiedzi.
    Czy istnieją wzmacniacze operacyjne niewymagające zasilania symetrycznego?

    0
  • Pomocny post
    #16 11 Lut 2019 18:50
    _jta_
    Specjalista elektronik

    Są. W szczególności LM358 nie wymaga. Ale nie robi takiego cudu, żeby dać na wyjściu napięcie ujemne względem minusa zasilania. A jak do wyjścia wpływa prąd (płynie przez oporniki 6k82 i 2k17), to daje nawet dodatnie.

    0
  • Pomocny post
    #17 11 Lut 2019 19:06
    trymer01
    Moderator Projektowanie

    Żaden wzmacniacz operacyjny nie musi być zasilany symetrycznie (tylko).
    Inaczej - każdy wzm. op. można zasilać napięciem symetrycznym (czyli podwójnym - przy czym nie muszą być one co do wartości bezwzględnej równe - np. +-5V, ale np. +5V, -1V) albo też napięciem niesymetrycznym (pojedynczym).
    Ale to nie oznacza, że zasilając go niesymetrycznie będzie można uzyskać dowolne napięcie na wyjściu. Zasilając go pojedynczym napięciem (dodatnim) możesz uzyskać na wyjściu tylko napięcie dodatnie, zasilając go symetrycznie (dodatnim i ujemnym) - możesz uzyskać na wyjściu napięcie dodatnie i ujemne.
    WO to nie przetwornica, więc zasilany dodatnim nie przerobi go na ujemne. Podając mu Uwe dodatnie i oczekując Uwy ujemnego musisz mu takowe dostarczyć - zasilić go i dodatnim i ujemnym (czyli symetrycznie).
    O amplitudzie napięcia wyjściowego decydują własności tego WO, jego obciążenie.

    Może tak łatwiej to zrozumieć; - WO zawsze widzi napięcie zasilania doprowadzone do swoich końcówek tak samo - i pojedyncze np. 10V i symetryczne np. ±5V=10V.
    Problem sprowadza się do masy - przy zasilaniu 10V masa to "zero" napięcia 10V, zaś przy zasilaniu ±5V masa jest pośrodku U=+5V i U=-5V. Jeśli np. wzmacniasz x2 napięcie zmienne 1Vpp (podawane wzgl masy) to chciałbyś uzyskać zmienne Uwy=2Vpp - ale przy zasilaniu 10V uzyskasz na wyjściu tylko dodatnie półfale tego napięcia zmiennego o amplitudzie 1V wzgl. masy, a przy zasilaniu ±5V uzyskasz Uwy=2Vpp wzgl. masy - jak chciałeś. Bo w tym drugim przypadku napięcia zasilania ujemne i dodatnie są większe od amplitud Uwe i Uwy, masa jest "pośrodku" więc i sygnał we. oraz wy. są w zakresie dozwolonym/obsługiwanym przez ten WO i tak zasilany.
    Jeśli wzmacniasz Uwe=0,000V - 1V, dwa razy to chcesz uzyskać Uwy=0,000V - 2V i dla zasilania ±5V uzyskasz to bo ten zakres napięć leży wewnątrz dopuszczalnych Uwe i Uwy oraz wewnątrz Uzas - z dala od "szyn zasilania" - czyli z dala od -5V i +5V. Dla zasilania 10V uzyskasz ok.0,05V - 2V bo Uwy nie może być =0,000V, nie istnieje taki WO, który osiągnie Uwy=napięciu którejś z szyn zasilania.
    W skrócie - zasilanie symetryczne powoduje, że sygnały są wewnątrz napięcia zasilania, a nie przy jednej z szyn zasilania - bo masa jest gdzie indziej.

    0
  • #18 11 Lut 2019 19:56
    krzysiek_krm
    Poziom 35  

    Jeszcze jedna uwaga - autor mógłby dokładniej napisać, co jest celem jego działań. Na przykład, pewną funkcjonalność wzmacniacza odwracającego przy pojedynczym zasilaniu uzyskuje się przez dość proste wprowadzenie odpowiedniego offsetu.

    0
  • #19 11 Lut 2019 20:44
    lokk
    Poziom 3  

    Celem tych działań nie jest nic konkretnego - po prostu uczę się właściwości elementów .

    Czyli jeśli zastosuję układ nieodwracający to już nie muszę zasilać symetrycznie, bo napięcie dodatnie uzyskać mogę?

    Dziękuję za odpowiedzi,
    Pozdrawiam.

    0
  • Pomocny post
    #20 11 Lut 2019 20:59
    trymer01
    Moderator Projektowanie

    lokk napisał:
    Czyli jeśli zastosuję układ nieodwracający to już nie muszę zasilać symetrycznie, bo napięcie dodatnie uzyskać mogę?

    Tak, ale Uwy>0, nie uzyskasz Uwy=0
    trymer01 napisał:
    Dla zasilania 10V uzyskasz ok.0,05V - 2V bo Uwy nie może być =0,000V, nie istnieje taki WO, który osiągnie Uwy=napięciu którejś z szyn zasilania.

    0