Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Współpraca ardiuno z PLC, wspólne wyjście z diodą led.

mutaz 10 Lut 2019 13:39 78 2
  • #1 10 Lut 2019 13:39
    mutaz
    Poziom 11  

    Witam

    Proszę o sprawdzenie poprawnosci układu.
    Arduino podaje plus na tranzystor który z kolei podaję masę na wejście PLC. Ten sam tranzystor steruje diodą led i sygnalizuje aktywację wyjsćia.
    PLC ma wejscie skonfigurowane jako OC czyli reaguje na masę. Plc posiada rezystory wbudowane podciągające.
    Chodzi mi szczególnie o diode led sterowaną z tego samego sygnału co sygnał podawany na PLC-czy to jest poprawne rozwiązanie?


    Współpraca ardiuno z PLC, wspólne wyjście z diodą led.

    0 2
  • #2 10 Lut 2019 15:26
    jarek_lnx
    Poziom 43  

    Układ będzie działać.

    Jeśli PLC ma rezystory podciągające, to na diodzie pojawi się zaporowe napięcie >5V czego większość producentów LED zabrania, żeby pozbyć się tej wady wypadało by dodać diodę 1N4148 szeregowo a LEDa zbocznikować rezystorem 100k.

    Twoje rozwiązanie niewiele się różni od takiego w którym LED-a podłączył byś z "od góry" do 12V, trochę więcej mocy do wytracenia w rezystorze, (tej która w przeciwnym przypadku wydzieliła by sie w stabilizatorze liniowym), jeśli LEDów było by dużo, a 5V pochodziło by z regulatora impulsowego twoje rozwiązanie mogło by zapewnić mniejsze straty mocy.

    0
  • #3 10 Lut 2019 15:49
    mutaz
    Poziom 11  

    jarek_lnx napisał:
    Układ będzie działać.

    Jeśli PLC ma rezystory podciągające, to na diodzie pojawi się zaporowe napięcie >5V czego większość producentów LED zabrania, żeby pozbyć się tej wady wypadało by dodać diodę 1N4148 szeregowo a LEDa zbocznikować rezystorem 100k.


    właśnie- i tu jest pewnie problem ponieważ układ zachowuje się niestabilnie tzn PLC losowo na okreslonych wejsciach reaguje na sygnał pomimo braku sygnału ze strony ardurino. Domyslam się ze to wina tego układu -dioda plus rezystor bo jak odłącze diodę wszystko jest ok.
    Dziwne jest to że układ jest powielony tzn. jest powiedzmy 5 wyjść i na dwóch wyjsciach problem występje a trzy działają poprawnie- od czego to zależy? Podzespoły identyczne. Mało o tym informacji w sieci .

    jarek_lnx napisał:

    Twoje rozwiązanie niewiele się różni od takiego w którym LED-a podłączył byś z "od góry" do 12V, trochę więcej mocy do wytracenia w rezystorze, (tej która w przeciwnym przypadku wydzieliła by sie w stabilizatorze liniowym), jeśli LEDów było by dużo, a 5V pochodziło by z regulatora impulsowego twoje rozwiązanie mogło by zapewnić mniejsze straty mocy.


    Tak myslałem o tym jednak przy takim rozwiązaniu mamy w pewnym stopniu zabezpieczoną diodę led i teoretycznie mozemy podać napięcie wyższe co nie spowoduje jakiegoś problemu z działaniem układu pomijając ewentualne straty na stabilizatorze liniowym.

    0