Elektroda.pl
Elektroda.pl
X
PCBwayPCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Brak internetu przy połączeniu dwóch switchy oraz routera.

09 Kwi 2019 12:17 1962 7
  • Poziom 3  
    Witam,
    Połączyłem 2 switche (TP-LINK TL SG3210, MikroTik Routerboard 1200) i router (Pentagram Cerberus P 6363) ze sobą, jak łącze jeden switch z routerem w obu przypadkach oraz przy połączeniu switchy ze sobą występuje połączenie, natomiast przy połączeniu wszystkiego nie ma dostępu do internetu.
    Czy ktoś spotkał się z podobnym problemem? Jeśli tak to proszę o pomoc. :D
  • PCBwayPCBway
  • specjalista-kamery przemysłowe
    Zacząłbym od sprawdzenia podłączonych urządzeń do tych switchy. Co się dzieje gdy podepniesz switcha nr 1, a w switchu nr 2 poodpinasz wszystkie kable(no oprócz tego łączącego switcha z routerem)? No i na odwrót.
    Podepnij też same switche bez dodatkowych urządzeń i później podpinaj pojedynczo kable.
  • PCBwayPCBway
  • Poziom 3  
    Po połączeniu ze sobą 2 urządzeń np. switch-switch, switch-router nie ma problemu. Problem występuje tylko wtedy kiedy podłączam wszystkie urządzenia (router-switch-switch-pc)

    Dodano po 20 [minuty]:

    Po połączeniu ze sobą 2 urządzeń np. switch-switch, switch-router nie ma problemu. Problem występuje tylko wtedy kiedy podłączam wszystkie urządzenia (router-switch-switch-pc)
  • specjalista-kamery przemysłowe
    A zrobiłeś tak jak proponowałem? Po kolei podpinać skrętki do switchy, i w momencie kiedy podepniesz kabel i nie będzie internetu, masz prawdopodobnie winowajcę całego zamieszania.
  • Poziom 3  
    Jak już wcześniej wspominałem przy podłączaniu dwóch urządzeń nie ma problemu z komunikacją, pojawia się tylko wtedy kiedy podłączam wszystkie urządzenia.

    Dodano po 8 [godziny] 56 [minuty]:

    W tym przypadku mam tylko switche, router oraz komputer. Więc najprawdopodobniej jest to problem z routerem bądź którymś z switchów.
  • Poziom 30  
    No to jeszcze wypadało by podać jak masz to skonfigurowane bo zarówno Switche jak i router są urządzeniami konfigurowalnymi/zarządzalnymi, gdzie może w Twoim przypadku występować jakiś konflikt lub masz jakieś VLANy/Izolacje poustawiane i wycinasz sobie ruch w ten sposób.
  • Poziom 42  
    Vytautas_YT napisał:
    No to jeszcze wypadało by podać jak masz to skonfigurowane


    I to powinno się znaleźć w #1 poście tego tematu.
  • Poziom 3  
    Switch1
    /interface bridge
    add fast-forward=no name=bridge_vlan_998
    add fast-forward=no name=bridge_vlan_999
    /interface vlan
    add interface=ether2 name=vlan_100 vlan-id=100
    add interface=bridge_vlan_998 name=vlan_998 vlan-id=998
    add interface=bridge_vlan_999 name=vlan_999 vlan-id=999
    /interface list
    add name=WAN
    add name=LAN
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    /ip hotspot profile
    set [ find default=yes ] html-directory=flash/hotspot
    /interface bridge port
    add bridge=bridge_vlan_998 interface=ether3
    add bridge=bridge_vlan_998 interface=ether4
    add bridge=bridge_vlan_999 interface=ether5
    add bridge=bridge_vlan_998 interface=ether1
    add bridge=bridge_vlan_998 interface=sfp1
    /interface list member
    add interface=ether1 list=WAN
    add interface=ether2 list=LAN
    add interface=ether3 list=LAN
    add interface=ether4 list=LAN
    add interface=ether5 list=LAN
    add interface=sfp1 list=LAN
    /ip address
    add address=192.168.0.1/24 interface=vlan_100 network=192.168.0.0
    /ip dhcp-client
    add dhcp-options=hostname,clientid interface=bridge_vlan_998
    /system routerboard settings
    set silent-boot=no












    Switch2
    /interface bridge
    add name=bridge_vlan_998
    add name=bridge_vlan_999
    /interface vlan
    add interface=ether1 name=vlan_100 vlan-id=100
    add interface=bridge_vlan_998 name=vlan_998 vlan-id=998
    add interface=bridge_vlan_999 name=vlan_999 vlan-id=999
    /interface bridge port
    add bridge=bridge_vlan_998 interface=ether2
    add bridge=bridge_vlan_998 interface=ether3
    add bridge=bridge_vlan_998 interface=ether4
    add bridge=bridge_vlan_998 interface=ether5
    add bridge=bridge_vlan_999 interface=ether6
    add bridge=bridge_vlan_999 interface=ether7
    add bridge=bridge_vlan_999 interface=ether8
    add bridge=bridge_vlan_999 interface=ether9
    add bridge=bridge_vlan_999 interface=ether10
    /ip address
    add address=192.168.0.2/24 interface=vlan_100 network=192.168.0.0
    /ip dhcp-client
    add dhcp-options=hostname,clientid
    /system routerboard settings
    set baud-rate=38400

    Dodano po 1 [godziny] 47 [minuty]:

    Problem rozwiązany
    MikroTik RouterBoard hEXs (switch1)
    /interface bridge
    add fast-forward=no name=bridge_vlan_998
    add fast-forward=no name=bridge_vlan_999
    /interface vlan
    add interface=ether1 name=vlan_100 vlan-id=100
    add interface=ether1 name=vlan_998 vlan-id=998
    add interface=ether1 name=vlan_999 vlan-id=999
    /interface wireless security-profiles
    set [ find default=yes ] supplicant-identity=MikroTik
    /ip hotspot profile
    set [ find default=yes ] html-directory=flash/hotspot
    /interface bridge port
    add bridge=bridge_vlan_998 interface=ether2
    add bridge=bridge_vlan_998 interface=ether3
    add bridge=bridge_vlan_999 interface=ether4
    add bridge=bridge_vlan_999 interface=ether5
    add bridge=bridge_vlan_998 interface=vlan_998
    add bridge=bridge_vlan_999 interface=vlan_999
    /ip address
    add address=192.168.0.1/24 interface=vlan_100 network=192.168.0.0
    /system routerboard settings
    set silent-boot=no


    MikroTik RouterBoard 1200(switch2)
    /interface bridge
    add name=bridge_vlan_998
    add name=bridge_vlan_999
    /interface vlan
    add interface=ether1 name=vlan_100 vlan-id=100
    add interface=ether1 name=vlan_998 vlan-id=998
    add interface=ether1 name=vlan_999 vlan-id=999
    /interface bridge port
    add bridge=bridge_vlan_998 interface=ether2
    add bridge=bridge_vlan_998 interface=ether3
    add bridge=bridge_vlan_998 interface=ether4
    add bridge=bridge_vlan_998 interface=ether5
    add bridge=bridge_vlan_999 interface=ether6
    add bridge=bridge_vlan_999 interface=ether7
    add bridge=bridge_vlan_999 interface=ether8
    add bridge=bridge_vlan_999 interface=ether9
    add bridge=bridge_vlan_999 interface=ether10
    add bridge=bridge_vlan_998 interface=vlan_998
    add bridge=bridge_vlan_999 interface=vlan_999
    /ip address
    add address=192.168.0.2/24 interface=vlan_100 network=192.168.0.0
    /system routerboard settings
    set baud-rate=38400

    Zamykam temat. :D