Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] przydźwięk przy użyciu modułu bt

20 Kwi 2019 19:43 504 36
  • Poziom 11  
    Witam,
    Zrobiłem wzmacniacz na lm386. Niedawno dodałem moduł bluetooth, lecz w tle dosyć mocno słychać Ten dźwięk. Moduł bluetooth jest zasilany z zasilacza 15v 1A oraz za pomocą stabilizatora 7805 (bt używa 5v). Jakieś pomysły? Mam pomysł, żeby użyć filtra rc, ale nie wiem czy to ma sens.
    Z góry dzięki.
  • PCBway
  • Poziom 19  
    Witam niestety te tanie moduły tak mają prawdopodobnie masa zasilająca i sygnałowa robią problem.Niech kolega poda co to za moduł to może się coś wymyśli mile widziany schemacik podłączenia modułu.Proponuję odłączyć którąś z mas na próbę.
  • PCBway
  • Poziom 11  
    A więc moduł to JDY-62. Nie wiem co rozumiesz przez odpięcie jednej z mas... Tu zamieszczę schemat:
    przydźwięk przy użyciu modułu bt
  • Poziom 19  
    Stara dobra szkoła podawała że w stabilizatorach LM7... należy jak najbliżej jego nóg wstawić kondensatory 47n-100n.
    Przede wszystkim na wejściu a i na wyjściu też jest wskazane.
    Jaki prąd pobiera Twój moduł.
    Możesz spróbować przy niewielkim poborze prądu dać na zasilaniu rezystor 100 Ohm i za nim elektrolit (tantal ) 100uF. Tak blokowało się przed wzbudzeniem czujki IR.
  • Poziom 11  
    Z tego co wyczytałem to pobiera on około 40 uA. Wypróbuję jeszcze wstawić kondensator 47n na wyjściu lm. Możliwe, że zastosuję rezystor, ale nie wiem, czy wtedy moduł wystartuje...
  • Poziom 40  
    _KoloroweKredki_ napisał:
    Moduł bluetooth jest zasilany z zasilacza 15v 1A oraz za pomocą stabilizatora 7805 (bt używa 5v). Jakieś pomysły?
    Może ten zasilacz 15V/1A jest źródłem zakłóceń. :cry:
  • Poziom 11  
    Właśnie dlatego użyłem kondensatorów 100n i 100u, aby je tłumić. Przy użyciu wejścia aux nie ma takich problemów. Jedynie moduł bt ma problem.
  • Poziom 40  
    _KoloroweKredki_ napisał:
    Jedynie moduł bt ma problem.
    Podaj link, lub konkretny typ tego BT.
  • Poziom 11  
    Polecam czytać post od początku. Model to JDY-62
  • Poziom 38  
    _KoloroweKredki_ napisał:
    Możliwe, że zastosuję rezystor, ale nie wiem, czy wtedy moduł wystartuje..

    Jeśli już to dławik ale najpierw należy zastosować kondensatory przy stabilizatorze o których pisali koledzy wyżej. Połączenia mas powinny być wykonane krótkim przewodem o średnicy 0,7mm - chodzi o to żeby nie było na nich dziwnych spadków napięcia czy różnicy potencjałów między modułami. Kolega w poście nr 6 pytał o zasilacz - więc się upewnijmy - to jest zasilacz liniowy czy impulsowy, bo kiepski impulsowy potrafi narobić problemów.
  • Poziom 40  
    _KoloroweKredki_ napisał:
    Polecam czytać post od początku.
    Ok. moja wina, lecz to nie ja oczekuję pomocy.
    zworys napisał:
    Kolega w poście nr 6 pytał o zasilacz - więc się upewnijmy - to jest zasilacz liniowy czy impulsowy, bo kiepski impulsowy potrafi narobić problemów.
    Właśnie to miałem na myśli pisząc #6.
    BT to nic innego jak odbiornik/nadajnik, fal "radiowych" i ma prawo zbierać jakieś harmoniczne sygnały, emitowane przez zasilacz.

    @_KoloroweKredki_
    , próbowałeś zasilić ten Twój układ (BT + wzmacniacz), akumulatorem ?.
  • Poziom 11  
    Spróbuję zobaczyć na baterii. Zasilacz jest chiński, ale nie wiem jaki to typ. Jak będę w domu pobawię się z Kondensatorami i dławikami.

    Dodano po 8 [minuty]:

    Aha i jeszcze jedno:
    Może zastosować stabilizator AMS1117?
  • Poziom 40  
    _KoloroweKredki_ napisał:
    Zasilacz jest chiński,
    Prawdopodobnie impulsowy i nie dostosowany do zasilania układów audio.
    Moim zdaniem, próby eliminacji zakłóceń emitowanych przez tego typu zasilacze, to strata czasu i nerwów.

    Pozdrawiam.

    Pogodnych Świąt Wielkiej Nocy, Życzę.

    R.
  • Poziom 11  
    Czy w takim wypadku można zastosować zasilacz antenowy?
  • Poziom 40  
    _KoloroweKredki_ napisał:
    Czy w takim wypadku można zastosować zasilacz antenowy?
    Moim zdaniem, to nie bardzo.
    Mała wydajność prądowa, oraz kiepska filtracja U_out (najczęściej stosowany w nich kondensator ma pojemność: 220 - 470µF).
  • Poziom 11  
    W takim razie co byś polecił? Prawdopodobnie użyję banku 18650

    Dodano po 4 [godziny] 21 [minuty]:

    Dobra. Na akumulatorach nie działa, zabawa z Kondensatorami tez nic nie dała. Nie wiem co dalej...
  • Poziom 11  
    bank miał około 11.5V, a obecny zasilacz wygląda na nawet rozbudowany. zamieszczam schemat. przydźwięk przy użyciu modułu bt
  • Poziom 38  
    Owszem rozbudowany ale niestety impulsowy. Żeby pracował z układami audio należałoby zwiększyć wartość indukcji FT i pojemność kondensatora za dławikiem.
    Najpierw sprawdź czy ten zasilacz jest źródłem zakłóceń - odłącz BT i zostaw otwarte wejście wzmacniacza - i wtedy posłuchaj czy są jakieś zakłócenia w głośniku. Jeśli nie to ten zasilacz może zostać ,ale zwróć uwagę na wersję LM bo nie wszystkie mogą pracować przy tak wysokim napięciu.
  • Poziom 40  
    _KoloroweKredki_ napisał:
    Na akumulatorach nie działa
    Przy napięciu 11,5V jak podałeś w #18, to jest wręcz niemożliwe aby nie działało. :cry:
    Coś robisz nie tak.
  • Poziom 11  
    Do zasilacza to we wzmacniaczy dałem kondensatory 100n i 100u, aby tłumiły zakłócenia zasilacza. A akumulatory poprostu podpinałem pod wejście na wtyczkę zasilacza, wtedy też się nie zmieniało pipczenie. gdy przełączyłem się na wejście aux i dałem max volume, to słychać cichutkie 50hz.
  • Poziom 38  
    _KoloroweKredki_ napisał:
    dałem kondensatory 100n i 100u, aby tłumiły zakłócenia zasilacza.

    Mogą nie wystarczyć.
    _KoloroweKredki_ napisał:
    ory poprostu podpinałem pod wejście na wtyczkę zasilacza,

    Trochę to niejasne - rozumiem że pod przewód wyjściowy z zasilacza ?
    _KoloroweKredki_ napisał:
    wtedy też się nie zmieniało pipczenie

    Jeśli wzmacniacz był zasilany tylko z akumulatora i dalej było zakłócenie to jego żródłem niestety jest BT i będzie trudno to zlikwidować.
    Spróbuj kolego zrobić tak - zasil wzmacniacz z zasilacza, a BT poprzez stabilizator z akumulatora. Czyli wg rysunku z postu nr 3 w miejsce Vcc podłączasz akumulator i z tego układu zasilasz tylko BT. Wzmacniacz zasilasz osobno z posiadanego zasilacza. Źródła zasilania spinasz tylko masą. Połączenie między wzmacniaczem a BT wykonujesz przewodem ekranowanym ale ekran łączysz z masą tylko we wzmacniaczu. W takim połączeniu sprawdź czy dalej są zakłócenia.
  • Poziom 11  
    Na razie ogarnąłem trochę przewody, przewodów ekranowany B niestety nie posiadam, leczy czy może to być dla testu przewód zawinięty w folię aluminiową?

    Dodano po 10 [minuty]:

    Aha i chyba znalazłem rozwiązanie - zrobić coś w stylu filtra za pomocą rezystora 2.2ohm i Kondensatora 470uF. https://youtu.be/jja6kz6Dte8
  • Poziom 38  
    _KoloroweKredki_ napisał:
    leczy czy może to być dla testu przewód zawinięty w folię aluminiową?

    Nie już lepiej zrobić skrętkę z dwu przewodów i jeden potraktować jako ekran.
    _KoloroweKredki_ napisał:
    zrobić coś w stylu filtra za pomocą rezystora 2.2ohm i Kondensatora 470uF

    Nie zaszkodzi ale gdyby to było takie proste to taki filtr zapewne byłby już na płytce BT, spróbować można.
  • Poziom 11  
    zrobiłem filtr... pipczenie jest prawie noesłyszalne. nadal pozostaje cichy brum, czy jest jakiś sposób aby go wyeliminować?
  • Poziom 40  
    _KoloroweKredki_ napisał:
    czy jest jakiś sposób aby go wyeliminować?
    Połączenia sygnałowe wykonać przewodem ekranowanym.
  • Pomocny post
    Poziom 38  
    _KoloroweKredki_ napisał:
    zrobiłem filtr... pipczenie jest prawie noesłyszalne. nadal pozostaje cichy brum, czy jest jakiś sposób aby go wyeliminować?

    Wartość rezystora w tym filtrze można podnieść do 4,7 oma ( jeśli będzie za małe napięcie dla BT to podpowiemy "sztuczkę " jak to naprawić.
    Brum powinno zmniejszyć zamontowanie wzmacniacza w metalowej obudowie połączonej w jednym miejscu z masą wzmacniacza ( najlepiej blisko wejścia )
  • Poziom 11  
    Jak elektroniczny będzie otwarty to kupię przewody ekranowane. co do mojego autorskiego filtra to nie miałem za bardzo pod ręką odpowiedniego rezystora, ale 10ohm działa bez problemu. Metalowej obudowy nie mam... jest jedynie taka w stylu z1a. Trzecie na ten wzmacniacz.
  • Poziom 38  
    Od biedy można wnętrze plastikowej obudowy wykleić folią aluminiową i postarać się o dobry kontakt folii i masy. Zasada podłączenia w jednym punkcie pozostaje aktualna. ( Należy tylko zapewnić odpowiedni dystans PCB i folii żeby nie zrobić przypadkowego zwarcia. )
    Można też z miękkiej blachy ocynowanej ( np. blachy do pieczenia ) zrobić pudełko , w nim umieścić wzmacniacz i to wszystko włożyć w obudowę końcową. Czasem pomaga ekranowanie tylko spodu PCB .
  • Poziom 40  
    @_KoloroweKredki_ ten wzmacniacz na LM386 to gotowy kupny moduł, czy własna konstrukcja ?.
    "Podrzuć" zdjęcie tego wzmacniacza, może coś się wyjaśni.