Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

komunikowanie modułu z komputerem (MIDI)

15 Maj 2019 21:53 84 5
  • Poziom 2  
    Hej

    Posiadam dwa moduły Alesis D4 i Black Hawk HXD II. Komputer widzi po podłączeniu oba urządzenia. Jednak gdy próbuję wyzwolić sygnał używając jakiegokolwiek programu DAW to nie działa.
    Robię identycznie jak na filmie:
    www youtube.com/watch?v=QV9WkY4Zy_I
    Wykorzystuję dodatkowo ASIO4All. Posiadam Windows 10. Niedawno go przeinstalowałem, wcześniej był win 7, komputer widział jeden z modułów i dodatkowo czytał z niego sygnał.

    Jakieś rady dlaczego po wyzwoleniu sygnału w module komputer go nie widzi?

    Pozdrawiam
  • Poziom 19  
    A jak masz ustawione kanały MIDI, czy przypadkiem nie ma konfliktu że oba na tym samym?
    Czy urządzenia podłączone pojedynczo też nie reagują na komendy MIDI z komputera?
    Jaki masz interfejs MIDI i jakim kablem połączone?

    Jedyne co Ci mogę polecić przy tak małej liczbie informacji, to użyj narzędzia MIDI-Ox które Ci pokaże, czy transmisja z komputera wychodzi prawidłowo i czy wraca z urządzeń.
  • Poziom 2  
    Hej, dzięki za odpowiedź.

    Nie rozumiem co znaczy jak mam ustawione kanały, nie mam pojęcia jak to sprawdzić. Robiłem jak na filmie identycznie.

    Tak, pojedynczo podłączone urządzenia nie reagują na komendy MIDI.

    Moduł Black Hawk HXD II podłączam do kompa USB i z drugiej strony wejściem MIDI (jak od drukarki).

    Moduł Alesis D4 złączem DIN-5 z konwerterem (czy adapterem) na kablu.

    Midi-Ox oczywiście używałem, tutaj też nie wiem jak powinno poprawie czytać kanały ale wchodzę w Options -> Midi Devices, urządzenia normalnie widzi. W okienku Monitor - Output pokazuje
    "Open MIDI Input
    Open MIDI Output"
    po czym wciskam trigger i nic się nie dzieje.
    W okienku Monitor - Input nie ma nic, także przy wyzwalaniu triggera.

    Czy jest ktoś mi w stanie pomóc? Na windows 7 działało normalnie... niestety tylko przy użyciu Black Hawk HXD II, natomiast Alesis D4 komputer nawet nie widział.
  • Poziom 19  
    kubu92 napisał:
    Nie rozumiem co znaczy jak mam ustawione kanały, nie mam pojęcia jak to sprawdzić.

    Albo masz to ustawiane z tyłu mikroprzełącznikami, albo w oprogramowaniu które jest dołączane do urządzenia.
    Ale z tego co piszesz dalej to już widzę, że to nie to.

    kubu92 napisał:
    Tak, pojedynczo podłączone urządzenia nie reagują na komendy MIDI.

    CZYM te komendy MIDI wydajesz? Jakiego oprogramowania używasz?
    Czy jak podłączysz i otworzysz Midi-Ox to jak coś pogmerasz w urządzeniu, to pokazuje w komputerze, że komunikaty przychodzą?

    kubu92 napisał:
    Moduł Black Hawk HXD II podłączam do kompa USB i z drugiej strony wejściem MIDI (jak od drukarki).

    Znaczy, że po USB masz transmisję. Czy Ableton widzi ten moduł jako urządzenie wejściowe?

    kubu92 napisał:
    Midi-Ox oczywiście używałem, tutaj też nie wiem jak powinno poprawie czytać kanały ale wchodzę w Options -> Midi Devices, urządzenia normalnie widzi.

    Znaczy pokazuje oba urządzenia kiedy są podłączone, na liście Midi Devices?
    Jeśli tak, to znaczy że komputer (i system operacyjny) je widzi, tylko Ty nie potrafisz ich skonfigurować tak, żeby Twoje oprogramowanie z nimi "gadało".

    kubu92 napisał:

    ...po czym wciskam trigger i nic się nie dzieje.

    Na czym wciskasz ten trigger?
  • Poziom 2  
    Piottr242 napisał:

    CZYM te komendy MIDI wydajesz? Jakiego oprogramowania używasz?
    Czy jak podłączysz i otworzysz Midi-Ox to jak coś pogmerasz w urządzeniu, to pokazuje w komputerze, że komunikaty przychodzą?


    Komendy wydaję triggerem podłączonym do modułu perkusyjnego - inaczej piezoelektrykiem na kablu. Sygnał z piezo idzie do modułu na 100 %, bo gdy uderzam w niego, to na module pali się kontrolka że sygnał poszedł... Niestety dalej do komputera nie idzie, ponieważ Midi-Ox sygnału nie widzi - komunikaty nie przychodzą. Same urządzenia (moduł/moduły) do komputera są podłączone poprawie bo komputer urządzenie czyta ale sygnału już nie.

    Piottr242 napisał:

    Znaczy, że po USB masz transmisję. Czy Ableton widzi ten moduł jako urządzenie wejściowe?

    Ableton nie, ale próbowałem inne DAWy jak Reaper. Wszystkie DAWy widzą urządzenia, które są ustawione na "Enabled" w ustawieniach wejściowych.

    Piottr242 napisał:

    Znaczy pokazuje oba urządzenia kiedy są podłączone, na liście Midi Devices?
    Jeśli tak, to znaczy że komputer (i system operacyjny) je widzi, tylko Ty nie potrafisz ich skonfigurować tak, żeby Twoje oprogramowanie z nimi "gadało".


    tak, dlatego założyłem temat bo to poważny, nie do rozwiązania problem dla mnie :)

    Piottr242 napisał:

    Na czym wciskasz ten trigger?


    Piezo na kablu, bądź padem do perkusji elektronicznej - opisałem wyżej.
  • Poziom 2  
    Czytałem w necie kolejne kilka godzin i nic nowego się się nie dowiedziałem. Jedyne co się zmieniło to, że po restarcie komputera i szybkim odpaleniu Midi-OX przez chwilę czyta sygnał jak wyzwalam trigger. Po chwili się zacina i jest znów to samo :)
    komunikowanie modułu z komputerem (MIDI)