Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica MP9486 - niestabilne działanie układu

07 Lip 2019 15:19 573 27
  • Poziom 23  
    Witam.
    Zbudowałem układ przetwornicy na scalaku MP9486:
    https://www.monolithicpower.com/en/documentvi...l/L20vcC9tcDk0ODZfcjEuMDEucGRm/prod_id/MjYwMQ
    Zasilanie wejściowe nie przekracza 85V a na wyjściu mam ustawione 12V. Przetwornica pracuje w rowerze elektrycznym więc pojawiają się różnego rodzaju zakłócenia z silnika z faz itp. I tutaj pojawia się problem, ponieważ przy jeździe przetwornica potrafi się wyłączyć na jakieś 200ms co widzę na przebiegu na oscyloskopie. Po prostu napięcie zjeżdża z 12 na jakieś 3-4V i za moment startuje znów na 12V, czyli scalak musi na ten czas się wyłączać. Chciałbym zasięgnąć opinii co może być powodem i czy schemat jest poprawny? Czy ktoś mógłby podsunąć pomysł co może być powodem? Wiem, że ciężko w takiej sytuacji coś doradzić, bo to trochę wróżenie z fusów. Nie wiadomo co to za zakłócenia. Ale może mimo to ktoś coś podpowie.
    Przetwornica MP9486 - niestabilne działanie układu
    Przetwornica MP9486 - niestabilne działanie układu
  • PCBway
  • Poziom 23  
    Stabilność napięcia wejściowego z akumulatora może spadać w zakresie nawet 10V od minimalnego napięcia baterii czyli do około 55-60V. Temperatura układu nigdy nie przekracza 50 stopni. Kondensatory wyjściowe były wymieniane kilkukrotnie więc zwarcie odpada. Przebieg na SW musiałbym zmierzyć. Czy podłączenie sondy oscyloskopu do pinu SW nie wpłynie na pracę przetwornicy? Czy dobrze rozumiem, że kondensator C1 musi być na napięcie najlepiej 100V (taki dałem)? Czy jest tam niższe napięcie?
  • Poziom 37  
    Może pull-up na EN i DIM jest zbyt cienki w przypadku silnych zakłóceń.
  • Poziom 23  
    Przepraszam za niedopatrzenie w kwestii napięcia kondensatora C1. Rzeczywiście w nocie jest napisane:
    Cytat:
    BST to SW ...................................... -0.3V to +6V

    Co do pinu EN to rzeczywiście może po prostu coś chwilowo wpływa na niego ściągając go poniżej poziomu. Pytanie tylko jak najlepiej rozwiązać kwestię podania stanu wysokiego? Jedyne co przychodzi mi do głowy to dioda zenera na 3.3V przez rezystor podpięta do napięcia zasilania przetwornicy. Czy można jakoś łatwiej to rozwiązać? Max zalecane napięcie to 5V a zasilanie mam tak jak podawałem od 60V w górę.
  • Poziom 37  
    splawik00 napisał:
    Jedyne co przychodzi mi do głowy to dioda zenera na 3.3V przez rezystor podpięta do napięcia zasilania przetwornicy. Czy można jakoś łatwiej to rozwiązać?

    Prościej chyba się nie da.
  • Poziom 31  
    Witam.

    Tego układu nie testowałem tylko inną przetwornicę z dopuszczalnym zasilanie do 76V.
    Problemem że czasami nie startowała lub pod obciążeniem się wyłączała był zbyt mały elektrolit na VIN.
    EN raczej do zasilanie tak by przekroczyć 1.55V

    Przetwornica MP9486 - niestabilne działanie układu

    Link do dokumentacji.
  • PCBway
  • Poziom 23  
    Zastanawia mnie jeszcze jedno. Teoretycznie w nocie opisane jest że piny EN i DIM powinny być sterowane napięciem w zakresie 0-5V.
    Jednocześnie według schematu blokowego pin EN jest podciągnięty do VIN więc czy napięcie na nim może jednak przekroczyć 5V?
    Jak to jest dokładnie?
    Czy mogę zastosować zewnętrzny rezystor podciągający do VIN bez diody zenera?
    Przetwornica MP9486 - niestabilne działanie układu
  • Poziom 31  
    @splawik00
    Masz schemat z płytki ewolucyjnej MPS. Oni jednak podciągneli to rezystorami do zasilania.
    W dokumentacji podają że poniżej 1.2 następuje wyłącznie przetwornicy a przy 1.55 ponowne włączenie.
    Nie wiadomo jak mocno wewnątrz to wejście jest podciągnięte.
    Z wyliczeń dzielnika wynika że układ przy 90V na EN dostanie prawie 22V.
    Natomiast przy 8V dostanie 1.95V. Czyli stale zostanie pokonany próg załączenia 1.55V
  • Poziom 23  
    Wewnątrz jest podciągnięcie o prądzie 2uA do VIN przynajmniej patrząc na schemat blokowy.
    Ale w tej samej dokumentacji jest też wpis:
    Cytat:
    When floating, EN is pulled up to about 3V by
    an internal 2µA current source, so it is enabled.

    Czyli to sugeruje, że nie jest to podciągnięte do VIN. Sam już nie wiem.
    Jaki jest cel stosowania dzielnika rezystorowego zamiast jednego rezystora do VIN?
  • Poziom 23  
    A więc dziś mam już jakieś konkrety. Po podłączeniu rezystora 50k od VIN do EN oraz diody zenera na 3,3V od EN do GND układ nie działa. Na wyjściu jest jakieś 3-4V a nie 12V. Czemu? Nie wiem. Zmierzyłem też napięcie na EN i jest poniżej 5V.
    Mam też oscylogramy. Pierwszy przedstawia stan pinu EN (niebieski) podczas spadku napięcia (żółty) na wyjściu. Jak widać napięcie na nim nie spada gdy przetwornica siada. Także tę potencjalną przyczynę można wyeliminować.
    Przetwornica MP9486 - niestabilne działanie układu
    Tutaj w zbliżeniu:
    Przetwornica MP9486 - niestabilne działanie układu
    Kolejny oscylogram to stan na pinie SW (niebieski) podczas spadku na wyjściu:
    Przetwornica MP9486 - niestabilne działanie układu
    W zbliżeniu:
    Przetwornica MP9486 - niestabilne działanie układu
    Zbliżenie miejsca gdzie przebieg na SW zmienia się (początek):
    Przetwornica MP9486 - niestabilne działanie układu
    I ponowny start przetwornicy i poprawny przebieg na SW:
    Przetwornica MP9486 - niestabilne działanie układu
    Proszę zauważyć też ciekawą rzecz, że widać tutaj nagłą zmianę częstotliwości na tym pinie, zaraz po ponownym starcie (widać to na powyższym przebiegu, a poniżej zbliżenie):
    Przetwornica MP9486 - niestabilne działanie układu
    Czy to normalne?
  • Poziom 31  
    @splawik00 Jaką przed VIN masz pojemność?
    Jak jest mała to daj minimum 470uF/100V i daj znać co się dzieje.
    Jakie masz podłączone obciążenie ( A )?
  • Poziom 23  
    Pojemność 2,2uF kondensatory ceramiczne 2 szt więc łącznie 4,4uF.
    Próbowałem też dawać kondensator 100uF 100V dodatkowo do tego na wejściu i niestety nic to nie zmieniło. Czy to może być za mało?
    Obciążenie na wyjściu max to kilkadziesiąt mA, max do 100mA.
  • Poziom 15  
    Kolejna rzecz do sprawdzenia to napięcie na kondensatorze C1. Przetwornica może robić sobie przerwy, żeby naładować ten kondensator jeśli wypełnienie przebiegu nie pozwala jej na naładowanie go podczas normalnego cyklu pracy. Jeśli to się potwierdzi to trzeba będzie zrobić zewnętrzny bootstrap co opisano w datasheet.
  • Poziom 23  
    Dziś podłączyłem na wejściu kondensator 470uF na 100V i niestety problem jest taki sam. Jak rozwiązać kwestię braku napięcia 5V żeby zasilić BST przez diodę? Można to jakoś inaczej rozwiązać nie mając do dyspozycji 5V?
  • Poziom 35  
    splawik00 napisał:
    Dziś podłączyłem na wejściu kondensator 470uF na 100V i niestety problem jest taki sam.


    Skoro jak piszesz masz różne śmieci na Vin jak silnik chodzi i wtedy tylko są te przerwy w działaniu przetwornicy, to możliwe że wyłączanie jest spowodowane przez układ UVLO z powodu jakiś szpilek na instalacji pochodzących od drivera silnika. Możliwe że wystarczy nawet jakiś mikrosekundowy dołek w Vin i UVLO wyłącza kość a następnie następuje startup, który trwa swoje.
    I tu takie małe kondensatorki (nawet bezindukcyjne) w zasilaniu kości mogą nie dać rady podtrzymać. A dowieszony elektrolit to już większa indukcyjność własna, też nie da rady jeśli te zakłócenia mają duże stromości prądu.

    Proponuję dla próby przetwornicę zasilić z instalacji przez jakąś diodę, tak by reszta instalacji nie mogła obciążyć kondensatorów przetwornicy na czas jakiś krótkich dołków prądowych.

    splawik00 napisał:
    Jak rozwiązać kwestię braku napięcia 5V żeby zasilić BST przez diodę? Można to jakoś inaczej rozwiązać nie mając do dyspozycji 5V?


    Co do tej dodatkowej diody BST, to w dokumentacji są wyliczone okoliczności kiedy ją stosować, ale u Ciebie one nie występują:

    Cytat:
    An external BST diode is recommended from the 5V supply to BST in the following cases:
    - There is a 5V rail available in the system
    - VIN is not greater than 5V
    - VOUT is between 3.3V and 5V


    Dlatego nie jestem przekonany czy w ogóle tu tkwi sedno problemu.
  • Poziom 23  
    No właśnie czytałem ten fragment dokumentacji i dlatego chciałem się upewnić. A co do diody to na wejściu przed kondensatorem mam diodę shottky żeby prąd nie wracał ale niestety i tak nie działa jak powinno. Co ciekawe czasem nawet nie trzeba silnikiem kręcić żeby były te same problemy.
  • Poziom 35  
    splawik00 napisał:
    A co do diody to na wejściu przed kondensatorem mam diodę shottky żeby prąd nie wracał ale niestety i tak nie działa jak powinno.


    Jeśli to nie UVLO powoduje, to może układ SCP. Tym bardziej że Twój czwarty i piąty oscylogram (konkretnie sygnał SW) jest uderzająco podobny (nagła zmiana częstotliwości impulsów SW na małą) do tego oscylogramu z dokumentacji ilustrującego jego pracę:
    Przetwornica MP9486 - niestabilne działanie układu

    Tyle tylko że w opisie funcji SCP warunkiem wejścia w ten stan jest nagły zanik napięcia na nodze FB. A u Ciebie akurat widać że nic złego się nie dzieje z napięciem wyjściowym i w konsekwencji (załóżmy) również na FB (bo to tylko dzielnik).
    Napięcie wyjściowe u Ciebie spada powoli ale wyraźnie już później, jako skutek zadziałania SCP a nie przyczyna. Czyli do sprawdzenia tylko luty na opornikach dzielnika i na nodze FB.



    Jest jeszcze jedno zabezpieczenie, ale niezbyt jasno opisane w dokumentacji przy okazji opisu SCP, przy przekroczeniu limitu chwilowego prądu na drenie mosfeta:

    Cytat:
    The power MOSFET current is also accurately sensed via a current sense MOSFET. If the current is over the current limit, the IC is shut down. This offers extra protection under output-short conditions.


    Epizodyczne przekroczenie prądu drenu mogło by nastąpić np. gdyby dioda D1 dostawała chwilowego przebicia. Mogło by to wynikać z zakłóceń dodatnich (szpilek) na Vin pojawiających się akurat w momencie załączenia mosfeta, gdy mosfet zwiera Vin i SW. Lub, mniej prawdopodobne, przy jakiś przebiciach w dławiku.

    Chyba że układ jest ok, ale Twoje obciążenie jest na skraju zadziałania zabezpieczenia. Bo tu nie piszesz nigdzie na ile obciążasz tą przetwornicę.
  • Poziom 23  
    Witam.
    Przede wszystkim dziękuję za zaangażowanie tematem, bo nie sądziłem, że uzyskam tak rzeczowe odpowiedzi. Postaram się opisać dodatkowe sprawy.
    Pisałem kilka postów temu o obciążeniu, ale mogło to oczywiście zostać przeoczone. Każdemu się zdarza. Zatem przypomnę:
    Obciążenie wyjścia to max kilkadziesiąt mA, nie więcej niż 100mA.
    Jeśli chodzi o złe luty, to również odpada. Zrobiłem już 3 takie przetwornice do testów i problem jest w każdej. Raczej niemożliwe, żeby 3 trzech były wadliwe luty. Więc to można moim zdaniem wykluczyć.
    Podam części które stosowałem. Może tu jest problem.
    Dławik:
    https://www.tme.eu/pl/details/hpi1040-330/dlawiki-smd-mocy/ferrocore/
    Dioda:
    https://www.tme.eu/pl/details/10mq100ntrpbf/diody-schottky-smd/vishay/vs-10mq100ntrpbf/
    Dodatkowo zastanawiam się, że skoro to jakiś kłopot może być z dzielnikiem, to czy zastosowanie równolegle z rezystorem jak na schemacie kondensatora 100nF jest poprawne?
    Niby w nocie jest on zawarty na schemacie, ale tak tylko pytam dla pewności ;)
    Raz jeszcze dziękuję.
  • Poziom 35  
    splawik00 napisał:
    Zrobiłem już 3 takie przetwornice do testów i problem jest w każdej. Raczej niemożliwe, żeby 3 trzech były wadliwe luty. Więc to można moim zdaniem wykluczyć.


    Cenna wskazówka. Szkoda że nie napisałeś wcześniej.


    splawik00 napisał:
    Podam części które stosowałem.


    Dioda wygląda ok. Dławik tym bardziej, bo ma ładny margines prądu.


    splawik00 napisał:
    to czy zastosowanie równolegle z rezystorem jak na schemacie kondensatora 100nF jest poprawne?


    O właśnie.
    Z początku nawet pomyślałem że pomylone są jednostki u Ciebie na schemacie, bo w różnych przetwornicach wartości zalecane dla kondensatora w tym miejscu są rzędu kilkudziesięciu, góra kilkaset pikofaradów i z reguły są opcjonalne. Lub zalecane w przypadku bardzo wysokoomowych dzielników dla kompensacji wobec pojemności montażowych.
    Tu trochę pierwszych z brzegu przykładów przetwornic z tym dodatkowym kondensatorem, gdzie widać że nawet tam gdzie oporności dzielnika są stosunkowo małe tzn. rzędu dziesiątek kiloomów to ta pojemność nie przekracza pół nanofarada a zwykle jest dużo mniejsza:
    Przetwornica MP9486 - niestabilne działanie układuPrzetwornica MP9486 - niestabilne działanie układu Przetwornica MP9486 - niestabilne działanie układu Przetwornica MP9486 - niestabilne działanie układu Przetwornica MP9486 - niestabilne działanie układu
    Przetwornica MP9486 - niestabilne działanie układuPrzetwornica MP9486 - niestabilne działanie układu


    Dlatego te 100nF wydają mi się wartością przesadnie duża, działaniem "z grubej rury".
    Ale jednak faktycznie, wartość 100nF występuje wyraźnie w różnych miejscach materiałów producenta w sposób niewątpliwy.
    Dla mnie wybór tej wartości wydaje się dziwny, bo silnie podbija charakterystykę pętli regulacji dla wysokich częstotliwości, gdzie właściwie główną rolę (stabilizacji i eliminacji tętnień) powinny odgrywać kondensatory wyjściowe.
    Ale najbardziej niepokoi mnie stosowanie tej wartości w zestawieniu z układem SCP działającym jak w opisie. Przy takim "przekompensowanym" dzielniku, wystarczy jakieś małe, nawet niewidoczne na oscyloskopie, zakłócenie szpilkowe na wyjściu o relatywnie małej amplitudzie (ułamka wolta) a stromym zboczu, by napięcie na pinie FB spadło chwilowo nawet do zera (a jest tam normalnie tylko 0,2V). Wyzwalając w ten sposób działanie układu SCP, który nawet nie potrzebuje do zadziałania czystego zera na FB.
    Ja na Twoim miejscu, wyrzuciłbym ten kondensator i przetestował układ bez niego.
    Tym bardziej że według producenta nie jest on w żadnym stopniu obligatoryjny a tylko zalecany w przypadku stosowania na wyjściu tantali lub elektrolitów aluminiowych:

    Cytat:
    A forward capacitor across R1 is recommended when the output capacitor is tantalum or aluminum electrolytic, which can set the desired frequency if the output capacitor and ESR cannot be changed. The forward capacitor can reduce the output voltage ripple.


    A tak po prawdzie to producent w swojej płytce ewaluacyjnej daje tantal ale równolegle z ceramicznym, tak że trudno nawet w świetle tej powyższej wskazówki sklasyfikować przypadek.
  • Poziom 17  
    Jedynie potworną anoreksją ścieżek, które są w praktyce pięknymi kilku-kilkunastonanohenrowymi ceweczkami. Przy częstotliwości kluczowania w okolicach 1MHz to ten układ na wszystkich doprowadzeniach wiodących prąd ma pewnie sieczkę z nanosekundowych szpilek.