Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel 2016 - Zamian formatu data na tekstowy by w tekstowym data byla poprawna

29 Sie 2019 10:50 153 7
  • Poziom 3  
    Witam,

    SAP robi nam export pliku excela ze sformatowanymi kolumnami typu: data, liczby. Niestety exportu nie mozemy edytowac.

    Potrzebujemy ten plik zaimportować do innego programu ktory potrzebuje formatowanie calego pliku jako tekstowe.

    Uzywamy excela 2016 problem pojawia sie podczas zaznaczenia kolumny z datami i zamian jej na tekstowy, wybieram kolumne z foramtowaniem dat:

    03.01.2019
    03.01.2019
    04.01.2019
    07.01.2019
    08.01.2019
    08.01.2019

    po zamianie jej na tekstowe wyskakuje:
    43468
    43468
    43469
    43472
    43473
    43473

    Tymczasowym obejsciem jest skopiowanie tych dat do notatnika i stamtad spowrotem do excela po uwczesnym ustawieniu formatowania tekstowego.

    Druga metoda to przerabianiu to na starym excelu 2007, wtedy po zmianie dat na tekstowy zamienia je poprawnie, niestety ten komputer jest na wymarciu :( a instalacja starego excela na innych komputerach nie wchodzi w gre.

    Jest inna metoda by zrobic to w excelu 2016 ?

    pozdrawiam
  • Poziom 33  
    Załącz małą próbkę takiego pliku w takim formacie, w jakim go otrzymujesz i ten sam plik w formacie docelowym. Problemu by nie było gdyby w komputerze format daty był inny niż z kropkami.
    Edit: Jeśli propozycja Prota rozwiązuje Twój problem, to w tym przypadku moja prośba jest nieaktualna, ale na przyszłość zawsze dołączaj plik, bo na nim można coś sprawdzić, a opis nie zawiera wszystkich szczegółów.
  • Poziom 33  
    I od załącznika trzeba było zacząć. Widzę to tak - 3 etapy:
    1. Zaznaczamy zakres dat i zmieniamy format na docelowy tzn. "rrrrddmm"
    2. Kopiujemy zakres do schowka Office (mała strzałka obok słowa Schowek otwiera go, kopiuje się normalnie) i wklejamy w to samo miejsce
    3. Zmieniamy format na Tekstowe.
  • Poziom 3  
    Maciej,

    Niestety narazie wlasnie to jest jedyny sposob, opisalem go w temacie, szukalismy jakiejs przyjazniejszej wersji.

    Dziwi nas ze w starej wersji excela 2007 po zmianie formatowania dat na tekstowy, nie zamienia go na jakies dziwne numery w stylu:
    43468
    43468
    43469

    Jesli ktos znajdzie jeszcze jakis pomysl bede wdzieczny!

    Pozdrawiam :)
  • Poziom 33  
    Nie rozumiem Twojego komentarza, przecież wg mojej propozycji nigdzie już nie występują liczby seryjne dat, a takie "udziwnione", jakich potrzebujesz. Ocena, co jest normalne, a co nietypowe jest bardzo względna. Sprawdzałem to na wersji 2016, której używasz, więc powinno działać tak samo. Zwracam uwagę na konieczność użycia schowka Office, a nie schowka systemowego. Excel 2016 - Zamian formatu data na tekstowy by w tekstowym data byla poprawna
    Te 3 etapy można wykonać na tym samym miejscu, ja to rozdzieliłem, żeby było bardziej poglądowo i było widać etapy pośrednie.
  • Poziom 18  
    =TEKST(A2;"rrrrmmdd")