Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wyświetlenie określonego wyniku - błąd funkcji

12 Wrz 2019 20:30 57 5
  • Poziom 5  
    Witam,

    w załączonym arkuszu jest funkcja z komórki E7 która oddaje wartość z komórki E2 jesli w zakresie D2:D11 pojawi się chociaż jeden znak C.

    Jak zmodyfikować funkcję z komórki E21 aby w przypadku braku w zakresie D16:D26 znaku C oddawała wartość z komórki D26 ?

    Pozdrawiam:

    Keszybz
  • Pomocny post
    Moderator - Komputery Serwis
    Witaj.
    Code:
    =JEŻELI(LICZ.JEŻELI(C16:C25;"c");"";D26)
  • Poziom 5  
    Tak funkcja zlicza w przypadku braku znaku C w podanym zakresie ale gdy znak się pojawi to nie oddaje wartości E16

    Dodano po 2 [minuty]:

    Faktycznie mój błąd nie napisałem od razu wszystkiego
    - jest znak C w zakresie funkcja oddaje wartość E16
    - nie ma znaku C w zakresie funkcja oddaje wartość D26
  • Pomocny post
    Moderator - Komputery Serwis
    W takim razie:
    Code:
    =JEŻELI(LICZ.JEŻELI(C16:C25;"c");E16;D26)
  • Poziom 5  
    Raczej
    Kod: vbnet
    Zaloguj się, aby zobaczyć kod
  • Pomocny post
    Moderator - Komputery Serwis
    keszybz napisał:
    Faktycznie mój błąd nie napisałem od razu wszystkiego
    - jest znak C w zakresie funkcja oddaje wartość E16
    - nie ma znaku C w zakresie funkcja oddaje wartość D26

    Nie widzę, aby Kolega pisał o jakiejkolwiek sumie. Z opisu Kolegi wynika, że chce Kolega wyświetlać albo E16 albo D26, więc taką funkcję Kolega dostał. Ale skoro oczekuje Kolega sumy - to już na pewno wie, co sobie wstawić.