Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Zmiana router''a tl-wr1042nd na archer c6 brak VPN

06 Paź 2019 16:13 135 4
  • Poziom 10  
    Witam
    Mam problem z poprawnym podłączeniem VPN.
    Do tej pory używałem router'a tp-link TL-WR1042ND oraz dwóch routerków mikrotik'a do połączenia vpn (łączyły się ze sobą tworząc w drugim miejscu moją sieć domową).Sprawdziłem porty jakie były przypisane do jednego z mikrotika(ten w domu) i przypisałem te same porty w nowym routerze archer c6 v2.00 Niestety nie mam już VPN.Co powinienem zrobić?ps firewall w nowym routerze wyłączony
  • Poziom 6  
    Witam, jaki protokół jest ustawiony na serwerze PPTP L2TP OpenVPN IPsec SSTP? Rozumiem że jeden mikrotik działa jako serwer i jest on poprawnie skonfigurowany?
  • Poziom 10  
    Zmiana router''a tl-wr1042nd na archer c6 brak VPN Witam
    Niestety nie mam pojęcia jakie protokóły są .Nie ja robiłem tego VPN.Ja tylko wymieniłem router i stało się to co się stało.Mam co prawda zdalny dostęp do mikrotików więc mogę to sprawdzić tyle że nie wiem gdzie?mogę porobić zrzuty ale tego będzie multum.Mogę udostępnić kompa przez teamviewer.Przypuszczam że jako serwer.konfiguracja była taka: mikrotik- router tl-wr1043nd(dwa porty dla mikrotika)-internet-router tp-link wr841nd-mikrotik. i to hulało do wymiany routera teraz jest:mikrotik-router archerc6(te same porty do mikrotika)-internet-reszta bez zmian.
    PS.czy zmiana wejścia lan(rj45)w mikrotiku ma znaczenie?
  • Pomocny post
    Poziom 6  
    Z tego co widzę uruchomione są dwa połączenia OVPN i PPTP pytanie co się znajduję w firewallu oraz PPTP server i OVPN serewer.
    Jeśli chodzi o konfiguracje serwera OVPN to tak:
    krok pierwszy Generowanie certyfikatów:
    /certificate add name=ca-template common-name=myCa key-usage=key-cert-sign,crl-sign
    /certificate add name=server-template common-name=server
    /certificate add name=client1-template common-name=client1
    krok drugi Podpisywanie certyfikatów:
    /certificate sign ca-template ca-crl-host=10.5.101.16 name=myCa
    /certificate sign server-template ca=myCa name=server
    /certificate sign client1-template ca=myCa name=client1
    tam gdzie jest host należy podać publiczny adres IP
    krok trzeci Dodanie certyfikatów do zaufanych:
    /certificate set myCa trusted=yes
    /certificate set server trusted=yes
    krok czwarty Przygotowanie adresacji dla klientów
    /ip pool add name=OVPN ranges=10.0.0.1-10.0.0.254
    krok piąty Konfiguracja serwera
    /interface ovpn-server server set enabled=yes certificate=server require-client-certificate=yes auth=sha1 cipher=aes256
    krok szósty Dodawanie profilu
    /ppp profile add name=ovpn local-address=10.0.0.1 remote-address=OVPN use-encryption=required
    krok siódmy Dodawanie użytkowników
    /ppp secret add name=user password=xxxxxx service=ovpn profile=ovpn
    należy zmienić nazwę użytkownika i hasło
    krok ósmy Konfiguracja firewalla
    /ip firewall filter add chain=input protocol=tcp dst-port=1194 action=accept
    Jeśli chodzi o konfiguracje klienta to tak:
    krok pierwszy Export certyfikatów z serwera
    /certificate export-certificate client1 export-passphrase=xxxxxxxx
    /certificate export-certificate myCa export-passphrase=xxxxxxxx
    w miejsce xxx jakieś hasło minimum 8 znaków
    krok drugi Import certyfikatów na kliencie
    /certificate import file-name=cert_export_client1.crt
    /certificate import file-name=cert_export_client1.key passphrase=xxxxxxxx
    /certificate import file-name=cert_export_myCa.crt
    /certificate import file-name=cert_export_myCa.key passphrase=xxxxxxxx
    w miejsce xxx hasło podane przy exporcie
    krok trzeci Dodawanie tunelu na kliencie
    /interface ovpn-client add connect-to=xxx.xxx.xxx.xxx user=user password=xxxxxx profile=default-encryption certificate=cert_export_client1.crt auth=sha1 cipher=aes256
    w miejsce xxx.xxx.xxx.xxx publiczny adres ip serwera w miejsce xxxxxx hasło do usera na serwerze
    certyfikaty należy przekopiować z serwera na klienta (drag and drop)
    Pozdrawiam
  • Poziom 10  
    Witam niestety nie pomogło