Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Niepowodzenie przy kopii systemu na inny dysk

23 Paź 2019 20:33 303 11
  • Poziom 5  
    Witam.

    Miałem 2 dyski SSD na SATA, podłączyłem dodatkowo dysk M.2 500GB (desktop) i chcąc przerzucić system na niego, zrobiłem kopię całej partycji, na której znajduje się system, programem EaseUs Todo Backup free (v. 11.5).

    Na nowym dysku powstaje jeden plik w folderze, utworzone przez program EaseUS. Ważą tyle co dane na partycji (ok. 125GB). Następnie wchodzę w BIOS i zmieniam mój dysk M.2 na pierwszy w kolejności do bootowania i robię reboot. Po chwili wyskakuje komunikat "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key".

    Rozmawiałem z supportem MSI, bo myślałem, że może w BIOSie coś trzeba ustawić, ale niestety po wymianie kilku wiadomości poddali się i nie pomogli. Jedyne co się dowiedziałem to wychodzi na to, że na dysku M.2 jakby nie czytało tego systemu. Rozmawiałem z nimi także o tym, że mój dysk (ten SATA SSD), na którym jest system, jest widziany jako UEFI chociaż system plików to NTFS (z tego co wyczytałem powinno być FAT32), a system odpala się w trybie zarówno UEFI + LEGACY jak i UEFI.

    Wrzucam kilka screenów z BIOSa, może coś to pomoże.

    Ogólnie to chcę przerzucić system na nowy szybszy dysk bez konieczności instalacji wszystkiego od nowa, ewentualnie dowiedzieć się jak potem usunąć sam system z tego poprzedniego dysku. Nie muszę wszystkiego rozumieć z tym UEFI itp. Czy ktoś mi powie co mogę robić źle, może coś trzeba zaznaczyć?



    Z góry dzięki

    Niepowodzenie przy kopii systemu na inny dysk Niepowodzenie przy kopii systemu na inny dysk Niepowodzenie przy kopii systemu na inny dysk Niepowodzenie przy kopii systemu na inny dysk
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 42  
    Powiem tak co do przenosin.

    Miałem system na 60 GB SSD, zakupiony SSD 512GB.

    Odpaliłem system win10 samo zło, odpaliłem DMDE i skopiowałem cały SSD 60 GB na 512GB pod działającym systemem ignorując informacje od DMDE.

    System normalnie działa na nowym 512GB tylko poszerzyłem partycje na pełny rozmiar dysku z 60GB jaki był na starym SSD.
  • Poziom 23  
    Do przenoszenia systemu na inny dysk polecam clonezillę. Najlepiej jest przenieść zawartość całego dysku, a nie samą partycję.
  • Poziom 5  
    @enhanced Niestety, ale nie do końca rozumiem o czym mówisz.

    @suser222 Niestety, ale przerzucenie całego dysku daje ten sam efekt. Ma to znaczenie, że te ukryte partycje systemowe od odzyskiwania itp. nie mają nadanej litery?
    Jakiś pomysł? Nowy komp a takie problemy... Może ja coś podstawowego robię źle, że nawet nikt tego nie zakłada?
  • Poziom 35  
    kozakinio napisał:
    zrobiłem kopię całej partycji

    i to był Twój błąd :cry:
    Zajrzyj jakimś narzędziem (np DMDE ) na stary dysk i popatrz ile tam jest partycji oprócz tej "systemowej" :D
    Najlepiej jest w takiej sytuacji przeprowadzić procedurę klonowaniadysku przy użyciu wyspecjalizowanych narzędzi (tj. programów), które uruchamiają własne środowisko i przeprowadzają tą procedurę poza zainstalowanym systemem :!:
    Jak wskazuje kolega enhanced czasami udaje się procedura kopii posektorowej realizowana spod działającego systemu :crazyeyes:
    enhanced napisał:
    skopiowałem cały SSD 60 GB

    Ale IMHO nie jest to metoda godna polecenia dla "unenhanced users" :please:
  • Poziom 5  
    Prot napisał:
    kozakinio napisał:
    zrobiłem kopię całej partycji

    i to był Twój błąd :cry:
    Zajrzyj jakimś narzędziem (np DMDE ) na stary dysk i popatrz ile tam jest partycji oprócz tej "systemowej" :D
    Najlepiej jest w takiej sytuacji przeprowadzić procedurę klonowaniadysku przy użyciu wyspecjalizowanych narzędzi (tj. programów), które uruchamiają własne środowisko i przeprowadzają tą procedurę poza zainstalowanym systemem :!:
    Jak wskazuje kolega enhanced czasami udaje się procedura kopii posektorowej realizowana spod działającego systemu :crazyeyes:
    enhanced napisał:
    skopiowałem cały SSD 60 GB

    Ale IMHO nie jest to metoda godna polecenia dla "unenhanced users" :please:



    @Prot No właśnie chwilę wcześniej opisałem przerzucenie całego dysku. Jest to samo. EaseUs pokazuje mi te wszystkie partycje, chyba dodatkowe 3 ukryte oprócz tych moich. Nic to nie zmienia ;/ A kopia sektorowa coś tam coś tam to tego nawet nie rozumiem :P

    EaseUs Todo Backup Free nie jest takim programem? Coś jeszcze mogę robić źle?
  • Poziom 5  
    Prot napisał:
    Przejrzyj sobie instrukcje klonowania dysków przy użyciu Twojego oprogramowania https://www.youtube.com/watch?v=pCLtwLRyvPw :idea:


    Nie rozumiem co sugerujesz. Obejrzałem ten tutorial i jest dokładnie taki sam jak inne. Robię dokładnie tak samo, tylko nie na laptopie z jednym dyskiem a na desktopie z 3 dyskami. Nie odłączam "starego" dysku z systemem tylko zmieniam priorytet bootowania.

    Mój przypadek jest taki, jakby temu gościowi po podłączeniu już na koncu adaty w laptopie, zamiast odpalenia windowsa wyskoczył mu komunikat, który cytuję w pierwszym poście o podłączeniu odpowiedniego dysku.

    Edit: próbowałem z kopią systemu i całego dysku.
  • Poziom 35  
    kozakinio napisał:
    Robię dokładnie tak samo
    :D
    Nie dostrzegasz oczywistych różnic (interfejs Twojego nowego dysku - M.2, praca z dwoma dyskami systemowymi itp) :?:
    Proponuję jeszcze raz zweryfikować Twoją płytę i Bios pod kątem współpracy z dyskami M.2, oraz sprawdzenie czy producent dysku nie oferuje jakiś programów do klonowania dysków (np Samsung ma swoje narzędzia https://www.samsung.com/semiconductor/minisite/ssd/download/tools/).
  • Poziom 5  
    Prot napisał:
    Nie dostrzegasz oczywistych różnic (interfejs Twojego nowego dysku - M.2, praca z dwoma dyskami systemowymi itp)


    Nie rozumiem o czym mówisz, bo znam różnice w interfejsach, ale czy to ma jakieś znacznie?

    Prot napisał:
    Proponuję jeszcze raz zweryfikować Twoją płytę i Bios pod kątem współpracy z dyskami M.2, oraz sprawdzenie czy producent dysku nie oferuje jakiś programów do klonowania dysków (np Samsung ma swoje narzędzia https://www.samsung.com/semiconductor/minisite/ssd/download/tools/).


    To mówisz w końcu, że robię coś źle i tego nie rozumiem, czy może jednak płyta nie obsługuje mi M.2?

    Otóż MSI Z370 Tomahawk obsługuje M.2 PCIe NVMe, sprawdzałem, BIOS jest aktualny.
    Na serio program ma tutaj znaczenie? Przecież ten jest popularny i raczej wszystkim działa.

    Zrobiłem jak gościu z tutorialu, który wrzuciłeś, tylko jakby jemu na końcu po wsadzeniu dysku ADATA do laptopa, zamiast otworzyć się system, to wyskoczył mu komunikat "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key", no i zamiast dysku na przejściówce na usb mam dysk na M.2.

    Nie chcę, aby to brzmiało jak jakieś dopieprzanie się, ale po prostu potrzebuję pomocy z jak wydawało mi się banalną sprawą (sam nie jestem ekspertem, ale tutoriali jest masę) i nigdzie nie mogę jej znaleźć, w dodatku nie rozumiem Twoich odpowiedzi...
  • Poziom 35  
    Jeśli korzystasz z zasobów wujka Google :?: To powinieneś wyłapać multum informacji nt instalacji systemu W10 na dyskach M.2 np. https://forum-en.msi.com/index.php?topic=297108.0.
    Niektórzy wręcz twierdzą, iż nie zalecane jest wykorzystywanie dysków M.2 jako urządzeń rozruchowych :| https://forum.dobreprogramy.pl/t/przeniesienie-systemu-na-ssd-m-2-w-laptopie/523217
    Cytat:
    The problem is that the existing Windows software has an issue with many drives booting from the PCI-Express bus rather than from SATA. This means that having an M.2 drive using PCI-Express while fast won't be the primary drive where the operating system or programs are installed. The result is a fast data drive but not the boot drive.
  • Poziom 5  
    Prot napisał:
    Jeśli korzystasz z zasobów wujka Google To powinieneś wyłapać multum informacji nt instalacji systemu W10 na dyskach M.2 np. https://forum-en.msi.com/index.php?topic=297108.0.

    Nie chcę instalować od nowa, nie chcę tracić danych i instalować masy rzeczy od nowa. Wyłapałem "multum informacji" ale żadnej o moim przypadku.
    Rozmawiałem nawet z supportem MSI, ale po dłuższej wymianie nie umieli pomóc (albo za dużo tłumaczenia i im się nie chciało).

    Prot napisał:
    Niektórzy wręcz twierdzą, iż nie zalecane jest wykorzystywanie dysków M.2 jako urządzeń rozruchowych https://forum.dobreprogramy.pl/t/przeniesienie-systemu-na-ssd-m-2-w-laptopie/523217


    Jeden komentarz, nigdzie indziej nie spotkałem go więcej, przestarzały sprzed 2 lat, większość ludzi próbuje jakieś dziwne akcje z odłączaniem wszystkich dysków i instalacją tylko na nvme i działa. Ale ja nie chcę instalować od nowa.

    Prot napisał:
    Cytat:
    The problem is that the existing Windows software has an issue with many drives booting from the PCI-Express bus rather than from SATA. This means that having an M.2 drive using PCI-Express while fast won't be the primary drive where the operating system or programs are installed. The result is a fast data drive but not the boot drive.


    Problem z bootowaniem wielu urządzen z PCIe? Chodzi o kartę graficzną plus M.2 PCIe? Tylko te 2 urządzenia są na PCIe, a tak na prawdę to mam odłączoną kartę graficzną kiedy to robię, więc jest jedno urządzenie, tylko ten dysk.

    Nie wiem, od początku próbujesz mi udowodnić, że czegoś nie umiem zrobić, albo znaleźć. Otóż gdybym umiał to bym nie szukał pomocy na forum. Sam raz odpowiadasz jakby to było banalne zagadnienie i coś robię nie tak, a potem wrzucasz, że nie powinno się korzystać z M.2 po OS. Sam sobie przeczysz.
    Szukałem i szukam sposobu jak to zrobić cały czas, ale jak widać XXI w. to jeszcze za wcześnie na komputery z systemem na dysku SSD M.2 PCIe.

    Dodano po 4 [minuty]:

    Niepowodzenie przy kopii systemu na inny dysk


    OK. Szkoda, że mi MSI tak nie odpowiedziało.

    Dodano po 58 [sekundy]:

    Ale to w półtora roku dalej nic nie brnęło na przód?