Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?

GanzConrad 05 Nov 2019 19:17 1095 9
Altium Designer Computer Controls
  • #1
    GanzConrad
    Level 25  
    Witam wszystkich.
    Naprawa dotyczy zasilacza z żarówki LED COB za 5pln (230V->42V), więc jest typowo hobbystyczno- edukacyjna.
    chodzi o poniższy zasilacz:
    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
    Sprawdziłem oba kondensatory elektrolityczne (na stronie pierwotnej i wtórnej) : mierzyłem pojemność miernikiem, więc tylko przy niskim napięciu i nie wiem do końca jak się zachowują w napięciach pracy, więc wymieniłem na podobne pojemności. Napięcie na kondensatorze pierwotnym to 320V, więc mostek Graetza też jest raczej OK.
    Sprawdziłem miernikiem diodę na wtórnym - wygląda OK.
    Wylutowałem i sprawdziłem kondensator Y - około 2nF, ale wydaje mi się, że nie ma on większego wpływu na pracę zasilacza.
    Na wyjściu z zasilacza mam coś takiego:
    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
    napięcie za niskie, okres tej "piły" to aż 15ms (66Hz, zamiast katalogowych 70kHz) a "tętnienia", to aż 10V.
    Nie ma tam zbyt dużo do sprawdzania, więc chciałem się upewnić - czy coś zrobiłem nie tak, czy kontroler PWM jest ewidentnie uwalony?
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • Altium Designer Computer Controls
  • Helpful post
    #2
    rb401
    Level 38  
    GanzConrad wrote:
    okres tej "piły" to aż 15ms (66Hz, zamiast katalogowych 70kHz) a "tętnienia", to aż 10V.


    Taki okres może ewentualnie wskazywać na cykliczne działanie któregoś z zabezpieczeń w kości (według producenta jest ich kilka). Przetwornica startuje, coś jest nie tak i się wyłącza aż do następnej próby za 15ms.
    Ale nie piszesz czy masz sprawdzone same LEDy. Gdyby była na nich przerwa, mogło by w ten sposób wyzwalać się zabezpieczenie przed otwartym obwodem na wyjściu (przetwornica jest "prądowa" więc przerwa na wtórnej stronie to sytuacja awaryjna).
    Niestety nie udało mi się znaleźć porządnej dokumentacji CS6553 by uzyskać pewność.
    Ale choćby ze schematu aplikacji widać że tu dużo do szukania nie ma:

    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
  • Altium Designer Computer Controls
  • #3
    GanzConrad
    Level 25  
    @rb401 przepraszam, o tym zapomniałem: LEDY są OK, podczas działania uszkodzonego zasilacza lekko się świecą i migają (na oko może być to 66Hz). Testowałem je na zasilaczu warsztatowym, ale tylko do 31V - delikatnie się świecą.
    Jest 14 struktur * 3V = 42V. Miałem przetestować zasilacz na sztucznym obciążeniu (rezystor mocy ok 350-400Ohm), ale zrezygnowałem, bo raczej nie jest to konieczne (teraz po namyśle, zrobię to wieczorem).
    Po stronie pierwotnej został do przetestowania jeszcze jakiś kondensator ceramiczny i rezystory.
  • Helpful post
    #4
    teskot
    Level 34  
    C2 na schemacie jak będzie miał zaniżoną pojemność to też może dawać takie efekty.
  • #5
    GanzConrad
    Level 25  
    Schemat troszkę się różni, bo na trafo jest drugie uzwojenie po stronie pierwotnej.

    Wyeliminowałem LEDy, poniżej test z sztucznym obciążeniem 270 Ohm:
    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
    410 Ohm :
    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?

    Mierzyłem C2 i wyszło mi 2.2uF co zgadzało by się z jednym ze schematów jakie znalazłem w sieci. Wymieniłem go na 10uF (jakiś niskonapięciowy SMD niestety nie mam danych, ale na razie nie wybuchł ;-) )
    Test z C2=10uF (częstotliwość zmalała):
    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
  • Helpful post
    #6
    teskot
    Level 34  
    Czyli przetwornica jednym słowem nie startuje-coś ją trzyma. Może to być kontrola prądu na Rcs, może być za niskie napięcie na Vdd wynikające z upływności C2 lub nadpalenia R1. A o co chodzi z tym drugim uzwojeniem pierwotnym? Są 2 uzwojenia po stronie pierwotnej?
  • Helpful post
    #7
    rb401
    Level 38  
    GanzConrad wrote:
    Schemat troszkę się różni, bo na trafo jest drugie uzwojenie po stronie pierwotnej.


    Być może trafo i płytka były projektowane pod kostkę CS6552, która bezwzględnie potrzebowała tego dodatkowego uzwojenia:
    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
    Ale ja widzę na Twoim zdjęciu ewidentnie CS6553, specjalnie reklamowana jako taka, która nie wymaga tego uzwojenia.
    Nie wiem czy potrafisz zajrzeć pod trafo czy tam są obsadzone miejsca na elementy konieczne pod wersję CS6552 (dioda i 3 oporniki). Ale podejrzewam że ich nie ma i to uzwojenie idzie donikąd.

    Co do Twoich oscylogramów, to może nie za bardzo widać co się dzieje, w małej okolicy tuż przed samym zadziałaniem zabezpieczenia. Konkretnie amplitudy napięcia po rozruchu przetwornicy, bo mnie nadal nurtuje czy aby napięcie skacze na taką wartość (dużo powyżej roboczego 42V), które ta kostka interpretuje jako rozwarty obwód.
  • #8
    GanzConrad
    Level 25  
    teskot wrote:
    Są 2 uzwojenia po stronie pierwotnej?

    tak, wylutowałem trafo, pomierzyłem, ma 4 wyprowadzenia : 1,2,3,4 i okazuje się, że są dwa różne uzwojenia (różna rezystancja) jedno pomiędzy 1 i 2, drugie pomiędzy 3 i 4, ale na płytce, zwarte są ze sobą nóżki 2 i 3 (wiszące w powietrzu), więc tworzy to jedno uzwojenie ;-)


    rb401 wrote:
    nie wiem czy potrafisz zajrzeć pod trafo czy tam są obsadzone miejsca na elementy konieczne pod wersję CS6552


    nic nie ma, pod tafem jest pusto, a większość miejsca zabiera wyfrezowana dziura

    rb401 wrote:
    czy aby napięcie skacze na taką wartość (dużo powyżej roboczego 42V)


    Przetwornica jest prądowa, więc może zaprojektowano ją do szerszego zakresu, choćby ze względu na rozrzut parametrów wśród chińskich LEDów COB.

    Nie chciałbym grzebać z oscyloskopem po stronie pierwotnej, bo trochę obawiam się o sprzęt (nie chciałbym go sfajczyć dla przetwornicy za 1pln ;-) )

    C1 (oznaczenie na płytce) wymieniłem na 10uF
    zaczyna mnie to osłabiać... 2 elementy na krzyż i nie chce działać...
    Może po weekendzie będę miał chwilę to wylutuje wszystko i zacznę testować po kolei.

    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?

    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?

    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?

    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?
  • Helpful post
    #9
    rb401
    Level 38  
    GanzConrad wrote:
    tak, wylutowałem trafo, pomierzyłem, ma 4 wyprowadzenia : 1,2,3,4 i okazuje się, że są dwa różne uzwojenia (różna rezystancja) jedno pomiędzy 1 i 2, drugie pomiędzy 3 i 4, ale na płytce, zwarte są ze sobą nóżki 2 i 3 (wiszące w powietrzu), więc tworzy to jedno uzwojenie ;-)


    Tak ma być. Znalazłem dokumentację nawijania transformatora do CS6552 na 8-12 LED szeregowo (pewnie różnica to tylko te uzwojenie pomocnicze N4, którego nie potrzeba w CS6553):

    Uszkodzony impulsowy zasilacz LED - padnięty sterownik PWM?

    i tu widać że z jakiś ważnych powodów (bo to zwiększa koszty o parę centow), uzwojenie pierwotne jest nawijane w dwóch częściach (N1 i N3), pod i nad uzwojeniem wtórnym (N2). Te części mają te same ilości zwojów, ale pewnie to zewnętrzne wymaga więcej drutu, bo jest nawijane na większym obwodzie. I dlatego widzisz inną oporność.
    Tak że jest ok. Płytka pod CS6553 i praktycznie schemat dokładnie jak w aplikacji (oprócz opornika 39kΩ na wtórnej stronie ale nie wygląda by był znaczący dla problemu tutaj).
    Znalazłem nawet podobną przetwornicę u siebie i też pierwotne jest z dwóch połówek, ale są zmostkowane na dodatkowym pinie transformatora a nie na druku.



    GanzConrad wrote:
    Nie chciałbym grzebać z oscyloskopem po stronie pierwotnej, bo trochę obawiam się o sprzęt (nie chciałbym go sfajczyć dla przetwornicy za 1pln ;-) )


    Ja też nie polecam.