Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Radeon HD 7850 - Awaria karty graficznej, widać dużo pionowych pasków w 3 kolora

25 Lis 2019 20:59 396 8
  • Poziom 7  
    Witam. Mam problem z kartą graficzną, prawdopodobnie mogła się uszkodzić. Nie znalazłem nigdzie podobnej usterki, więc napisałem temat.
    Na początku podam specyfikacje komputera (sprzęt z 2013 ze sklepu):

    Karta: Sapphire Radeon HD 7850 OC (11200-14-20G) 2GB DDR5 PCI-E BOX
    Zasilacz: SilentiumPC Deus G1 80Plus Bronze 500W
    Płyta: MSI Z68A-G43 (G3)
    Procesor: Intel Core i5-3350P
    Wersja sterowników: Catalyst Omega 14.12 (najprawdopodobniej, nie pamiętam co było przed awarią. Teraz brak sterowników poza systemowymi)
    System operacyjny: Windows 7 x64 Ultimate SP1


    Wersja TL/DR:

    Podczas grania pojawiło mi się dużo wąskich pionowych pasków w 3 kolorach na całej szerokości ekranu (jakby 3 odcienie czegoś szarego-brązowego). Na ekranie były widoczne tylko te paski - nic w tle. Wszystkie paski były takiej samej szerokości, regularne. Poza problemem graficznym wszystko wydawało się normalne - słyszałem dźwięki z gry, przyciski na klawiaturze działały. Podobny problem pojawił się wcześniej 2 razy, ale wtedy komputer sam się zrestartował zanim coś zrobiłem, a problem "zniknął". Po trzeciej awarii musiałem zrobić cold reseta, a po ponownym uruchomieniu pojawił się czarny obraz na monitorze i komunikat monitora "out of range". Problem dotyczył tylko jednego wyjścia karty DVI-D, które było używane. Wyjścia DVI-I i hdmi działały, i z powrotem miałem obraz. Pojawił się komunikat "System Windows nie został poprawnie zamknięty" i nic nie pomagało. Po reinstalu systemu było normalnie do czasu instalacji sterowników karty graficznej, bo po ponownym uruchomieniu pojawiał się komunikat "System Windows nie został poprawnie zamknięty".
    Teraz komputer chodzi bez sterowników karty graficznej i prawie wszystko chodzi normalnie.


    Pełny opis problemu:

    Grałem w grę i nagle pojawiło mi się dużo wąskich pionowych pasków w 3 kolorach na całej szerokości ekranu (jakby 3 odcienie czegoś szarego-brązowego). Na ekranie były widoczne tylko te paski - nic w tle. Wszystkie paski były takiej samej szerokości, regularne, nie znalazłem w internecie żadnej grafiki, która by to przypominała. Poza problemem graficznym wszystko wydawało się normalne - słyszałem dźwięki z gry, przyciski na klawiaturze działały.
    Ten problem graficzny pojawił mi się wcześniej 2 razy w oknie logowania do gry po kilku minutach bezczynności (tj. włączałem grę, gra przechodziła do okna logowania, ja w międzyczasie coś robiłem z dala od komputera, a jak podchodziłem do komputera, to widziałem te paski na ekranie). Przy tych dwóch przypadkach ctrl+alt+del nic nie robił, a po paru minutach (kiedy ja szukałem jakiś rozwiązań) komputer sam się restartował i problem się nie pojawiał po ponownych uruchomieniu.
    Wszystkie te 3 zdarzenia wystąpiły w ponad 1 tygodniowych odstępach czasu. Przy tym trzecim zdarzeniu komputer sam się nie zrestartował, więc ja zrobiłem cold reseta.

    Po ponownym uruchomieniu komputera na monitorze miałem czarny obraz i komunikat od monitora "out of range". Jakoś doszedłem, że problem "out of range" dotyczył tylko jednego wyjścia DVI-D w karcie graficznej, którego używałem w momencie powstania problemu z kartą. Wyjścia DVI-I i hdmi działają, ale muszę ponownie uruchamiać komputer, aby dostać obraz na takim wyjściu. Nie testowałem podłączania naraz dwóch monitorów. W początkach tego problemu zauważyłem również, że jeden wentylator się nie uruchamiał, ale obecnie oba kręcą się tak samo.

    Po znalezieniu działających wyjść w karcie graficznej pojawił się nowy problem, bo pojawiało się okno "System Windows nie został poprawnie zamknięty" z opcjami uruchamiania w trybie awaryjnym, albo uruchomienia normalnie. Uruchamianie normalnie nic nie dawało, więc postawiłem od nowa postawić system. Reinstal pomógł, dało się używać komputer i instalować sterowniki, włączyłem nawet rozdzielczość 1920x1080.

    I tu pojawił się następny problem. Po instalacji sterowników karty graficznej i ponownym uruchomieniu komputera pojawiało się okno "System Windows nie został poprawnie zamknięty". Próbowałem nowszego i starszego sterownika, ten sam problem. Poza tym dało się wchodzić do trybu awaryjnego z obsługą sieci.


    W tym momencie korzystam z systemu bez sterowników karty graficznej. Prawie wszystko chodzi normalnie. Czuć brak sterowników, bo obraz przycina się przy przewijaniu. Mogę odtwarzać na YouTube 1080p w widoku pełnoekranowym, na komputerze w odtwarzaczu mpc 1080p też chodzi w porządku, jakieś mniej zaawansowane gry też chodzą płynnie.


    Zauważyłem tylko 4 problemy przy użytkowaniu komputera bez sterowników karty graficznej:

    1. Zmiana profilu w Realtek HD audio (to sama zmiana głośności: 12%, 25%, 50% lub 100%) powoduje na przerwanie odtwarzania video na niektórych stronach (np. YouTube). Na odtwarzaczu jest stan, jakby wideo nadal było odtwarzane, ale trzeba włączyć pauzę i jeszcze raz play, żeby wznowić odtwarzanie wideo. Zmiana głośności poprzez suwak w Realtek HD audio lub narzędzie Windows nie powoduje tego problemu.

    2. Twitch chodzi wolniej, dużo wolniej zaczyna stream wideo, niektóre streamy potrafią się zacinać. To jedyna strona, gdzie zauważyłem takie duże uniedogodnienia. Poza tym twitch się ostatnio zmienił, może to jest tego powodem.

    3. Niektóre gry we flashu chodzą niepłynnie, albo sporadycznie zawieszają się na jakieś 5 sekund.

    4. Czasem dźwięk w słuchawkach jest cichszy po włączeniu głośników. Ciężko odtworzyć to zdarzenie. Miałem wrażenie, że zdarzyło się to, jak oglądałem coś na pilot.wp.pl.


    Czy na tej podstawie da się określić, co jest nie tak z kartą, albo czy to nie jej wina?


    Pozostałe informacje:

    Z kartą nigdy nic nie robiłem poza jednym epizodem niewielkim podkręcaniem w MSI Afterburner. Dużej różnicy wydajności nie widziałem, to po 1-2 dniach wróciłem do ustawień fabrycznych. To chyba też był jedyny moment, gdzie jakoś obserwowałem temperatury na karcie, ale nie pamiętam, żeby coś było nie tak.

    Na ile mogłem, na tyle obejrzałem kartę. Nie widziałem niczego spalonego, żadnych zepsutych kondensatorów. Niestety obudowa karty jest tak zaprojektowana, że bez odkręcania chłodzenia nie mogę dokładnie jej obejrzeć.
    Link poglądowy karty:
    https://www.emag.pl/karta-graficzna-sapphire-...2gb-ddr5-pci-e-box-11200-14-20g/pd/EHFPKBBBM/

    Karta sporadycznie czyszczona, mało kurzu zbierała w porównaniu do procesora.

    Według HWiNFO temperatura na karcie teraz jest 34-36 stopni. MSI Afterburner nic nie chce pokazywać. Wygląda na to, że nie widzi karty.

    W grze przy której wystąpiła awaria GPU było zazwyczaj obciążone 36-40%. Temperatur karty nie śledziłem na bieżąco, ale te kilka razy co miałem włączony MSI Afterburner, to chyba nie przekraczało 50 stopni (dane z pamięci, dawno to robiłem, a nie mam screenów). Obciążenie GPU rosło do 100% kiedy wyłączyłem w opcjach gry vsync (monitor 60 Hz, nie widziałem potrzeby więcej fps), ale tego ustawienia używałem dawno, może przez miesiąc. Zauważyłem, to jak się coś zwieszało w grze (lub gwałtowny spadek FPS), to obciążenie karty spadało z 36-40% do 0% zamiast wzrastać.

    Inne gry w jakie gram, to starsze, prostsze tytuły, co prawie karty nie obciążają.

    Aktualnie monitor jest podłączony za pomocą kabla hdmi, ale w oknie Windowsa do zmiany rozdzielczości monitor widać jako "Rodzajowy monitor PnP na Standardowa karta graficzna VGA", a rozdzielczość jest 1920x1080 (a nie 1080p jak to bywa przy podłączaniu monitora przez kabel hdmi).

    Karta przez rok chodziła z monitorem VGA z przejsciówką DVI-I na VGA. Przez pozostałe 5 lat używałem monitora z wejściem DVI-D i podłączonym do tego odpowiednika w karcie. Czasami używałem dwóch monitorów w tej konfiguracji.

    W miarę możliwości mogę dostarczyć innych informacji. Z góry dziękuję za odpowiedzi.

  • Poziom 43  
    Cóż - w większości przypadków artefakty spowodowane są uszkodzeniem karty więc powinieneś sie z tym liczyć.
  • Poziom 42  
    Luuuke napisał:
    W miarę możliwości mogę dostarczyć innych informacji

    Proszę sprawdzić w menedżerze urządzeń właściwości karty graficznej czy występuje kod błędu 43.
    Przydałby się screen lub zdjęcie z problemem, chociaż opis sugeruje awarię GPU.
    Przy obniżonych taktowaniach również karta również nie chce poprawnie działać?
    Proszę jeszcze podać wersję sterowników i systemu operacyjnego, nie potrafiłem tego znaleźć w opisie.
  • Poziom 7  
    Na początku chciałem dodać, że nie mogłem dodać obrazków normalnie (komunikat "upload failed", ale nie podaje przyczyny), ale udało się dodać jako załączniki. Dodatkowo umieściłem obrazki na imgur i wrzuciłem do posta, żeby chociaż teraz było lepiej przeglądać temat.

    Cytat:
    Proszę sprawdzić w menedżerze urządzeń właściwości karty graficznej czy występuje kod błędu 43.

    W menedżerze urządzeń mam tylko "To urządzenie działa poprawnie". Na wszelki wypadek wrzucam screen, żeby mieć pewność, że patrzę tam, gdzie trzeba. Nie ma pozycji "Radeon HD 7850".

    Radeon HD 7850 - Awaria karty graficznej, widać dużo pionowych pasków w 3 koloramenedzer_u...awarii.png Download (3.28 MB)

    Cytat:
    Przydałby się screen lub zdjęcie z problemem, chociaż opis sugeruje awarię GPU.

    Zrobienie screena tamtego błędu z paskami było niemożliwe, a niestety nie zrobiłem zdjęcia. Starałem się odtworzyć to, co wtedy było widoczne na ekranie. Te paski chyba były nieco gęstsze od tego, co tu narysowałem i raczej jeszcze ciemniejsze.

    Radeon HD 7850 - Awaria karty graficznej, widać dużo pionowych pasków w 3 koloraobraz_na_e...estsze.png Download (3.34 MB)


    Cytat:
    Przy obniżonych taktowaniach również karta również nie chce poprawnie działać?

    Kartę tylko raz podkręcałem (chyba 2 lata temu), ale po kilku dniach wróciłem do ustawień fabrycznych, bo nie widziałem znaczącej poprawy wydajności i z tymi ustawieniami fabrycznymi karta chodziła do czasu awarii. Wrzucam screen z HWiNFO aktualnych parametrów karty

    Radeon HD 7850 - Awaria karty graficznej, widać dużo pionowych pasków w 3 koloraHWINFO_po_..rii.png Download (205.93 kB)

    Ze starych danych ze sklepu miałem parametry: Taktowanie rdzenia 920 MHz, Taktowanie pamięci 5000 MHz. Nie znam się, ale 5000 MHz może być częstotliwością efektywną pamięci, bo na Amazon znalazłem normalne taktowanie pamięci to 1250 MHz.
    Teraz nie mogę zmieniać żadnych parametrów karty, bo wygląda na to, że MSI Afterburner nie widzi karty graficznej.

    Cytat:
    Proszę jeszcze podać wersję sterowników i systemu operacyjnego, nie potrafiłem tego znaleźć w opisie.

    Nie mam pewności, które sterowniki miałem ostatnio zainstalowane. Najprawdopodobniej był to Catalyst Omega 14.12, który testowałem w 2015.04.26 (to nie podaje szczegółowych danych sterownika, ale to jest możliwe do sprawdzenie po instalacji sterowników, co teraz jest niemożliwe).
    System operacyjny to Windows 7 x64 Ultimate SP1.
    Dodam te informacje również to głównego postu.

    Chciałem powtórzyć, że artefakt wystąpił tylko 3 razy. Pierwsze 2 razy powstały w oknie logowania do gry, trwały około 1-2 minuty, po czym komputer sam się zrestartował. Trzeci raz powstał w czasie gry, mógł trwać z 10 minut i to ja zrobiłem cold reset. Po ponownym uruchomieniu okazało się, że wcześniej używane wyjście DVI-D daje teraz błąd "out of range" oraz otrzymałem błąd "System Windows nie został poprawnie zamknięty". Podpięcie monitora do wyjścia hdmi oraz czysta instalacja systemu częściowo rozwiązały problem, jednakże instalacja sterowników karty graficznej (Catalyst 14.12 albo oryginalnych z płyty) powoduje pojawienie się błędu "System Windows nie został poprawnie zamknięty" po wymaganym ponownym uruchomieniu komputera po instalacji sterowników i jedyne co mogę wtedy zrobić, to uruchomić tryb awaryjny. Aktualnie używam komputer z tą kartą graficzną, ale bez jej sterowników.


    Generalnie, to chciałbym się dowiedzieć, czy problem po instalacji sterowników karty graficznej jest spowodowany przez kartę graficzną. Jeżeli jest to problem karty graficznej, to czy kartę da się jeszcze naprawić oraz czy to jest opłacalne.
  • Poziom 7  
    Precyzyjniej mówiąc powiedziałbym, że port DVI-D działa niewłaściwie. Całkiem nie padł, daje jakiś sygnał.

    Zostaje kwestia, czy da się z danych określić przyczynę awarii karty oraz czy warto oddać ją do serwisu. Brak widocznych uszkodzeń fizycznych, czy to może być kwestia odlutowania i przylutowania jakiś części? Na przykład procesora. Czy może jakiś jej soft się uszkodził?
  • Pomocny post

    Poziom 43  
    Jakakolwiek naprawa karty nie opłacalna, reballing GPU pomoże na chwilę, wymiana GPU na pozbawiony wad przewyższy znacznie wartość karty.
  • Poziom 7  
    Witam,
    Nowa karta graficzna i komputer chodzi. Po czasie stwierdzam, że jedynie został problem przy zmianie profilu głośności w Realtek HD Audio (zacina się odtwarzanie filmów na niektórych stronach, np YouTube).
  • Poziom 7  
    Witam,
    Nowa karta graficzna i komputer chodzi. Po czasie stwierdzam, że jedynie został problem przy zmianie profilu głośności w Realtek HD Audio (zacina się odtwarzanie filmów na niektórych stronach, np YouTube).

    Dodano po 59 [sekundy]:

    Kupiłem nową kartę graficzną.