Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Debian 6.0.5 - unstable package

Gelip 11 Dec 2019 18:26 273 6
  • #1
    Gelip
    Level 33  
    Kilka lat temu zainstalowałem Debian'a 6.0.5 standard czyli tylko terminal w maszynie wirtualnej na Windows. Dziś odpaliłem maszynę i chcę zainstalować pakiet smbfs aby mapować dysk Windows poleceniem mount.cifs, niestety pojawia mi się info, że pakiet samba jest niestabilny i że jakieś pakiety zależne zostały podzielone i trzeba ręcznie instalować:
    Spoiler:
    Code:
    root@debian:~# apt-get install smbfs
    
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following package was automatically installed and is no longer required:
      libftdi1
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      cifs-utils keyutils libnss-winbind libpam-winbind libtdb1 libwbclient0 samba
      samba-common winbind
    Suggested packages:
      smbclient openbsd-inetd inet-superserver smbldap-tools ldb-tools ctdb
    Recommended packages:
      tdb-tools
    The following NEW packages will be installed:
      cifs-utils keyutils libnss-winbind libpam-winbind libtdb1 smbfs winbind
    The following packages will be upgraded:
      libwbclient0 samba samba-common
    3 upgraded, 7 newly installed, 0 to remove and 75 not upgraded.
    Need to get 0 B/13.0 MB of archives.
    After this operation, 14.0 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    WARNING: The following packages cannot be authenticated!
      libtdb1 samba libwbclient0 samba-common winbind libnss-winbind
      libpam-winbind cifs-utils keyutils smbfs
    Install these packages without verification [y/N]? y
    Reading changelogs... Done
    samba (2:3.6.5-2) unstable; urgency=low

        NSS modules have been split out from libpam-winbind to
        libnss-winbind.

        If Recommends: installs are disabled on your system you may need
        to manually install the libnss-winbind package after upgrading
        from former versions of winbind (for instance from squeeze) or
        from former versions of libpam-winbind.

     -- Christian Perrier <bubulle@debian.org>  Mon, 07 May 2012 22:16:32 +0200

    samba (2:3.5.11~dfsg-3) unstable; urgency=low

        PAM modules and NSS modules have been split out from the winbind
        package into libpam-winbind.



        If Recommends: installs are disabled on your system you may need
        to manually install the libpam-winbind package after upgrading
        from former versions of winbind (for instance from squeeze)

     -- Steve Langasek <vorlon@debian.org>  Fri, 21 Oct 2011 20:00:13 +0000

    /tmp/tmpuRRnng (END)

    Jak mam zainstalować ręcznie te pakiety libnss-winbind i libpam-winbind

    Kiedyś zrobiłem własnego debiana-live.iso i w nim działa mapowanie dysku Windows. Myślałem aby może zainstalować smbfs z CD zamiast z Internetu więc zrobiłem to, ale nie działa: Installing Debian Packages from CD-ROM - w sources.list zakomentowałem wszystkie linie oprócz deb cdrom

    Może można zainstalować inny pakiet aby mieć narzędzie mount.cifs ?

    Oczywiście ten Debian jest już stary i pojawia się komunikat, iż nie można zweryfikować pakietu ale po wciśnięciu Y inne pakiety normalnie się instalują np. flashrom czy ssh

    Może do instalacji z CD muszę użyć innej wersji debian - nie liveCD?
  • Helpful post
    #2
    szwagros
    Level 33  
    Nie bardzo rozumiem z czym masz problem, to co pokazałeś to tzw. nowości dla pakietu, jeśli wciśniesz 'q' to instalacja powinna pójść dalej.
  • #3
    Gelip
    Level 33  
    szwagros wrote:
    Nie bardzo rozumiem z czym masz problem, to co pokazałeś to tzw. nowości dla pakietu, jeśli wciśniesz 'q' to instalacja powinna pójść dalej.

    No, patrz jak to jest jak się człowiek nie za bardzo zna na tych całych instalacjach. W logach nie ma, żeby wcisnąć 'q'

    No ale dzięki wielkie - działa :-) Punkty dla Ciebie.
    Debian 6.0.5 - unstable package

    P.S. Swoją drogą wkurzają mnie trzy rzeczy w Debianie:
    • w Internecie nie można już znaleźć starszych wersji ISO np. właśnie 6.0.5
    • czemu Debian (nie live) zajmuje tyle płyt CD lub DVD
    • czemu z wersji graficznej Live np. gnome nie można zainstalować tylko wersji tekstowej
    Jeszcze 3 lata temu mogłem pobrać ISO a dziś już nie ma :-x
    Na razie można jeszcze zainstalować system przez sieć. Dobrze, że swego czasu zbudowałem własną wersję live z potrzebnymi pakietami i narzędziami bo jeszcze parę lat i Squeeze całkiem zniknie z sieci :cry:
  • #4
    Gelip
    Level 33  
    Pomyślałem, że może tego 'q' nie było widać bo miałem za małą rozdzielczość ekranu w maszynie. Odpaliłem więc oryginalny Debian-Live 6.0.5 standard z ISO wciskając 'Tab' i 'e' aby edytować parametry uruchamiania po czym dopisałem vga=0x31e i usunąłem quiet po czym wcisnąłem 'Ctrl+X' aby bootować. Odpaliło mi z komunikatem iż taka rozdzielczość nie jest rozpoznawana i aby wcisnąć spację to wyświetli mi dostępne rozdzielczości po czym z listy wybrałem jakąś dużą chyba 1600x1200 i system uruchomił się. Edytowałem plik sources.list i zrobiłem apt-get update
    Teraz instaluję smbfs i nie pojawia mi się żadne info nowości jak poprzednio i nie trzeba wciskać żadnego 'q'.
    Tamten Debian był zainstalowany na dysku a teraz odpaliłem Live z CD (ISO). Czemu teraz nie pojawiły mi się nowości.
    Instalowałem w Debianie pakiety wiele razy ale nigdy nie pojawiały mi się żadne nowości i aby wcisnąć 'q' - zawsze wystarczyło tylko apt-get install nazwa_pakietu i wszystko robiło się samo.
  • #5
    freebsd
    Level 39  
    Gelip wrote:
    w Internecie nie można już znaleźć starszych wersji ISO np. właśnie 6.0.5
    Zwróć uwagę, że pracujesz na wersji "przedpotopowej":
    6.0 Squeeze, data wydania: 2011-02-06, wsparcie do: 2016-02-29
  • #6
    Gelip
    Level 33  
    freebsd wrote:
    Zwróć uwagę, że pracujesz na wersji "przedpotopowej":
    6.0 Squeeze, data wydania: 2011-02-06, wsparcie do: 2016-02-29

    No i co z tego, że przedpotopowa - mi pasuje taka i wystarcza do moich celów na starszym sprzęcie a zresztą do nowszego sprzętu mam też nowszą wersję Debiana.

    MS-DOS czy Win95 jest prehistoryczny a ciągle można go pobrać z Internetu :D

    Znalazłem informacje, że to pager less wyświetla changelogi i można to wyłączyć:
    https://www.linuxquestions.org/questions/linux-newbie-8/apt-get-update-stops-at-reading-changelogs-930486/
    https://unix.stackexchange.com/questions/124468/how-do-i-resolve-an-apparent-hanging-update-process

    Chcę wiedzieć od czego to zależy czy changelog pojawi się czy nie w czasie instalacji pakietu?

    Dodano po 5 [minuty]:

    Czy na serwerach Debiana jest jakaś opcja, która wymusza wyświetlanie changelogu w czasie używania apt-get ?

    Dodano po 1 [godziny] 28 [minuty]:

    P.S. W jednym miejscu w sieci da się znaleźć co nieco starszych wersji Debiana Live: debian-live