Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Samsung RF511 - Brak dźwięku w głośnikach, w słuchawkach jest.

01 Sty 2020 18:13 186 8
  • Poziom 20  
    Brak dźwięku w głośnikach. W słuchawkach gra.
    Sprawdzane pod Win7, Wi10 i Linux Live CD - za każdym razem zachowuje sie system tak że wszystko w porządku. Brak błędów, urządzenia zainstalowane i pokazuje że dźwięk jest, ale jego brak. W słuchawkach jest.

    Po podłączeniu słuchawek wykrywa wtyknięcie Jack-a i daje stosowny komunikat na ekranie o podłączeniu słuchawek. Po wyjęciu wtyczki wyświetla się komunikat że odłączono słuchawki. Więc wydaje się ze Jack sensing działa (gdyby styk był zawieszony to by przecież nie wykrywało włożenia JACKa - chyba).
    Wg. serwisówki podczas braku wtyku Jack w wyjściu słuchawkowym zwarty jest kanał R do masy. Po wetknięciu wtyku JACK przełącza się masa na AUD5_SENS_HP# - wtedy dostaje info że wetknięto wtyk. Ten mechanizm jest tylko na kanale R. Na L wg. serwisówki styk przełączający nie jest wykorzystany. Próbowałem pobrać z punktów lutowniczych gniazda JACK sygnał AUDIO i przy braku wtyku w gnieździe słuchawkowym ALC nie daje sygnału na słuchawki. Po wetknięciu nawet pustego JACKa pojawia się sygnał muzyki na punktach lutowniczych gniazda - więc przełączanie działa.


    Głośniki wymieniłem i dalej nic nie dało.
    Sprawdzałem też audio na pinach gniada głośnikowego.

    Wg. serwisówki nie ma tam końcowego stopnia mocy na tranzystorach, tylko sygnał na głośniki wychodzi wprost z ALC269 poprzez BLM18PG181SN1.
    Wyjście słuchawkowe ma osobne wyjście z ALC269.

    Zastanawiam się co tu jeszcze sprawdzić.
    Czy głośniki podłączone do wejścia słuchawkowego mają grać bardzo cicho?
    Wejście głośnikowe ma inną moc niż słuchawkowe?
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 26  
    tata1 napisał:
    Czy głośniki podłączone do wejścia słuchawkowego mają grać bardzo cicho?
    Wejście głośnikowe ma inną moc niż słuchawkowe?
    I to jest poprawny tok rozumowania. Czy głośniki mają wbudowany wzmacniacz? Są to głośniki komputerowe czy jakiś zorganizowałeś na zwykłym przewodzie i tylko jacka założyłeś? Zwykle różne wejścia mają rożną moc wyjściową, choć niektóre laptopy mają regulację głośności w okienku, które się pojawia podczas podłączenia jacka (można wybrać co się podłączyło. Po to żeby nie ogłuchnąć i nie uszkodzić sprzętu.
  • Poziom 20  
    Głośniki w RF511 nie mają żadnego wzmacniacza, kabelki przylutowane bezpośrednio do głośniczków - nie są zwarte. Kupiłem inne na All....i tak samo się zachowują.

    Myślałem że zrobię prowizorkę i podłączę kabelki od głośników bezpośrednio pod piny gniazda słuchawkowego - wtykając oczywiście pusty JACK, tak by przełączyło sygnał na to wejście. Niestety głośniczki grały bardzo cicho - identycznie cicho jak słuchawki leżące na stole. Dopiero jak się słuchawki umieści w uszach to słychać ich moc. Dlatego mi się wydaje że nie da się w ten sposób wykorzystać wyjścia słuchawkowego.

    Dla testu podłączyłem też kartę dźwiękową USB i ona również nie daje POWERa na głośniki z RF511, na słuchawki jest idealna. Dopiero jak się podłączy głośniki ze wzmacniaczem to jest POWER.

    Piszecie powyżej że mógł paść ALC, ale zastanawiam się jak sprawdzić te tranzystory na wejściu PD# kodeka ALC, bo wg. serwisówki (w załączeniu) do nich dochodzi sygnał SPKMUTE# więc może tu być problem - jak to sprawdzić?
    Na to wejście w ALC porzez te tranzystory w celu wyciszenia podawana jest masa, czy +5V?. Bo może tak by jeszcze tak to sprawdził?
  • Pomocny post

    Spec od komputerów
    tata1 napisał:
    zastanawiam się jak sprawdzić te tranzystory na wejściu PD# kodeka ALC
    - wystarczy zmierzyć napięcie na PD# (laptop uruchomiony).
    Stan niski to wyłączenie głośników.
  • Poziom 20  
    sk1977 napisał:
    tata1 napisał:
    zastanawiam się jak sprawdzić te tranzystory na wejściu PD# kodeka ALC
    - wystarczy zmierzyć napięcie na PD# (laptop uruchomiony).
    Stan niski to wyłączenie głośników.



    Jutro pomierzę, ale wyłączenie głośników nie byłoby również równoznaczne z wyłączeniem słuchawek?
  • Poziom 20  
    sk1977 napisał:
    tata1 napisał:
    zastanawiam się jak sprawdzić te tranzystory na wejściu PD# kodeka ALC
    - wystarczy zmierzyć napięcie na PD# (laptop uruchomiony).
    Stan niski to wyłączenie głośników.


    No i na PD był stan niski - stąd głośniki wyłączone.

    Robiąc eksperyment wylutowałem tranzystor który załączał nóżkę PD do GND i bez tego tranzystora teraz poprzez rezystor podciagajacy do +5V mam na PD stan wysoki - GŁOŚNIKI GRAJĄ.

    Zastanawiam się czy zamawiać ten tranzystor, bo może nie on winny tylko te dwa MOSFETY przed nim. PD ma wyciszać głośniki, ale MUTE działa w Windowsie, więc sam nie wiem czy tak nie zostawić. Wiem że to niezgodne ze sztuką, ale.......