Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Transmisje live z kościoła jak zorganizować

Jolaos 24 May 2020 18:45 5580 88
Optex
  • #31
    moungo
    Level 14  
    Piszczałkowe... Właśnie myślałem, żeby jakoś zmiksować 100V z dodatkowym mikrofonem - tylko, że musi być to małe i najlepiej niskonapięciowe, żeby umieścić dyskretnie za głośnikiem, tak jak zastosowany transformator TX-100. Mam mikrofon Boya BY-MM1, który niby współpracuje z kamerami, ale w tym przypadku kamera "go nie widzi". Wg producenta teoretycznie nie potrzebuje on zasilania, ale do końca nie wiem, na jakiej zasadzie miałby wtedy działać...

    Modulacja to chyba bardziej wina kodeka AAC (ustawione 48kHz), który jest wymagany na yt - ale nie jestem w tym temacie specjalistą.

    Model kamery to DH-SD49225T-HN
  • Optex
  • #32
    szklarska
    Level 17  
    Witajcie ,

    czy masz może problem z rozjezdzaniem sie synchronizcji miedzy dzwiękiem i obrazem .Dzwięk wyprzedza obraz kilkasekund?

    Mirek
  • Optex
  • #33
    moungo
    Level 14  
    Modulacja była spowodowana załączonym filtrem szumu, który sporo wycinał i taki był efekt. Po jego wyłączeniu wszystko jest w porządku. Czasami jest problem z synchronizacją między obrazem i dźwiękiem. Zazwyczaj w stronę taką, że to dźwięk się spóźnia wobec obrazu. Podobno Dahua pracuje nad problemem. Zauważyłem, że dzieje się tak jak transmisja jest już jakiś czas włączona. Wyłączenie/włączenie RTMP rozwiązuje problem.
  • #34
    szklarska
    Level 17  
    Tak zgadza się ten filtr trochę dziwnie działa, wiec mam go wyłączony.

    Tak Dahua pracuje nad tematem w innym modelu kamer gdzie wprowadzili poprawki w RTMP jest już dobrze i dźwięk się nie rozjeżdża.
    Tylko mala sugestio na 100% wykonajcie powrót do ustawień fabrycznych i ponowna konfiguracja.Jak wykonałem zdalna aktualizacje bez powrotu do ustawień fabrycznych to RTMP był bez zmian.
    Kilka dni później pojechałem na miejsce i po testach jest ok.
  • #35
    moungo
    Level 14  
    A czy u Was Dahua po restarcie też gubi ustawienie kodeka H264 i ma ustawione H265?
  • #36
    szklarska
    Level 17  
    Nie, pozostaje na 264 jak przejdzie na 265 to transmisja na Youtuuba sie zatrzyma.

    Ok 10 czerwca beda juz oficilane poprawki softu do Dahua-y

    Pzdr mIrek
  • #37
    Alumster
    Level 2  
    A nie można zrobić tego za pomocą OBS'a?
    Ja u siebie w kościele nadaję transmisje (na skonfigurowanych kanale YouTube, gdzie najpierw planuję transmisję i jak mam skopiowany klucz i nazwę serwera to skonfiguruję odpowiednio program i OBS sam podpina się pod tą transmisję).
    Kamery mam podłączone przez HDMI i SDI doATEM Swich
    Stamtąd przez AJA U-TAP do komputera.
    Dźwięk z miksera bezpośrednio do ATEM'a i wszystko pięknie śmiga.
    Wszystko wychodzi w FHD
    Trzeba tylko uważać bo ATEM ma wyjście jedynie w SDI
    Kamery muszą mieć wyjście HDMI (ja używam Panasonic AG-AC 30)
  • #38
    gkwiatkowski
    CCTV and Stationary Alarms specialist
    Alumster wrote:
    A nie można zrobić tego za pomocą OBS'a?
    Ja u siebie w kościele nadaję transmisje (na skonfigurowanych kanale YouTube, gdzie najpierw planuję transmisję i jak mam skopiowany klucz i nazwę serwera to skonfiguruję odpowiednio program i OBS sam podpina się pod tą transmisję).
    Kamery mam podłączone przez HDMI i SDI doATEM Swich
    Stamtąd przez AJA U-TAP do komputera.
    Dźwięk z miksera bezpośrednio do ATEM'a i wszystko pięknie śmiga.
    Wszystko wychodzi w FHD
    Trzeba tylko uważać bo ATEM ma wyjście jedynie w SDI
    Kamery muszą mieć wyjście HDMI (ja używam Panasonic AG-AC 30)


    Można zrobić transmisję przez OBS, ale omawiane kamery zostały wyposażone przez producenta we wbudowany komputer specjalnie na potrzeby transmisji do Youtuba. Więc już nie trzeba kupować żadnego innego sprzętu do tego celu. Problem w tym, że firmware kamery nie było dobrze przetestowane i po kilku godzinach dźwięk i obraz traciły synchronizację.
  • #39
    moungo
    Level 14  
    Z OBSa można robić transmisję sporadycznie, ale jeśli to ma być ciągłe 24/7 to komputer na pełnych obrotach może tego nie udźwignąć na dłuższą metę. Z kamerą jest prościej i bardziej "ekonomicznie".
  • #40
    szklarska
    Level 17  
    Dahua rozwiaala problem z rozjadzem synchronizacji miedzy audio i video.
    Wlasnie pojawil sie nowy soft.
    Pzdr MIrek

    Koniecznie wykonac restrt do ustawien fabrycznych
  • #41
    moungo
    Level 14  
    Chodzi Ci o te, które są na stronie Dahua w zakładce Firmwares? Szkoda tylko, że do wybranych kamer, a gdzie reszta które mają RTMP?

    EDIT. Dopiero dziś wrzucili na FTP ;) Zrobię aktualizację i sprawdzę, czy nadal jest problem. Dzięki!
  • #43
    moungo
    Level 14  
    W tygodniu dam znać, bo czekamy na włączenie światłowodu. Na mobilnym nadal były problemy z synchronizacją, ale możliwe, że to wina Internetu... Tak przy okazji - możecie sprawdzić, czy u Was też jest takie charczenie na dźwięku przy kodeku G726? Dla AAC jest z kolei cykanie, stukanie... Załączam nagrania.
  • #44
    moungo
    Level 14  
    Na światłowodzie przy jednoczesnej transmisji z dwóch kamer w HD - strasznie się rozjeżdza obraz i dźwięk po kilku godzinach. Prędkość wysyłu to ok. 100Mbps więc nie powinno być problemów a są i to bardzo duże.
  • #45
    szklarska
    Level 17  
    Witam ,

    po kilku miesiacach poprawnego dzialania transmisji RTMP na Youtuba zerwało mi transmisje .
    I tu niestety nie moge uruchomic jej inaczej niz tylko w Youtube ale tylko w Studio , a te kreowanie transmisji nie odswieza sie samoczynnie po zaniku transmisji z kamery ( prąd intenet padł).

    Tak mam w 2 kościołach.

    Poprzedni chyba tworzylem transmisje w innym panelu (chyba Tradycyjna )

    Ma ktos taki problem ?
  • #46
    arekj1974
    Level 11  
    Witajcie

    mam dwie różne kamery Dahua :
    Typ urządzeniaIPC-HDBW5431E-ZE
    Wersja systemuV2.800.0000016.0.R, Build Date: 2020-06-05
    Wersja WEBV3.2.1.903288
    Wersja ONVIF19.06(V2.6.1.845551)
    S/N3G0618DPAG00162
    Bezpieczna wersja bazowaV2.0

    do tej pory na oprogramowaniu w wersji 13 z automatycznym restartem codziennie o 4 rano i nie było problemów od jakiś dwóch tygodni jest problem że po restarcie youtube nie wznawia transmisji .

    Dzisiaj zaktualizowałem soft do wersji 16 i wyłączyłem codzienny restart zobaczymy co będzie , na początku myślałem że to wina youtube co sugerowałoby że obie zachowywały sie tak samo ,ale obecnie mam wątpliwość czy nie jest to zachowanie samego softu w kamerze

    Arek
  • #47
    szklarska
    Level 17  
    Ja na 1 mam V2.800.1051000.0.T.R4.1217.3S.NR, Build Date: 2020-06-09 i druga
    V2.800.0000014.0.T, Build Date: 2020-04-23

    Ja mysle ze to od Yotuba bowiem zauwaz ze tylko wykreujesz transmisje w Studio a tam transmisja sama nie startowala po przerwie .

    I jeszcze jedno po wykreowaniu transmisji mam opis doskonala jest na zielono ale nie wystartuje sama , dopiero po restarcie kamery wystartuje i tak mam na obu kamerach
  • #48
    moungo
    Level 14  
    szklarska wrote:
    I jeszcze jedno po wykreowaniu transmisji mam opis doskonala jest na zielono ale nie wystartuje sama , dopiero po restarcie kamery wystartuje i tak mam na obu kamerach


    Ja muszę kilka razy włączyć/wyłączyć RTMP - wtedy startuje transmisja.
  • #49
    szklarska
    Level 17  
    Dzisjaj na 3 kamerze mam to soamo
  • #50
    arekj1974
    Level 11  
    Panowie ja na dwóch kamerach ma tak samo czyli dokładnie jak pisze kolega transmisja idzie z niewiadomych przyczyn się zatrzymuje i dopiero fizyczne otwarcie kanału potem restart kamery przywraca transmisje .

    Spostrzeżenia :

    obie kamery ten sam soft v16
    jedna kamera na koncie bez molowości liniowania na inne strony - nowe konto
    druga kamera n starym koncie z możliwością linkowania na inne strony


    I ciekawostka : trzecia kamera puszczona na sofcie v14 działa od maja - konto nowe bez możliwości linkowania na inne strony.

    Tutaj chyba jest jakaś kwestia youtube co się dzieje na koncie bo nie wiem czy zauważyliście ale ja tak mam :
    po zawieszeniu się transmisji wchodzę na kamerę normalnie działa robię restart kamery transmisja nie działa , wchodzę na konto youtube w transmisje pokazuje mi się doskonale polaczenie ale strumień się nie pokazuje , robię restart kamery strumień się pokazuje , jednak youtube nadaje inny link do filmu .

    Jest to o tyle irytujące że trzeba zmieniać link na stronie . kto chce skonsultować offline proszę o kontakt na email arek.jaskulski(malpa)g..il.com

    Arek
  • #51
    szklarska
    Level 17  
    Witam
    Zglaszajcie temat do Dahua szybciej sie zajma tematem.

    Czy ktos z was zrobil teraz powrot do fabrycznych i poustawial wszystko od nowa ?

    Mirek
  • #52
    moungo
    Level 14  
    Jak często Wam zrywa transmisję? Moja od 5 dni idzie bez problemu. Ale firmware Dahua co kilka godzin robi restart RTMP, więc może to pomaga na to "zrywanie". Z kolei dla drugiej kamery ustawiłem streaming przy użyciu restreamera https://datarhei.github.io/restreamer/ tutaj z kolei co kilkadziesiąt sekund jakby przycinał się sam dźwięk, ale to może kwestia ustawień próbkowania i bitrate?
  • #53
    szklarska
    Level 17  
    Wczoraj zrobilem fabryczne ustawienia i do teraz jest ok.
    Wystartowala takze bez problemow
  • #54
    arekj1974
    Level 11  
    Cześć

    Czy na wszystkich zrobiliście fabryczne ustawienia ? i działają ? jeśli tak to na jakiej wersji softu ? Jakie macie kamery , bo ja już robiłem downgreade softu i nadal nic , obojętnie czy steram idzie przez restreamer czy przez kamerę bezpośrednio , co dziwne e na jednej jest ok a na kolejnych trzech jest problem .Zauważyłem że jak niestety restreamer przekazuje wszystko z kamery, a YouTube daje dziwny komunikat jeśli kamera nie przekazuje obrazu , a ja miałem ustawiony restart na 4 rano codziennie wiec kamera robiła restart , restreamer i YouTube nie dostawały obrazu i YouTube studio mówiło że jak za chwile nie dostanie obrazu to zakończy transmisje i sądzę ze to jest powodem - czyli YouTube pewnie skrócił ten czas

    Arek
  • #55
    moungo
    Level 14  
    arekj1974 wrote:
    czyli YouTube pewnie skrócił ten czas
    Arek


    Też tak myślę. Z moich obserwacji jest tak, że restart przerywa transmisję i te kilkadziesiąt sekund YT interpretuje jako jej koniec. Następnie trzeba utworzyć nową bo YT już nie powiąże kolejnego sygnału z kamery z przerwaną transmisją. Możliwe, że by tak się stało, jakby po restarcie kamery następował też restart RTMP w kamerze, ale zauważyłem że po włączeniu kamery, mimo że RTMP jest zaptaszkowane, to tak jakby to było nieaktywne dopóki się go (RTMP) nie zaklika ponownie.
  • #56
    arekj1974
    Level 11  
    A kolega szklarska wypowie się czy po fabryce jest ok ja dzisiaj postawiłem jedna kamerę specjalnie z ustawieniami fabrycznymi zobaczę jak będzie
  • #57
    arekj1974
    Level 11  
    Witajcie jeszcze jedna ciekawostka : w każdej kamerze miałem włączony restart codziennie o 4 rano i teraz co ciekawe na jednej z kamer cały czas jest to włączone i nie ma problemu , natomiast w kolejnych pwodowało to problem dlatego wyłaczyłem i nie zapeszając od wczoraj transmisja idzie bez problemu .

    To oznaczałoby, że dla różnych kont youtube , są to rózne czasy po kotrym transmisja jest zakańczana.


    Arek
  • #58
    szklarska
    Level 17  
    U mnie po fabrycznych do dzisiaj 3 kamery chodzily poprawnie , ale dzisiaj 1 zatrzymnala sie ( mimo ze na Youtubie bylo ok na zielono , rstrart transmisji nie pomogł , wykreowanie nowej transmisji na Youtube i dziala.)
  • #59
    moungo
    Level 14  
    Przeszedłem na próbę na OBSa i od kilku dni żadna z transmisji się nie zatrzymała, więc chyba jednak to problem softu Dahua. Choć OBS ma funkcję wznawiania transmisji, ale raczej nie można sprawdzić czy taka operacja miała miejsce. Jak tylko coś się zmieni, to dam znać.
  • #60
    szklarska
    Level 17  
    Mi inna kamera zatrzymala sie transmisja ( ale byla na ok z czerwonym LIVE) Pomogla ponowne wykreowanie na Youtubie