Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

excel jak wydrębnić 9 literowe słowo zaczynające się na E z ciągu znaków

21 Maj 2020 19:52 150 4
  • Poziom 3  
    Witajcie,
    jak wyodrębnić w excelu z ciągu znaków, 7 literowe słowo zaczynające się na E lub K ?

    Np. "bla bla bla E123456 bla bla bla " Chcę wyodrębnić E123456"
    ciągi znaków mają różną długość i raczej funkcje Fragment tekstu; lewy ;prawy odpadają.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Pomocny post
    Poziom 33  
    Ode mnie propozycja połączenia klasycznej formuły z funkcją UDF, która jest bardzo prostą adaptacją funkcji VBA Split:
    Kod: vbscript
    Zaloguj się, aby zobaczyć kod
    Funkcja ta dzieli tekstową zawartość komórki na słowa (w miejscach spacji) i zwraca tablicę poziomą złożoną z tekstów. Dalsze obliczenia już zwykłą formułą:
    Code:
    =JEŻELI.BŁĄD(WYSZUKAJ("żżż";WYSZUKAJ.POZIOMO(T(INDEKS({"K"\"E"};))&"??????";Words($A6);1;FAŁSZ));"")
    Jeżeli brak tekstu spełniającego warunek, funkcja zwraca pusty tekst, jeśli kilka tekstów spełnia warunek, funkcja zwraca ostatni z nich.
  • Poziom 3  
    Hej dzięki za pomoc! Wszystkie sposoby działają jak należy.Jesteście wielcy!!