Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2

23 Maj 2020 14:17 534 24
  • Poziom 11  
    Witam
    Dokładnie chodzi o dysk Toshiba KBG40ZNS128, czy będzie działał na płycie Asrock Fatality 970 Performance 3,1, I czy można będzie zainstalować na nim systemowy Win 10?

    Pozdr.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.

  • Poziom 27  
    https://www.asrock.com/mb/AMD/Fatal1ty%20970%20Performance3.1/
    Cytat:
    Storage
    - 6 x SATA3 6.0 Gb/s Connectors, support RAID (RAID 0, RAID 1, RAID 5 and RAID 10), NCQ, AHCI and Hot Plug
    - 1 x M.2_SSD (NGFF) Socket 3, supports M Key M.2 SATA3 6.0 Gb/s module and M.2 PCI Express module up to Gen2 x4 (20 Gb/s) (M.2_SSD (NGFF) Socket 3 is shared with the SATA3_0 connector)

    To nie jest PCIe x2, tylko drugiej generacji.
    Powinien działać.
  • Poziom 11  
    A co z postawieniem na tym dysku systemu WIN 10.
    Moja płyta ma BIOS UEFI, jednak nie bardzo wiem czy potrzebne są jakieś dodatkowe sterowniki do tego dysku na bootowanie czy całość zapewnia WIN 10. Dysk pracuje w trybie NVMe, ostatnie uaktualnienie BIOS obejmuje tego typu dyski.
    Pozdr.
  • Poziom 43  
    Co do zasady Windows 10 nie potrzebuje żadnych modyfikacji instalatora, by na takim dysku "się" zainstalować. Tym samym kłopotów nie powinien Pan doświadczyć.
  • Poziom 11  
    Dziękuję - tym samym teraz tylko zamontować i próbować, opiszę jak mi poszło.
  • Poziom 11  
    I zgodnie z prawem Murphyego, nie idzie bez bólu.
    Bios najprawdopodobniej nie rozpoznaje tego dysku, ale system już go widzi co będzie widoczne na załączonych zrzutach.
    Przy próbie wgrywania WIN 10 dysk jest widoczny, ale niemożna na nim wgrać systemu bo jak twierdzi instalator sprzęt nie może się bootować z tego dysku.
    W Biosie nie widzę możliwości włączenia obsługi NVME ani w ogóle M.2, dysk jest "chyba" jest wykrywany ale nie podaje ani jego nazwy ani pojemności. To dosyć stara płyta i zamontowano gniazdo aby podnieść jej "image". Jak widać zapis na dysku jest przyzwoity ale już odczyt nie przekracza SATA 3.
    Proszę jeśli ktoś ma jakieś pomysły
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2 Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2 Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2

    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2

    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2 Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Dodam jeszcze fotki z BIOS i próby wgrania systemu
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2 Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2 Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
  • Poziom 11  
    Bios mam najnowszy, jego można w każdej chwili uaktualnić przez internet będąc nawet w danej wchwili w BIOS, pakiet instalacyjny także miałem zrobiony w zeszłym tygodniu, odpiąłem wszystkie dyski oprócz tego M.2 jak widać na fotce z instalacji.
    Dziwne jest to że BIOS "widzi" dysk M.2 ale go nie wykrywa jak widać na focie z BIOS-u "SATA3_0/M.2 SSD : Not detected.
    Gniazdo Sata0 jest współdzielone z gniazdem M.2 i jeśli jest dysk M.2 nie można do niego podpinać dysku SATA.

    Dodano po 3 [godziny] 16 [minuty]:

    W pewnym momencie udało mi się doprowadzić do tego, że system zaczął się instalować na tym dyski ale po wgraniu I części i zrestartowaniu się niestety system się nie podnosi ponieważ bios nie widzi dysku. W opcji boot option mam tylko Built in EFI Shell oraz USB.
    Prawdopodobnie problem polegana tym że BIOS nie rozpoznaje dydku.
    Czy ktoś ma jakiś pomysł na tak słaby odczyt, w danych jest to ok. 1300 a u mnie ok. 500.
  • Poziom 34  
    Sprawdź historię zmian w kolejnych wersjach biosu do tej płyty, bo wydaje się że wciąż nie ma możliwości ładowania systemu z dysku NVMe. Prawdopodobnie nie obejdzie się bez modowania biosu albo rozwiązania "pośredniego" z kartą pamięci ze sterownikami NVMe.

    Dodano po 7 [minuty]:

    Co to za urządzenie w biosie "SCSI SG1.8.4.8.00 1.00"?

    Dodano po 7 [minuty]:

    Ponieważ kupiłeś dysk NVMe (elektrycznie PCI-E) to nie szukaj go w biosie pod urządzeniami SATA, tylko raczej pod PCI-E, tam gdzie dedykowane karty. Jest?
  • Poziom 11  
    Odnośnie BIOS na stronie Asrock-a tej płyty jest tylko jeden w ver. 1.1, który mam zainstalowany i pisze o nim:
    1. Improve USB compatibility.
    2. Add m.2 support.
    3. Add NVMe support.
    To SCSI BIOS tworzy gdy w porcie USB znajduje się jakiś pendrive - w tym wypadku był to pendrive instalacyjny z WIN 10. Gdy się pendrive wyciągnie to rozszeżenie w BIOS znika.

    U mnie w BIOS nie ma opcji abym mógł sprawdzić jakie mam zainstalowane karty PCIE, przeszukałem wszystkie podmenu i nic takiego nie znalazłem.
  • Poziom 34  
    Obawiam się że obsługa NVMe wprowadzona przez producenta polega na tym że z dysku można korzystać w systemie już załadowanym (posiadającym sterowniki, rzecz jasna) ale nie można z niego załadować systemu. Uruchom komputer do wiersza poleceń EFI shell i zobacz czy EFI widzi dysk NVMe. Tu masz listę (po angielsku), to chyba będzie "devices" oraz "drivers":
    http://www.opslib.com/2012/01/efi-shell-commands.html
    Powyłączaj też wszystkie opcje typu "fast boot", wyświetlanie logo itd. żeby widzieć komunikaty UEFI.
  • Poziom 11  
    To wszystko co mi pokazał na starcie
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2

    Nie reaguje na te komendy,które podałeś w linku, twierdząc że ich nie rozpoznaje, chyba że trzeba je specjalnie jakoś wpisywać.
    Mi ten wykaz nic nie mówi, m.2 u mnie zajmuje slot 0

    pokusił bym się do napisania do Asrocka, ale wymagają tam nr seryjnego płyty, znasz może jakiś program który to wyciągnie (nie posiadam już pudełka po płycie)
  • Poziom 34  
    To mi wygląda na wynik polecenia "map" czyli przypisanie nazw uproszczonych do, umownie, partycji dyskowych.
    Urządzenia NVMe tu nie widzę.
    Wyjmij pendrive bo chyba był włożony, na razie tylko gmatwa odczyt.
    Zobacz czy pójdzie
    "bcfg driver dump"
    "bcfg boot dump"
    Można ew. ściągnąć sterownik NVMe do EFI i spróbować go załadować ręcznie z pendrive. Oczywiście nie jest to rozwiązanie docelowe ale będziemy mieli pewność co do płyty.
    Numer seryjny płyty powinien być na naklejce na laminacie.
  • Poziom 11  
    Mimo ponownych prób wg. instrukcji znalezionych na forum Asrock-a nie udało mi się zainstalować systemu na tym dysku. Na 90% będzie to brak obsługi tego dysku w BIOS płyty, zawsze kończy się wgraniem na dysk I części system, jednak po restarcie, jak BIOS nie wykrywa dysku, to nie może też z niego bootować.
    Czy ktoś może coś wie o sterowniku NVMe do tego dysku Toshiby do WIN10 64 innym niż Microsoftu?
  • Poziom 11  
    Odnośnie zmniejszonego transferu dysku zagadka tkwiła w trybie transferu - dysk posiada tryb PCIe 3,0x2, płyta główna obsługuje max. PCIe 2,0x4, więc transfer może odbywać się w trybie PCIe 2,0x2 i żaden sterownik tu nie pomoże.

  • Poziom 27  
    ITSpec. napisał:
    To nie jest PCIe x2, tylko drugiej generacji.
  • Poziom 11  
    Tak jest, popełniłem ten sam błąd co poprzednio, powinno być Gen 3x2 oraz Gen 2x4.

  • Poziom 27  
    Nie o to chodziło, po prostu od początku pisałem, że transfer będzie ograniczony ze względu na to, że to druga generacja.
    W sumie przy amatorskich zastosowaniach nie będzie to odczuwalne.
  • VIP Zasłużony dla elektroda
    W10 zainstaluj w trybie UEFI - na SSD ma być utworzony styl part. GPT
    czyli pendrive instalacyjny ma mieć w menu bootowania prefix UEFI:

    Możesz wrzucić widok okna Zarządzanie dyskami z zainstalowanym systemem.

    BTW: co to jest za urządzenie: hd21b1 z part. 59,6 GiB (post #12)?
  • Poziom 11  
    Spójrz na drugi obrazek z BIOS powyżej w poście - jest tam na trzeciej pozycji UEFI: SCSI....... , to jest właśnie utworzony pendrive rozruchowy, pobrany ze strony Microsoft. Ten element (SCSI) pojawia się tylko wtedy gdy pendrive jest włożony do gniazda, gdy jest wyciągnięty tego wpisu nie ma, są tylko dwa pozostałe.
    Dlaczego BIOS określa go jako SCISi........ nie mam pojęcia, ale normalnie butuje komputer i Windows zaczyna się instalować. Podczas wgrywania rozpoznaje dysk SSD Toshiby, tworzy na nim swoje 3 czy 4 partycje i zaczyna się dalej wgrywać. Jak wiesz po I części wgrywania na SSD dochodzi do zresetowania i później USB rozruchowe powinno być już niepotrzebne, ponieważ powinien startować już z tego SSD.
    U mnie cały problem polega na tym, że po restarcie BIOS nie widzi dysku startowego SSD (oczywiście wszystkie inne dyski mam odłączone, jest tylko SSD.
    Dzieje się tak zarówno jak mam całkowicie wyłączony CSM (karta graficzna obsługuje UEFI), lub CSM jest włączony a tylko opcja "Uruchom pamięć OPROM na Tylko UEFI" reszta na Legacy.
    Według instrukcji z forum ASROCK-a powinna się w menu Boot Option pojawić pozycja Windows Boot ale jej nie ma. Dlatego jak napisałem podejrzewam, że jest to wina BIOS bo chyba nie obsługuje tego dysku.
    Ten hd21b1 to stary dysk SSD pracujący jeszcze na SATA 2, ale jak napisałem wszystkie oprócz M.2 Toshiby są na czas instalacji odłączone.
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Jak widzisz dysk4 jest tym co sobie Windows przygotowywał.
  • Poziom 34  
    Pewnie nie masz w biosie sterownika UEFI więc po restarcie już dalej instalacja nie idzie. Instalka Windowsa jeszcze zobaczyła dysk bo używała sterowników swoich systemowych a została uruchomiona z USB, do którego sterownik w UEFI jest. Notabene jest to bezpieczny i kompatybilny sposób żeby używać dysku NVMe nawet na starych płytach: pendrive lub karta pamięci z bootloaderem i sterownikami NVMe.
    Wejdź do UEFI Shell i zrób to co we wpisie #13 w tym wątku.
  • Poziom 11  
    Mam jakąś prymitywną wersję tego UEFI bo komendy obsługuje tylko takie:
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Po wpisaniu komendy "drivers", wyświetla :
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Cześć komend z góry niestety ich nie widać ponieważ ekran się przesuwa a ja nie wiem jak go zatrzymać.
    Jednak w tym co się wyświetla jest jeden jakiś sterownik na pozycji 69 - Ami NVMe BUS Driver
    Jeśli masz jakiś pomysł to napisz , bo to już przekracza moje umiejętności, ale chętnie poeksperymentuje, po to ten dysk zamontowałem.
  • Poziom 34  
    Odłącz wszystkie pamięci masowe z wyj. dysku NVMe, wejdź do UEFI Shell i jeszcze raz zamieść ekran z polecenia "map" (to co się wyświetla na samym początku). Zobacz czy są jakieś podpowiedzi do polecenia "connect" - żeby można było ręcznie rozpoznać ten dysk. Zobacz podlinkowany przykład - on dotyczy RAID ale może podobnie konfiguruje się bootowanie z NVMe.
    https://www.asrock.com/support/faq.asp?id=316
  • Poziom 11  
    Sorry za zwłokę ale życie toczy się dalej.
    Zrobiłem tak jak napisałeś, odłączyłem wszystkie dyski Shell EFI wyglada tak:
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Nie widać nic oprócz urządzeń USB, ale ich nie mogę wyłączyć bo mam myszkę i klawiaturę USB. Komenda connect w różnym wydaniu
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2 Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    komenda dh daje na pozycji 62 taki odczyt odnośnie sterownika NVMe
    Czy dysk M.2 w generacji PCIe x4 będzie działał na PCIe x2
    Niestety nie przynosi to żadnego efektu i próba wgrania systemu po tym wszystkim kończy się tak samo.
    Wg mnie zainstalowany sterownik w BIOS UEFI może i obsługuje 2 generację dysków PCIe, natomiast zamontowany dysk m.2 jest generacji 3 i sterownik go nie widzi.