Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Kabel do sterownika LOGO Siemens -sprawdzony

Marko121 04 Paź 2005 18:08 19787 23
  • #1 04 Paź 2005 18:08
    Marko121
    Poziom 17  

    Działający i przetestowany interfejs do podłączenia sterownika logo- Siemens z komputerem PC

    Życzę sukcesów w pracy ze sterownikiem

    2 23
    Załączniki:
  • Sklep HeluKabel
  • #2 13 Sty 2006 19:11
    kubanczyk
    Poziom 14  

    witam
    wszystko fajnie ale ja chcialem sie zapytać gdzie mozna kupić wtyczke do programowania sterownika LOGO ponieważ kabelek sobie zrobie sam ale brak wtyczki.

    0
  • Sklep HeluKabel
  • #3 16 Sty 2006 00:11
    edwaku
    Specjalista Automatyk

    I po co ten kabel? Przecież taki już dawno posiadam - a gdzie można kupić wtyk do niego - i to jest pytanie.

    0
  • #4 04 Kwi 2006 17:15
    maciuś1
    Poziom 12  

    wtyczkę można zrobić z zewnętrznej karty pamięci (jest tańsza od kabla)

    0
  • #5 19 Maj 2006 15:23
    Juni[]r
    Poziom 16  

    a macie zrobiona jakąś płytke pod kabelek czy jak pajaczka zrobiliście.... aha no i skąd wziąść taką malutka wtyczke ?

    0
  • #6 28 Sie 2006 23:49
    Marko121
    Poziom 17  

    Witam
    ja zrobiłem tak jak na zdjęciach ,może nie jest to dzieło sztuki ale amatorsko wystarczy
    poxilina + wyprowadzenia z tranzystora + trochę chęci = wtyczka do LOGO

    Pozdrawiam

    0
  • #7 29 Sie 2006 15:26
    Juni[]r
    Poziom 16  

    Musze powiedzieć: Chyle Czoła :D i takie pytanko mozesz pokazac plytke bo nie chce mi sie kąbinować :D

    0
  • #8 29 Sie 2008 17:09
    Maatiii
    Poziom 10  

    Posiadam właśnie taki oto sterownik Siemens LOGO! 24RL (6ED1 053-1HA00-0BAA0) i mam pytanie czy ten kabel bedzie z nim współpracował jeżeli tak to bym prosił o płytkę do niego. Serdecznie dziękuje i pozdrawiam.

    0
  • #9 04 Gru 2008 12:28
    cobynieby
    Poziom 10  

    Jesli mozesz pokazac płytkę to było by fajnie i pytanko czy kabelek pozwala na pracę w trybie no lajn.Pozdrawiam i dziękuję.

    0
  • #11 13 Lut 2009 23:11
    IZYCH
    Poziom 15  

    narki1 napisał:
    Płytka proszę. Natomiast mam pytanie:
    czy działa ten kabel pod logo SoftComfort 6 wraz z logo 6 ?
    Mi jakoś nie chce.

    Masz może rysunek tej płytki w EAGLE , uprościło by to wykonanie płytki.

    0
  • #12 15 Lut 2009 21:14
    narki1
    Poziom 13  

    Mam tylko to co zamieściłem.
    Pozdr

    0
  • #13 11 Mar 2009 16:53
    Maatiii
    Poziom 10  

    Kabel do sterownika LOGO Siemens -sprawdzony Kabel do sterownika LOGO Siemens -sprawdzony Kabel do sterownika LOGO Siemens -sprawdzony Kabel do sterownika LOGO Siemens -sprawdzony

    Witam
    Zmontowałem ten kabelek według schematu Marko121, ale płytkę sam rysowałem w Eagle 5.0.0. Posiadam sterownik Siemens LOGO! 24RL (6ED1 053-1HA00-0BA0) i LOGO!Soft Comfort V5.0.23, gdy chce z czytać zawartość sterownika to wyskakuje mi błąd weryfikacji, czym to może być spowodowane. Jako transoptora użyłem LTV827C, reszta to: CD4049UBE, MAX232CPE. Jakby ktoś mógł sprawdzić czy poprawnie wykonałem płytkę i co ewentualnie mam zmienić żeby zaczęło działać. Czy mogłem jakoś uszkodzić sterownik, gdy źle wpiąłem wtyczkę.
    Pozdrawiam i dziękuje
    W załączniku płytka w Eagle:

    0
  • #14 14 Mar 2009 18:37
    IZYCH
    Poziom 15  

    maciuś1 napisał:
    wtyczkę można zrobić z zewnętrznej karty pamięci (jest tańsza od kabla)

    Gdzie mogę tanio dostać wtyk do gniazda i jakie oznaczenie ma ten rodzaj gniazd i wtyków. Ile kosztuje taka karta pamięci ? i czy może ma ktoś uszkodzoną to można by było ją wykorzystać na wtyk.
    Chętnie wymienię pełną wersję programu Logo Soft Comfort V6.0 na oryginalny kabelek,lub oryginalny wtyk.RS232 zrobiłem sam i świetnie działa tylko to pdłączanie bez wtyku,bezpośrednio przewody do gniazda jest takie niefachowe.W tej sprawie proszę pisać na PW

    0
  • #15 16 Mar 2009 23:28
    Marko121
    Poziom 17  

    Cytat:
    LOGO!Soft Comfort V5.0.23, gdy chce z czytać zawartość sterownika to wyskakuje mi błąd weryfikacji, czym to może być spowodowane. Jako transoptora użyłem LTV827C


    spróbuj zastosować transoptory -PC817 na których pisze "sharp" i spróbuj nowszej wersji LOGO!Soft Comfort

    0
  • #16 23 Mar 2009 15:52
    IZYCH
    Poziom 15  

    Maatiii napisał:
    Kabel do sterownika LOGO Siemens -sprawdzony Kabel do sterownika LOGO Siemens -sprawdzony Kabel do sterownika LOGO Siemens -sprawdzony Kabel do sterownika LOGO Siemens -sprawdzony

    Witam
    Zmontowałem ten kabelek według schematu Marko121, ale płytkę sam rysowałem w Eagle 5.0.0. Posiadam sterownik Siemens LOGO! 24RL (6ED1 053-1HA00-0BA0) i LOGO!Soft Comfort V5.0.23, gdy chce z czytać zawartość sterownika to wyskakuje mi błąd weryfikacji, czym to może być spowodowane. Jako transoptora użyłem LTV827C, reszta to: CD4049UBE, MAX232CPE. Jakby ktoś mógł sprawdzić czy poprawnie wykonałem płytkę i co ewentualnie mam zmienić żeby zaczęło działać. Czy mogłem jakoś uszkodzić sterownik, gdy źle wpiąłem wtyczkę.
    Pozdrawiam i dziękuje
    W załączniku płytka w Eagle:


    Na schemacie masy przed i za transoptorem są rozdzielone , natomiast na płytce masz te masy razem połączone. Poprawiłem tę płytkę w ten sposób że , rozdzieliłem masy z możliwością ich połączenia na pinach , dodałem piny do zewnętrznego zasilania 5V części za transoptorami i możliwość zmostkowania połączeń zasilania wszystkich układów ( bardziej uniwersalne wykorzystanie interfejsu )

    Ja wykonałem interfejs z Nowego Elektronika i z braku optoizolacji stosuję przy zasilaniu sterownika napięciem 230V , mały transformator separacyjny. Działa to bezbłędnie , brakuje mi tylko oryginalnego wtyku.

    Niżej zmieniona płytka w Eaglu 5.1.0

    1
  • #17 29 Mar 2009 14:09
    IZYCH
    Poziom 15  

    Mam w pracy taki interfejs:
    http://www.elmark.com.pl/products/advantech/produkt.php?produkt=1053

    . podłączyłem go do sterownika i nie działa.W programie Logo Soft Comfort 6.0 wykrywany jest port 3 , pod którym pracuje interfejs ale wyświetlany jest błąd połączenia.Wykonałem też interfejs wedgług schematu Marko 121 i też nie działa.Zastosowałem tam 2 pojedyncze transoptory PC123 , które mają takie same parametry jak PC817 czy podwójny PC827 , dobrałem rezystory , dodałem dwie diody LED by móc obserwować transmisję i tez jest błąd w połączeniu ze sterownikiem.Obydwa interfejsy sprawdzałem w Hyper Terminalu i działają dobrze.Co może być problemem z tymi interfejsami , ten wykonany z Nowego Elektronika działa idelanie ale nie ma optoizolacji.
    Nadal poszukuję wtyku do pragramowania sterownika.

    0
  • #18 29 Mar 2009 21:00
    Marko121
    Poziom 17  

    może masz "nie kontakt" na styku jeśli nie masz wtyczki (jak piszesz ) to jak się podłączasz do sterownika ? co tam wkładasz do gniazda? ,czy zrobiłeś zworę pinów opisanych w moim dokumencie czy sterownik przechodzi w tryb programowania ?

    0
  • #19 29 Mar 2009 21:36
    IZYCH
    Poziom 15  

    Jeżeli piszę że działa mi na interfejsie zrobionym z Nowego Elektronika tzn. że potrafię podłączyć go z mini gniazdkiem w sterowniku.Mam cieniutkie i giętkie przewody z przylutowanymi na końcach , końcówkami obciętymi z tranzystorów , na te połączenia mam nałożone koszulki termokurczliwe. Więc połączenie mam dobre , zwarcia są niemożliwe , zworka też jest , bez niej nie mógłbym programować sterownika.
    Interesuje mnie dlaczego nie działa dobry , firmowy interfejs i ten wykonany według schematu. Tym bardziej że wszystkie sprawdzałem programem Hyper Terminal , ten z Nowego Elektronika chodzi do 115.2 Kbps , natomiast ten wykonany z tej strony do 9.6 Kbps .
    Interfejs "ADAM 4561" w terminalu pracuje poprawnie do 230.4 Kbps , a już z błędami przy 460.8 Kbps. Natomiast nie działa ze sterownikiem.

    0
  • #20 29 Mar 2009 21:56
    Marko121
    Poziom 17  

    nie zrozumiałem twojej poprzedniej wypowiedzi ,myślałem że żaden kabel nie działa Ci ze sterownikiem .
    Skoro jednak nie działa CI ten z tej strony z optoizolacją to powodem najprawdopodobniej jest właśnie dobór rezystorów do transoptorów dobież je tak żeby w terminalu interfejs pracował prawidłowo wyżej niż 9.6 Kbps i powinno być dobrze .

    0
  • #21 29 Mar 2009 23:54
    IZYCH
    Poziom 15  

    Zmniejszyłem już wcześniej wartość R2 i R3 na 1K i będę zmieniał jeszcze ich wartość stopniowo do 100R. Myślę że będzie to bezpieczne dla transoptorów , mają dopuszczalny prąd 50mA. Zresztą w tym działającym z Nowego Elektronika , wartości rezystorów w obwodzie diod wynoszą tylko 100R , a w obwodzie Tx i RX ich wartości to 10R.

    0
  • #22 28 Cze 2015 13:34
    pik22
    Poziom 11  

    Witam.
    Nie można po prostu kopic na eBayu kabla za 3 złote z darmową przesyłką - USB To RS232 TTL?
    Wydaje mi się że taka przejściówka powinna działać.

    P.S.
    Zamówiłem tą przejściówkę za dolara i potwierdzam że to działa, tylko musiałem ściągnąć nowszą wersję LOGO!Soft Comfort V8.
    Do podłączenia wystarczą 3 kabelki: RX,TX,MASA (i zworka, ale nie wiem czy musi być w wersji LOGO 0BA6, robiąc kabelek dałem na wszelki wypadek).

    0
  • #23 19 Paź 2015 18:54
    pathryk
    Poziom 9  

    Dzisiaj próbowałem i niestety nie wyszło. Może coś źle zrobiłem.

    Jeśli się komuś udało proszę o informację.

    0
  • #24 29 Lis 2016 15:34
    Grzegorzxxx
    Poziom 12  

    Witam,
    Czy ktoś poradził sobie ze standardowym konwerterem ft232 bo próbowałem już na klika sposobów i brak połączenia z logo?

    0