Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dwa zarządzalne switche i problem z zarządzaniem jednym z nich

29 Cze 2020 23:13 183 5
  • Poziom 10  
    Witam,

    Problem jest taki, że są dwa zarządzalne switche Dlink dgs 1100 8 portowe, jeden ma zasilanie poe z portów lanowych(będę go dalej nazywał głównym) i ma on przenosić ruch do drugiego switcha(tego będę dalej nazywał drugim) z którego ma być internet na podpiętych do niego komputerach za pomocą pppoe. Wszystko działa poprawnie poza zdalnym dostępem sieciowym do konfiguracji drugiego switcha, do głównego da się dostać po sieci i po lanie a do drugiego tylko po sieci. Poniżej napiszę mniej więcej jak to jest skonfigurowane:

    Switch główny jest podpięty do onu który ma domyślny internetowy odtagowany vlan 100, oprócz tego ma zatagowany vlan 101 dla iptv oraz 102 właśnie dla zdalnego zarządzania.

    Zarówno switch główny jak i drugi są skonfigurowane tak samo pod względem vlanòw. Odtagowany vlan internetowy 100 na portach 1-8, zatagowany vlan iptv 101 na portach 1-8 i zatagowany vlan 102 dla zarządzania na porcie 8. Switch drugi jest podpięty do portu numer 8 głównego switcha. Oczywiście oba switche mają ustawione statyczne adresy IP z podsieci w której jest vlan do zarządzania 102 i nie są to te same adresy tylko wiadomo kolejne przykładowo 192.168.10.100 główny switch a drugi 10.101.

    Tak jak pisałem internet i iptv działają na obu switchach ale z sieci da się zarządzać tylko switchem głównym a drugim nie. Na portach drugiego switcha nie widać żadnych adresów MAC tak jakby vlan zarządzania 102 w ogóle tam nie docierał, oczywiście na głównym gdzie się da dostać do zarządzania poprzez adres ip po sieci na portach pojawia się vlan 102.

    Będę wdzięczny za pomoc
  • Poziom 21  
    Pogubiłem się w tym co piszesz, ale ogólnie to ma wyglądać tak że tagowanymi wszystkimi vlanami port trunk w switchu 1 ma być połączony z port trunk w switchu 2 i powinno działać.
  • Poziom 10  
    Wydawało mi się że tak to mam właśnie skonfigurowane, poniżej zdjęcia z konfiguracji portów switchy i onu. Tak dla przypomnienia, switche są ze sobą połączone gniazdami nr 8 w obu.

    Tak jest skonfigurowany pierwszy główny co switch który jest połączony do światłowodu
    Dwa zarządzalne switche i problem z zarządzaniem jednym z nich

    Taka jest konfiguracja drugiego switcha:
    Dwa zarządzalne switche i problem z zarządzaniem jednym z nich

    Taka jak konfiguracja portu na onu do którego podpięty jest główny switch:
    Dwa zarządzalne switche i problem z zarządzaniem jednym z nich
  • Poziom 21  
    Zrób na drugim switchu nietagowany eth7 ale w vlanie do zarządzania 102 wepnij w niego rjke od komputera i sprawdź czy da się nim zarządzać.
  • Poziom 10  
    Nie wiem czy dobrze zrozumiałem ale na drugim switchu zrobiłem na porcie 7 nietagowany vlan 102(żadnych innych vlanòw na tym porcie. Jak tak to robię to powinien mieć 102 na jakimś innym porcie na drugim switchu czy tylko na tym 7 ? Miałem tylko na 7 ale na tym porcie nie dało się na wejść na zarządzenie. Z rzeczy które od dzisiaj zauważyłem to że jeśli zrobię nietagowany vlan 102 na porcie 8 drugiego switcha to pojawia się mac chyba pierwszego switcha w tabeli na adresów, jeśli 102 jest tagowany na tym 8 porcie drugiego to ten vlan nie pojawia się nigdzie.
  • Poziom 21  
    Na switchu może być wybór vlanu z którego ma być zezwolone zarządzanie default jest vlan1