Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Ładowarka Li-Ion dwie nieciekawe zagwozdki

resetmen 08 Jul 2020 17:34 1644 15
  • #1
    resetmen
    Level 15  
    Witam ! No początku chciałbym powiedzieć, że zdaję sobie sprawę z niebezpieczeństwa z tego typu projektem jeżeli chodzi o udział w nim Li-Ion.
    Oto schemat ładowarki jaką próbuję skonstruować:
    Ładowarka Li-Ion dwie nieciekawe zagwozdki
    Chodzi o to, że układ działa prawidłowo..czyli ładuje stałym prądem ustawionym potencjometrem 100k do wartości napięcia 4.2V i gdy osiągnie tę wartość ładuje li-ion malejącym prądęm utrzymując napięcie na Li-ion bliskie 4.2V.Problem jest jednak wtedy gdy akumulatorek jest podłączony a ładowarka jest jeszcze nie włączona...wtedy po podłączeniu ładowarki do prądu pojawia się maksymalny prąd jaki może dać przetwornica..myślałem żeby dla zabezpieczenia wpiąć pomiędzy wejście odwracające us1 ,a wyjście przetwornicy mikroprzekaźnik i załączać go po tym jak na wejściu nieodwracającym jest już 4.2V...to by zabezpieczyło sprawę podłączonego akumulatorka przed włączeniem zasilania...druga niepokojącą sprawa to regulacja prądu ładowania potencjometrem 100k...tutaj też bardzo łatwo przekroczyć próg napięcia na wejściu odwracającym us2 co skutkuje tym że pojawia się maksymalny prąd na wyjściu przetwornicy...co tu na to poradzić ? Więcej wad nie znalazłem...oczywiście przydałby się jakiś sensowny bezpiecznik w obwodzie Li-Ion...nie ma go na schemacie ale to podstawa !
  • Helpful post
    #2
    jarek_lnx
    Level 43  
    resetmen wrote:
    Problem jest jednak wtedy gdy akumulatorek jest podłączony a ładowarka jest jeszcze nie włączona...wtedy po podłączeniu ładowarki do prądu pojawia się maksymalny prąd jaki może dać przetwornica
    Co masz na myśli? brak zasilania wzmacniacza operacyjnego? oczywiście że jak część układu nie będzie zasilana to całość nie będzie działać.

    Dlaczego nie wykorzystałeś stabilizacji napięcia wbudowanej w XL4016 do uzyskania 4,2V
    resetmen wrote:
    .druga niepokojącą sprawa to regulacja prądu ładowania potencjometrem 100k...tutaj też bardzo łatwo przekroczyć próg napięcia na wejściu odwracającym us2 co skutkuje tym że pojawia się maksymalny prąd na wyjściu przetwornicy...co tu na to poradzić ?
    Zmniejszyć zakres regulacji potencjometru dzielnikiem

    resetmen wrote:
    Więcej wad nie znalazłem
    A skąd będziesz wiedział że ładowanie sie zakończyło?
  • #3
    resetmen
    Level 15  
    jarek_lnx wrote:
    resetmen wrote:
    Problem jest jednak wtedy gdy akumulatorek jest podłączony a ładowarka jest jeszcze nie włączona...wtedy po podłączeniu ładowarki do prądu pojawia się maksymalny prąd jaki może dać przetwornica
    Co masz na myśli? brak zasilania wzmacniacza operacyjnego? oczywiście że jak część układu nie będzie zasilana to całość nie będzie działać.

    Dlaczego nie wykorzystałeś stabilizacji napięcia wbudowanej w XL4016 do uzyskania 4,2V
    resetmen wrote:
    .druga niepokojącą sprawa to regulacja prądu ładowania potencjometrem 100k...tutaj też bardzo łatwo przekroczyć próg napięcia na wejściu odwracającym us2 co skutkuje tym że pojawia się maksymalny prąd na wyjściu przetwornicy...co tu na to poradzić ?
    Zmniejszyć zakres regulacji potencjometru dzielnikiem

    resetmen wrote:
    Więcej wad nie znalazłem
    A skąd będziesz wiedział że ładowanie sie zakończyło?

    Chodzi o to, żeby ładowarka działała niezależnie od tego czy najpierw jest włączona i potem włożony li-ion czy też na odwrót...bo jak najpierw jest włożony li-,ion to napięcie na wyjściu us1 podczas włączania jest 0V co powoduje 0V na FB Xl4016 i Xl4016 daje na maksa napięcie na wyjściu i prąd wzrasta do 7A i tak zostaje...a gdy najpierw jest włączona ładowarka to napięcie odniesienia na wejściu nieodwracającym us1 nie pozwoli na wystawienie 0V na wyjściu us1 i wszystko działa prawidłowo...
    Jeżeli chodzi o stabilizację to układ z dwoma WO jest dla mnie łatwiejszy w konstrukcji
    ...fakt trzeba by pomyśleć o sygnalizacji ładowania...
  • Helpful post
    #4
    jarek_lnx
    Level 43  
    resetmen wrote:
    Chodzi o to, żeby ładowarka działała niezależnie od tego czy najpierw jest włączona i potem włożony li-ion czy też na odwrót...bo jak najpierw jest włożony li-,ion to napięcie na wyjściu us1 podczas włączania jest 0V co powoduje 0V na FB Xl4016 i Xl4016 daje na maksa napięcie na wyjściu i prąd wzrasta do 7A i tak zostaje...a gdy najpierw jest włączona ładowarka to napięcie odniesienia na wejściu nieodwracającym us1 nie pozwoli na wystawienie 0V na wyjściu us1 i wszystko działa prawidłowo...
    Czyli chodzi ci o to że wzmacniacz sie zatrzaskuje i mimo podania poprawnych napięć po chwili nie zaczyna pracować poprawnie, czy dobrze rozumiem?
    Daj szeregowo w obwodzie wejścia odwracającego US1 rezystor 10k, żeby ograniczyć prąd który tam płynie bez zasilania.
    Jaki to typ wzmacniacza? Dlaczego masa US1 jest za rezystorem 0,1R?
    resetmen wrote:
    Jeżeli chodzi o stabilizację to układ z dwoma WO jest dla mnie łatwiejszy w konstrukcji

    Przecież dorobienie samej stabilizacji prądu jest prostsze niż zrobienie stabilizacji napięcia i prądu, układ poniżej jest prostszy, a drugi wzmacniacz zostaje wolny do sygnalizacji końca ładowania
    Ładowarka Li-Ion dwie nieciekawe zagwozdki
  • #5
    resetmen
    Level 15  
    No jak się pojawi prąd 7A na li-ion to wtedy na nim napięcie jest 4.4v i układ się zatrzaskuje na 7A ...mam kilka takich układów jak na schemacie :
    Ładowarka Li-Ion dwie nieciekawe zagwozdki

    Niestety nie działają one do końca tak jak ładowarka CC CV. Prąd zaczyna spadać już od 3.8V.
    Masa us1 jest dlatego za rezystorem, żeby dobrze było względem tej masy mierzone napięcie li-ion które wchodzi na wejście odwracające us1 .gdyby była masa przed rezystorem to napięcie odniesienia musiało by być 4.2V + spadek napięcia na rezystorze 0.1 Ohm...a gdy prąd by spadał ładowania to na 0.1 Ohm by spadało napięcie i wszystko by się rozjeżdżało...wzmacniacze operacyjne to DWA lm358.
  • #6
    jarek_lnx
    Level 43  
    resetmen wrote:
    Niestety nie działają one do końca tak jak ładowarka CC CV. Prąd zaczyna spadać już od 3.8V.
    Może miałeś za długie przewody i mierzyłeś na końcu, albo jest niestabilność.
    resetmen wrote:
    Masa us1 jest dlatego za rezystorem, żeby dobrze było względem tej masy mierzone napięcie li-ion które wchodzi na wejście odwracające us1 .gdyby była masa przed rezystorem to napięcie odniesienia musiało by być 4.2V + spadek napięcia na rezystorze 0.1 Ohm...a gdy prąd by spadał ładowania to na 0.1 Ohm by spadało napięcie i wszystko by się rozjeżdżało...
    Napięcie wejściowe wzmacniacza operacyjnego nie może wyjść poza szyny zasilające, szczególnie takiego jak LM358, w którym występuje zjawisko opisane poniżej
    Ładowarka Li-Ion dwie nieciekawe zagwozdki

    Natomiast to co piszesz dotyczy podłączenia źródła napięcia odniesienia, zmieniając podłączenie zasilania WO niczego nie odejmiesz ani nie dodasz, wzmacniacz nie "mierzy" względem masy - przecież ma wejście różnicowe , podłączając zasilanie w ten czy inny sposób możesz tylko spowodować prawidłową lub nieprawidłową pracę WO.
  • #7
    resetmen
    Level 15  
    No widzisz...ale jednak jak podłączyłem masę zasilania us1 przed rezystorem 0.1 Ohm to układ się rozjeżdżał tak jak przewidywałem...robiłem różne próby...
  • #8
    jarek_lnx
    Level 43  
    resetmen wrote:
    No widzisz...ale jednak jak podłączyłem masę zasilania us1 przed rezystorem 0.1 Ohm to układ się rozjeżdżał tak jak przewidywałem...robiłem różne próby...
    Bo lepiej działa błędny układ - tyle że do końca działa.
    Żaden układ w którym wejście LM358 może osiągnąć <-0,3V względem ujemnej szyny zasilania nie będzie poprawny i ma prawo się zatrzaskiwać.
  • #9
    resetmen
    Level 15  
    Tu poruszyłeś ciekawy temat...ale nie ma takiej sytuacji w tym układzie, w której by napięcie na wejściu odwracającym us1 mogło spaść względem masy za rezystorem 0.1 Ohm poniżej - 0.3V ...
  • Helpful post
    #10
    jarek_lnx
    Level 43  
    Myślałem o sytuacji podczas załączania zasilania zanim kondensatory sie naładują ale teraz widzę ze faktycznie nie jest to możliwe.
  • #11
    resetmen
    Level 15  
    Wstawię mikroprzekaźnik na wejście odwracające us1 i będę go załączał z opóźnieniem...wahałem się ale przecież tam nie płynie praktycznie prąd co oznacza, że nawet jak by na stykach była rezystancja 10 kOhm to i tak na wejściu odwracającycm us1 będzie napięcie li-ion...
  • #12
    jarek_lnx
    Level 43  
    resetmen wrote:
    Wstawię mikroprzekaźnik na wejście odwracające us1 i będę go załączał z opóźnieniem...wahałem się ale przecież tam nie płynie praktycznie prąd co oznacza, że nawet jak by na stykach była rezystancja 10 kOhm to i tak na wejściu odwracającycm us1 będzie napięcie li-ion...
    Wstaw tam najpierw rezystor, kiedy wzmacniacz nie ma zasilania, wejście nie ma małej impedancji, tylko pasożytniczo zasila wzmacniacz, płyną prądy przez diody anty-esd, wtedy podstawowe założenie poprawnej pracy układu scalonego - izolacja złączowa nie jest spełnione.

    Rzadko stosuję przekaźniki w układach niskoprądowych, wolę rozwiązania półprzewodnikowe, zajmują mniej miejsca.
  • #13
    resetmen
    Level 15  
    Spróbuję z tym rezystorem...tak przy okazji...chciałbym nawinąć dławik do tej przetwornicy...47uh 12A...czy orientujesz się może jaki rdzeń toroidalny zakupić...przetwornica ta chodzi na 180 kHz ...
  • #14
    jarek_lnx
    Level 43  
    resetmen wrote:
    Spróbuję z tym rezystorem...tak przy okazji...chciałbym nawinąć dławik do tej przetwornicy...47uh 12A...czy orientujesz się może jaki rdzeń toroidalny zakupić...przetwornica ta chodzi na 180 kHz ...
    Możesz kupic gotowy dławik DTMSS-27/0,047/15-V możesz też wykonać na wzór tego
  • #15
    resetmen
    Level 15  
    Jeszcze jedno mam pytanie...jaka jest impedancja wejściowa lm358 ? Czy podając napięcie z dzielnika 120k i 300k na wejście np: odwracające nie wpłynie ona na napięcie na wyjściu dzielnika ?
  • #16
    jarek_lnx
    Level 43  
    resetmen wrote:
    Czy podając napięcie z dzielnika 120k i 300k na wejście np: odwracające nie wpłynie ona na napięcie na wyjściu dzielnika ?
    Przy typowym prądzie wejściowym dla tego wzmacniacza 45nA na takim dzielniku powstanie 4mV błędu (w punkcie podłączenia wejścia WO będzie o 4mV więcej niż gdybyś nie podłączył WO)