Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

KDE Plasma - świruje capslock, zamykanie procesów

Piotr160292 03 Oct 2020 15:19 396 12
  • #1
    Piotr160292
    Level 38  
    Witam, posiadam Debiana 10, którego sobie z ciekawości wyglądu wgrałem z GUI KDE Plasma. Niestety zawróciłem uwagę, że po wciśnięciu klawisza caps lock i jego wyjączeniu, klawiatura jakby się glitchuje i cały piszę dużymi literami, pomimo że caps się nie świeci na klawiturze, jest wyłączony. Problem ustępuje w momencie restartu systemu dopóki znowu go nie wcisnę. Jako że jestem przyzwyczajony do jego używania, strasznie mnie irytuje fakt że muszę restartować system, ew. pogodzić się z tym i pisać z wciśniętym shift. po jego użyciu, Czy ktoś może spotkał się z tym problemem i wie w jaki sposób go wyleminowac, czy zostaje mi wywalenie KDE i przesiadka na inne GUI? Drugie pytanie to takie, czy ktoś wie może w jaki sposób mogę wywołać menadżer zadań, albo spod konsoli dowiedzieć się pod jakim PID proces wisi i wtedy zabić komendą kill? Czasami zdarza mi się, że program do odtwarzania wideo glitchuje się w taki sposób, że niby film odtwarza, ale przestaje reagować na przyciski i nie mam możliwości zamknąć go klasycznie przez przycisk X. Na Lubuntu zauważyłem że można zrobić to b. prosto, ponieważ jak w Windowsie należy wcisnąć ctrl,alt,delete i wtedy otwiera się okno z listą aktywnych procesów i wtedy mam możliwość odszukania sobie zawieszonego, kliknąć prawym i dać kill, w KDE ten skrot niestety nie działa i nie wiem czy po prostu jest inny skrót, czy nie ma po prostu czegoś takiego preinstalowanego i trzeba zabić poprzez sudo komendą kill, lecz niestety z tego co zauważyłem komenda nie działa na nazwę programu i trzeba wklepać PID.
  • #2
    User removed account
    Level 1  
  • #3
    Piotr160292
    Level 38  
    Nie, apt podaje że nie ma czegoś takiego... Teraz o dziwo klawiatura z czasem zaczęła działać poprawnie, ale jak wcisnę caps to znowu jess to samo - dziwne... Może to jest jakiś bug tego GUI?
  • #4
    User removed account
    Level 1  
  • #5
    Piotr160292
    Level 38  
    Nie mam takiej funkcji... W ogóle te opcje mam zdezaktywowane. Jak aktywuję i dam że caps wyłączony to dalej pisze dużyymi, czyli wychodzi na to że ustawienia klawy nic do tego nie mają. Co ciekawe w ogole zauważyłem że w sumie raz pisze dużymi, raz małymi, więc tym bardziej tego nie czaję. Kwestia klawiatury też nie jest bo na Windzie działa.
  • #6
    User removed account
    Level 1  
  • #7
    Piotr160292
    Level 38  
    No patrz, a jak wpisałem apt-get remove ibus to wyrzuciło błąd że nie ma takiego pakietu... Może to jest to, że ja nie używałem live tylko netinst'a i dałem mu żeby wgrał tylko sam core systemu plus kde, jak dobrze pamiętam... Skoro nie masz pomysłu to po prostu wywalę to KDE, wrzce też Cynamon'a albo xfce i wyrąbane... Co do Linuxa to polecam Lubuntu - przynajmniej na razie nie dopatrzyłem się problemów. Na własne to tego Debiana na vm postawiłem tak o dla testu który mi lepiej przypadnie...Debian mi się lepiej nawet podoba bo komendą su mogę wejść na roota i nie muszę wkółko klepać tego sudo, a w lubuntu niestety muszę bo nie mam opcji wejścia komendą su na roota. Jak dobrze pamiętam wpisuję hasło i wywala mi że błędne hasło a na bank jest takie jak w instalatorze ustawiłem bo daję takie samo po wklepaniu komendy z sudo i wchodzi. Windows też jest spoko, ale nie podoba mi się w nim to że jest podatny na infekcje, ataki hakerskie i w przypadku 10 jest gniazdem spyware'u. To mi się właśnie bardzo w nim nie podoba że bardzo mocno szpieguje... Osobiście podpasował mi Linux, ponieważ to co w nim kocham to to, że jest super elastycznym OS i mogę sobie go customizować jak mi się tylko podoba i zajedzie taka potrzeba to, jak to zwykło się mówić, zmuszę go nawet na długopisie do działania....
  • #8
    User removed account
    Level 1  
  • #9
    Piotr160292
    Level 38  
    Tak ale zrozum że ja nie korzystałem z live cd w snesie że odpaliłem i wybrałem installację, tylko pobrałem iso instalacji sieciowej i tam ustawiłem mu żeby wgrał tylko podstawowe składniki i wtedy podociągał mi wszystko z neta... Wgrałem nawet synaptic i sprawdziłem i faktycznie - jest ibus tylko mam go wskazanego jako nie zainstalowany, więc to nie on bo jak może bruździć jak fizycznie go nie ma w systemie. :) Co dziwne to ma związek tak jakby z xorgiem, ponieważ jak go ubiję to w trybie tekstowym caps działa prawidłowo...
  • #10
    User removed account
    Level 1  
  • #11
    Piotr160292
    Level 38  
    Ha, znalazłem gnoja - chyba. To nie jest problem z Linuxem tylko vmware, ponieważ odpaliłem na nim innego linuxa i jest dokładnie to samo, czyli to jest prawdopodobnie jakiś bug związany z tymże programem wirtualizującym. Odpaliłem tak samo drugą maszynę, którą znalazłem w odchłani mojego dysku, na której było ok i jest to samo teź, więc to może potwierdzać, że vmware ma jakiś bug i z jego winy to się robi, na maszynie gdzie było ok problem występuje przez to, że mi się rozkrzaczył i jako że instalki nie miałem, wgrałem nowszą wersję, która jest po prostu zbugowana... Z killowaniem procesów też sobie poradziłem - po prostu dotarło do mnie, że przecież Linux nie ma z tym problemów żeby wgrać pakiety należące do innego GUI, więc dograłem sobie pakiet menadżera zadań z innego GUI i tyle... Teraz mam nawet lepiej jak na Lubuntu, ponieważ mi się na pasku zadań mam go wyciągniętego w postaci wykresu obciażenia, więc jak coś się zawiesi tylko klikam w wykres, otwiera się menadżer i mogę ubić proces...Dziwne tylko że pod XORG a jak ubiję xorg i przejdzie do trybu tekstowego to jest okej...

    Dodano po 35 [minuty]:

    No proszę jak warto ogarniać angielski: https://communities.vmware.com/thread/634592 . Okazuje się, że miałem rację i jest to zany bug tej wersji co mam. Zaktualizowałem od razu do 16, chociaż 15,5,6 podają że problem naprawia i problem zniknął - hurra. :)
  • #12
    User removed account
    Level 1  
  • #13
    Piotr160292
    Level 38  
    Nie da rady... Nlite nie obsługuje obrazów wim... Był jakiś program do modyfikacji Windows 7 ,ale nie pamiętam jak się nazywł - może on by dał radę. Z resztą spyware wyrąbiesz z systemu bez reinstalacji - są skrypty PS na to...